Jump to content
Sign in to follow this  
Wolfgang1

Hyper V VM`s keine Netzwerkverbindung mehr

Recommended Posts

Hallo,

auf einem Desktop Rechner habe ich seit ca. 2 Jahren Windows 10 64 bit installiert. Dazu habe ich auch Hyper V installiert und 4 verschiedene Virtuelle Rechner angelegt. Funktionierte bis alles.

Nun habe ich Windows update auf 1803 installiert. Wenn ich nun eine VM aufrufe, so fehlt bei allen die Netzwerkverbindung. Installiere ich das vor dem Update gesicherte Version W10 wieder, läuft wieder alles. Von daher nehme ich an, dass das etwas mit dem Update zu tun hat. 

 

Hat einer eine Idee wo ich suchen muss?

 

mfg

Wolfgang

Share this post


Link to post

Moin,

 

was heißt denn "fehlt die Netzwerkverbindung"? Sind die VMs nach dem Upgrade noch mit einem virtuellen Switch verbunden?

 

Wie soll denn die Netzwerkverbindung sein? Eigene vSwitches und dann ins LAN? Oder ist der vordefinierte vSwitch mit der Internetverbindung des "Hosts" in Verwendung? Beschreibe bitte mal die Konfig und die Anforderungen genauer.

 

Gruß, Nils

Share this post


Link to post

Moin Wolfgang,

 

wenn ich mich recht entsinne gab's Probleme mit Hyper-V, Intel NICs und 1803. Solltest Du eine Intel NIC haben, schau doch mal, ob es neuere Treiber als die bei Dir installierten gibt.

 

[Edit] Habe mich geirrt, war das March 2018 Update für Windows 7 und 2008 R2: https://blog.brankovucinec.com/2018/03/19/march-2018-windows-update-removes-virtual-network-adapter/

Edited by Stibo

Share this post


Link to post

Hallo,

Es scheint mir so, als wenn die VM nicht mehr mit dem virtuellen Switch verbunden sind. Im Abschnitt  Netzwerk und Internetverbindungen der VM sehe ich keine Verbindung. Beim Netzwerk Icon steht "nicht identifiziertes Netzwerk". Ping zu einem anderen Rechner kann ich auch nicht machen.

Auf dem Rechern, auf dem ich Hyper-V laufen habe, gibt es einen Adapter Ethernet und VEthernet virtueller Switch. Der Ethernetadapter verbindet sich wahrscheinlich auch mit dem virtuellen Switch. Dieser Ethernetadapter ist aber ganz anders angekreuzt als der auf der VM. Auch gibt es dort einen Punkt Hyper-V extensible virtuell Switch, der angekreuzt ist. Das fehlt auf der VM.  

Auf der VM gibt es nur einen Adapter. Ist das so richtig?

Ich weiß nicht wie mann den Netzwerkadapter einstellen muss damit er sich mit mit dem virtuellen Switch verbindet.

 

Wo kann ich nachlesen was da unter Hyper-V mit den Netzwerkadaptern passiert?

 

mfg

Wolfgang

Share this post


Link to post

Moin,

 

wenn du im Hyper-V-Manager die Eigenschaften einer VM öffnest, siehst im Abschnitt der Netzwerkkarte rechts oben den Namen des virtuellen Switches, auf den diese virtuelle Netzwerkkarte verbunden ist. Was steht dort? Taucht derselbe Name auch im Hyper-V-Manager unter "Manager für virtuelle Switches" auf? Falls ja, ist diese virtuelle Netzwerkkarte (also die VM) mit dem betreffenden virtuellen Switch verbunden.

 

In dem Fall geht es an dieser Stelle weiter: Im Manager für virtuelle Switches siehst du in den Eigenschaften des Switches, mit welcher physischen Netzwerkkarte dieser an das Netzwerk angebunden ist. Dort steht allerdings leider nicht der "sprechende" Name, sondern der Gerätename. Um hier Klarheit zu erreichen, brauchst du die Netzwerkübersicht aus der Systemsteuerung. Rufe z.B. über Start-Ausführen auf:

C:\Windows\System32\control.exe netconnections

In dem Fenster findest du unten rechts ein kleines Icon, mit dem du in die Detailansicht schaltest (Tastatur: Strg-Shift-6). In der Spalte "Gerätename" findet sich dann der gesuchte Name, der bei dem virtuellen Switch auch auftaucht. Hier ist also wichtig, dass im virtuellen Switch die richtige Netzwerkkarte zugewiesen ist, die physisch mit dem gewünschten Netzwerk verbunden ist.

 

Unter Windows 10 hat der "Standardswitch" besondere Bedeutung: Der ist vom System erzeugt und soll VMs einfachen Internetzugriff geben, indem die Internetverbindung des Hosts (also des PCs) dynamisch weitergereicht wird. Dieser Standardswitch weist den verbundenen virtuellen Netzwerkkarten per DHCP passende Adressen zu und übersetzt diese (NAT). In der betreffenden VM muss also die Netzwerkkonfig auf DHCP gestellt sein, keine feste IP-Adresse.

 

Das ist alles leider sehr unübersichtlich und für "Einsteiger" nicht auf Anhieb zu verstehen.

 

Gruß, Nils

 

Edited by NilsK
das andere Links. ;)

Share this post


Link to post

Hi,

ich habe leichte Verständnisprobleme. Bei mir gibt es keine Eigenschaften. Aber es gibt Einstellungen. Dort gibt es einen Punkt Netzwerkkarte. Da finde ich rechts oben den rechts gleichen Namen für den virtuellen wie im Manager für virtuelle Switche. Ich habe dann mal von Haus virtueller Switch auf Standardswitch gewechselt. Siehe da jetzt funktioniert alles wieder.

Es funktioniert aber nur wenn ich die IP automatisch beziehe. Das was vorher nicht. Da habe ich jeder VM eine eigene IP vergeben können.

Was jetzt aber auch neu ist, dass es seit dem Update so viele Switche gibt.

Habe ich die vielleicht versehentlich angelegt?

 

mfg

Wolfgang

netzwerk.pdf

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...