Jump to content
webbies

RAID Performance sehr schlecht

Empfohlene Beiträge

Schlecht.

 

Rüste alle CPUs mit der exakt gleichen RAM-Config aus. nichts ist schlimmer von eine VM über NUMA den RAM von einer anderen CPU benutzen muss.

So ein Server ist nichts für den "Heimgebrauch".

bearbeitet von zahni

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Wie sind denn die Performance-Einstellungen bzw. die Energiesparmodi konfiguriert? In den Windows OS und dem BIOS alles auf Höchstleistung?

1 Gbe NICs und VMQ evtl. an?

 

Ansonsten: https://www.datev.de/dnlexom/client/app/index.html#/document/1080080 und https://www.datev.de/dnlexom/client/app/index.html#/document/1014806

 

Die CPUs sind allerdings auch schon etwas betagter. Daher könnte evtl. ein Gedanke an komplett neue Hardware nicht schaden.

 

P.S.: Und für 4 User würde ich DATEV nicht im Haus betreiben -> SmartIT / PARTNERasp ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Daten geben eigentlich Anlass zur Sorge. Eine Laufzeit von 27 s ist schon unter aller Würde.

 

https://www.datev.de/dnlexom/client/app/index.html#/document/0908365

 

gibt auch noch weitere Hinweise.

 

Was mir Sorge macht ist die Startzeit des Tests, hier liegt auch schon etwas im Argen. Ändern sich die Daten, wenn der Test 2 mal nacheinander ausgeführt wird?

 

Wurde der TS genau nach DATEV Vorgaben istalliert? Ist es ein TS oder nur eine Einzelplatzinstallation auf die 4 Personen gleichzeitig zugreifen? Wenn dies der Fall ist, dann sind die Ergebnisse normal und erklärbar. Wurde die Grundinstallation auch TS Installationsmodus durchgeführt, die Insatallation ist ja noch relativ frisch?

Rote Lampen im Servicetool? Gerne auch mal die Leistungsdaten im Servicetool einstellen und durchlaufen lassen.

Wenn im Unternehmen kein DATEV know how vorhanden ist sollte überlegt werden ob SmartIT evtl. in Frage kommt (so etwas von mir, der das ansonsten ablehnt...).

 

Die Ausstattung der VMs und die Leistungsdaten der Hardware sind in Ordnung, ein DATEV TS lässt auch bei 16GB Speicher und 7 gleichzeitigen Usern noch gut betreiben, Reserven sind dann aber nicht mehr da.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

auch ein zweiter Durchlauf ist genauso langsam. Datev wurde von einem Datev Mitarbeiter installiert, wir haben nur zwei VMs zur Verfügung gestellt. Ob die Installation im TS Installationsmodus durchgeführt wurde kann ich leider nicht sagen ... will ich doch mal schwer hoffen, wenn man auf einem TS installiert. Outsourcing kommt leider nicht in Frage.

Im Servicetool ist bis auf Excel Makros alles grün. Wie/wo stelle ich Leistungsdaten im Servicetool ein?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Im Servicetool kannst Du verschiedene Prüfprofile einstellen, "Standard" ist vorbelegt, "Laufzeitprofile" kann und sollte ausgewählt werden. Die Hinweise sind dann schon einmal ein Einstieg.

 

Ich gehe davon aus, dass es sich bei dieser Konfiguration nicht um eine Kanzlei sondern um ein Unternehmen handelt. Manche Dinge sehen in Unternehmensinstallationen anders aus. Prüfe als Erstes, ob der TS tatsächlich die Rolle Terminalserver installiert hat.

 

Es lohnt sich auch, die Netzwerkkarten der VM zu prüfen, es müssen die VMXnet3 eingestellt werden, alles andere macht keinen Spaß.

 

Hilfreich ist es auch diesen KB Artikel https://kb.vmware.com/s/article/2008925

abzuarbeiten, gilt auch für neuere Serverversionen.

 

Das gilt auch für die VM auf der der SQL Server installiert ist. Prüfe dort mit dem SQL Tool die DATEV Datenbanken (Admin Modus).

 

Zum Schluss die größe der virtuellen Platen prüfen und ob diese sich physikalisch auch auf die volle Größe ausdehnen können. Die Bereitstellungsart hat bei DATEV eigentlich eine sehr geringe Auswirkung, auch SSD oder die Drehzahl macht bei RAID 1 für DATEV keinen großen Unterschied (dazu sollte der Plattenindex am Ende unter 1s liegen).

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Es lohnt sich auch, die Netzwerkkarten der VM zu prüfen, es müssen die VMXnet3 eingestellt werden, alles andere macht keinen Spaß.

 

Hilfreich ist es auch diesen KB Artikel https://kb.vmware.com/s/article/2008925

abzuarbeiten, gilt auch für neuere Serverversionen.

Das mag ja evtl. bei VMware helfen, aber nicht bei Hyper-V ;)

 

 

Zum Schluss die größe der virtuellen Platen prüfen und ob diese sich physikalisch auch auf die volle Größe ausdehnen können. Die Bereitstellungsart hat bei DATEV eigentlich eine sehr geringe Auswirkung, auch SSD oder die Drehzahl macht bei RAID 1 für DATEV keinen großen Unterschied (dazu sollte der Plattenindex am Ende unter 1s liegen).

Ein SQL bzw. DATEV Software soll nicht von SSDs profitieren? :schreck:

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Woraus leitest Du Hyper-V ab?

 

Zur SSD: Bei DATEV verstopfen die Logs den Cache, da kann die SSD ihre Vorteile nur in ganz geringem Maß ausspielen. Hab zum Spaß mal eine DATEV Umgebung komplett auf SSD unter VMWare verschoben, das Ergebnis war aus der Abteilung "lohnt nicht" (VMWare erkennt die SSD). Was messbar lohnt sind mehr Kerne zuteilen und die genannten Maßnahmen an der Konfiguration der Netzwerkadapter.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ja, es ist Hyper-V :) Ich habe die "Laufzeitfaktoren" im Servicetool laufen lassen und dort ist alles grün. Remotedesktopdienste sind auf dem Server installiert. Wenn meine Recherchen stimmen und im install mode Registry Einträge unter HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install zu finden sein müssten, dann wurde Datev nicht im install mode installiert, denn hier ist nichts zu sehen. Zum Thema Netzwerkkarten: Der Befehl Get-NetAdapterVmq –Name * liefert mir keinerlei Ergebnisse

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

OK, bei Hyper-V bin ich "hardwarenah" draußen. Bei DATEV kann ich nur noch beisteuern, dass DATEV in den Leitfäden explizit auf den Installationsmodus hinweist. Es sind auch Fälle bekannt wo nach SR Installationen im execute Modus DATEV Programme nur noch von einem User genutzt werden konnten.

 

Meine Empfehlung ist daher den TS neu aufsetzen, aber dann im Installationsmodus.

 

Bei der Gelegenheit gleich prüfen ob KommServer und LizenzServer auf dem SQL installiert sind. Falls nicht vorher die Daten des LizenzManagers sichern (gibt dazu ein InfoDB Dok.) und den dann auf dem SQL installieren. Mach zukünftig erheblich weniger Stress.

bearbeitet von muenster

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

OK, bei Hyper-V bin ich "hardwarenah" draußen. Bei DATEV kann ich nur noch beisteuern, dass DATEV in den Leitfäden explizit auf den Installationsmodus hinweist. Es sind auch Fälle bekannt wo nach SR Installationen im execute Modus DATEV Programme nur noch von einem User genutzt werden konnten.

 

Meine Empfehlung ist daher den TS neu aufsetzen, aber dann im Installationsmodus.

Dagegen spricht, das der ja laut TO von Datev aufgesetzt wurde.

 

Ich vermute nach wie vor ein Problem mit der physischen Netzwerkkarte im Host.

 

Wäre nicht der Erste, wo nicht nur am Host das VMQ disabled werden müsste, sondern auch noch das Offloading auf der Karte der VM

Bei SQL kann man so nachweislich bis zum 10-fachen Durchsatz haben.

 

Aber alles nur Vermutung, müsste man halt einfach ausprobieren.

 

;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×