Jump to content
Doso

Outlook Anywhere - Laptop Schlafmodus - Outlook keine Verbindung

Empfohlene Beiträge

Wir haben einen Exchange 2016 Server CU6 und verwenden ein aktuelles Outlook 2016.

 

Einige wenige Nutzer haben manchmal Verbindungsprobleme mit ihrem Outlook. Ich konnte das jetzt nachstellen:

 

- Nutzer hat Outlook offen

- Nutzer klappt Laptop zu -> Laptop geht in den Schlafmodus

- Nutzer macht Laptop wieder auf

 

Wenn der Nutzer das 2-3x macht zeigt Outlook einen Verbindungsfehler. Der Verbindungsfehler ist nur bei Outlook, Webmail geht. Der Verbindungsfehler ist dann auch unabhängig vom Rechner oder Betriebssystem. Er scheint also allgemein an der Mailbox des Nutzers zu hängen

 

Wenn der Nutzer Verbindungsprobleme hat, lasse ich den Outlook Verbindungstest laufen: https://testconnectivity.microsoft.com

 

Er wirft mir einen MAPI Fehler:

 

Testing the MAPI Mail Store endpoint on the Exchange server.

     An error occurred while testing the Mail Store.

....

     

    Attempting to log on to the Mailbox.

     An error occurred while logging on to the Mailbox.

     

The mailbox logon failed with unknown error 2614.

StatusCode: 2614

 

 

Ich vermute daher das Outlook durch den Energiesparmodus irgendwelche Verbindungen nicht trennt und dann neue aufmacht und man dann in irgendein Verbindungslimit auf dem Exchange Server rein läuft. Wenn ich in den Verbinungsstatus von Outlook reinschaue sehe ich das teilweise auch nicht alle zusätzlichen Postfächer verbunden werden.

 

Leider finde ich in den Logfiles vom Exchange Server auf Anhieb nichts, muss aber gestehen das ich auch nicht genau weiß wo ich jetzt suchen sollte.

 

Von Exchange 2010 kenne ich Nutzer die teilweise Verbindungsprobleme hatten da sie viel zu viele Ordner in freigegebenen Postfächern hatten. Man konnte hier dann das Limit höher schrauben. Diese Fehler konnte ich aber leicht finden da sie in der Ereignisanzeige leicht zu sehen waren.

 

Hat hier jemand eine Idee wo man hier nachschauen könnte bzw. was man dagegen machen kann?

  • Like 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Zu diesem Zeitpunkt auf dem Exchange Server leider keine Meldungen dazu. Wäre ja auch zu einfach gewesen.


Konnte es nochmals einschränken. Outlook Anyhwere von extern funktioniert mit Nutzername/Passwort. Mache ich Outlook auf fragt es erneut nach Nutzername/Passwort und ich melde mich an, mache ich das Spielchen dann 2-3x klappt die Verbindung nicht mehr.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Haben seit ein paar Tagen das selbe Problem. OL2016 mit EX2016 nach einer Server- und Postfachmigration von Exchange 2010

Da ich bisher fast nichts zu diesem Problem gefunden habe und das hier genau in die Richtung geht, habe ich mich extra angemeldet.

 

Outlook lässt sich normal starten, macht man es en paar mal auf und zu, gehen die Probleme los und alle oder einzelne auto-gemappte Postfächer werden nicht verbunden.

Connectivity Analyzer bringt einen MAPI Fehler bei MANCHEN Usern:

 Attempting to log on to the Mailbox.
     An error occurred while logging on to the Mailbox.
     
The mailbox logon failed with unknown error 2614.
StatusCode: 2614
HTTP Response Headers:
request-id: 38ccb5fe-ff93-43d6-becf-36fd5fb5499c
X-CalculatedBETarget: ex2016.internaldomain.local
X-ServerApplication: Exchange/15.01.1261.035
X-RequestId: 91681322-2055-4754-ba39-6a7de0613323:1
X-ClientInfo: c84e16ed-b0a5-4fd2-a37f-d1ac76a9ed1b:1
X-RequestType: Connect
X-TunnelExpirationTime: 1800000
X-PendingPeriod: 30000
X-ExpirationInfo: 300000
X-ResponseCode: 0
X-DiagInfo: EX2016
X-BEServer: EX2016
Persistent-Auth: true
X-FEServer: EX2016
 

 

Auf dem Exchange 2016 nur ganz sporadische (<20) Fehler 9646. Obwohl das Problem andauernd auftritt.

Heute 300€ an MS bezahlt, nachdem wir schon über 1,5 Tage frustrierendes Troubleshooting betrieben haben.

 

Vorläufige Lösung:

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem]
"DatabaseType"=dword:00000000
"MaxObjsPerMapiSession"=dword:000007d0
"Maximum Allowed Exchange Sessions Per Service"=dword:00002710
"Maximum Allowed Sessions Per User"=dword:00002710
"Maximum Allowed Service Sessions Per User"=dword:00002710
"Maximum Allowed Concurrent Exchange Sessions Per Service"=dword:00002710
 
 
Exchange Powershell:
New-ThrottlingPolicy  NoPolicy


Name     ThrottlingPolicyScope IsServiceAccount
----     --------------------- ----------------
NoPolicy Regular               False




Set-ThrottlingPolicy NoPolicy -RCAMaxConcurrency Unlimited -EWSMaxConcurrency Unlimited -EWSMaxSubscriptions Unlimited -CPAMaxConcurrency Unlimited -EwsCutoffBalance Unlimited -EwsMaxBurst Unlimited -EwsRechargeR
ate Unlimited


Get-Mailbox -Identity test.user | Set-Mailbox -ThrottlingPolicy NoPolicy
30 Minuten warten oder Server neustarten.
 
Wenn das die Lösung für dein Problem ist, darfst du dich gerne an den MS-Support Kosten mit einem 6-Pack Bier beteiligen :-)

Noch ein Hinweis: hier findet kein OutlookAnywhere statt sondern MAPI over HTTP, sofern du das nicht global abgestellt hast. Exchange 2016 default ist MAPI-HTTP.

get-mapivirtualdirectory | fl

bearbeitet von wurzelbrunft

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

"Auf Arbeit" haben wir die MSI Installationen. Privat habe ich eine C2R Version, bei beiden Versionen selbes Verhalten.

 

Danke Wurzelbrunft. Das hört sich genau so an wie bei uns. Du hast Recht da ist natürlich MAPI/HTTP im Einsatz.

 

Die Lösung von Microsoft hört sich aber sehr nach Holzhammer Methode an. Schalte einfach mal alle Limits ab und hoffen wir mal...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Naja, die Lösung ist das nicht, aber es ist eine Variante zu prüfen, ob der Exchange Server dich da ausbremst oder ob ein anderes Problem auftritt. Wir haben in alle Richtungen vermutet: abgelaufene Web-Cookies, Authentifizierung schlägt fehl...

 

Wenn du nach diesen Schritten diese Probleme nicht mehr hast, musst du eine ThrottlingPolicy bauen, die auf deine spezifische Umgebung passt.

 

Im Normalen Betrieb merken die User das ja garnicht. Nur wenn man anfängt Outlook auf mehreren Endgeräten zu benutzen, mobile Geräte sich Syncen etc, dann gehen die Probleme los. Ein User kann ja schnell mal gleichzeitig vom PC, Notebook, Tablet, Smartphone... mehrere Verbindungen gleichzeitig zu seinem Postfach aufbauen. Wenn man dann noch anfängt, das Problem nachzustellen wird es richtig stressig für den Server.

 

Insgesamt wäre es hier schön gewesen, wenn der Exchange Server diese Blockierungen aktiv im Eventlog gemeldet hätte. 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Wir haben halt eine Nutzerin die von Besprechung zu Besprechung hastet und derweil immer ihren Laptop auf und zuklappt und wohl auch Outlook auf und zumacht und derweil in externen WLANs ist.

Workaround ist bisher Webmail.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Habe weiter gesucht. Es reicht in der Tat wenn man von extern Outlook mehrmals am Stück auf und wieder zu macht. Dabei scheint das Patch Level von Outlook 2016 keinen Einfluss zu machen.

 

Ich konnte es auch bei Outlook 2010 (mit MAPI HTTP Patches) nachstellen. Interessanterweise wird bei Outlook 2010 hier dann aber bei den Verbindungsproblemen etwas auf dem Exchange Server protokolliert:

 

Log Name:      Application
Source:        MSExchangeIS
Date:          17.10.2017 15:10:51
Event ID:      9646
Description:
Mapi session /O=ourorg/OU=org/cn=Recipients/cn=nutzername with client type MoMT exceeded the maximum of 32 objects of type Session.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×