Jump to content

Relaunch 2018: Willkommen im neuen Forum - Das MCSEboard.de wurde runderneuert. Wir wünschen Euch viel Spaß an Board.

monstermania

WSUS bietet keine Updates mehr für Win 10 (1607) und (1703) an

Empfohlene Beiträge

Hallo,
unser WSUS bietet seit ca. Mitte August keine OS-Updates mehr für alle Clients mit Windows 10 Pro (1607) und (1703) an. Die Updates der Win 10 Clients mit 1511 funktioniert weiterhin fehlerfrei. 
Auch die Updates für Windows 7 und die Server 2008R2/2012/2012R2 laufen fehlerfrei.

 

Es geht ‚nur‘ um die eigentlichen Updates für Win 10 selbst. Updates für z.B. Office 2010/2013/2016 werden auch für die Clients mit Win 10 1607 und 1703 angeboten.

 

Ich vermute stark, dass das mit der Einführung von Windows 10 (1703) im Unternehmen zu tun hat. Da ich in diesem Zeitraum meinen ersten Client mit 1703 bestückt habe (Update unseres Win10 Testrechners von 1607 auf 1703). Ausgehend von diesem Testclient wurde die GPO des WSUS entsprechend angepasst (3. Eintrag für den WSUS) und natürlich auch Windows 10 (Creators Update = 1703) in der Produktklassifizierungsoptionen des WSUS aktiviert.

Bis zu diesem Zeitpunkt hat die Verteilung der Updates auch für Windows 10 Pro (1607) problemlos funktioniert!

 

Die Clients melden sich täglich beim WSUS und zeigen auch an welche Updates fehlen (z.B. MS Office). Nur, dass bei allen Clients mit 1607 und 1703 halt keinerlei Update für das OS angefragt wird.
Der Versuch manuell nach Updates zu suchen führt immer zum Fehler (0x8024500c). Googeln zu diesem Fehler brachte mich nicht so recht weiter. Die Problemlösungen beziehen sich eigentlich immer auf dien fehlenden 3. Eintrag des WSUS in der Policy. Der ist aber definitiv da.

Der WSUS hat die Version 6.2.9200.22167 (Windows 2012).

Hat dazu Jemand eine Idee?

 

Gruß

Dirk

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hast Du %windir%\Softwaredistribution auf einem Testclient schon geleert? Lass den WSUS doch mal Online nach Updates für sich selbst suchen. Wird noch etwas gefunden?

 

EDIT: Möglich ist natürlich, der W2012(ohne R2) wird von MSFT nicht mehr für W10 unterstützt, kann ich allerdings nicht verifizieren da wir nur W2016 und W2012R2 im Angebot haben. Mittelfristig solltest Du aber auf W2016 für den WSUS umsteigen.

bearbeitet von Sunny61

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hast Du %windir%\Softwaredistribution auf einem Testclient schon geleert? Lass den WSUS doch mal Online nach Updates für sich selbst suchen. Wird noch etwas gefunden?

Hab ich schon durch! Softwaredistribution sowohl auf einem Client mit 1607 als auch mit 1703 geleert. Manuelle Updatesuche bringt dann erneut den Fehler (0x8024500c).

Das mit dem manuellen Online-Update des WSUS werde ich mal ausprobieren.

 

EDIT: Möglich ist natürlich, der W2012(ohne R2) wird von MSFT nicht mehr für W10 unterstützt, kann ich allerdings nicht verifizieren da wir nur W2016 und W2012R2 im Angebot haben. Mittelfristig solltest Du aber auf W2016 für den WSUS umsteigen.

Das wäre natürlich mal wieder ein geniales Feature von MS  :cry:!

W2016 kommt bei uns erst im Herbst 2018! Haben auf unserem VM Hosts jeweils W2012 Datacenter lizenziert und sind daher entsprechend darauf beschränkt. Im Herbst 2018 kommt dann neue Hard- und Software.

Unser einziger W2012R2 ist unser Backupserver (Blech).

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

KB3095113 + KB3159706 sind auf dem WSUS installiert?

 

Bezüglich der Clients, manchmal hilft es auch, den Schnellstart zu deaktivieren und den Client neu zu starten. Dann das ganze von vorne.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

KB3095113 + KB3159706 sind auf dem WSUS installiert?

 

Bezüglich der Clients, manchmal hilft es auch, den Schnellstart zu deaktivieren und den Client neu zu starten. Dann das ganze von vorne.

Jo,

beide Updates sind drauf (seit August 2016).

Das das mit dem Schnellstart zu tun hat glaube ich eher nicht. Schließlich hat der WSUS ja einige Monate mit den Updates für Windows 10 (1607) funktioniert (bis mitte August 2017).

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Unser WSUS ist ein 2012 (ohne R2) und verteilt problemlos alle Updates auf die Win10 Clients, durchgängig von 1511 bis 1703. Sollte also nicht am 2012er liegen...

bearbeitet von Marco31

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

 Prüfe doch mal bitte am Client in der Registry den folgenden Schlüssel. Die Einstellungen sollten wie im Bild so aussehen.

 

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings

 

 

post-70913-0-16606900-1506401597_thumb.jpg

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

anbei ein Bild meiner Registry (Windows 10 Pro 1703).

 

Ich habe zwischenzeitlich mal eine neue OU angelegt um ausschliesen zu können, dass es Probleme mit einem GPO-Objekt gibt. 

Hatte keine Auswirkungen.

Immer noch Fehler (0x8024500c) bei manueller suche nach Updates (Software-Distribution-Ordner wurde zuvor geleert!)

 

Gruß

Dirk

post-59487-0-15563800-1506408756_thumb.png

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gibt es unter HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate einen Eintrag mit "DeferUpgrade"? Wenn ja, dann diesen entfernen.

 

Ansonsten hier vielleicht noch einmal reinschauen. https://docs.microsoft.com/de-de/windows/deployment/update/waas-configure-wufb


Wir hatten bei uns das gleiche Verhalten, allerdings betraf es hier nur fünf Rechner. An den Rechnern waren jeweils an den oben genannten zwei Stellen die Einstellungen nicht korrekt. 

Nach manueller Korrektur rufen sie nun auch wieder die Windows 10 1703 Updates ab. Der WSUS läuft auch hier unter 2012, also prinzipell funktioniert es mit den.

 

Gruß

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gibt es unter HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate einen Eintrag mit "DeferUpgrade"? Wenn ja, dann diesen entfernen.

Dieser Eintrag war zumindest auf meinen 2 Windows 10 Pro (1703) Clients vorhanden. Nach dem manuellen löschen klappte es dann auch wieder mit den Updates auf den beiden Clients.

Werde das jetzt nochmal auf den 1607 Clients prüfen. 

Ich frag mich bloß, warum der Eintrag überhaupt gesetzt war.  :confused: Im WSUS GPO steht der entsprechende Eintrag auf 'nicht definiert'.

Hab jetzt erstmal ein GPO erstellt, die diesen Eintrag löscht!

 

Vielen Dank!

 

Gruß

Dirk

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Guten Morgen,

 

der Eintrag wird eigentlich über die ADMX Vorlagen von Windows 10 1511 gesetzt. Waren die betroffenen Clients vorher Version 1511 und wurden aktualisiert? Waren die ADMX Vorlagen im Central Store vorher aus der Version 1511 mit der die GPO für Windows Update verteilt wurde?

Wenn die Einstellung in den Vorlagen der Version 1511 gesetzt wurde und anschließend die Vorlagen auf Version 1607 oder 1703 aktualisiert werden, dann bleibt die Einstellung auf den Clients erhalten.

Die neuen Vorlagen verwenden hier andere Einträge, daher wird dann hier auch die Einstellung nicht angezeigt. Mann müsste dann mit den "alten" Vorlagen die Einstellung wieder rückgängig machen.

 

Gruß

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×