Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
Knorkator

Anwenden von Snapshot funktioniert nicht

Empfohlene Beiträge

Hallo zusammen,

 

wir setzen hier einen Hyper-V Server 2016 ein.

Eine VM mit Debian 7 wurde heruntergefahren, mit einem Snapshot versehen und sollte nach einigen Programmtest in der VM wieder in den vorherigen Zustand zurückgesetzt werden.

2 Stunden später quittierte mit die Hyper-V Konsole das Anwenden des Snapshots leider so: 

PS C:\vm> Get-VM zabbix| Foreach-Object { $_ | Get-VMSnapshot | Sort CreationTime | Select -Last 1 | Restore-VMSnapshot  }

Bestätigen
Möchten Sie die Aktion wirklich ausführen?
Restore-VMSnapshot stellt die Momentaufnahme "Vor Upgrade auf 3.4" wieder her.
[J] Ja  [A] Ja, alle  [N] Nein  [K] Nein, keine  [H] Anhalten  [?] Hilfe (Standard ist "J"): j
Restore-VMSnapshot : "Zabbix": Fehler beim Anwenden des Prüfpunkts.
"Zabbix": Fehler beim Anwenden des Prüfpunkts (ID des virtuellen Computers: 8C59C82F-F0F3-4F2E-A03C-D06A7216F6B2).
In Zeile:1 Zeichen:92
+ ... Snapshot | Sort CreationTime | Select -Last 1 | Restore-VMSnapshot  }
+                                                     ~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Restore-VMSnapshot], VirtualizationException
    + FullyQualifiedErrorId : OperationFailed,Microsoft.HyperV.PowerShell.Commands.RestoreVMSnapshot

Der Hyper-V Manager liefert mir die gleiche Fehlermeldung.

Im Eventlog wird unter Hyper-V-VMMS\Admin die Event-ID 15060 protokolliert:

"Zabbix": Fehler beim Anwenden des Prüfpunkts (ID des virtuellen Computers: 8C59C82F-F0F3-4F2E-A03C-D06A7216F6B2).

Microsoft liefert dazu scheinbar nur einen Beitrag zum Server 2008.

Dden höchst hilfreichen Ratschlag, man möge es doch bitte noch einmal probieren....

https://technet.microsoft.com/en-us/library/dd581823(v=ws.10).aspx

 

Hat jemand einen Tipp, woran das liegen kann?

Ist der erste Snapshot den ich zu dieser VM gemacht habe, ggf. liegt es an Debian 7 und Hyper-V 2016?

https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/supported-debian-virtual-machines-on-hyper-v

 

Vielen Dank für Ratschläge!

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Snapshots sind so eine Sache, zumindest im laufenden Betrieb gibt es da Kommunikation mit den Hyper-V Integrationskomponenten im Gastbetriebssystem - und wenn die kaputt/unsupported sind wird es nervig.

 

Wir halten uns da an die Microsoft Empfehlung: Snapshots haben in produktiven Umgebungen nichts zu suchen. Daher kann ich dir da nicht weiterhelfen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

×