Jump to content

Relaunch 2018: Willkommen im neuen Forum - Das MCSEboard.de wurde runderneuert. Wir wünschen Euch viel Spaß an Board.

matzko

Fehler beim Anpassen von GPO (Unbehandelte Ausnahme in einer Komponente der Anwendung

Empfohlene Beiträge

Hallo, 

ich bekommen seit kurzem nur noch Fehlermeldungen beim Anpassen von Gruppenrichtlinien auf unserem SBS 2011:

Unbehandelte Ausnahme in einer Komponente der Anwendung. Wenn Sie auf "Weiter" klicken, ignoriert die Anwendung den Fehler und setzt den Vorgang fort.
Der Wert liegt außerhalb des erwarteten Bereichs.

Details:

Informationen über das Aufrufen von JIT-Debuggen anstelle dieses Dialogfelds finden Sie am Ende dieser Meldung.


************** Ausnahmetext **************
System.ArgumentException: Der Wert liegt außerhalb des erwarteten Bereichs.
   bei Microsoft.GroupPolicy.AdmTmplEditor.IGPMAdmTmplEditorCallback.ApplyChanges()
   bei Microsoft.GroupPolicy.AdmTmplEditor.Editor.SaveChanges()
   bei Microsoft.GroupPolicy.AdmTmplEditor.Editor.buttonApply_Click(Object sender, EventArgs e)
   bei System.Windows.Forms.Control.OnClick(EventArgs e)
   bei System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.ButtonBase.WndProc(Message& m)
   bei System.Windows.Forms.Button.WndProc(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Geladene Assemblys **************
mscorlib
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.8762 (QFE.050727-8700).
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll.
----------------------------------------
Microsoft.GroupPolicy.AdmTmplEditor
    Assembly-Version: 6.1.0.0.
    Win32-Version: 6.1.7601.17514 (win7sp1_rtm.101119-1850).
    CodeBase: file:///C:/Windows/assembly/GAC_64/Microsoft.GroupPolicy.AdmTmplEditor/6.1.0.0__31bf3856ad364e35/Microsoft.GroupPolicy.AdmTmplEditor.dll.
----------------------------------------
System
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.8759 (QFE.050727-8700).
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll.
----------------------------------------
System.Windows.Forms
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.5491 (Win7SP1GDR.050727-5400).
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.
----------------------------------------
System.Drawing
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.5495 (Win7SP1GDR.050727-5400).
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.
----------------------------------------
System.Xml
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.5494 (Win7SP1GDR.050727-5400).
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
Microsoft.GroupPolicy.AdmTmplEditor.resources
    Assembly-Version: 6.1.0.0.
    Win32-Version: 6.1.7600.16385.
    CodeBase: file:///C:/Windows/assembly/GAC_64/Microsoft.GroupPolicy.AdmTmplEditor.resources/6.1.0.0_de_31bf3856ad364e35/Microsoft.GroupPolicy.AdmTmplEditor.resources.dll.
----------------------------------------
Accessibility
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400).
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll.
----------------------------------------
mscorlib.resources
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.8762 (QFE.050727-8700).
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll.
----------------------------------------
System.Windows.Forms.resources
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.5420 (Win7SP1.050727-5400).
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms.resources/2.0.0.0_de_b77a5c561934e089/System.Windows.Forms.resources.dll.
----------------------------------------

************** JIT-Debuggen **************
Um das JIT-Debuggen (Just-In-Time) zu aktivieren, muss in der
Konfigurationsdatei der Anwendung oder des Computers
(machine.config) der jitDebugging-Wert im Abschnitt system.windows.forms festgelegt werden.
Die Anwendung muss mit aktiviertem Debuggen kompiliert werden.

Zum Beispiel:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

Wenn das JIT-Debuggen aktiviert ist, werden alle nicht behandelten
Ausnahmen an den JIT-Debugger gesendet, der auf dem
Computer registriert ist, und nicht in diesem Dialogfeld behandelt.

 

Wenn ich den Fehler, wie vorgeschlagen, ignoriere, werden die Einstellungen dennoch nicht übernommen. Es ist dabei egal, ob ich bestehende GPOs anpassen möchte, oder eine neue erstelle. Es gibt immer diesen Fehler und keine Änderungen werden übernommen. 

Kann mir dabei jemand weiterhelfen?

Besten Dank und Grüße

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Im Technet-Forum habe ich folgende Rückmeldung dazu erhalten: 

 

Das ist leider ein Fehler in der Anwendung, die versucht, einen ungültigen Wert zu speichern.
Im angezeigten CallStack (s.o.) wird der Fehler ab " bei System.Windows.Forms.Control.OnClick(EventArgs e)" nicht überwacht.
Da musst du dich leider an den Hersteller der Anwendung wenden wenn du es nicht selbst bist.

Welcher ungültige Wert dies ist, lässt sich eben anhand der angegeben Exception im obersten Stackentry vielleicht feststellen. Hier müsste der Debugger die Möglichkeit haben sich diese Variable beim Breakpoint dann anzusehen.

 

Hilft mir leider nicht weiter. Mit dem Debugger kenn' ich mich auch 0 aus.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

 

passiert dasselbe auch, wenn du über RSAT von einem Client aus arbeitest? Wenn nicht, dann liegt es am Editor auf dem Server. Vielleicht hat der bei einem Update was weggekriegt. Updates prüfen und neu einspielen könnte dann helfen.

 

Gruß, Nils

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Im Technet-Forum habe ich folgende Rückmeldung dazu erhalten: 

 

Das ist leider ein Fehler in der Anwendung, die versucht, einen ungültigen Wert zu speichern.

Im angezeigten CallStack (s.o.) wird der Fehler ab " bei System.Windows.Forms.Control.OnClick(EventArgs e)" nicht überwacht.

Da musst du dich leider an den Hersteller der Anwendung wenden wenn du es nicht selbst bist.

Welcher ungültige Wert dies ist, lässt sich eben anhand der angegeben Exception im obersten Stackentry vielleicht feststellen. Hier müsste der Debugger die Möglichkeit haben sich diese Variable beim Breakpoint dann anzusehen.

 

Hilft mir leider nicht weiter. Mit dem Debugger kenn' ich mich auch 0 aus.

Das ist ja witzig, Hersteller der Anwendung ist doch Microsoft! 

Oder gehört die Gruppenrichtlinienverwaltung jetzt nicht mehr zum Betriebssystem?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe das gleiche Problem, gibt es eine Lösung dafür?

Mit den selben Eckdaten? SBS2011? welcher Patchstand usw. usf.?

 

Ansonsten ist das hier vielleicht einen Blick wert:

https://social.technet.microsoft.com/Forums/windowsserver/en-US/02275c52-cdce-4770-86be-5002cac5759c/unhandled-exception-when-modifying-a-gpo?forum=winserverGP

bearbeitet von NorbertFe

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Mit den selben Eckdaten? SBS2011? welcher Patchstand usw. usf.?

 

Ansonsten ist das hier vielleicht einen Blick wert:

https://social.technet.microsoft.com/Forums/windowsserver/en-US/02275c52-cdce-4770-86be-5002cac5759c/unhandled-exception-when-modifying-a-gpo?forum=winserverGP

Es handelt ich bei mir ebenfalls um einen SBS2011 auf den alle Updates installiert werden.

Derzeit Build 7601!

 

Sonst genau das gleiche Fehlerbild, man keine GPOs bearbeiten oder neu erstellen.

bearbeitet von Matthias_Jessin

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Link gelesen und überprüft?

 

Ich weiß nicht was ich überprüfen soll!

Es gibt nur einen DC, mit wem soll er replizieren.

 

Gibt es etwas spezielles worauf Du hinaus willst?

Mein Englisch ist auch nicht so gut, dass ich alles verstehe was in dem Beitrag steht.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich hatte den Link selbst schon beim Googeln gefunden. Allerdings ist das Fehlerbild auch ein anderes. Beim Link geht es um den Zugriff auf eine Datei:

 

The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020).

 

Hilft leider nicht weiter. 

 

 

 

Sonst genau das gleiche Fehlerbild, man keine GPOs bearbeiten oder neu erstellen.

 

Ich kann allerdings neue GPOs erstellen. Nur keine Werte ändern. 

 

Edit: Hab das gerade nochmal getestet. Ich kann eine GPO erstellen; dann ändere ich einen Wert und Übernehme diese Änderung. Alles OK. Stelle ich den Wert zurück kommt die o.g. Fehlermeldung. Bei bestehenden GPOs kommt die Fehlermeldung sofort. Irgendwas stimmt da wirklich nicht..

bearbeitet von matzko

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Unter Vorbehalt möchte ich vermelden das Problem gelöst zu haben. Ich hatte bei meiner Recherche einen Zusammenhang zum .NET Framework gefunden und darauf hin Version 4.7 (KB3186497) deinstalliert. Der Fehler bestand aber weiterhin und ich habe es auch nicht wieder installiert.

Dies habe ich jetzt nachgeholt und KB3186497 sowie KB 4032113 installiert. Jetzt funktioniert das bearbeiten der GPOs wieder als wäre nichts gewesen. 

 

@Matthias: Du kannst ja mal versuchen ebenfalls die genannten Updates neu aufzuspielen. Hoffe es klappt auch bei dir. 

@NorbertFE: Danke für die Hilfe! Um Deine Frage auch noch zu beantworten: Ja und Ja. :)

 

Beste Grüße

Mathias

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Aus allem, was ich dazu in Technet bisher gelesen habe: Scheint ein Fehler im aktuellen .NET 4.7 zu sein... Runter damit auf 4.6 oder 4.5, dann sollte es wieder gehen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×