Jump to content
Sign in to follow this  
overlord

DNS Problem mit _mcdcs

Recommended Posts

Hallo Leute,

 

wie aus heiterem Himmel ein DNS-Problem. Ursache kann ich (noch) nicht feststellen, da an den beteiligten Maschinen nichts verändert wurde.

Folgende Konstellation ist aktuell:

 

Standort A

DC1 IP= .1.3

DNS1=.1.2

DNS2=.1.3

DNS3= .2.3

 

DC3 IP= .1.2

DNS1=.1.3

DNS2=.1.2

DNS3= .2.3

 

Standort B

DC2 IP= .2.3 (PDC)

DNS1=.2.3

DNS2=.1.3

DNS3= .1.2

 

Zwischen den Subnetzen wird nicht gefiltert.

 

Was mir komisch vorkommt, im eventlog (Fehler 4015) bzw. der BPA zeigt u.a. an:

 

Problem:
Die Active Directory-integrierte DNS-Zone _msdcs.domain.de wurde nicht gefunden.

 

Im DNS Manger existiert jedoch auf allen 3 DC´s in der entsprechenden FWD-Lookupzone ein Eintrag _msdcs

Darunter sind die 3 Einträge (CNAME) für die domaincontroller und die weiteren Ordner:

dc

Domains

gc

pdc

 

Auch unter den _sites gibt es entsprechende _ldap SRV´s für die DC´s, scheint also alles da zu sein.....

Habe auf allen DC´s mal noch ein dcdiag /fix durchgeführt, letzter Stand immer mal wieder timeouts bei der Auflösung nach extern.

 

repadmin /syncall verläuft erfolgreich....

 

 

Hat hierzu noch jemand eine Idee was das Problem sein kann?

 

Share this post


Link to post
Share on other sites

Moin,

 

also ist _msdcs bei dir ein Unter-Eintrag der Domänen-DNS-Zone?

 

In dem Fall wird alles funktionieren, nur die Regel im BPA berücksichtigt diesen Sonderfall nicht. Ich nehme mal an, dass eure Domäne noch unter Windows 2000 angelegt wurde, da hat dcpromo das so eingerichtet. Die delegierte Zone gab es, soweit ich mich erinnere, erst ab Windows 2003.

 

Gruß, Nils

Share this post


Link to post
Share on other sites

Hallo,

 

wenn das was Nils geschrieben hat zutrifft und die Fehlermeldung dich stört, kannst du auch eine neue Forward Lookupzone mit dem entsprechenden Namen anlegen. Der Rest geht dann (fast) von selber.

 

Grüße

 

willy

 

 

EDIT: Wenn du mit meinem Geschreibe etwas anfangen kannst, kannst du auch mal in mein Thema dazu kucken. Hatte das "Problem" auch erst vor kurzem und es im Laufe des Themas gelöst:

 

http://www.mcseboard.de/topic/204421-externe-namensaufl%C3%B6sung-im-ad-mit-2-dns-servern-etwas-lahm/

Edited by willy-goergen

Share this post


Link to post
Share on other sites

Moin!

 

Ja, Nils liegt mit seiner Vermutung richtig, also eine NT/2000er weiß ich nicht, aber es war mal ein 2003er AD.

Was mir eben nur komisch vorkommt, dass der Fehler 4015 seit kurzem im eventlog auftaucht!

IdR meldet zB dcdiag /test:dns keine Fehler, aber dann kommt zB wie gerade eben auf DC1:

 

Test Records Registration

Warnung

Fehlender SRV-Eintrag beim DNS-Server .2.3 (=PDC)

_ldap._tcp.gc._mcdcs.domain.de

 

Warnung

Fehlender A-Eintrag beim DNS-Server .2.3 (=PDC)

gc._mcdcs.domain.de

 

 

Und ja, die Struktur sieht so aus:

 

Forwardlookupzonen

---domain1.intra

---domain2.intra

---domain.de

--------_msdcs

--------_sites

--------_tcp

--------_udp

--------DomainDNSZones

--------ForestDNSZones

 

Denkt ihr es macht Sinn dies zu korrigieren oder hat dies nichts direkt mit den Fehlern zu tun?

Share this post


Link to post
Share on other sites

Hallo,

 

den Fehler vom BPA-Analyzer hab ich in der Hoffnung behoben, dass sich da irgendwer etwas dabei gedacht hat, ohne das jetzt weiter zu hinterfragen.

 

Das Problem mit den Timeouts bei Namensauflösung nach extern hatte ich auch. Die sind mal aufgetreten und mal nicht. Insgesamt lief das aber alles sehr zäh. Allerdings hat das bei mir mit ziemlicher Sicherheit daran gelegen, dass die DNS-Server lediglich mit den Stammhinweisen gearbeitet haben und keine Weiterleitungen konfiguriert waren.

 

Das Event 4015 ist bei mir gar nicht aufgetreten.
Eventuell ist dir das eine Hilfe:

https://technet.microsoft.com/de-de/library/cc735674(v=ws.10).aspx

http://www.mcseboard.de/topic/78242-dns-probleme-error-40154004/

https://community.spiceworks.com/topic/873480-event-id-4015-dns-server-active-directory-integration

 

Wenn das alles nichts hilft, solltest du vorher auch einige Fragen stellen und eventuell (auch hier) beantworten:

- Ist die Konfiguration der DNS Server korrekt und nochmal überprüft?

- Wann tritt der Fehler auf? Tritt er öfter auf?

- Tritt er auf allen DCs auf oder nur auf einem?

- Hast du die letzte Zeit irgendeine Änderung am System vorgenommen, die das verursacht haben könnte?

 

Das nur als kleinen Denkanstoß. Vielleicht konnte ich dir helfen.

 

Grüße

 

willy

 

PS: Ich habe es leider zu spät gesehen. Aber du solltest die geposteten Fehlermeldungen nach dem Kopieren vielleicht nochmal lesen, so dass nicht gleich jeder weiß, wo du arbeitest.

Edited by willy-goergen

Share this post


Link to post
Share on other sites

Hallo zusammen,

 

Rückmeldung meinerseits. Der Fehler 4015 ist genauso schnell verschwunden, wie er gekommen ist. Es scheint wieder alles rund zu laufen....

Geblieben sind nur die BPA-Fehler, aufgrund der alten, "falschen" _mcdcs-Struktur:

 

DNS: Sekundäre Server der Zone TrustAnchors müssen auf Abfragen für die Zone reagieren

DNS: Zone _mcdcs.Domain.de ist eine ActiveDirectory integrierte DNS-Zone, die verfügbar sein muss

 

Danke willy für die Infos!

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...