Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
tramp

Ändern der Reihenfolge von Netzwerkprotokollbindungen nicht möglich

Empfohlene Beiträge

Kommen wir wieder zu den DNS-Servern. Siehe weiter oben.

Also doch Dein Lieblingsthema :-)

Aber ich benutzte (viel) früher ebenfalls diesen Standardsatz , als ich noch mehrere Domänennetzwerke aufbaute und betrieb.

 

Nochmals:

Die NIC (hier Ethernet 4) hat aktiviertes DHCP, bekommt alles korrekt von der FritzBox.

Wenn ich den VB Host-OnlyNetwork Adapter deaktiviere, dann ist alles ok, wenn er aktiviert ist, dauert es 3-4 Sekunden.

Die virtuellen VMWare Adapter haben keinen Einfluss darauf.

 

Wenn ich die IP-Einstellungen der Ethernet 4 NIC von selbst eingebe, ob ich IPv6 verwende oder deaktiviere, oder ob ich an der Schnittstellenmetrik drehe, hat alles ebenfalls keinen Einfluss.

 

Gibt es ein Programm (ähnlich wie tracert), das mir zeigt, was Windows da bis zum Anzeigen der Seite tut?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nimm Wireshark und beobachte die DNS-Queries.

 

Mit dem Wireshark habe ich noch nichts sinnvolles herauslesen können.

 

Aber ich habe inzwischen mal den DNS-Eintrag im VirtualBox Host-Only-Adapter entfernt und jetzt scheint es seit ein paar Stunden zu klappen.

Bei den VMWare virtuellen Adapter steht auch keiner drin.

post-34225-0-89569600-1443346092_thumb.jpg

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ach doch.. ;)

Na gut :-)

 

Bleibt nur noch die Frage, warum bei einer virtuellen NIC nichts im DNS-Eintrag stehen darf (es war egal, was für eine Adresse) und warum das BS sich über die (veraltete) Bindungsreihenfolge und Metrik hinweg sieht.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Bindungsreihenfolge und Metrik entscheiden, über welches Netzwerkinterface der Traffic gehen soll für ein nicht-lokales Netzwerk. Dein Problem hat damit nix zu tun.

 

Du wunderst Dich, warum DNS-Antworten länger brauchen. Der DNS-Resolver wurde unter Windows 10 geändert und befragt alle DNS-Server gleichzeitig. Vermutlich antwortet einer Deiner konfigurierten DNS-Server nicht und es dauert bis zum Timeout von 10 Sekunden, bis der Resolver dann antwortet.

 

Experimentiere mal mit den beiden Einstellungen hier:

 

Turn off smart multi-homed name resolution

 

Specifies that a multi-homed DNS client should optimize name resolution across networks. The setting improves performance by issuing parallel DNS link local multicast name resolution (LLMNR) and NetBIOS over TCP/IP (NetBT) queries across all networks. In the event that multiple positive responses are received the network binding order is used to determine which response to accept.If you enable this policy setting the DNS client will not perform any optimizations. DNS queries will be issued across all networks first. LLMNR queries will be issued if the DNS queries fail followed by NetBT queries if LLMNR queries fail.If you disable this policy setting or if you do not configure this policy setting name resolution will be optimized when issuing DNS LLMNR and NetBT queries.

Policy path: Network\DNS Client

Scope: Machine

Supported on: At least Windows Server 2012 Windows 8 or Windows RT

Registry settings: HKLM\Software\Policies\Microsoft\Windows NT\DNSClient!DisableSmartNameResolution

Filename: DnsClient.admx

 

 

DisableParallelAandAAAA (DWORD)

 

In registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters.

The value is 0 to enable, 1 to disable DNS A and AAAA queries from executing in parallel on all configured DNS servers, with the fastest response being theoretically accepted first.

bearbeitet von Daniel -MSFT-

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Bindungsreihenfolge und Metrik entscheiden, über welches Netzwerkinterface der Traffic gehen soll für ein nicht-lokales Netzwerk. Dein Problem hat damit nix zu tun.

 

Du wunderst Dich, warum DNS-Antworten länger brauchen. Der DNS-Resolver wurde unter Windows 10 geändert und befragt alle DNS-Server gleichzeitig. Vermutlich antwortet einer Deiner konfigurierten DNS-Server nicht und es dauert bis zum Timeout von 10 Sekunden, bis der Resolver dann antwortet.

 

 

Danke.

zahni hatte hier http://www.mcseboard.de/topic/204569-%C3%A4ndern-der-reihenfolge-von-netzwerkprotokollbindungen-nicht-m%C3%B6glich/?do=findComment&comment=1278995

geschrieben, dass Win10 die Bindungsreihenfolge ignoriert und alles durch die automatische Metrik geregelt wird (oder werden sollte).

 

Ich musste nie, wie Du schriebst, 10 Sekunden warten, nach höchstens 3-4 Sekunden war die neue URL "da".

Nachdem ich den DNS-Eintrag im virtuellen VB Host-only-Ethernet-Adapter gelöscht habe (ohne einen Einfluss auf die virtuellen Maschinen), dauert es nur vielleicht 0,5 Sekunden.

Ich habe die VirtualBox bereits mehrmals neu installiert und weiß im Augenblick noch nicht, woher der DNS-Eintrag kommt (ich muss das mal auf einem zweiten PC testen).

 

Zu Deinem Tipp: wenn ich mal mehr Zeit für so etwas habe, probiere ich es.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

 

um noch kurz was in die Runde zu werfen: Die Probleme, die ich auf meinem Rechner habe (ich erwähnte das weiter oben), haben nichts mit der Bindungs- oder Abfragereihenfolge zu tun. Hier ist es offenbar der WLAN-Treiber, der nicht richtig mit dem Hibernate umgehen kann. Derzeitiger Workaround: Wenn er spinnt, einmal deaktivieren und wieder aktivieren. Hatte ich schon mal unter Windows 7.

 

Gruß, Nils

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

×