Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
exchge

SBS2011 skript Backup auf NAS

Empfohlene Beiträge

hi,

 

ich möchte gerne mit normalen Boardmitteln Backups auf unserem NAS sichern.


Von Haus aus geht ja immer nur eins. (wobei der sbs auch hier andauernd mit Fehlern abbricht)

 

Hat da jemand eine funktionierende batch wie man mehrer backups auf dem nas speichern kann? (wbadmin+ordner umbenennen oder so?)

 

bin ein sch+#+ß Programmierer!

 

danke!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

So könnte z.B. so ein Skript aussehen:

 

REM zuerst Backup Verzeichnis der NAS mappen und alte Verzeichnisse löschen

REM Anzahl = Anzahl der Verzeichnisse, die nicht gelöscht werden

REM

REM fuer Aktivierung ECHO entfernen, ansonsten nur Anzeige

REM

 

 

net use x: \\NAS\Backup

set Loesch=X:\

set Anzahl=5

REM

for /f "skip=%Anzahl%" %%i in ('dir /AD /B /O-D %Loesch%') do echo rd /s /q "%Loesch%\%%i"

 

REM neues Backupverzeichnis nach Datum erstellen

set jahr=%date:~-4%

set monat=%date:~-7,2%

set tag=%date:~-10,2%

 

set newfolder=%jahr%-%monat%-%tag%

mkdir X:\%newfolder%

 

REM Backup durchführen

REM wbadmin Befehlszeile einfügen, z.B

wbadmin start backup -allCritical -include:d: -backupTarget:X:\%newfolder% -vssfull -quiet

 

REM Variablen loeschen

net use X: /delete /yes > NUL

set Loesch=

set Anzahl=

set jahr=

set monat=

set tag=

set newfolder=

 

LG Günther

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

hi G., von wegen habs doch nicht hinbekommen. :( Also ich habe ein QNAP 219+ was auch in der Domäne ist. Dort habe ich ein Laufwerk gemappt. Er erkennt auch alle Domänennutzer - trotzdem muss ich mich beim Mappen immer mit dem lokaluser anmelden. Dann läuft es auch. Nach gewisser Zeit verschwindet das LW aber. habe noch nebenbei ein robocopy laufen - das bricht dann immer irgendwann ab, genauso wie das Windowsbackup - Ziellaufwerk nicht erreichbar. Wenn ich das Laufwerk öffnen will kommt die Fehlermeldung: Fehler bei der erneuten Verbindungswiederherstellung mit LW X Micorsoft windows network:Der lokale Gerätename wird schon verwendet. versuche jetzt nochmal das gemappte lw zu trennen und nur mit netzwerkpfaden zu arbeiten hoffe das bringt was .. ?? http://forum.qnapclub.de/viewtopic.php?f=35&t=22690 ??? Hilfä! thx!

bearbeitet von exchge

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi.

 

Baue deine Scripts so auf, dass nach Jobende das Mapping immer gelöscht wird, und sich die Jobs nicht überschneiden.

 

Wobei wbadmin sowieso nicht auf gemappte Laufwerke sichern kann.

 

LG Günther

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

 

das Wort Ereignisanzeige habe ich in diesem Thread nicht gelesen bisher.

 

Also, was steht in der Ereignisanzeige, gibt es darin Fehlermeldungen und Warnungen, die mit dem Problem, den Problemen zu tun haben könnten?

 

Hat das NAS eine Ereignisanzeige?

 

Ist eine Netzlaufwerk für das Backup überhaupt notwendig, ist es nicht möglich auf dem UNC-Pfad?

 

Ich sichere auch auf ein NAS, auch per robocopy, auf UNC-Pfad.

bearbeitet von lefg

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Mal so eine ganz naive Frage - warum sicherst Du nicht per Server-Sicherung auf das NAS? Richte das NAS als iSCSI-Laufwerk ein, richte dieses auf dem Server ein und konfiguriere die Serversicherung - entweder per Console oder händisch...

So würde ich das machen ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@kk: gerne wie stelle ich das an?

 

@all: die Freigabe/Nas verschwindet andauernd - ich mappe nichts mehr sondern benutze nur noch unc-pfade

 

wenn ich versuche zu mappen: fehlermeldung: der angegebene Netzwerkname ist nicht merh verfügbar

 

obwohl das nas da ist, per webkonsole komme ich rauf

 

@lefg:

 

Backup

Ereignisdetails:   

Fehler beim Starten der um ‎2013‎-‎07‎-‎04T01:00:46.768604300Z auszuführenden Sicherung. Fehlercode: "2155348081" (Der freigegebene Remoteordner ist nicht vorhanden.). Suchen Sie in den Ereignisdetails nach einer Lösung, und führen Sie die Sicherung erneut aus, nachdem das Problem behoben wurde.

 

DCOM konnte mit dem Computer "nas.domain.de" unter Verwendung eines beliebigen, konfigurierten Protokolls keine Daten austauschen.

(die fehlermeldung gibt es ohne ende)

 

danke leutz!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

die Freigabe/Nas verschwindet andauernd - ich mappe nichts mehr sondern benutze nur noch unc-pfade

 

Dann hast du anscheinend Probleme mit deiner NAS, die zuerst behoben werden müssen.

 

 

DCOM konnte mit dem Computer "nas.domain.de"

 

Das ist normal, da Windows mit einem Samba Rechner nichts anfangen kann. Nimm die NAS wieder aus Domäne, und der Fehler verschwindet.

 

Und zum Thema iSCSI. Schau in der Beschreibung der NAS nach, ob die das kann. Wenn ja, dann hilft dir das Handbuch weiter.

 

LG Günther

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi günther,

 

es läuft jetzt alles super,

 

aber ... :)

 

leider löscht er die alten ordner nicht. deswegen bekomme ich aller 3 tage die fehlermeldung nix backup wegen nix platz.

 

wie kann ich ihm sagen das er nach 3 tagen die alten löscht?

 

danke!

 

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

wie kann ich ihm sagen das er nach 3 tagen die alten löscht?

 

Wenn du den kompletten von mir geposteten Script benutzt und ihn 1:1 übernommen hast, dann musst du nur einmal lesen, was unter Anmerkungen angeführt ist.

 

Wenn du diesen Script nicht verwendest, dann musst du uns mehr Infos liefern.

 

LG Günther

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

hi g,

 

also ich habe dein skript 1zu1 übernommen (nur den wbadmin noch verfeinert) und anzahl steht auf 3 - trotzdem macht er munter weiter und versucht backup nr4 zu erstellen ohne ein altes zu löschen.

 

was mache ich falsch? - hier mein skript!

 

danke!

 

[

 

REM zuerst Backup Verzeichnis der NAS mappen und alte Verzeichnisse löschen
REM Anzahl = Anzahl der Verzeichnisse, die nicht gelöscht werden
REM
REM fuer Aktivierung ECHO entfernen, ansonsten nur Anzeige
REM
 
 
net use x: \\NAS\Backup\wbadmin
set Loesch=X:\
set Anzahl=3
for /f "skip=%Anzahl%" %%i in ('dir /AD /B /O-D %Loesch%') do echo rd /s /q "%Loesch%\%%i"
 
REM neues Backupverzeichnis nach Datum erstellen
set jahr=%date:~-4%
set monat=%date:~-7,2%
set tag=%date:~-10,2%
 
set newfolder=%jahr%-%monat%-%tag%
mkdir X:\%newfolder%
 
REM Backup durchführen
REM wbadmin Befehlszeile einfügen, z.B
wbadmin start backup -allCritical -include:C:,D:,E: -backuptarget:\\nas\backup\wbadmin\%newfolder% -vssfull -quiet
 
REM Variablen loeschen
net use X: /delete /yes > NUL
set Loesch=
set Anzahl=
set jahr=
set monat=
set tag=
set newfolder=

 

]

bearbeitet von exchge

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo.

 

 

dann musst du nur einmal lesen, was unter Anmerkungen angeführt ist.

 

Warum machst du nicht das was dir geschrieben habe? Da steht doch klar: "fuer Aktivierung ECHO entfernen, ansonsten nur Anzeige" - also entferne an der Stelle "do echo rd /s /q "%Loesch%\%%i"" den Befehl echo, und es wird klappen.

 

LG Günther

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

Werbepartner:


×