Jump to content

Login auf Terastation nur möglich über Hostname


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo Zusammen,

 

gestern habe ich versucht eine Buffalo Terastation in eine frisch eingerichtete Windows Server 2008 R2 Domäne zu integrieren. Auf der Terastation kommt die neuste Firmare 1.55 zum Einsatz.

 

Leider haben wir nun das Problem, dass ein Login auf der Terastation über ActiveDirectory-Benutzer nur funktioniert, wenn auf die Terastation über ihren Hostnamen zugegriffen wird. Wird hingegen direkt über die IP-Adresse zugegriffen, so ist kein Login mit den Zugangsdaten des AD-Benutzers möglich.

Die Einstellungen der Terastation lauten:

 

Authentifizierungsebene: Active Directory

Domänenname (NetBIOS-Name) für Active Directory: example

Domänenname (DNS-/Ream-Name) für Active Directory: example.local

Name des Domänencontrollers: windc

IP-Adresse des WINS-Servers: <leer>

 

Auch ist der Primäre DNS-Server auf die IP-Adresse des Domänencontroller (hier läuft auch das DNS) gesetzt.

 

Einstellungen auf dem Domänencontroller:

 

Die Terastation wird in der Domäne unter "Computers" gelistet.

 

Computername (Prä-Windows 2000): terastation

DNS-Name: terastation.example.local

Domänencontrollertyp: Arbeitsstation oder Server

 

Unter dem Reiter "Delegierung" ist ausgewählt: Computer bei Delegierung aller Dienste vertrauen (nur Kerberos)

 

DNS-Einstellungen:

 

In der Forward-Lookupzone existiert unter der Domäne ein A-Record auf die terastation.

 

In der Reverse-Lookupzone existiert ein PTR auf die IP-Adresse der terastation.

 

Ein

nslookup terastation.example.local

und ein

nslookup 192.168.205.14

liefern korrekte Werte zurück.

 

Das Ereignisprotokoll auf dem Domänencontroller zeigt beim Loginversuch über den Hostnamen einen korrekten Login an. Auch der verwendete Benutzername ist in den Logfiles aufgeführt. Bei einem Login über die IP-Adresse werden keine Einträge geschrieben. Bzw. ich bin mir hier nicht ganz sicher, da sich teilweise einige Sekunden später folgende Ereignisse im Protokoll finden lassen:

 

4672 Spezielle Anmeldung

 

Einer neuen Anmeldung wurden besondere Rechte zugewiesen.

 

Antragsteller:

Sicherheits-ID: SYSTEM

Kontoname: WINDC$

Kontodomäne: EXAMPLE

Anmelde-ID: 0x1493c6

 

4624 Anmelden

 

Ein Konto wurde erfolgreich angemeldet.

 

Antragsteller:

Sicherheits-ID: NULL SID

Kontoname: -

Kontodomäne: -

Anmelde-ID: 0x0

 

Anmeldetyp: 3

 

Neue Anmeldung:

Sicherheits-ID: SYSTEM

Kontoname: WINDC$

Kontodomäne: EXAMPLE

Anmelde-ID: 0x1493c6

Anmelde-GUID: {d8a79e38-1bf2-e1c9-5bff-4dc40498beef}

 

Prozessinformationen:

Prozess-ID: 0x0

Prozessname: -

 

Netzwerkinformationen:

Arbeitsstationsname:

Quellnetzwerkadresse: ::1

Quellport: 59110

 

Detaillierte Authentifizierungsinformationen:

Anmeldeprozess: Kerberos

Authentifizierungspaket: Kerberos

Übertragene Dienste: -

Paketname (nur NTLM): -

Schlüssellänge: 0

 

4634 Abmelden

 

Ein Konto wurde abgemeldet.

 

Antragsteller:

Sicherheits-ID: SYSTEM

Kontoname: WINDC$

Kontodomäne: EXAMPLE

Anmelde-ID: 0x1493c6

 

Anmeldetyp: 3

 

Für mich klingt das alles nach irgendeinem DNS-Problem. Ich versteh nur nicht was genau schief läuft und wäre über passende Hinweise sehr dankbar :)

 

viele Grüße

 

Stephan

Link to comment

Hallo!

 

Interessant wäre mal die genaue IP-Konfiguration der Terrastation.

Da der Forward-Lookup ja offenbar funktioniert, glaube ich hier nicht an ein DNS-Problem.

Treten denn noch ander DNS-Probleme in der Domäne auf?

 

Netzwerkinformationen:

Arbeitsstationsname:

Quellnetzwerkadresse: ::1

 

Unterstützt die NAS auch IPv6?

Gibt es Records dazu im DNS?

 

Grüße

Link to comment

Hallo Gabriel,

 

danke für deine Nachricht.

 

Interessant wäre mal die genaue IP-Konfiguration der Terrastation.

 

DHCP: Deaktiviert

Primäre IP-Adresse: 192.168.205.14 (liegt somit im gleichen Netz wie der primäre Domänencontroller)

Subnetzmaske: 255.255.255.0

 

Standard-Gateway-Adresse: 192.168.205.1 (das ist die IP-Adresse des Routers)

Primärer DNS-Server: 192.168.205.10 (IP-Adresse des primären Domänencontrollers)

 

Ethernet-1-Frame-Größe: 1.518 Byte (Standard)

 

Port-Trunking: Aus

 

Aktivierte Dienste: HTTP, HTTPS, SMB, AFP, Backup/Replikationsdienst, NasNavi-Erkennung, NFS, SFTP, WebAccess, TeraSearch, Koordiniertes Ein-/Ausschalten, Media Server, iTunes-Server, BitTorrent

 

Da der Forward-Lookup ja offenbar funktioniert, glaube ich hier nicht an ein DNS-Problem.

Treten denn noch ander DNS-Probleme in der Domäne auf?

 

mir sind sonst keine DNS-Probleme aufgefallen. Da sämtliche Netzwerkgeräte als primären Nameserver den Domänencontroller eingestellt haben wüsste ich auch nicht, warum DNS-Probleme auftreten sollten. Bei meinen Tests konnten problemlos alle Adressen aufgelöst werden.

 

Unterstützt die NAS auch IPv6?

Gibt es Records dazu im DNS?

 

die Terastation unterstützt meines Wissens nach kein IPv6. Zumindest gibt es keine Möglichkeit eine IPv6-Adresse zu konfigurieren. Im DNS habe ich nur einen A-Record und einen PTR-Eintrag für Reverse-DNS (manuell) angelegt. Bei der Einbuchung der Terastation in das AD wurden diese nämlich nicht automatisch angelegt.

 

Gruß

Stephan

Edited by stephanmunz
Link to comment

Hallo!

 

Im DNS habe ich nur einen A-Record und einen PTR-Eintrag für Reverse-DNS (manuell) angelegt. Bei der Einbuchung der Terastation in das AD wurden diese nämlich nicht automatisch angelegt.

 

Teste mal probeweise das deaktivieren sämtlicher, nicht zwingender Dienste auf der NAS. Hast du mal geprüft, ob es evtl. ein Update der Firmware für die NAS gibt?

 

Wenn das alles nicht hilft, würde ich sagen: Freunde dich einfach damit an, daß es nur über den Namen funktioniert. Gibt schlimmere Störungen.

 

Eine Alternative wäre noch FreeNAS, wenn du den Konfigurationsaufwand nicht scheust. ;)

 

Download FreeNAS from SourceForge.net

 

Grüße

Link to comment

Hallo Gabriel,

 

Teste mal probeweise das deaktivieren sämtlicher, nicht zwingender Dienste auf der NAS.

 

das werde ich einmal testen und dann hier berichten.

 

Hast du mal geprüft, ob es evtl. ein Update der Firmware für die NAS gibt?

 

ich habe gleich zu Beginn der Problematik uach eine neue Firmware installiert.

 

Wenn das alles nicht hilft, würde ich sagen: Freunde dich einfach damit an, daß es nur über den Namen funktioniert. Gibt schlimmere Störungen.

 

das Problem ist, dass es VPN-Benutzer gibt, welche direkt über die IP darauf zugreifen. Das spart dann die Umkonfigurierung der eingestellten Nameserver und ist weniger fehleranfällig. Das klappt so natürlich nicht mehr :(

 

Eine Alternative wäre noch FreeNAS, wenn du den Konfigurationsaufwand nicht scheust. ;)

 

ich weiß gar nicht ob das auf der Terastation laufen würde (wobei eigentlich nichts dagegen spricht). Aber das erscheint mir schon ein großer Aufwand zu sein ...

Link to comment
Hallo,

 

ist das nicht ein Indiz für ein grundlegendes Problem?

 

diese Einträge wurden bei mir auch in anderen Domänen noch nie automatisch bei einer Terastation angelegt. Auch finde ich generell im Internet den Hinweis, dass diese manuell angelegt werden müssen. Z.B. hier unter "Vorarbeiten am Domänencontroller": http://www.buffalo-technology.com/knowledgebase/users/kb.php?id=10228&category_id=14&sid2

 

//Nachtrag: Oder auch hier: http://buffalo.nas-central.org/index.php/Joining_Active_Directory

 

Ältere Terastations habe ich so problemlos in Win2k3-ADs einbinden können. Hier funktioniert auch alles über die IP. Die AD-Unterstützung der Terastation scheint mir aber generell nicht so der Hit zu sein ...

Link to comment
Kann man denn ein Linux tatsächlich zum Member einer Windoes 200x Domän machen, in ein AD joinen?

 

die Terastation bietet das in der Weboberfläche an. Das klappt sonst auch gut und die Terastation zeigt auf der Weboberfläche die Domänenbenutzer und Domänengruppen an. Ich nutze auch sonst in anderen Domänen Terastations und das seit Jahren ohne große Probleme. Das scheint also schon zu klappen. Allerdings scheinen mir bei der Terastation die passenden DNS-Einträge nicht automatisch angelegt werden. Die Integration in eine Domäne ist daher sicherlich nicht perfekt gelöst.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...