Jump to content
Sign in to follow this  
michael771

Globalen Katalog auf DC erzwingen?

Recommended Posts

Hallo,

 

ich möchte einen Exchange 2010 Server installieren, was mir so einiges Kopfzerbrechen bereitet... bevor ich das nämlich in unserer echten Umgebung mache, möchte ich das in einer Testumgebung (Esxi) probieren!

 

Ich erkläre erst mal am besten was ich gemacht habe:

Ich habe mir in der Testumgebung (Esxi) einen frischen Server2008R2 installiert. Ich hab zur Vorbereitung für die Exchange Installation das

  • Office 2007 Filterpack installiert,
  • IIS-Installiert,
  • WWW-Dienst neugestartet,
  • Net.Tcp-Portfreigabe auf automatisch gesetzt
  • und Desktopdarstellung installiert.

soweit so gut...

 

Der Exchange Server braucht aber natürlich ein Active Directory. Natürlich möchte ich die Schema-Erweiterung, die der Exchange automatisch macht, nicht am Produktiv-System ausprobieren...

 

Ich habe mir also unseren Domaincontroller als VM auf meine Testumgebung (Esxi) gezogen. Als nächstes habe ich den Server2008R2 der Domäne beitreten lassen und die Installation des Exchange gestartet...

 

Jetzt fangen die Probleme an. Ich erhalte folgende Fehlermeldung:

"Fehler:
Problem beim Überprüfen des Status von Active Directory: In der Gesamtstruktur [i]meine-domain.org[/i] konnte kein globaler Katalog gefunden werden."

 

In der echten Umgebung existiert noch ein 2. sekundärer Domänencontroller der wohl den Globalen Katalog hat.

 

Ich hab also unter Active Directory-Standort und -Dienste -> Sites -> Ort -> Servers -> NTDS Settings

 

den Haken bei Globale Kataloge vom 2. Domänencontroller entfernt und ihn beim ersten gesetzt... und einen Reboot gemacht. Der 2. Domänencontroller existiert aber in der VM nicht. (kann ja auch passieren, dass der Domänenkontroller wegen einem Hardwaredefekt unwiederherstellbar abraucht :) )

 

Leider kommt die gleiche Fehlermeldung bei der Exchange Installation. Was kann ich tun? (an den 2. Domänencontroller komm ich nicht ran.)

 

Nochmal ein Screenshot mit der Fehlermeldung:

NeueBitmap.png

Edited by michael771

Share this post


Link to post
Der Exchange Server braucht aber natürlich ein Active Directory. Natürlich möchte ich die Schema-Erweiterung, die der Exchange automatisch macht, nicht am Produktiv-System ausprobieren...

 

Warum nicht? :) Die funktioniert ohne Probleme.

 

Ich habe mir also unseren Domaincontroller als VM auf meine Testumgebung (Esxi) gezogen. Als nächstes habe ich den Server2008R2 der Domäne beitreten lassen und die Installation des Exchange gestartet...

 

Wieviele DCs hast du denn?

 

Jetzt fangen die Probleme an. Ich erhalte folgende Fehlermeldung:

"Fehler:
Problem beim Überprüfen des Status von Active Directory: In der Gesamtstruktur [i]meine-domain.org[/i] konnte kein globaler Katalog gefunden werden."

 

Ist dein DC denn kein GC? Falls ja, warum nicht?

 

In der echten Umgebung existiert noch ein 2. sekundärer Domänencontroller der wohl den Globalen Katalog hat.

 

Mach alle DCs zum GC. Oder was versprichst du dir von deiner jetzigen Konfiguration?

 

Ich hab also unter Active Directory-Standort und -Dienste -> Sites -> Ort -> Servers -> NTDS Settings

 

den Haken bei Globale Kataloge vom 2. Domänencontroller entfernt und ihn beim ersten gesetzt... und einen Reboot gemacht.

 

Häh? Warum machst du denn so einen Quark? Setz ihn einfach bei beiden.

 

Leider kommt die gleiche Fehlermeldung bei der Exchange Installation. Was kann ich tun? (an den 2. Domänencontroller komm ich nicht ran.)

 

Wir reden hier über die geclonte VM Installation? Schmeiß den zweiten DC mittels ntdsutil raus und mach den einen DC zum GC. Fertig.

 

Bye

Norbert

Share this post


Link to post
Warum nicht? :) Die funktioniert ohne Probleme.

Ich hab da bedenken wenn was schief läuft. Da ist ja auch noch ein Exchange 2003 im Produktiv System unterweg.

 

Wieviele DCs hast du denn?

Im echten System 2! Der Primäre in Hyper-V und den 2. physisch. Obwohl der nur der sekundäre ist.

 

In meiner Testumgebung habe ich jetzt den Primären von Hyper-V mittels Starwind für den Esxi in eine VMDK umgewandelt. Läuft auch ganz gut.

 

Ist dein DC denn kein GC? Falls ja, warum nicht?

Sollte er sein...aber Exchange meckert mich trotzdem an (siehe Fehlermeldung)

 

Häh? Warum machst du denn so einen Quark? Setz ihn einfach bei beiden.

Ja, aber der 2. Server existiert doch in meiner Testumgebung nicht. Man könnte es ja auch so sehen: Angenommen mir raucht der 2. Domänencontroller unwiederherstellbar ab, was dann?

 

Wir reden hier über die geclonte VM Installation? Schmeiß den zweiten DC mittels ntdsutil raus und mach den einen DC zum GC. Fertig.

Ja, der primäre ist geclont. Ich möchte halt unsere Domäne in der Testumgebung nachbilden. Aber eben nur mit den Primären Domänencontroller.

 

Wie geht das genau mit ntdsutil wenn es den 2. Domänencontroller nicht in meiner Testumgebung gibt?

Share this post


Link to post
Ja, der primäre ist geclont. Ich möchte halt unsere Domäne in der Testumgebung nachbilden. Aber eben nur mit den Primären Domänencontroller.

 

Dann solltest du dir vorher erstmal überlegen, wie sowas abläuft und nicht einfach erwarten, dass du sowas mal eben kopieren kannst und es funktioniert. ;)

 

Wie geht das genau mit ntdsutil wenn es den 2. Domänencontroller nicht in meiner Testumgebung gibt?

 

Google ;)

 

Du suchst metadatacleanup

 

Bye

Norbert

Share this post


Link to post
Aber prinzipiell funktioniert mein Vorhaben? :wink2:

 

Ja, wenn man weiß, was man tut. Nur sollte man dann mit der Testumgebung vorsichtig umgehen, da sie alle Sicherheitsinformationen der Liveumgebung enthält. Und du wärest nicht der erste, der voller Überzeugung in der Testumgebung was löscht und danach feststellt, dass es ****erweise doch die identisch heißende Liveumgebung war. :p

 

Bye

Norbert

 

PS: Dass eine strikte Trennung dieser beiden Umgebungen immer einzuhalten ist, brauch ich nicht erwähnen, oder?

Share this post


Link to post
Ich hab da bedenken wenn was schief läuft. Da ist ja auch noch ein Exchange 2003 im Produktiv System unterweg.

Meinst du, du bist der erste der das ausprobiert?

Share this post


Link to post
Natürlich möchte ich die Schema-Erweiterung, die der Exchange automatisch macht, nicht am Produktiv-System ausprobieren...

 

Du wirst nicht darum herumkommen, das irgendwann doch zu tun. Du willst am Ende ja den Exchange Server 2010 in der produktiven Umgebung einsetzen.

 

Falls Du wirklich so furchtbar Angst vor der Schemaerweiterung hast, kannst Du

 

1.) temporär einen zusätzlichen virtuellen DC in die produktive Umgebung aufnehmen;

2.) diesem die notwendigen FSMO-Rollen übertragen;

3.) die ausgehende Replikation auf diesem DC mit repadmin deaktivieren;

4.) die Schemaerweiterung gegen diesen DC ausführen;

5.) die ausgehende Replikation auf diesem DC wieder aktivieren, wenn alles gut gegangen ist.

 

Wenn nicht (was kaum passieren wird), schaltest Du den DC aus, erzwingst die Übertragung der zuvor übertragenen FSMO-Rollen auf einem anderen DC und führst eine Bereinigung der Metadaten durch. Soweit wird es aber bestimmt nicht kommen.

Share this post


Link to post
Off-Topic:
Alles klar, fürchtete schon, unverständliches Gemurmel von mir gegeben zu haben. :shock:

Meistens antworte ich nicht nur dem TO, sondern allen, die das heute und in Zukunft je lesen könnten. Der eien oder andere könnte es ja verstehen. Einen haben wir ja schon...:D

Share this post


Link to post

Moin,

 

Falls Du wirklich so furchtbar Angst vor der Schemaerweiterung hast, kannst Du

 

dieses Verfahren ist "not recommended"! Microsoft rät ausdrücklich davon ab.

 

Friday Mail Sack ? I live again edition - Ask the Directory Services Team - Site Home - TechNet Blogs

 

Es ist gar keine falsche Idee, das Schema-Update unter realistischen Bedingungen zu testen. Wobei man allerdings im Fall von Exchange 2010 wirklich davon ausgehen kann, dass das bereits ausreichend getestet ist.

 

Gruß, Nils

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...