Jump to content
Sign in to follow this  
saggi

Fehler bei Migration SBS 2008 > SBS2008

Recommended Posts

Hallo,

 

ich bin ja gerade dabei unseren "alten" SBS 2008 aus verschiedenen Gründen auf neue Hardware zu schieben.

 

Das ganze hat in der Testumgebung auch reibungslos geklappt als Windows dann endlich mal das Antwortfile gefunden hat.

 

Nun habe ich auf dem echten Server allerdings ein Problem.

 

Folgendes habe ich gemacht:

AntwortFile erstellt

Antwortfile in neuen Server eingebunden

der neue Server übernimmt auch soweit alles wunderbar -> ja bis zum Schritt Dateien werden expandiert (das 2.mal, nicht da wo man dann noch die Firmendaten etc tippen müsste.)

 

Nun macht er nämlich nichts mehr und alle 20 Minuten kommt die Meldung das die replikation lange dauert und ob ich diese denn weiter laufen lassen möchte. Wenn ich dies nicht machen würde ist davon auszugehen, dass es eunen Datenverlust gibt blabla.....

 

Ich habe dann auf dem neuen Server einmal den Taskmgr gestartet und habe via CMD mal nach *.log Dateien von der Installation ausschau gehalten.

 

Ist ja auch nicht so schwer ;)

 

Habe mir die Logs dann auf nen Netzlaufwerk gekopiert weil es mehrere und große Dateien waren (type ist das nicht so schön)

 

HINWEIS: Hier ist übrigens interessant - die Laufwerke waren schon aktiv! Wurden also bereits vom alten Server übernommen! Ich sehe den neuen Server auch schon unter Domaincontroller auf dem alten Ding - auch als TYP GC...wobei der alte auch noch GC ist.

 

So, dann habe ich die SBSSetup.log mal geöffnet und finde am Ende der Datei immer wieder den Eintrag:

 

[3872] 101215.084402.7708: Setup: DsGetDcName returned: 0
[3872] 101215.084402.7708: Setup: DsGetDcName returned name: Server.Server24.local
[3872] 101215.084402.7708: Setup: Expected name: Server2.Server24.local
[3872] 101215.084402.7708: Task: 	There are 0 pending replication operations.
[3872] 101215.084402.7708: Setup: 	Attempting LDAP bind.
[3872] 101215.084402.7708: Setup: 	Bind successful
[3872] 101215.084402.7708: Task: Waiting for replication to finish
[3872] 101215.084902.7756: Task: 	Finished waiting.

 

Mein English könnte besser sein, aber wnen ich alles richtig verstehe ;) will er das der DC Server2 heißt ...bekommt aber immer die Meldung das es Server ist....aber warum??

 

Im Ereignissprotokoll steht im übrigen

"Das Computer "LPDSVC"-Einstellungselement im Gruppenrichtlinienobjekt "Default Domian Policy.....wurde nicht übernommen, da ein Fehler mit Fehlercode "0x80070424 Der angegebene Dienst ist kein installierter Dienst." Dieser Fehler wurde unterdrückt. aufgetreten ist"

 

als letzter Eintrag.

 

 

Hat das schonmal jemand gehabt?

 

Ich habe bereits nach "there are 0 pending..." gegoogelt aber man findet dazu nichtmal sch.... sondern einfach garnix....

 

Ich hoffe mal das Ihr vielleicht etwas dazu wissen.

 

Als Anhang habe ich mal die Meldung mit der langen Replizierung angefügt

post-55924-13567389914813_thumb.jpg

Edited by saggi

Share this post


Link to post

Wir haben dieses Problem in SBS- und Nicht-SBS-Umgebungen angetroffen. Ursachen waren unterschiedlich, z.B. FRS auf dem Quellserver oder früher ausgeführte autoritative AD-Wiederherstellungen auf dem Quellserver etc. Je nachdem ist der Lösungweg definiert.

 

Du erwähnst ja:

 

ich bin ja gerade dabei unseren "alten" SBS 2008 aus verschiedenen Gründen auf neue Hardware zu schieben.

 

Die verschiedenen Gründe wären hier möglicherweise aufschlussreich.

 

Das ganze hat in der Testumgebung auch reibungslos geklappt als Windows dann endlich mal das Antwortfile gefunden hat.

 

Weil es nicht der gleiche Quellserver war. Du kannst mit sehr hoher Wahrscheinlichkeit davon ausgehen, dass nicht der neue SBS 2008 die Replikationsprobleme verursacht, sondern der Quellserver.

Share this post


Link to post

Hallo,

 

danke für die schnlle Antwort.

 

Die Probleme sind folgende:

 

Wir haben vor ca. einem Jahr unsere Domäne umgestellt von 2000 auf 2008.

In diesem Zusammenhang wurden 2 neue Server gekauft um zwei zuvor auf einem Server liegende Aplikationen zu trennen.

 

Wir haben das ganze budgetiert (das ist immer ein Kampf um jeden Euro bei uns.."..ist ja nicht nötig"..)

und dann die Server gekauft.

 

Geplan war dann folgendes:

Neuer DC soll der "alte" Server werden, welcher vorher die Aplikationen gehostet hat

Dieser wäre dafür auch - so denke ich ausreichend gewesen.

 

Nun haben wir aber kurz vor der Umstellung die Meldung bekommen, dass die neue Domäne VORHER bereitstehen muss, weil z.B. informix sonst nicht in diese installiert werden kann.

 

Wir haben daraufhin nun also schnell einen neuen Server gekauft für den SBS2008 (das gleiche hier beim Budget wie oben)

 

dieser hat nun leider nur einen onBoard Raid - 5 und ist lahm wie 14 Schildkröten zusammen!

Beispiel: 2 kleine Fehler welche im Raid gefunden wurden dauern 18h zur Wiederherstellubng

Eine ausgefallene HDD benötigt über 36h zur Wiederherstellung.

 

Wenn wir Updates auf dem Server installieren, fährt dieser ca 5 Stunden neu hoch. Beim booten zeigt er nämlich die 16000 Einstellungen die er macht einzeln an..und man kann wirkluch mitlesen so langsam ist das...

 

Dieser Server soll nun neue Hardware bekommen sprich ein schönes Raid 10 mit eigenem Controller.

 

Das System selbst muss aber noch irgendwo eine Macke haben - wir finden diese aber nicht. Es werden z.B. kaum Sicherungen vom Exchange gemacht, weil der VSS Writer laut Status nicht reagiert. Bedeutet, heute wird DB1 gesichert - morgen nicht etc etc...Mal so mal so.

Aus diesem Grund soll es eine "Neuinstallation" werden und kein wiederhergestelltes Backup auf erweiterter Hardware.

 

Das st die Situation...

Share this post


Link to post
Wir haben vor ca. einem Jahr unsere Domäne umgestellt von 2000 auf 2008.

 

Migriert oder aktualisiert?

 

In diesem Zusammenhang wurden 2 neue Server gekauft um zwei zuvor auf einem Server liegende Aplikationen zu trennen.

 

Sind denn diese Server bereits in Betrieb?

 

Wir haben das ganze budgetiert (das ist immer ein Kampf um jeden Euro bei uns.."..ist ja nicht nötig"..)

und dann die Server gekauft.

 

Ist für die Problemstellung und -lösung unerheblich.

 

Geplan war dann folgendes:

Neuer DC soll der "alte" Server werden, welcher vorher die Aplikationen gehostet hat.

 

Das war also vorher kein DC? Von wie viele Mitgliedsserver und DCs sprichst Du, und welcher ist welcher - Du siehst und kennst sie, wir nicht.

 

Nun haben wir aber kurz vor der Umstellung die Meldung bekommen, dass die neue Domäne VORHER bereitstehen muss, weil z.B. informix sonst nicht in diese installiert werden kann.

 

Welche neue Domäne? Wollt Ihr migrieren oder aktualisieren, habt Ihr migriert oder aktualisiert - siehe oben.

 

Wir haben daraufhin nun also schnell einen neuen Server gekauft für den SBS2008

 

Und warum schon wieder soll jetzt nicht der alte Server, der vielleicht bisher kein DC war, auf einmal nicht mehr genügen?

 

dieser hat nun leider nur einen onBoard Raid - 5 und ist lahm wie 14 Schildkröten zusammen! Beispiel: 2 kleine Fehler welche im Raid gefunden wurden dauern 18h zur Wiederherstellubng Eine ausgefallene HDD benötigt über 36h zur Wiederherstellung.

 

Wenn wir Updates auf dem Server installieren, fährt dieser ca 5 Stunden neu hoch. Beim booten zeigt er nämlich die 16000 Einstellungen die er macht einzeln an..und man kann wirkluch mitlesen so langsam ist das...

 

Dieser Server soll nun neue Hardware bekommen sprich ein schönes Raid 10 mit eigenem Controller.

 

Vielleicht sollte Ihr das zuerst in Ordnung bringen und ggf. mit dem Hersteller reden. Geräteschäden bei Auslieferung kommen vor.

 

Das System selbst muss aber noch irgendwo eine Macke haben - wir finden diese aber nicht. Es werden z.B. kaum Sicherungen vom Exchange gemacht, weil der VSS Writer laut Status nicht reagiert. Bedeutet, heute wird DB1 gesichert - morgen nicht etc etc...Mal so mal so.

 

Was meinst Du mit "Das System" genau?

 

Aus diesem Grund soll es eine "Neuinstallation" werden und kein wiederhergestelltes Backup auf erweiterter Hardware.

 

In der Hoffnung, dass eine Neuinstallation auf wundersame Weise alle Probleme löst, die existieren und bisher nicht behoben wurden? Hat man Euch nicht gesagt, dass man vor jeder Migration udn Aktualisierung zuerst im bestehenden Umfeld alles bereinigen muss, ehe man loslegt?

Share this post


Link to post
Migriert oder aktualisiert?

Komplett neu eingerichtet. Aus der alten 2000er Domäne wurde NICHTS übernommen.

 

Sind denn diese Server bereits in Betrieb?

[/Quote]

Ja, die beiden Server sind im Betrieb und laufen wunderbar.

 

Das war also vorher kein DC? Von wie viele Mitgliedsserver und DCs sprichst Du, und welcher ist welcher - Du siehst und kennst sie, wir nicht.

 

Nein, es war vorher nur eun Mitgliedsserver , jetzt ist es ein Fileserver.

Aktuell haben wir nur den SBS2008 - keinen zweiten DC.

Insgesamt geht es um 4 Mitgliedsserver plus SBS2008 wobei die Probleme nur mit dem SBS2008 bestehen

 

Welche neue Domäne? Wollt Ihr migrieren oder aktualisieren, habt Ihr migriert oder aktualisiert - siehe oben.

 

[/Quote]

 

Neue Domäne ist die aktuelle - also nach Umstellung von der 2000er.

Der SBS2008 soll nun "migriert" werden auf SBS2008.

 

Und warum schon wieder soll jetzt nicht der alte Server, der vielleicht bisher kein DC war, auf einmal nicht mehr genügen?

[/Quote]

 

Weil der bei der Umstellung damals Fileserver wurde und somit nicht zur Verfügung steht.

 

Vielleicht sollte Ihr das zuerst in Ordnung bringen und ggf. mit dem Hersteller reden. Geräteschäden bei Auslieferung kommen vor.

[/Quote]

 

Naja, ich will eh keinen OnBoard-Controller mehr für das Raid. Erstens habe ich da keine Möglichkeit einer HotSpear und zweitens halt die Performanceprobleme (zumindest beim Raid5). Außerdem geht das ganze relativ stark auf die CPU (Onboard-Raid eben)

 

Was meinst Du mit "Das System" genau?

 

Damit meine ich den SBS2008

 

Der hat z.B. irgendwann einfach angefangen die Exchange-Sicherungen durch "nicht verfügbaren VSS Writer" nur noch teilweise zu sichern. Auch wenn ich z.B. ein Postfach verschiebe in eine andere DB (mit vielleicht 100MB) dauert das 4-5 Stunden.

 

In der Hoffnung, dass eine Neuinstallation auf wundersame Weise alle Probleme löst, die existieren und bisher nicht behoben wurden? Hat man Euch nicht gesagt, dass man vor jeder Migration udn Aktualisierung zuerst im bestehenden Umfeld alles bereinigen muss, ehe man loslegt?

 

Wir hatten ein ähnliches Problem schonmal auf einem der neuen ApliServer.

Dort wurde eine komplette Neuinstallation vom Server durchgeführt - seid dem läuft der wieder tadellos. Ich/wir/Aplikationshersteller haben vermutet das im Windows selbst irgendwo ein Fehler ist - es hat in aber niemand gefunden und er konnte somit nicht behoben werden. Der Aplikationshersteller hat 1 Woche jeden Tag nach dem Fehler gesucht und wollte ihn nachstellen - alles nicht geklappt.

 

Der Fehler hat das System so träge gemacht das ein längerer Ausfall nicht mehr hinnehmbar war und somit die neue Install.

 

Mir ist klar, dass ein System sauber laufen muss/sollte vor einer Migration, nur gibt es keinerlei Anhaltspunkte für das träge Verhalten und die anderen Probleme - außer halt teilweise das Raid. Das komplette Ereignissprotokoll ist nur mit normalen Einträgen versehen und gibt keinen Hinweis auf die bestehenden Probleme.

Hoffe das diese Infos dir ein wenig mehr helfen. :\...

Share this post


Link to post

Hallo,

 

VASSADMIN 1.1.Verwaltungsbefehlszeilenprogram des Volumenschattenkopie-Dienst

 

Er listet alles mit keine Fehler auf...dauert nur relativ lange...

 

EDITH:Beim ersten mal hat er scheinbar nur weitergemacht weil ich Enter gedrückt habe...also ein zweites mal ,)

 

Nachdem ich es jetzt einmal ausgeführt habe läuft er in 5sek durch...vorher hat es ca 4min gedauert bis ich enter gedrückt habe....

 

 

EDITH2: Nachtrag: Wenn ich im Backup Exec auf testen klicke beim Exchange sagt er mir Ressouce nicht gefunden. Die Sicherung wird übrigens von einem Extra Rechner gemacht.

 

und noch ne EDITH: habe ir gerade mal die verfügbaren Schattenkopien angezeigt

Der zeigt mir für jeden tag seit dem 02.11 zwei Einträge - insgesamt ca 70GB

Immer 07:00 und 12:00 Uhr und ich hätte kein Plan was da laufen sollte?!

Edited by saggi

Share this post


Link to post
Immer 07:00 und 12:00 Uhr und ich hätte kein Plan was da laufen sollte?!

 

Das sind die Schattenkopien für Netzlaufwerke, damit Nutzer deren vorhergehende Versionen sehen und ggf. selbst wiederherstellen können. 7:00 Uhr und 12:00 Uhr sind die Standardzeiten. Wird unter den Eigenschaften des Volumes konfiguriert respektive aktiviert oder deaktiviert.

Share this post


Link to post

Mhhh,

 

Um nochmal auf das primäre Problem bei der Migration zurück zu kommen..

Hast du vielleicht dort nich einen Anhaltspunkte zu der fehlermeldung?

 

Asche auf mein Haupt..sitze gerade im Zug und überlege..da fällt mir ein,wir hatten diese Woche teilweise enen zweiten dc installierte. Der hat zumindest die ad einstellungen etc wunderbar repliziert

 

mich stort immernich der Satz im log das er n anderes result bekommt als erwartet...

Edited by saggi

Share this post


Link to post

Hallo nochmals,

 

ich habe gerade mal im dssite.msc ne replikation angeworfen.

 

Wenn ich dies auf dem alten SBS2008 ausführe bekomme ich unter dem neuen Server alles wunderbar...Wenn ich denn unter dem alten Sevrer replizieren klicke die Meldung, dass nicht auf SERVER zugegriffen werden konnte: Zugriff verweigert.

 

Wenn ich diese bleiden Punte auf dem neuen, welcher immernoch am expandieren ist ;) auswähle, läuft alles perfekt durch. Ich bekomm also bei beiden Servern die OK-Meldung.

 

Nochmals zur Meldung im Log oben:

 

Er macht doch scheinbar nur ne Abfrage mit nltest /dsgetdc:domname

und bekommt da dann die Rückmeldung, dass der DC nicht der neue sondern der alte Server weiterhin ist.

 

Kann ich das nicht irgendwie manuell auf dem alten ändern, dass diese Abfrage "positiv" ausgeht?

 

EDITH:

 

Mit nltest /dclist

bekomm ich übriegs auch ein "schönes" Ergebniss und er zeigt sogar den neuen Server als PDC an.

Was würde denn passieren, wenn ich nun einfach sage nicht länger warten bei Replizierung? Bzw. Kann ich irgendwo rausfinden was er in den nächsten Schritten machen würde oder versucht er die autom noch durchzuführen und überspringt nur seinen aktuell gefundenen "Fehler" mit dem falschen Namen ?

 

Der "neue" Server hat auch schon alle FSMO Rollen....

 

MfG

Edited by saggi

Share this post


Link to post

Hallo,

 

ich werd jetzt bestimmt erschlagen....

 

Ich hab jetzt mal den Best Practicss laufen lassen auf dem alten Server. Der spuckt mir

auch keine Fehler aus. Ich würde also wirklich gern das "wartren auf Migrationsdaten" abbrechen - weiß und find aber auch nix darüber, was dann passiert.

 

Nehmen wir an es läuft was schief, kann ich dann die Rollen einfach wieder auf den alten SBS übernehmen und alles ist "wunderbar"?

 

MfG und sorry wegen "push" :\

Share this post


Link to post

Hallo,

 

wir haben den Migrationsfehler nun behoben. Habe mir weitere Hilfe ins Haus geholt und nach 5 Stunden suchen haben wir den "Fehler" behoben.

 

Es bestand scheinbar ein Fehler beim replizieren o.ä. aufgetreten ist und diese im JRNL_WARP_ERROR Status stand.

 

Nach dem hinzufügen des Schlüssels Enable Journal Wrap Automatic Restore unter

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NtFrs\Parameters

 

ging die Migration weiter und wurde auch abgeschlossen.

 

Exchange hatte dabei jedoch ein Problem beim install der HUB. Wir haben den dann nochmal "manuell" installiert. Vorher wie auch nachher will er nun aber einen Lizenzkey haben.

 

Muss ich mich an MS wenden? Für den SBS habe ich ja keinen Exchange Key oder gibt es eine andere Methode?

 

MfG

Sandro

Share this post


Link to post

Ich fürchte du musst die Migration noch einmal machen. Beim SBS 2008 gibt es keinen separaten Lizenz-Key und keinen entsprechenden Datenträger.

 

Bei einer Migration w2k (über einen virtuellen w2k3) zum SBS 2008 hatte ich den gleichen Fehler. Es war allerdings vorher kein Exchange in der Domäne (Fehler war ein Problem beim Hochstufen der Gesamtstrukturfunktionsebene).

 

Ich habe das nur durch ein (Acronis) - Restore des alten (und einzigen) w2k-DC und nochmaliger Migration beheben können.

 

GGF. hat GüntherH hier noch wertvolle Hinweise.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...