Jump to content
Sign in to follow this  
stopsy

Exchange2007SP1 unter SBS2008 - Autodiscover

Recommended Posts

Hei Ihr,

 

habe folgende Frage:

 

Ich möchte Autodiscover von extern für Handys mit WM6.5 und 7 zur Verfügung stellen.

 

Was muss ich beim Provider konfigurieren?

SRV-Eintrag? _autodiscover._tcp.domäne.de

Subdomain?: autodiscover.domäne.de

 

Ein Zertifikat ist vorhanden mit folgenden SAN:

WINS-Name des Servers

FQDN extern (de)

FQDN intern (local)

autodiscover.domäne.de

 

-------

Damit ich das richtig verstanden habe was ich bei Technet gelesen hab:

 

1. Zuerst wird versucht das AD zu erreichen um durch den SCP-Eintrag im AD autodiscover zu nutzen. Im SCP-Eintrag findet er die URL damit der Webservice Autodiscover überhaupt gefunden werde kann. Kann er AD nicht erreichen da. z.B. von extern dann...

 

2. ...versucht er mittels https://autodiscover.domäne.de/autodiscover/autodicover.xml zu erreichen (Also sollte ich eine subdomain beim Provider anlegen; Im Zertifikat ist die Subdomäne mit angegben.) Wenn das auch nicht funktionerit dann...

 

3. versucht er per DNS den SRV-Eintrag (_autodiscover._tcp.domäne.de welcher auf FQDN des Exchangeservers verweist) zu finden welcher beim Provider konfiguriert werden muss.

 

Ist das richtig???

 

Thanx

Share this post


Link to post

Habe gestern das Problem auch gehabt, gelößt habe ich es wie folgt :

 

_autodiscover._tcp.meinedomäne.com SRV 231.xxx.xxx.xxx

 

Danach ging autodiscover einwandfrei.

Share this post


Link to post

Das Whitepaper werde ich mir übers WE durcharbeiten...

Aber ist mein Ansatz komplett verkehrt??

 

Wegen dem SRV-Eintrag. Den hast du beim Provider angelegt??

Share this post


Link to post

den SRV Record habe ich beim Provider angelegt, danach ging zumindest mal folgender Abschnitt laut http://www.testexchangeconnectivity.com

 

Teil 2 des Tests

Es wird versucht, die mögliche AutoErmittlungs-URL https://autodiscover.meinedomain.com/AutoDiscover/AutoDiscover.xml zu testen.

URL der AutoErmittlung erfolgreich getestet.

 

Allerdings habe ich noch ein Problem bei Test 1

 

Testschritte

Es wird versucht, die mögliche AutoErmittlungs-URL https://meinedomain.com/AutoDiscover/AutoDiscover.xml zu testen.

Fehler beim Testen dieser potenziellen AutoErmittlungs-URL.

 

Hier antwortet der Webserver des Providers wo unsere HP liegt mit seinem Zertifikat welches natürlich falsch ist.

Hier bin ich im moment ratlos wie ich das auf unseren internen umleiten soll.

Ev. hast du ja hier einen Tipp für mich.

Das Whitepaper verstehe ich nicht bzw. bin auch nicht sicher das es bei mir zutrifft.

Share this post


Link to post

In meinen Augen müssen nicht alle Test erfolgreich durchlaufen. Autodiscover versucht es auf verschiedene Art und weisen, z.B. per AD SCP, dann direkt per URL dann per SRV....

Hauptsache einer davon ist erfolgreich...

 

Die URL welcher er probiert sind:

https://domäne.tld/autodiscover/autodiscover.xml -- wenn er die nicht erreichen kann probiert er es mit:

https://autodiscover.domäne.tld/autodiscover/autodiscover.xml

 

dann per SRV...

 

----

Bei mir funktioniert das autodiscover genauso wie outlook-anywhere nur wenn ich mich per domäne\benutername anmelde.

Wenn ich ich es mit UPN versuche, klappt es nicht. Das ist deswegen schlecht, da ein Handy bei der Outlookkonfiguration erstmal nur die E-Mailadresse und Passwort abfrägt.

 

Hast du eine Idee wie man das umstellen kann??

 

Update:

Das Problem liegt darin, das er eine Anmeldedomäne domäne.DE sucht die es aber nicht gibt. Es gibt ja nur eine Anmeldedomäne namens domäne.LOCAL

Wie kann ich jetzt das Umleiten???

Edited by stopsy

Share this post


Link to post

Wie das mit dem UPN geht habe ich noch nicht probiert, zum testen reicht mir das mit benutzernamen und passwort.

Mein problem ist auch das die Domain intern bei mir meinedomain.local und nicht meinedomain.com benannt ist.

Ich denke das daher auch viele meiner Probleme herkommen wie z.b. mein dringenstes Problem :

 

Es wird sichergestellt, dass der Testpostfachordner leer ist und darauf zugegriffen werden kann.

Es konnte von ExRCA nicht bestätigt werden, dass der Ordner leer ist und darauf zugegriffen werden kann.

Weitere Details

Ausnahmedetails:

Nachricht: The request failed. The remote name could not be resolved: 'srv-mail-01.meinedomain.local'Typ: Microsoft.Exchange.WebServices.Data.ServiceRequestException

Stacktrace:

at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ValidateAndEmitRequest(HttpWebRequest& request)

at Microsoft.Exchange.WebServices.Data.SimpleServiceRequestBase.InternalExecute()

at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()

at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder(FolderId folderId, PropertySet propertySet)

at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder[TFolder](FolderId folderId, PropertySet

 

 

Wie hast du das gelößt ??

Share this post


Link to post

LOL ich glaube nun stehen wir beide wirklich auf dem schlauch und ich bin mir sicher wir haben das Problem wegen den local domains.

Aber ev. hilft uns beiden ja noch jemand weiter ! :D

Mal schauer ob DMetzer noch die auflösung geben kann, bei den MS Papers verstehe ich in Englisch nur Bahnhof.........

Share this post


Link to post

Also, das Whitepaper von MS ist super - vielen Dank hierfür.

 

Also, die Funktionsweise war korrekt so wie ich mir das auch dachte.

 

Autodiscover funktioniert bei mir auch mit ActiveSync und OutlookAnywhere.

Nur das ich mich immer mittels:

 

Domäne\benutzername

 

anmelden muss. Per E-Mailadresse funktioniert das ganze leider nicht, da er keinen Domänencontroller domäne.de findet. Ändere ich das manuell in domäne.local um funktioniert die Authtentifizierung.

 

Wo da mein Problem liegt weiß ich leider nicht. Hab Ihr eine Idee??

Share this post


Link to post

Ich verstehe die Welt nicht mehr.

Auf einmal geht alles und ich habe keine weiteren Änderungen vorgenommen oder Dienste neu gestartet.

Das soll mal einer verstehen.

Werde jetzt mal ganz schnell alles Einstellungen Dokumentieren.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...