Jump to content
Sign in to follow this  
pfeifera

XPMode in Domäne und für All-Users?

Recommended Posts

Hallo,

 

ich bin gerade am testen von Win7-Pro 64bit und den damit verbundenen XP-Mode. Soweit konnte ich mit unserem Admin die Software einwandfrei installieren und auch die ersten Tests liefen sehr gut.

 

Nun habe ich mal einen PC für einen Test-User fertig gemacht und wollte nochmal den XP-Mode unter dem normalen Domänen-User testen... Und siehe da, es funktioniert nicht. Hat jemand evtl. schon ähnliche Erfahrungen gemacht und evtl. einen Vorschlag, wie man den XPMode für alle User, die sich an dem PC anmelden, verwenden kann?

 

Viele Grüße

 

pfeifera

Share this post


Link to post

Nun habe ich mal einen PC für einen Test-User fertig gemacht und wollte nochmal den XP-Mode unter dem normalen Domänen-User testen... Und siehe da, es funktioniert nicht.

Hi,

 

wohin habt ihr den XPMode installiert? In das Userverzeichnis?

Share this post


Link to post

Hallo und vielen Dank für die schnellen Antworten,

 

also der XP-Mode, genauer gesagt die virtuelle Maschine wurde auf D:\XP-Mode installiert. D:\ ist bei uns als Datenpartition eingerichtet und jeder Dom.-User hat darauf Änderungsrechte.

 

Hm, ich glaube ich habe mein Problem nicht so exakt beschrieben... Also wenn man unter dem Admin, der das ganze installiert hat, eingeloggt ist, dann erscheint im Startmenü unter "Windows Virutal PC" der Eintrag "Windows XP-Mode Anwendungen". Sobald ich mich allerdings als normaler Dom-User anmelde, fehlt dieser Eintrag. Mir geht es hauptsächlich darum, im Startmenü für jeden User, der sich an der Maschine anmeldet, ebenfalls diesen Eintrag zu haben. Der normale User kann grundsätzlich schon den VPC, bzw. den XP-Mode, als Maschine starten, aber eben nicht als Applikation, auch wenn man den Eintrag vom Startmenü des Admins in das Startmenü des Users kopiert.

 

Vielen Dank im voraus für eure Unterstützung.

 

Viele Grüße

 

pfeifera

Share this post


Link to post

Hm, ich habe eben nochmal einen Dom-User angemeldet und versucht, über das Startmenü den XP-Mode (also die komplette virtuelle Maschine) zu starten. Dabei kam die Meldung mit dem Akzeptieren der Lizenz und die Konfiguration einer neuen VM wurde gestartet... irgendwie stehe ich gerade auf dem Schlauch... Ich habe diese Installation abgebrochen und die auf D:\ zur Verfügung stehende XP-Mode-VM gestartet - diese wurde ohne Probleme gestartet und auch alle darin installierten Applikationen sind enthalten.

 

Zur Zeit würde ich sagen, dass jeder User im Startmenü einen eigenen Eintrag für die VM erhält. Sobald der User diese VM startet, wird diese separat für den User "konfiguriert".

 

Hat jemand eine Idee, wie man zentral eine VM für alle User bereitstellt - so daß jeder User über das Startmenü die gleiche VM startet? Zudem wäre es für das Handlich wichtig, daß auch jeder User den Punkt "Windows XP-Mode Anwendungen" zur Verfügung hat.

 

Hoffe ihr könnt mir helfen - wobei dieses Problem doch bestimmt auch andere hatten/ haben oder haben werden, die das System in einem Unternehmen einsetzen.

 

Vielen Dank im voraus.

 

Viele Grüße

 

pfeifera

Share this post


Link to post

Moin,

 

der ganze Ansatz führt in die Irre. XP Mode ist nicht als unternehmensweite Lösun gedacht, sondern als Notbehelf für einzelne Arbeitsplätze.

 

Gruß, Nils

Share this post


Link to post

Moin,

 

nunja, in gewissem Maß wäre das ganze ja ein Notbehelf... z.B. unser ERP-System basiert auf Oracle und ist leider nicht Win7 tauglich. Durch die Nutzung von XP-Mode könnten wir weiterhin unsere "alten" Systeme beibehalten.

 

Ich meine, die VM selbst kann ich ja vom Laufwerk D:\ starten, funktioniert auch ohne Probleme mit jedem User. Nur es wäre halt schön, wenn man eine "einfache" Integration der Applikationen vom XP-Mode in das Startmenü eines jeden Users integrieren könnte.

 

Gruß

 

pfeifera

Share this post


Link to post

Hi,

 

okay unter dem Gesichtspunkt wirst du um MED-V nicht herumkommen. Das ist nämlich die XP Mode Lösung für den Einsatz im Unternehmen.

Share this post


Link to post

Hi,

 

hm, was ist MED-V?

 

Nun ja mit dem ERP-System ist das so ne Sache... Es basiert auf Oracle und das wiederum ist nicht für Win7 und vor allem nicht für 64-bit freigegeben.

 

Habe aber eben eine recht interessante Entdeckung gemacht....

 

Ich habe eben einen Dom-User an dem System angemeldet - wie erwartet war unter dem Startmenü unter "Virtual PC" nicht der Unterordner "Windows XP-Mode Anwendungen" zu finden.

 

Ich habe daraufhin die zentral Abgelegte VPC "XP-Mode" von meinem D-Laufwerk direkt gestartet, den User angemeldet und die Maschine wieder geschlossen. Zur Sicherheit habe ich den Rechner neu gebootet und nach der erneuten Anmeldung des zuletzt verwendeten Users steht unter dem Startmenüpunkt "Virutal PC" plötzlich der Punkt "Windows XP-Mode Anwendungen" - und alle Applikationen funktionieren.

 

Scheinbar muss einmal die komplette VPC unter dem neuen User gestartet werden, daß anschließend die Freigaben vom XP-Mode zur Verfügung stehen.

 

Viele Grüße

 

pfeifera

 

edit: ah, hab mir eben mal MED-V angeschaut - ist aber ein teurer Spaß zumal wir keine SA´s haben. Aber für diese Möglichkeiten gibt es ja auch andere Anbieter (VM, Citrix...).

Share this post


Link to post

Moin,

 

ich kann mich an der Stelle nur wiederholen:

XP Mode ist nicht als unternehmensweite Lösung gedacht, sondern als Notbehelf für einzelne Arbeitsplätze.

 

Neben dem von dir beobachteten Umstand gibt es zahlreiche Komponenten im XP-Mode, die in eurem Szenario problematisch sind. Angefangen bei den nicht vorhandenen Management-Werkzeugen über das Patchmanagement, Sicherheitsfragen (der User ist im XP Mode lokaler Administrator), separatem Virenschutz usw. usf.

 

Gruß, Nils

Share this post


Link to post

Neben dem von dir beobachteten Umstand gibt es zahlreiche Komponenten im XP-Mode, die in eurem Szenario problematisch sind. Angefangen bei den nicht vorhandenen Management-Werkzeugen über das Patchmanagement, Sicherheitsfragen (der User ist im XP Mode lokaler Administrator), separatem Virenschutz usw. usf.

 

Die virtuellen Maschinen können selbstverständlich ganz normal über den WSUS up2date gehalten werden. Es gibt leider einen gravierenden Nachteil. MS hat im Image überall die gleiche SUSClientID drin gelassen. Wenn mal also die Maschinen an den WSUS bringt, sollte man vorher die SUSClientID löschen. Sobald sich der Client zum ersten Mal beim WSUS meldet bekommt er eine neue SUSClientID.

 

WSUS.DE - Windows 7 Ultimate + XP-Mode + WSUS

WSUS.DE - Bei Clone-PC funktionieren die Automatischen Updates nicht

Share this post


Link to post

Moin,

 

sicher, aber man muss das eben für jede XP-Mode-VM einzeln einrichten. In die Domäne will man die normalerweise nicht heben. Und wenn doch, müsste man das eben auch einzeln machen. Und den Virenschutz usw. müsste man auch jeweils einzeln einrichten.

 

XP Mode zielt nicht auf den unternehmensweiten Einsatz. Punkt.

 

Gruß, Nils

Share this post


Link to post

sicher, aber man muss das eben für jede XP-Mode-VM einzeln einrichten. In die Domäne will man die normalerweise nicht heben. Und wenn doch, müsste man das eben auch einzeln machen. Und den Virenschutz usw. müsste man auch jeweils einzeln einrichten.

 

ACK. Ich wollte nur auf die Problematik mit der SUSClientID hinweisen. ;)

 

XP Mode zielt nicht auf den unternehmensweiten Einsatz. Punkt.

 

Jepp.

Share this post


Link to post

Hm, also die Xp-Mode-VM muss bei uns in die Domäne genommen werden, da der Client ja auf gemappte Laufwerke und Co. Zugreifen muss.

 

Gut für die Useranmeldung haben wir einen Domänen-User erstellt, der automatisch an dem System angemeldet wird. Bringt eben den vorteil, daß hier keine Admin-Rechte verwendet werden.

 

Grundsätzlich gebe ich euch ja recht, daß hier eine andere Lösung für Appliktions-virutalisierung besser wäre, aber man muß auch immer wieder die Kosten sehen. Für voraussichtlich 20 User, die auf Win7 umgestellt werden wird sich eine solche Investition nicht wirklich lohnen. Zumal hier die finanziellen Mittel etwas beengt sind.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...