Jump to content

Exchange 2k7 / Outlook 2k7 - OAB wird nicht runtergeladen


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Moin Moin,

 

Mal wieder, ein Exchange Paradoxon ... und ich verstehe es nicht. Eventuell fällt jemanden ja noch was ein. Zu dem Thema kann man sich im Internet ja quasi totlesen, aber nach x-Versuchen hat noch immer nichts gefruchtet:

 

Basis: Win2k3 R2 x64 Standard mit Exchange 2k7, Clients mit Win7 und Outlook 2k7.

 

IP ist dynamisch, Mails laufen über einen Smarthost da die Domain bei einem Provider liegt (sehr kleiner Kunde) ... alles halb so wild, schon paar mal gemacht.

 

testexchangeconnectivity.com stellt keine Fehler (mal vom Zertifikat abgesehen) fest, OAB, Autodiscover etc. funktioniert alles.

 

Beim Provider ist für Autodiscover eine Subdomain eingerichtet die auf die dyndns Adresse von Server verweist. Klappt auch alles ohne Probleme.

 

Tja, nur Outlook spielt nicht mit: Alle 30 Minuten ein Synconisationsproblem das das OAB nicht runtergeladen werden kann weil der Server nicht gefunden wird.

 

Getestet habe ich:

 

- Mit testexchangeconnectivity, einem test Account auf dem Server, alle test durchgeführt und erfolgreich abgeschlossen.

- OAB URL intern/extern eingetragen, stimmt auch ... wenn ich die URL im Browser eingebe und mir die oab.xml anzeigen lasse sehe ich auch alles sinnvolle was ich von einer xml erwarte

- OAB Ordner im Programm Ordner von Exchange ist vorhanden und gefüllt

- Einstellungen in der Exchange Verwaltungskonsole sind, bis auf die URLs, unangetastet, hat bislang immer so funktioniert.

- Ich bin ratlos...

 

Jemand noch eine Idee, ausser Cachemodus ausschalten?! Die Rechner sind zwar nie "unterwegs" und vom Server getrennt aber wer weiß was da noch kommt, ich würde das natürlich gerne korrekt lösen anstatt ein "Work around" zu basteln.

 

für jeden Tipp dankbar... Fabian

Link to comment

Hm ... also die URL die per Autodiscover übergeben wird stimmt und ist auch die die im Zertifikat der eigenen Zertifizierungsstelle eingetragen ist.

 

Wenn ich auf die URL im Browser connecte und die oab.xml aufrufe passt alles, Logindaten stimmen, alles schön. Ich bin total Ratlos was das sein kann :/

 

ich glaub ich stell das OAB einfach aus... was anderes fällt mir da grade nicht zu ein :(

 

grüße...

Link to comment

Moin,

 

danke für die Antwort.

 

Nein es funktioniert grundsätzlich nicht.

 

Hier das Log:

 

09:05:17 Microsoft Exchange-Offlineadressbuch

09:05:17 Die Offlineadressbuchdateien werden nicht heruntergeladen. Es wurde kein Server (URL) gefunden.

09:05:17 0X8004010F

 

Zum Fehler 0x8004010f findet sich einiges im Internet, aber nichts hat bei mir bislang funktioniert und fast alle haben mit einem nicht funktionierenden Autodiscover zu tun.

 

Autodiscover funktioniert hier aber sowohl über <postfach>@domain.com als auch über <postfach>@domain.dyndns.org ... in der empfangenen Autodiscover.xml steht auch die von mir eingetragene URL vom OAB drin und wenn ich diese URL im Explorer öffne (mit oab.xml zusatz hinten dran), mich mit meinen Userdaten anmelde, kommt auch alles.

 

Ich habe bald die Vermutung das es ein Zertifikatproblem sein muss/kann, weiß nur nicht wie ich dem zu leibe rücken könnte. Auf dem Server ist eine Zertifizierungsstelle eingerichtet und ein internes Zertifikat für OWA ausgestellt damit externe Clients mit installiertem Root CA ohne Zertifikatfehler auf OWA zugreifen können (was auch auch absolut Problemlos klappt) Das Webseitencert ist auf die dyndns.org Adresse ausgestellt und vom eigenen CA beglaubigt. Kann es was damit zu tun haben? Wie gesagt, AUTODISCOVER üer Outlook Einrichtungsassistent und testexchangeconnectivity.com funktioniert absolut problemlos.

 

grüße, Fabian

Link to comment

Hallo kaype

 

Wie du schon bereits sagst, die 0X8004010F kann viele Ursachen haben. Wenn es bei keinem der User Funktioniert könnte da schon was am Zertifikat nicht gut sein. Ich hänge dir einfach mal ein Workaround an der vielleicht einen Fix mitbringt:

 

0X8004010F is thrown when trying to download an OAB#

####################################################

####################################################

 

1.

Besteht eine Verbindung vom Postfach zu den Public Folder Servern?

Die Ctrl Taste gedrückt halten, rechter Mausklick auf das Outlook Symbol im Infobereich, Verbindungsstatus

 

2.

Sind die Netzwerkanbindungen der Clients ev .mit VPN oder per WLAN?

 

3.

Ist der Cache Modus eingeschaltet?

 

4.

Manueller Download

To work around this problem, you must download the offline Address Book manually. To do this, follow these steps in the Outlook client.

Click Tools, point to Send/Receive, and then click Download Address Book.

Click OK to accept the Offline Address Book dialog box settings.

 

Was passiert da? Kann auch länger dauern….

 

5.

E-Mail Autokonfiguration testen (Geht nur mit Outlook 2007)

- Die Ctrl Taste gedrückt halten, rechter Mausklick auf das Outlook Symbol im Infobereich, E-Mail-AutoKonfiguration testen...

- E-Mail Adresse und Passwort eingeben

- Guesssmart verwenden und Sichere Guessmart-Authentifizierung deaktivieren

- Test klicken

Die Ausgabe auf Errors überprüfen. Wichtig ist der Pfad OABUrl wie unten. Dort befinden sich die Offline Adressbuch Dateien (OAB Files)

OABUrl:https://maildoamin.ch/OAB/6d3bff98-6c23-42fa-9199-9d997b291d98/

 

6.

Authentifizierung der User mit den OAB Problemen an folgenden Verzeichnissen möglich:

https://maildoamin.ch/OAB/6d3bff98-6c23-42fa-9199-9d997b291d98/oab.xml

Die XML sollte geöffnet werden können….

 

7.

Hier wird beschrieben was zu OAB Download Problemen führen kann:

Dgoldman's WebLog : Understanding why error code 0X8004010F is thrown when trying to download an OAB

 

8.

Gibt es beim Client Event Log Einträge zum OAB download (event ID 27)

Troubleshooting OAB Download Issues with Outlook Diagnostic Logging: Exchange 2007 Help

 

9.

Hier noch ein hilfreicher KB Artikel zum OAB für Outlook 2003 und 2007:

Administering the offline address book in Outlook 2003 and Outlook 2007

Besonders F30;F31 (Sind die .oab Dateien vorhanden)?

 

10.

Und hier noch etwas das mit dem Proxy zu tun haben könnte:

Error message when Outlook synchronizes an offline address book with Exchange Server 2007 and Exchange Server 2010: "0x8004010F"

Die Ausnahmen für den Proxy müssen richtig sein, download des OAB nicht über einen Proxy

 

11. Outlook Profil neu anlegen

 

 

Grüsse

fluehmann

Link to comment

Yeah!

DANKE!

 

5. hat mich auf die richtige Spur gebracht, hatte ganz vergessen das ich die Autoermittlung auch mit Outlook testen kann.

 

Das Problem war das ich den redirect als "301 - moved permanently" gesetzt hatte um von der Domain beim Hoster auf die dyndns.org zu kommen. Das versteht zwar testexchangeconnectivity.com aber Outlook nicht. Habe den Redirect auf "302 - found" gesetzt, dann funktionierte das auch über Outlook.

 

Weiteres Problem war das ich das Server Webseitencert auf die dyndns.org Adresse ausgestellt hatte und nun noch einen:

 

11:48:12 Microsoft Exchange-Offlineadressbuch

11:48:12 0X80072F06

 

Fehler hatte. Etwas googlen hat gezeigt das dies aber nur ein Zertifikatfehler sein kann und nach ändern der internen URL auf die die auch im Zertifikat steht lief es.

 

Man man man ... Fazit: Achtet bei redirect darauf WIE ihr redirected ... :/

 

Danke für den Richtigen Lösungsansatz, hat mich fast zum verzweifeln gebracht ;)

 

grüße, Fabian

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...