Jump to content

Probelm mit RPC over HTTPS und Outlook 2007


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

wir setzen seit einiger Zeit Exchange 2007 mit Outlook 2007 ein.

Für unsere Mitarbeiter, die regelmäßig im Außendienst sind haben wir Outlook so eingerichtet, dass diese über RPC over HTTPS die Verbindung zum Exchange aufbauen. Als Authentifikationsmethode haben wir die NTLM-Authentifizierung eingerichtet.

Beim externen Zugriff hängt als Reverseproxy zurzeit noch ein ISA 2004 Server dazwischen. Die Konfiguration scheint soweit stimmig und der Zugriff von extern auf die Exchange-Accounts funktioniert auch.

Allerdings habe ich schon seit einiger Zeit mit einen Phänomen zu kämpfen, wo ich mir absolut keinen Reim drauf machen kann.

Outlook schein in unregelmäßigen Abständen einen Anflug von Gedächtnisschwund zu haben und setzt die Authenifizierungsmethode stumpf auf „Standard-Authentifikation“ zurück. Der User wird beim Start von Outlook daraufhin aufgefordert seinen Nutzernamen und Kennwort einzugeben.

Stelle ich die Authentifikation wieder auf NTLM und starte Outlook wieder neu, ist das Problem vorerst wieder behoben und der User kann ohne sich anmelden zu müssen wieder mit Outlook arbeiten.

 

Das ist noch nicht alles:

Von dem oben geschilderten Problem abgesehen taucht seit einigen Wochen noch ein weiteres Problem auf. Wir haben seit ein paar Wochen einen neuen Proxy im Einsatz, der den Internetzugriff vom internen Netz aus kontrolliert. Seitdem die Clients in den Standard Proxy-Settings den neuen Server stehen haben wird den Outlook-Clients mit RPC over HTTPS Konfiguration total schwindelig!

Bislang hatten wir das oben genannte Authentifizierungsproblem nur bei Zugriff von extern auf die Exchange-Accounts. Befand sich der Client im internen Netz, gab es keine Probleme. Jetzt mit dem neuen Proxy, verlangt Outlook auch im internen Netz eine Authentifikation des Users. Ich verstehe die Welt nicht mehr. Die Proxy-Konfiguration auf den Clients ist so eingerichtet, dass im internen Netz bei Anfragen an den Exchange Server der Proxy-Server umgangen wird (Proxyeinstellung – Ausnahmen)

Ich denke, die beiden Probleme haben den gleichen Ursprung. Hat jemand von euch eine Idee, wo das Problem liegen kann? Warum setzt Outlook die Authentifizierungsmethode zurück auf die Standardauthentifizierung und weshalb verhält sich Outlook im internen Netz so seltsam?

Für Eure Hilfe wäre ich dankbar

 

Gruß

Link to comment

Hallo.

 

Warum setzt Outlook die Authentifizierungsmethode zurück auf die Standardauthentifizierung

 

Ich vermute einmal, dass dies mit dem neuen Proxy zusammenhängt. Der ISA ab 2004 kann mit der NTLM-Authentifizierung umgehen, der neue Proxy kann das nicht.

 

Dieses Verhalten ist z.B. auch hier beschrieben - http://www.mcseboard.de/windows-forum-ms-backoffice-31/outlook-https-121731.html#post750593

 

LG Günther

Link to comment
Bei der Verzeichnisssicherheit des rpc-webseite mal die integrierte windowsauthentifizierung anklicken.

 

btw. das der user unterwegs bei outlook anywhere sein passwort eingeben muss ist aber gewollt, ich kenne es nicht anders.

 

Die integrierte Windowsauthentifizierung ist aktiv.

Dass von unterwegs aus das Passwort eingeben werden muss, ist nicht ganz richtig. Es ist durchaus möglich mit der NTLM-Authentifizierung die Passwortabfrage zu unterdrücken. Allerding muss ein Wert in der Registry gesetzt werden.

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA

dort muss der Wert "Incompatibilitylevel" auf 2 oder 3 gesetzt werden. Danach erscheint die Passwortabfrage nicht mehr und Outlook authentifiziert sich sauber mit dem Exchange. Das Problem was ich habe ist halt, dass die Authentifizierungsmethode auf "Standardauthentifizierung" zurückgesetzt wird... und ich weiß einfach nicht warum....

Link to comment
Hallo.

 

 

 

Ich vermute einmal, dass dies mit dem neuen Proxy zusammenhängt. Der ISA ab 2004 kann mit der NTLM-Authentifizierung umgehen, der neue Proxy kann das nicht.

 

Dieses Verhalten ist z.B. auch hier beschrieben - http://www.mcseboard.de/windows-forum-ms-backoffice-31/outlook-https-121731.html#post750593

 

LG Günther

 

Hallo GuentherH,

 

beim Zugriff von extern aus ist der ISA 2004 noch als Reverse Proxy im Einsatz.

Von intern nach extern ist der neue Proxy im Einsatz wobei dieser bei der Verbindung zu Exchange umgangen wird d.h. im internen Netz baut der Client ohne Umwege eine Verbindung zum Exchange auf ohne Proxy. Dennoch erhalte ich unregemäßigen Abständen eine Passwortabfrage....

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...