Jump to content
Sign in to follow this  
Muffel

Ex 2003 will immer wieder Spam-Filter installieren (vermutlich WSUS-Problem)

Recommended Posts

Ich habe heute wieder ein Phänomen beobachtet, dass ich schon mal vor weit über einem Jahr hatte.

 

Ein Exchange Server 2003 SP 2 berichtet alle 12 Stunden an den WSUS-Server. Jedes Mal findet er ein Update für den Intelligent Message Filter und installiert es. Er installiert das alle 12 Stunden und findet es nach 12 Stunden immer wieder als nicht installiert. Das betrifft im Moment das Update vom 3.3.2008. Die ganzen letzten Monate lief das einwandfrei, wenn ein Update gefunden wurde wurde es genau einmal installiert. Dieses Update wird trotz Installation immer wieder als neu gefunden.

 

Ich vermute einen Bug beim WSUS-Server, denn als ich das Problem schon einmal vor laaaanger Zeit (das waren noch zur Zeit von WSUS 2.0) hatte, hat sich das Problem nach einem Neustart des WSUS behoben.

 

Wer hat diesen Bug auch schon mal gehabt?

Share this post


Link to post

Nein, das ist kein BUG vom WSUS. Der WU-Agent holt sich das Update vom WSUS. Der stellt das allen zur Verfügung, die es haben wollen. So betrachtet ist der WSUS-Dienst ganz dumm und ****. Er bietet es nur an, die WU-Agents holen sich die Updates.

 

Du mußt also auf Seiten des Exchange suchen. Du könntest damit beginnen:

net stop wuauserv

rd /s %windir%\SoftwareDistribution

net start wuauserv

wuauclt /resetauthorization /detectnow

wuauclt /detectnow

wuauclt /reportnow

 

Will der Exchange das Update wieder nach 12 Stunden installieren? Wenn ja, wäre mal die WindowsUpdate.log interessant.

Share this post


Link to post
So betrachtet ist der WSUS-Dienst ganz dumm und ****. Er bietet es nur an, die WU-Agents holen sich die Updates.

 

[/Quote]

 

Stimmt. Wobei ich das mit den IMF Updates auch schon öfter gesehen habe. Problemlösung war bisher die Installation eines neueren Updates über die WindowsUpdate Seite. Danach war meist Ruhe.

 

Bye

Norbert

Share this post


Link to post
Wobei ich das mit den IMF Updates auch schon öfter gesehen habe. Problemlösung war bisher die Installation eines neueren Updates über die WindowsUpdate Seite. Danach war meist Ruhe.

 

 

Probier doch das nächste Mal meinen Weg aus. Würde mich interessieren ob das etwas hilft. ;)

Share this post


Link to post
Probier doch das nächste Mal meinen Weg aus. Würde mich interessieren ob das etwas hilft. ;)

 

Ja, wenn ich dran denken sollte ;)

 

Bye

Norbert

Share this post


Link to post

Bei mir ist es mal wieder so weit. Das letzte Update installiert sich jeden Tag wieder. Ich merke es daran, dass die Dienste auf dem ExS jeden Tag neu starten. In der KB907747.LOG steht folgender Salat:

 

0.250: 2008/06/22 16:14:42.325 (local)
0.250: C:\WINDOWS\SoftwareDistribution\Download\bec71b298a17de046eaf3657d07759b4\update\update.exe (version 6.1.22.4)
0.310: DoInstallation: GetProcAddress(InitializeCustomizationDLL) Returned: 0x7f 
0.310: [color="Red"]Failed[/color] To Enable SE_SHUTDOWN_PRIVILEGE
0.360: Hotfix started with following command line: /quiet /norestart /ParentInfo:6a6a12bd296d0c4f97dd4f85b1ddab95 
2.403: PrepareToTrustInfFile: MySetupCopyOEMInf [color="red"]failed[/color]: 0xe0000243
2.403: IsInfFileTrusted: PrepareToTrustInfFile [color="red"]Failed[/color]: 0xe0000243 
2.594: InstallInfCatalogFile: Installing c:\windows\softwaredistribution\download\bec71b298a17de046eaf3657d07759b4\update\exhotfix.cat as _000000_.cat...
2.604: VerifySize: Unable to verify size: Source = NULL: c:\windows\_000000_.cat 
2.684: InstallInfCatalogFile: Installation succeeded.
2.804: In Function TestVolatileFlag, line 11660, RegOpenKeyEx [color="Red"]failed[/color] with error 0x2
2.804: In Function TestVolatileFlag, line 11692, RegOpenKeyEx [color="red"]failed[/color] with error 0x2
2.804: DoInstallation: CleanPFR [color="red"]failed[/color]: 0x2 
2.834: SetProductTypes: InfProductBuildType=BuildType.Sel
2.844: SetAltOsLoaderPath: No section uses DirId 65701; done.
2.924: GetGenericPathNameWithRoot: Unable to open HKLM, SOFTWARE\Microsoft\Exchange Conferencing\Setup, 0x2.
2.924: SetDynamicDirectoryId: [color="red"]Failure[/color] while generating dynamic path, 0xf111
2.934: GetGenericPathNameWithRoot: Unable to read HKLM, SOFTWARE\Microsoft\Exchange\Setup, InstantMessaging, 0x2.
2.934: SetDynamicDirectoryId: [color="red"]Failure[/color] while generating dynamic path, 0xf111
2.944: GetGenericPathNameWithRoot: Unable to open HKLM, SOFTWARE\Microsoft\ADCSetup, 0x2.
2.944: SetDynamicDirectoryId: [color="red"]Failure[/color] while generating dynamic path, 0xf111
2.974: DoInstallation: FetchSourceURL for c:\windows\softwaredistribution\download\bec71b298a17de046eaf3657d07759b4\update\update.inf [color="Red"]failed[/color]
2.974: CreateUninstall = 0,Directory = C:\WINDOWS\$ExchUninstallKB907747$ 
2.984: LoadFileQueues: UpdSpGetSourceFileLocation for halacpi.dll [color="red"]failed[/color]: 0xe0000102
2.984: BuildCabinetManifest: update.url absent
2.994: Starting AnalyzeComponents
2.994: AnalyzePhaseZero used 0 ticks
2.994: SetupFindFirstLine in LoadExclusionList [color="red"]Failed[/color] with error: 0xe0000102
2.994: SetupFindFirstLine in LoadExclusionList [color="red"]Failed[/color] with error: 0xe0000102

 

Ich habe jetzt erst mal den WSUS neu gestartet. Den Rest sehe ich morgen.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...