Jump to content
Sign in to follow this  
a_hempelt

Windows-Zeitgeber Aktivieren und dann Starten

Recommended Posts

Hallo,

 

es ist auf den Clients der Dienst "Windows-Zeitgeber" deaktiviert.

 

Jetzt möchte ich per BATCH den Dienst aktivieren und dann starten.

 

Das Aktivieren "Automatisch" schein zu klappen, zumindest finde ich nach folgendem Script den Dienst auf Automatisch wieder.

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time" /v Start /t REG_DWORD /d 2 /f

 

Nun möchte ich als nächsten Schritt diesen Dienst gleich starten, ohne Reboot.

net start "Windows-Zeitgeber"

 

Hier bekomme ich aber folgenden Fehler:

Systemfehler 1058 aufgetreten.

Der angegebene Dienst kann nicht gestartet werden. er ist deaktiviert oder nicht mit aktiviertem Gerät verbunden.

 

Nach einem Reboot der Maschine lässt sich der Befehl

net start "Windows-Zeitgeber"

problemlos ausführen. Ich vermute mal, das der Client noch nicht wirklich weiß das der Dienst nun eigentlich aktiviert ist und jetzt gestartet werden kann... ???

 

Ich möchte das aber gern ohne Reboot durchführen.

 

Clients sind alle WXP SP2.

 

Danke im Voraus!

Share this post


Link to post
Share on other sites

Habe noch folgendes gefunden.

 

Nach Ausführung von

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time" /v Start /t REG_DWORD /d 2 /f

 

ist der dienst "Windows-Zeitgeber" aktiviert.

 

Der Befehl

net start

zweigt den Dienst "Windows-Zeitgeber" nicht mit an.

 

Nach einem Neustart der Maschine, ist der Dienst "windows-Zeitgeber" automatisch gestartet.

 

 

So, und nun möchte ich das ganze nur noch ohne zwingenden Neustart. :)

Share this post


Link to post
Share on other sites

@Stevie-B

 

Will ja über GPO einrichten, habe mir die Defaulteinstellungen mit XP-AntiSpy zerstört und will nun das Problem manuell beheben.

 

 

 

 

Ich denke das ich die Lösung gefunden habe.

Nach Eintrag des Autostart "Windows-Zeitgeber" in der Registry muss ich diesen Registrieren, dann kann ich den Dienst auch starten.

 

@echo off

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time" /v Start /t REG_DWORD /d 2 /f

w32tm /register

net start "Windows-Zeitgeber"

Share this post


Link to post
Share on other sites

So nun habe ich das Problem der Berechtigung für die clients, welche in der Registry Einträge vornehmen sollen.

Dazu habe ich in der GPO einer Benutzergruppe XYZ Vollzugriff auf den Eintrag

 

MACHINE\SYSTEM\CurrentControlSet\Services\W32Time

 

gegeben und die Einstellung "Vererbbare Einstellungen an alle Unterschlüssel übermitteln" aktiviert.

 

 

Die Berechtigungen werden nciht auf die Clients übertragen, alle anderen Richtlinien greifen (Benutzer wie Computer).

 

Habt Ihr hier noch einen Tipp für mich?

Share this post


Link to post
Share on other sites

Fehlermeldungen im Ereignisprotokoll auf den Clients? Hast Du auch die restlichen benötigten Benutzer-Gruppen mit aufgenommen? Hier gibts ein Beispiel: Eingeschränkte Gruppen

 

BTW: Bezüglich der Dienste, vergiss den Displaynamen eines Dienstes, nimm besser den Originalnamen, Du bekommst ansonsten Probleme mit anders sprachigen Clients. In den Eigenschaften jedes Dienstes, auf dem ersten Register Allgemein, ist immer gleich der Dienstname zu finden. In Deinem Fall wäre das der W32Time gewesen.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...