Jump to content
Sign in to follow this  
readhead

SBS R2 - DHCP und DNS Probleme

Recommended Posts

Hi,

 

ich hab hier ein paar Probleme, DNS / DHCP sind zwar nach meinem Empfinden richtig aufgesetz, aber es klappt gar nichts :-(

 

Hier ein paar infos:

frischer SBS Standard, Exchange nicht aktiviert (ich benutze David), alle Updates installiert

 

C:\Dokumente und Einstellungen\Administrator>dnscmd /info
Query result:
Server info
       server name              = betaserv-de01.beta.local
       version                  = 0ECE0205 (5.2 build 3790)
       DS container             = cn=MicrosoftDNS,cn=System,DC=beta,DC=local
       forest name              = beta.local
       domain name              = beta.local
       builtin domain partition = ForestDnsZones.beta.local
       builtin forest partition = DomainDnsZones.beta.local
       last scavenge cycle      = not since restart (0)
 Configuration:
       dwLogLevel               = 00000000
       dwDebugLevel             = 00000000
       dwRpcProtocol            = FFFFFFFF
       dwNameCheckFlag          = 00000002
       cAddressAnswerLimit      = 0
       dwRecursionRetry         = 3
       dwRecursionTimeout       = 15
       dwDsPollingInterval      = 180
 Configuration Flags:
       fBootMethod                  = 3
       fAdminConfigured             = 1
       fAllowUpdate                 = 1
       fDsAvailable                 = 1
       fAutoReverseZones            = 1
       fAutoCacheUpdate             = 0
       fSlave                       = 0
       fNoRecursion                 = 0
       fRoundRobin                  = 0
       fStrictFileParsing           = 0
       fLooseWildcarding            = 0
       fBindSecondaries             = 1
       fWriteAuthorityNs            = 0
       fLocalNetPriority            = 1
 Aging Configuration:
       ScavengingInterval           = 0
       DefaultAgingState            = 0
       DefaultRefreshInterval       = 168
       DefaultNoRefreshInterval     = 168
 ServerAddresses:
Addr Count = 1
               Addr[0] => 192.168.5.1
 ListenAddresses:
Addr Count = 1
               Addr[0] => 192.168.5.1
 Forwarders:
Addr Count = 2
               Addr[0] => 192.168.5.101
               Addr[1] => 217.237.151.115
       forward timeout  = 5
       slave            = 0
Command completed successfully.

Share this post


Link to post
Share on other sites

Fortsetzung:

C:\Dokumente und Einstellungen\Administrator>ipconfig -all

Windows-IP-Konfiguration

  Hostname  . . . . . . . . . . . . : betaserv-de01
  Primäres DNS-Suffix . . . . . . . : beta.local
  Knotentyp . . . . . . . . . . . . : Hybrid
  IP-Routing aktiviert  . . . . . . : Nein
  WINS-Proxy aktiviert  . . . . . . : Nein
  DNS-Suffixsuchliste . . . . . . . : beta.local

Ethernet-Adapter LAN-Verbindung des Servers:

  Verbindungsspezifisches DNS-Suffix:
  Beschreibung  . . . . . . . . . . : Attansic L1 Gigabit Ethernet 10/100/1000Base-T Adapter
  Physikalische Adresse . . . . . . : 00-1B-FC-92-79-C8
  DHCP aktiviert  . . . . . . . . . : Nein
  IP-Adresse. . . . . . . . . . . . : 192.168.5.1
  Subnetzmaske  . . . . . . . . . . : 255.255.255.0
  IP-Adresse. . . . . . . . . . . . : fe80::21b:fcff:fe92:79c8%4
  Standardgateway . . . . . . . . . : 192.168.5.101
  DNS-Server  . . . . . . . . . . . : 192.168.5.1
                                      192.168.5.101
                                      fec0:0:0:ffff::1%1
                                      fec0:0:0:ffff::2%1
                                      fec0:0:0:ffff::3%1
  Primärer WINS-Server  . . . . . . : 192.168.5.1

Tunneladapter Teredo Tunneling Pseudo-Interface:

  Verbindungsspezifisches DNS-Suffix:
  Beschreibung  . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
  Physikalische Adresse . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
  DHCP aktiviert  . . . . . . . . . : Nein
  IP-Adresse. . . . . . . . . . . . : fe80::ffff:ffff:fffd%5
  Standardgateway . . . . . . . . . :
  NetBIOS über TCP/IP . . . . . . . : Deaktiviert

Tunneladapter Automatic Tunneling Pseudo-Interface:

  Verbindungsspezifisches DNS-Suffix:
  Beschreibung  . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
  Physikalische Adresse . . . . . . : C0-A8-05-01
  DHCP aktiviert  . . . . . . . . . : Nein
  IP-Adresse. . . . . . . . . . . . : fe80::5efe:192.168.5.1%2
  Standardgateway . . . . . . . . . :
  DNS-Server  . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                      fec0:0:0:ffff::2%1
                                      fec0:0:0:ffff::3%1
  NetBIOS über TCP/IP . . . . . . . : Deaktiviert

 

C:\Dokumente und Einstellungen\Administrator>nslookup 192.168.5.1
*** Der Servername für die Adresse 192.168.5.1 konnte nicht gefunden werden: Non-existent domain
Server:  UnKnown
Address:  192.168.5.1

*** 192.168.5.1 wurde von UnKnown nicht gefunden: Non-existent domain

 

Der DHCP ist gegenüber beta.local authentifiziert,

Adresspool 192.168.5.11 -192.168.5.240 , Ausnahme 192.168.5.101

Bereichsoptionen:

003 Router

192.168.5.101

006 DNS Servers

192.168.5.1, 192.168.5.101

015 DNS Domain Name

beta.local

 

für jeden Tipp wäre ich sehr dankbar!!!

 

Gruß,

 

radhead

Share this post


Link to post
Share on other sites

Was bedeutet bei dir "es klappt gar nichts "

 

Welcher Server ist 192.168.5.101? Ist das ein Router? Wenn ja dann mal schnell auf allen Servern / DHCP Konf löschen.

Mach mal bitte ein DCDIAG bzw NETDIAG auf deinem Server und poste das Ergebnis.

Share this post


Link to post
Share on other sites

192.168.5.101 ist der Router, hatte ich vergessen, sorry.

 

DHCP & DNS Dienste laufen ohne Fehlermeldung, aber weder werden leases verteil, noch ist wird ein nslookup aufgelöst.

DHCP am Router ist aus. beide Dienste wurden mit dem Assistenten konfiguriert.

 

Ich wünche mir dmsmaq oder bind zurück, schnüff....

 

C:\Dokumente und Einstellungen\Administrator>"C:\tools\Support Tools\dcdiag.exe"

Domain Controller Diagnosis

Performing initial setup:
  Done gathering initial info.

Doing initial required tests

  Testing server: Standardname-des-ersten-Standorts\BETASERV-DE01
     Starting test: Connectivity
        The host 2b78bc1c-8c64-4948-9e3d-5d2f99e92bcf._msdcs.beta.local could not be resolved to an

        IP address.  Check the DNS server, DHCP, server name, etc
        Although the Guid DNS name (2b78bc1c-8c64-4948-9e3d-5d2f99e92bcf._msdcs.beta.local)
        couldn't be resolved, the server name (betaserv-de01.beta.local) resolved to the IP
        address (192.168.5.1) and was pingable.  Check that the IP address is registered correctly
        with the DNS server.
        ......................... BETASERV-DE01 failed test Connectivity

Doing primary tests

  Testing server: Standardname-des-ersten-Standorts\BETASERV-DE01
     Skipping all tests, because server BETASERV-DE01 is
     not responding to directory service requests

  Running partition tests on : ForestDnsZones
     Starting test: CrossRefValidation
        ......................... ForestDnsZones passed test CrossRefValidation
     Starting test: CheckSDRefDom
        ......................... ForestDnsZones passed test CheckSDRefDom

  Running partition tests on : DomainDnsZones
     Starting test: CrossRefValidation
        ......................... DomainDnsZones passed test CrossRefValidation
     Starting test: CheckSDRefDom
        ......................... DomainDnsZones passed test CheckSDRefDom

  Running partition tests on : Schema
     Starting test: CrossRefValidation
        ......................... Schema passed test CrossRefValidation
     Starting test: CheckSDRefDom
        ......................... Schema passed test CheckSDRefDom

  Running partition tests on : Configuration
     Starting test: CrossRefValidation
        ......................... Configuration passed test CrossRefValidation
     Starting test: CheckSDRefDom
        ......................... Configuration passed test CheckSDRefDom

  Running partition tests on : beta
     Starting test: CrossRefValidation
        ......................... beta passed test CrossRefValidation
     Starting test: CheckSDRefDom
        ......................... beta passed test CheckSDRefDom

  Running enterprise tests on : beta.local
     Starting test: Intersite
        ......................... beta.local passed test Intersite
     Starting test: FsmoCheck
        ......................... beta.local passed test FsmoCheck

Share this post


Link to post
Share on other sites

Hi.

 

Führe doch einmal den Assistenten für die Internetverbindung aus, der konfiguriert dir deinen DNS und sonstige Netzwerkeinstellungen einfach und sauber.

 

Lg Günther

Share this post


Link to post
Share on other sites
C:\Dokumente und Einstellungen\Administrator>netdiag

.......................................

   Computer Name: BETASERV-DE01
   DNS Host Name: betaserv-de01.beta.local
   System info : Microsoft Windows Server 2003 (Build 3790)
   Processor : x86 Family 6 Model 15 Stepping 6, GenuineIntel
   List of installed hotfixes :
       KB924667-v2
       KB925398_WMP64
       KB925876
       KB925902
       KB926122
       KB927891
       KB929123
       KB930178
       KB931784
       KB931836
       KB932168
       KB933566
       KB933566-IE7
       KB933854
       KB935839
       KB935840
       KB935966
       KB936357
       KB936594
       Q147222


Netcard queries test . . . . . . . : Passed
   GetStats failed for 'Parallelanschluss (direkt)'. [ERROR_NOT_SUPPORTED]
   [WARNING] The net card 'WAN-Miniport (AppleTalk) - Paketplaner-Miniport' may not be working beca
use it has not received any packets.
   [WARNING] The net card 'WAN-Miniport (Netzwerkmonitor) - Paketplaner-Miniport' may not be workin
g because it has not received any packets.
   [WARNING] The net card 'WAN-Miniport (IP) - Paketplaner-Miniport' may not be working because it
has not received any packets.
   [WARNING] The net card 'WAN-Miniport (PPTP)' may not be working because it has not received any
packets.
   [WARNING] The net card 'WAN-Miniport (PPPOE)' may not be working because it has not received any
packets.
   [WARNING] The net card 'WAN-Miniport (IP)' may not be working because it has not received any pa
ckets.
   [WARNING] The net card 'WAN-Miniport (Netzwerkmonitor)' may not be working because it has not re
ceived any packets.
   [WARNING] The net card 'WAN-Miniport (AppleTalk)' may not be working because it has not received
any packets.
   GetStats failed for 'WAN-Miniport (L2TP)'. [ERROR_NOT_SUPPORTED]
   [WARNING] The net card 'AVM ISDN CoNDIS WAN CAPI Treiber #2' may not be working because it has n
ot received any packets.
   [WARNING] The net card 'AVM ISDN CoNDIS WAN CAPI Treiber' may not be working because it has not
received any packets.
   [WARNING] The net card 'Microsoft Tun-Miniportadapter' may not be working.


Share this post


Link to post
Share on other sites
Per interface results:

   Adapter : LAN-Verbindung des Servers

       Netcard queries test . . . : Passed

       Host Name. . . . . . . . . : betaserv-de01
       IP Address . . . . . . . . : 192.168.5.1
       Subnet Mask. . . . . . . . : 255.255.255.0
       Default Gateway. . . . . . : 192.168.5.101
       Primary WINS Server. . . . : 192.168.5.1
       Dns Servers. . . . . . . . : 192.168.5.1
                                    192.168.5.101


       AutoConfiguration results. . . . . . : Passed

       Default gateway test . . . : Passed

       NetBT name test. . . . . . : Passed
       [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WI
NS' names is missing.

       WINS service test. . . . . : Passed


Global results:


Domain membership test . . . . . . : Passed


NetBT transports test. . . . . . . : Passed
   List of NetBt transports currently configured:
       NetBT_Tcpip_{04D0F116-0361-437C-8626-B46A7AB3A7B0}
   1 NetBt transport currently configured.


Autonet address test . . . . . . . : Passed


IP loopback ping test. . . . . . . : Passed


Default gateway test . . . . . . . : Passed


NetBT name test. . . . . . . . . . : Passed
   [WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger
Service', <20> 'WINS' names defined.


Winsock test . . . . . . . . . . . : Passed


DNS test . . . . . . . . . . . . . : Failed
         [WARNING] Cannot find a primary authoritative DNS server for the name
           'betaserv-de01.beta.local.'. [WSAEADDRNOTAVAIL           ]
           The name 'betaserv-de01.beta.local.' may not be registered in DNS.
         [WARNING] Cannot find a primary authoritative DNS server for the name
           'betaserv-de01.beta.local.'. [ERROR_TIMEOUT]
           The name 'betaserv-de01.beta.local.' may not be registered in DNS.
         [WARNING] Cannot find a primary authoritative DNS server for the name
           'betaserv-de01.beta.local.'. [WSAEADDRNOTAVAIL           ]
           The name 'betaserv-de01.beta.local.' may not be registered in DNS.
         [WARNING] Cannot find a primary authoritative DNS server for the name
           'betaserv-de01.beta.local.'. [ERROR_TIMEOUT]
           The name 'betaserv-de01.beta.local.' may not be registered in DNS.
   [WARNING] The DNS entries for this DC are not registered correctly on DNS server '0.0.0.0'. Plea
se wait for 30 minutes for DNS server replication.
   [FATAL] No DNS servers have the DNS records for this DC registered.


Redir and Browser test . . . . . . : Passed
   List of NetBt transports currently bound to the Redir
       NetBT_Tcpip_{04D0F116-0361-437C-8626-B46A7AB3A7B0}
   The redir is bound to 1 NetBt transport.

   List of NetBt transports currently bound to the browser
       NetBT_Tcpip_{04D0F116-0361-437C-8626-B46A7AB3A7B0}
   The browser is bound to 1 NetBt transport.


DC discovery test. . . . . . . . . : Passed


DC list test . . . . . . . . . . . : Passed


Trust relationship test. . . . . . : Skipped


Kerberos test. . . . . . . . . . . : Passed


LDAP test. . . . . . . . . . . . . : Passed


Bindings test. . . . . . . . . . . : Passed


WAN configuration test . . . . . . : Skipped
   No active remote access connections.


Modem diagnostics test . . . . . . : Passed

IP Security test . . . . . . . . . : Skipped

   Note: run "netsh ipsec dynamic show /?" for more detailed information


The command completed successfully

Share this post


Link to post
Share on other sites

Hi.

 

- gib bei der Netzwerkkartenkonfigruation einmal den 2. DNS Eintrag weg. Hier hat nur die IP des eigenen DNS zu stehen. Weiterleitungen werden im DNS selbst konfiguriert

 

- überprüfe, ob im DNS Forward und Reverse Zonen angelegt wurden. Wenn nein, dann nachträglich einrichten, wenn ja, dann überprüfen, ob in beiden Zonen der Server korrekt eingetrgen wurde.

 

LG Günther

Share this post


Link to post
Share on other sites

So, ich hab jetzt einfach mal mit dcpromo die komplette Domäne (waren eh noch nicht viele Einstellungen gemacht) und alle einträge beim DNS & DHCP gelöscht.

Jetzt lasse ich gerade mit Hilfe des Setups ein neues AD installieren.

 

melde mich wenn's was neues gibt

 

Danke für den Tipp mit Dem 2. DNS, kannte es immer nur so.

Die Lookupzonen waren eingerichtet, da es aber nicht funktioniert hat, gehe ich davon aus, das sie nicht korrekt waren.

Share this post


Link to post
Share on other sites

So ich war es leid, habe dem RAID den Spiegel geklaut, neuinstalliert und alles wunderbar!

Hätt ich das mal eher gemacht, drei Tage Stress und Verzweiflung wären mir erspart geblieben!

 

Ein kleines Prob habe ich aber noch, mein Auftraggeber wollte sparen und hat weder floppy noch einen RAID-Controller verbauen lassen (dabei Kosten ja wirklich beide nicht mehr die Welle!).

 

Das Problem ist das er einen SW RAID-1 haben will. Ich konnte den Mirror bisher nicht davon überzeugen zu booten (blinkender Curser oben links).

 

Es wurden zwei baugleiche SATA-HDD verbaut, den Slave (Mirror) als Master zu nutzen brachte keinen Erfolg.

 

Ich weiß, dass man sich eine floppy erstellen kann, mit der man dieses Problem umgeht, habe aber nichts gefunden um dafür einen USB-Stick oder CD zu verwenden.

 

Ich vermute ich werde ein Floppy-LW besorgen müssen, floppy anlegen, und das ganze dann auf stick oder cd packen müssen. Hat jemand eine Alternative?

 

Gruß,

 

readhead

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...