Jump to content
Sign in to follow this  
kaype

FTP Verbindung bricht nach Login einfach ab

Recommended Posts

Mahlzeit...

 

Ich benutze bei 2 Servern die gleiche Methode um von einem Softwarehersteller mit dennen die Kunden arbeiten Fernwartung zu realisieren, zum einen einen sehr eingeschränkten Account der quasi nur das Programm des Herstellers aufrufen kann über den mit VPN gearbeitet wird und ein FTP Server um Updates etc. einzuspielen und Datenbanken zu holen falls etwas verändert werden muss.

 

Seit geraumer Zeit läuft das nicht mehr ... und zwar auf beiden Servern. Da ich beide quasi identisch eingerichtet hab muss es also irgendwie zusammenhängen ... leider benutz ich selbst den FTP Account nicht und der Hersteller nur sehr sehr sporadisch, somit kann nicht festgestellt werden seit wann dieser Zustand ist ...

 

Umgebung:

 

Windows 2003 SBS SP2 inkl Exchange 2003

Serv-U 4.0 als FTP Server, sehr simpel eingerichtet.

 

Ich hab alles versucht, auf anderen Ports ausser 21 gehts bis zum Directorylisting, dann kommen aber keine Daten mehr an, auf Port 21 bricht es sofort ab nachdem der Username eingegeben wurde ... ohne irgendwelche Rückmeldungen ... OFFLINE. Der User ist im FTP Server noch angemeldet wie mir da activity anzeige sagt.

 

Ich hab dann einen anderen Freeware Server getestet PFTP ... gleiches Bild ... an der Software kann es also nicht liegen ... Fehler ist EXAKT der gleiche.

 

Verbindungen direkt vom Server zur eigenen IP oder localhost funktionieren absolut Problemlos.

 

Aus dem Eigenen Netz gehts schon nicht also kann der Router nicht schuld sein

 

Das Switch ist in beiden Fällen ein dlink 48 Prt Managed Layer2 Switch, einmal als 100Mbit und einmal als 1000Mbit Variante ... und da sonst alles läuft kann ich die eigentlich auch ausschließen.

 

Jemand eine Idee was das sein kann? Ich bin hier schon am Haare raufen ... aber ich find nix.

 

Für jedem Tipp dankbar ... Fabian

Share this post


Link to post
Share on other sites

Öhm, wo befindet sich der oder die FTP-Server ? Bei Dir im Haus und die Leute greifen drauf zu oder Du greifst vom Firmennetz auf FTP-Server ausserhalb zu ? Wie erfolgt der Zugriff, mit aktivem oder passivem FTP ?

Share this post


Link to post
Share on other sites

Das ist vermutlich der Proxy/Firewall ins Internet nicht korrekt konfiguriert. MAch Dich hier mal File Transfer Protocol - Wikipedia über das FTP-Protokoll schlau. Im übrigen sollte ein Hersteller kein Password verwenden, dass Du nciht kennst. Und zur Sicherheit sollte zumindest Secure File Transfer Protocol - Wikipedia verwendet werden.

 

-Zahni

Share this post


Link to post
Share on other sites

Der Server steht hier im Haus, ich teste aber auch steht von aussen.

 

- Zugriff vom Server selbst (IP, localhost, 127.0.0.1) geht ohne problem, egal auf welchem Port

- Zugriff aus dem internen Netz klappt nur auf Port 777, nicht auf 21

- Zugriff von extern bricht bei Port 21 direkt nach der Eingbe des Users ab ohne Kommentar, bei Port 777 kommt er bis zum directorylisting und bleibt dort stehen.

 

Ich hab grade bei dem einen Router den Port 21 extern auf intern 777 umlegen lassen, nun klappts komischer weiße, wenn ich 777 durchrouten lasse gehts nicht sondern er bleibt bei dir. listing stehen ... das scheint also an dem router zu liegen (ist so ne SMC büchse)

 

Ist erstmal ne Lösung, nur kann das der Router (Linksys) des anderen Kunden nicht ... hm ... aber eventuell geht da ja auch 777 direkt von aussen, das hab ich noch garnicht getestet ...

 

Bleibt trotzdem die Frage warum funktioniert Port 21 nicht?

 

Verbindung ist aktiv ... kein PASV Mode ... daher auch kein Routing von Port 20.

 

grüße, Fabian

Share this post


Link to post
Share on other sites
Das ist vermutlich der Proxy/Firewall ins Internet nicht korrekt konfiguriert. MAch Dich hier mal File Transfer Protocol - Wikipedia über das FTP-Protokoll schlau. Im übrigen sollte ein Hersteller kein Password verwenden, dass Du nciht kennst. Und zur Sicherheit sollte zumindest Secure File Transfer Protocol - Wikipedia verwendet werden.

 

-Zahni

 

Moin

 

ich weiß wohl was ftp ist ;) ...

 

Wieso Passwort? ich kenn alle Passwörter ... nur komme ich nicht dazu eines einzugeben ...

 

grüße ...

Share this post


Link to post
Share on other sites

Aktive Verbindungen benutzen Port TCP 20, passive nicht (oder meinst Du das so und ich habe es falsch verstanden ?) und ausserdem sind die Verbindungsrichtungen anders. Der Router erkennt an dem State, das FTP benutzt wird und Standard ist die Initialverbindung über TCP 21 (meiner kann das auch nur so erkennen). Application Layer Firewalls können in den Datenstrom sehen und können auch andere Ports benutzen ...

edit: Hm, aber wenn ich mir das recht überlege, ist das eher relevant, wenn die Verbindung von innen nach aussen mit aktivem FTP und Outgoing-Regeln erfolgt , hmmm. Und ausserdem, wo kommt denn der TCP-Port 777 her, horcht der FTP-Server auf diesem Port, weil Du ja selbst von innen nur mit diesem Port Verbindung bekommst ?

Share this post


Link to post
Share on other sites

Hab ich einfach mal als "test" eingegeben ...

 

Auf 777 funktionierts ja auch problemlos.

 

Mich wundert es halt nur das der kram seit über 2 Jahren Problemlos lief, ohne das ich da jemals was dran gemacht oder gar dran gedacht hätte, und auf einmal kommt der anruf vonwegen ... "können nicht mehr connecten" ... und es ist auf 2 server exakt das gleiche ... egal mit welchem FTP Server program ... Firewall ist auf dem Server direkt keine aktiv, daher wundert es mich ja auch das ich intern im netz solche Probleme hab.

 

grüße ...

Share this post


Link to post
Share on other sites

Nur damit ich es richtig verstehe ... Du hast den FTP-Server auf einen anderen Port als den Default Port gestellt (TCP 777 z.B.) und damit klappt intern die Verbindung. Wenn Du ihn auf TCP 21 stellst, klappt die Verbindung nicht. Läuft da noch ein zweiter FTP-Server, eventuell einer, der Dir untergejubelt wurde ?

edit: Oder hat einer Deiner Kollegen den IIS-FTP da raufgemacht ? :D

Share this post


Link to post
Share on other sites

Also jetzt wirds langsam wirr ...

 

Erstmal zu ITHome,

 

nein, da läuft kein 2. FTP ... wenn ich einen 2. Aufmache und den anderen Versuch auf dem gleichen Port zu starten kommt auch sofort eine Meldung das der Port nicht mehr frei ist.

 

Das hab ich ja wie gesagt gelöst indem ich einfach den FTP Server auf nem 2. Server (in dem Fall ein SQL ServeR) installiert hab der per Netzwerk auf den gewünschten Pfad zugreift. Zwar nicht die eleganteste Lösung aber ich brauchte erstmal was was funktioniert.

 

Was ich aber grade festgestellt hab bringt mich doch echt zum verzweifeln.

 

Ausgehende Verbindungen auf Port 21 sind auch nicht möglich ... HÄÄÄÄ?!?!?!?!?!

 

Ich update einmal am Tag ein "Webpinboard" auf der Firmenseite ein Verzeichniss auf einer Netzwerkfreigabe ... PDFs, Bilder, etc. ... das mach ich einfach Nachts via FTP Verbindung, lösch alles auf dem Webspace und kopier das Verzeichniss neu rüber. So können Mitarbeiter Dokumente und Bilder Tagsüber in das Verzeichniss legen und am nächsten Tag können Kunden etc. dann drauf zugreifen. Wir haben unseren Webspace bei einem Hoster... daher die komplzierte Weg. Dies Script funktioniert nun halt auch nicht mehr da die FTP Verbindung stehen bleibt. ÄH!? Login etc. klappt aber sobald auf dem FTP "gearbeitet" werden soll, in dem Fall mdelete, bleibts einfach stehen.

 

Switch, Router, DSL Leitung, Firewall, Hardware kann ich komplett ausschließen da ich es EXAKT so auf einem 2. Server habe. Also GENAU den gleichen Fehler mit anderem Router, Swicht, Serverhardware.

 

Hat jemand ne Idee? Ich krieg echt die Kriese.

 

Aus IRGENDEINEM Grund gehen ein und ausgehende Verbindungen über Port 21 nicht Störungsfrei. Ich bin sogar schon soweit gewesen das ich nach Viren und Trojanern geforscht habe ... aber das war wie erwartet nicht der Fall, Virencheck blieb ohne befund und hijackthis log hat auch kein bösartigen Dienst festgestellt.

 

ich rauf mir hier wirklich die Haare ... einen eingehenden Fehler bei einem Dienst der irgendwie Port 21 benutzt hät ich ja verstanden ... aber ausgehend auch?

 

Am Prot Forwarding vom Router kann es auch nicht liegen, von meiner Workstation geht der FTP Befehl ohne Probleme. ES MUSS an der Konfiguration von Windows 2003 liegen.

 

Any ideas? Ich würd graue Haare kriegen wenn ich nicht schon welche hät :/

 

grüße, Fabian

Share this post


Link to post
Share on other sites

Hab es jetzt erstmal soweit eingegrenzt das es vom Server aus wegen der fehlenden PASV unterstützung des Commandline FTP Programms nicht geht, habs jetzt mit einem andere (ncFTP) gemacht und damit funktioniert es.

 

Nachwievor muss es aber eine Sache sein die wegen dem Server nicht geht da ich von meiner Workstation aus mit dem FTP Programm wunderbar alles machen kann, vom Server aus ging es bis vor wenige Wochen ja auch Problemlos, wenn ich dem Datum der files auf dem Webserver glauben darf bis zum 11.6.

 

Schon sehr merkwürdig...

 

Danke für die Links, werde ich mal testen wenn ich Abends hier meine ruhe hab, an der TCP/IP Config vom Server rumbasteln im normalen Betrieb kommt wohl eher nicht so gut :)

 

Trotzdem alles sehr sehr merkwürdig ... :|

 

grüße, Fabian

Share this post


Link to post
Share on other sites

@ITHome,

 

hab mal den Reset gemacht, hat allerdings nichts gebracht ... den TCP/IP Kram deinstallieren wie in dem 2. Link von dir wollt ich den letzte Nacht doch nicht noch machen ... kam grad mit meiner Freundin ausm Kino und bin noch schnell in das Büro des Kunden da es auf dem Weg nach Hause lag und um 1:15 war meine Freundin dann doch etwas genervt noch ins Büro zu "dürfen" :D :D :D

 

Naja, hab den Server nun auch weitgehendst von seinen FTP Pflichten entbunden von daher ist das alles auch nicht so wild, aber ich würde es trotzdem gerne verstehen.

 

defacto kann es nicht am Netzwerk liegen da ja wie gesagt die FTP Verbindung via ftp.exe von Microsoft von einer Workstation aus problemlos funktioniert, egal ob an IP oder domainname. Sonst funktioniert ja auch alles prächtig ... nur halt aktives FTP vom server aus geht nicht, ging aber bis vor ein paar Wochen Problemlos.

 

Wenn noch wer ne Idee hat, nur her damit!

 

grüße, Fabian

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...