Jump to content
Sign in to follow this  
tomw

DOS Programme langsam

Recommended Posts

vorab - es ist NICHT das Problem der 100% CPU Auslastung!

 

Wir hatten einen Win2000 server im EInsatz auf dem ein altes DOS Buchhaltngs-Programm läuft (die Buchhalter lieben die DOS Version).

PCs laufen alle mit WinXP Prof - am alten server null probleme mit dem DOS Programm.

 

Jetzt wurde der durch einen Win2003 server ersetzt - setdem haben 2 (und nur diese ZWEI) PCs Probleme mit dem DOS Programm - ist läuft aber LANGSAM.

So langsam dass die beiden Benutzer fast nicht damit arbeiten können.

 

Reporte die früher und an den anderen PCs nicht mal ne Sekunde dauern, dauern auf den beiden PCs 20 Sekunden.

 

Alles andere EMail, Office, andere DB-Anwendungen laufen auf ALLEN PCs (inkl. der zwei Problemrechner) einwandfrei und schnell.

 

Das Dos Programm liegt auf dem Server und wird per Batch von den PCs auf einem gemappten Laufwerk aufgerufen. Die Serverdateien wurden 1:1 kopiert, an den PCs nichts verändert was das DOS betreffen könnte.

 

Das DOS programm läuft auf dem Server einwandfrei schnell - files buffers alles kontrolliert und identisch - netzwerkeinstellungen unverändert und ok - antivirus deaktiviert an PC und server = nix

 

mir gehen die Ideen aus!!!??? hat jemand noch welche ???

Share this post


Link to post

Tach auch ;)

Die Serverdateien wurden 1:1 kopiert, an den PCs nichts verändert was das DOS betreffen könnte.

 

Anhand der Antwort vom Doc magst du erkennen, wie schwierig eine weitere Diagnose ist; auch wenn kein fortführender Hinweis zur Lösung ersichtlich ist.

 

Du allein hast es in der Hand, die Unterschiede zu finden:

Servicepack, Hotfixes, Ereignisanzeige der Clients.

Eventuell Eventlog am Server greift einer der Clients auf die Anwendung zu (Sage KhK Classic 1.0 denke ich?) ;)

 

Deine einzige Chance ist ein Vergleich mit einem funktionierendem Client, nicht selten klemmt es an fehlerhaft angewandten Gruppenrichtlinien weil die Clients per Image duppliziert worden sind.

Viel Erfolg bei der Suche ;)

So als Ansatzpunkt

Share this post


Link to post

Sachma, taugt das alte Teil überhaupt noch? Ich denke da mal nur an die MwSt. Wenn das noch DOS ist hat das wohl noch 15% drin. Oder ist es schon wieder alt genug, dass man den Steuersatz noch direkt im Prog ändern kann? Ist ja heutzutage von der Oberfinanzbehörde nichtmehr gestattet, dass das im Prog geändert werden kann.

 

Edit: Hast du evtl auf den anderen PCs den Share aus dem Virenscanner ausgeschlossen und nur auf den beiden nicht?

Share this post


Link to post

Edit: Hast du evtl auf den anderen PCs den Share aus dem Virenscanner ausgeschlossen und nur auf den beiden nicht?

Hatte mal einen Kunden, der hat auf Server und Clients McAfee installiert, nur auf einen PC war McAfee/Home. Der PC war extrem lagsam im Netz, ein arbeiten war nicht möglich. Stelle mal zum Test mit Msconfig auch die Dienste vom Virenscanner aus.

 

MfG Schotte

Share this post


Link to post

-Leg da DOS-Programm lokal auf einen der PCs ab

-probier den Aufruf mit "start /separate program.cmd"

-füge den Uservariablen auf den PCs tmp und temp den Pfad "c:\windows\temp" hinzu

 

cu

blub

Share this post


Link to post

Manchmal hilft da auch der Parameter -forcedos, ausserdem sollte man ebenso die Pfadvariablen auf Vollständigkeit/Gleichheit bei funktionierendem und Problem-Client checken und die Einstellungen "Files" und "Buffer" in der config.sys (ja eigentlich config.nt) verglichen werden.

 

Grüsse

 

Gulp

Share this post


Link to post

erstmal Danke für die Antworten

 

1.- ob das DOS Prog was taugt oder nicht, habe ich nicht zu entscheiden, ich muss es nur ans laufen bringen. Die Buchhalter sind so glücklich damit weil es im Vergleich zur Windows Version (die sie auch installiert haben) viel schneller zu bedienen ist - bis man sich in der Win Version durch die Felder getapt hat, ev. listboxen bearbeitet hat und kreuzchen gesetzt hat und hier und da geklickt hat - hat man in DOS die gleiche Arbeit schon 10mal erledigt - fortschritt ? naja....

 

2.- Netzlaufwerke werden durchs loginscript alle erstmal getrennt und neu verbunden - bei jedem einloggen

 

3.- wir verwenden McAfee Virusscan Enterprise 8.0 auf PC und server, zusätzlich den Orchestrator - die konfiguraiton aller PCs wurde durch ein FramePackage gemacht - alle PCs also identisch

 

4.- Dos lokal geht nicht da mehere user darin arbeiten - würde auch nix bringen weil es da nicht verbleiben könnte

 

5.- uservariablen die tmp und temp, files und buffers und die config.net (auch autoexec.nt) habe ich verglichen = nix

 

NEU - ich hab auf einem der Problemrechner TameDOS installiert ( Tame Product Summary ) was mir vor langer zeit schon mal geholfen hat bei dem Dos Programm 100% CPU Problem - hat aber hier leider nix genutzt.

 

Wie gesagt, hat sich an den PCs nix verändert durch den serverwechsel, ok dns wurde verändert - McAfee mit neuem FramePackage (das aber auf ALLEN PCs) den rest erledigt das geänderte loginscript - daten wurden 1:1 kopiert

 

kennt jemand irgendwas was auf dem win2003 server dazu führen könnte dass DOS Progs langsam ausgeführt werden....

 

Danke - ich bin echt am verzwifeln... :-(

Share this post


Link to post

zu files und buffers:

 

Buffers

Der Befehl wird nicht von Windows XP und der Windows Server 2003-Produktfamilie verwendet. Der Befehl ist nur deshalb vorhanden, um die Kompatibilität mit vorhandenen MS-DOS-Dateien aufrechtzuerhalten. Bei der Eingabe an der Befehlszeile hat der Befehl keine Wirkung, da die Funktionalität automatisch gegeben ist.

Share this post


Link to post
Hatte mal einen Kunden, der hat auf Server und Clients McAfee installiert, nur auf einen PC war McAfee/Home. Der PC war extrem lagsam im Netz, ein arbeiten war nicht möglich. Stelle mal zum Test mit Msconfig auch die Dienste vom Virenscanner aus.

 

MfG Schotte

 

 

Das wars scheinbar - hab den on.access scan vom McAfee komplett deaktiviert und schon lief DOS wie gedopt... da das natürlich keine permanente lösung ist hab ich die das DOS-Programm betreffenden netzlaufwerke ausgeschlossen aus dem scan und das wars..!

 

Danke für den Tip Schotte !

 

komisch is nur dass ALLE PCs mit dem gleichen FramePackage konfiguriert wurden und alle anderen ausser den beiden einwandfrei laufen... naja ein weiteres IT miracle

Share this post


Link to post

Hallo,

hab ich die das DOS-Programm betreffenden netzlaufwerke ausgeschlossen aus dem scan und das wars..!

jepp, so hatte ich das Problem dann auch gelöst.

 

 

MfG Schotte

Share this post


Link to post

das wars doch NICHT :-(

 

die kollegen stellen fast dass es wieder langsam ist - ich kann den on-access scan aktivieren, deaktivieren, laufwerke ausschliessen oder auch nicht = keine veränderung das DOS prog is langsam

 

einziger unterschied der jetzt noch aufgefallen ist

es läuft deutlich schneller im fenster

in fullscreen ist es sooooo langsam das die jungs nicht arbeiten können/wollen damit, in einem fenster dauern reportberechnungen die sonst innerhalb einer sekunde aufm schirm waren jetzt so 5 - 10 sekunden - im fullscrenn zum vergleich 30 - 60 sekunden

 

da muss ich wohl morgen mal suchen gehen nach DOS Programm langsam vollbild

 

jetzt reichts mir aber erstmal, jetzt geh ich heim - bis morgen

 

Tom

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...