Jump to content

Community durchsuchen

Zeige Ergebnisse für die Tags "'Windows 10'".

  • Suche mithilfe von Tags

    Trenne mehrere Tags mit Kommata voneinander
  • Suche Inhalte eines Autors

Inhaltstyp


Forum

  • Windows Server Forum & IT Pro Forum
    • Windows Forum — Clients
    • Windows Forum — Server & Backoffice
    • Windows Forum — LAN & WAN
    • Windows Forum — Scripting
    • Windows Forum — Security
    • Tipps & Links
  • MCSE Forum & Cisco Forum
    • Microsoft Zertifizierungen
    • Cisco Forum — Allgemein
    • Testsoftware & Bücher
    • Off Topic

Blogs

  • MCSEboard.de Blog

364 Ergebnisse gefunden

  1. Hi Leute, ich erläutere euch mal mein Problem. Ich suchte nach einem Powershell Script was ich wiederum als LogonScript auf meinem WindowsServer 2016 einbinden wollte. Das heisst wenn sich Jemand mit egal welchem User anmeldet ob am Server oder an einem der beiden Clients die auch in der Domäne sind das sie Automatisch ein eigenes Homeverzeichnis bekommen. Das Script sieht wie folgt aus: param([Parameter(Mandatory=$true)][String]$samAccountName) $fullPath = „\\DC01\HomeDir2\{0}“ -f $samAccountName $driveLetter = „H:“ $User = Get-ADUser -Identity $samAccountName if($User -ne $Null) { Set-ADUser $User -HomeDrive $driveLetter -HomeDirectory $fullPath -ea Stop $homeShare = New-Item -path $fullPath -ItemType Directory -force -ea Stop $acl = Get-Acl $homeShare $FileSystemRights = [System.Security.AccessControl.FileSystemRights]“Modify“ $AccessControlType = [System.Security.AccessControl.AccessControlType]::Allow $InheritanceFlags = [System.Security.AccessControl.InheritanceFlags]“ContainerInherit, ObjectInherit“ $PropagationFlags = [System.Security.AccessControl.PropagationFlags]“InheritOnly“ $AccessRule = New-Object System.Security.AccessControl.FileSystemAccessRule ($User.SID, $FileSystemRights, $InheritanceFlags, $PropagationFlags, $AccessControlType) $acl.AddAccessRule($AccessRule) Set-Acl -Path $homeShare -AclObject $acl -ea Stop Write-Host („HomeDirectory created at {0}“ -f $fullPath) } Wenn ich es mit der Powershell öffne also er es ausführt kommt direkt eine Fehlermeldung die sieht man nicht weil sich die PS Console direkt schließt, deswegen habe ich das Script mal per STRG+V in eine geöffnete Console eingefügt Da läuft es dann zwar er legt das Verzeichnis also Das Homeverzeichnis auch an aber er fragt den SAMACCOUNTNAME ab also den muss ich dann Manuell in die Console eingeben. genau deswegen funktioniert das als Logon Script nicht. Die Frage ist wie mache ich das das er einfach den eingeloggten User erkennt und für den dann das Homeverzeichnis anlegt? PS: Ich weiss ich weiss ich kann das auch Manuell alles anlegen aber das will ich nicht und das ist auch nicht meine Aufgabe es muss so gehen. thx:)
  2. Grüßt euch, folgendes Problem und ich hoffe ihr habt noch eine Idee: Im Einsatz ist ein WSUS auf Server 2016 (1607). Des Weiteren hauptsächlich Windows 7 und einige Windows 10-Clients (1607). Server sind 2008 R2, 2012 R2 und 2016 (1607) im Einsatz. Die GPO zum verteilen der Updates sieht wie folgt aus: Clients automatisch herunterladen und installieren, Server nur auf neue Updates prüfen. Das herunterladen und die Installation mache ich nachts manuell. Des Weiteren ist der WSUS-Server mit FQDN und insgesamt 3x in der entsprechenden GPO angegeben (z.B. auch im Punkt "Alternativen Update-Server angeben"). Die ADMX-Dateien sind aktuell (kopiert von einem Server 2016 (1607)). Windows 7, Server 2008 R2 und Server 2012 R2 finden alle Updates per WSUS und installieren diese auch ordnungsgemäß. Nur bei Server 2016 und Windows 10 gibt es Probleme. Dort werden zwar alle normalen Updates, z.B. KB4091664 oder Defender-Definitionen gefunden und installiert, nicht aber die monatlichen Kumulativen Updates (z.B. KB4457131), obwohl WSUS diese gefunden hat und von mir freigegeben werden. Hat hier noch jemand eine Idee woran das liegen könnte? Vielen Dank!
  3. Hallo zusammen, in einer Schulungsumgebung mit Windows 10 Education mit SA steht die Aufgabe, einige vorkonfigurierte VM's auf mehrere Hosts zu verteilen. Die VM's wurden auf einem der Rechner unter Hyper-V erstellt und exportiert. Leider sieht der Import-Assistent diese exportierten VM's gar nicht. Die Ursprungsmaschine erkennt die exportierte VM, jedoch keine andere tut es. Ähnliche Themen hier (die ich gefunden habe) beziehen sich auf Export/Import zwischen verschiedenen Server-Versionen. Bei uns sind jedoch alle Rechner hardware- und softwaremäßig gleich. Was mache ich falsch? Viele Grüße varnik
  4. Hallo, ich suche eine Netzwerkkarte von Intel zum Nachrüsten, damit WOL unter Windows 10 funktioniert. Das geht am Besten, wenn der original Treiber von Intel installiert werden kann und nicht jede Karte unterstützt die Win10 Treiber von Intel. Hat jemand einen Tip? v
  5. Hallo. Hier mal eine Frage zum Thema Reparatur von Workstations. Wir hatten in unserer Außenstellen einen Rechner, bei dem das Computerkonto wohl beschädigt war. Das Zurücksetzen des Computerpasswortes war leider nicht erfolgreich. Was macht man am sinnvollsten, ohne den Kollegen in der Außenstellen das lokale Adminpasswort zu geben oder erst stundenlang zur Außenstelle zu fahren? 4-5 Stunden Arbeitszeit für eine solche Wartung sind irgendwie uneffektiv... Vielen Dank im voraus für Eure Antworten. LG Dirk Emmermacher
  6. Moin, wie wohl so viele andere auch haben wir Probleme mit den nervigen Windows-Updates und dem noch nervigeren automatischen automatischen Neustart. Egal, in wie lange ich schon im Internet nachgeforscht habe und welche Einstellungen ich gemacht habe, die Clients starten immer selbstständig neu solange ich autom. Updates per GPO aktiviert habe, Vielleicht kann sich hier ein Experte unsere Einstellungen mal anschauen und mir sagen was ich verkehrt eingestellt habe. Die Rechner sollen automatisch Updates suchen und installieren. Nur soll der benötigte Neustart bitte immer beim manuellen Herunterfahren durchgeführt werden. Die Rechner werden in der Regel alle über Nacht zum Feierabend heruntergefahren. Trotzdem wollen die PCs ab und an den Zeitpunkt des Neustartes selber festlegen (meistens mit ca. 10 Minuten Vorlauf oder auch ganz ohne Warnung) Wir haben einen WSUS-Server bei und im Büro laufen. Der Server ist auf Windows Server 2012 R2 aufgesetzt und beinhaltet keine weiteren speziellen Dienste Die Rechner laufen bis auf 2-3 Ausnahmen alle auf Windows 10.
  7. Surface 4 Pro Windows 10 Bootet nicht mehr

    Hi, ich verzweifle hier mit einem Surface 4 Pro und Windows 10. Das Teil bootet nicht mehr, sondern bringt nur noch einen blauen Bildschirm mit der Meldung: Ich habe schon versucht, von einem Windows 10 Stick zu booten, was mir aber auch nicht gelungen ist. Ich habe es sogar schon mit Ubuntu versucht, aber auch das ging schief. SecureBoot und TPM habe ich schon deaktiviert. Ebenfalls ohne Erfolg. Seltsamerweise kommt die oben genannte Fehlermeldung nur, wenn ich das Ladegerät am Surface angeschlossen habe. Starte ich das Gerät, während es auf Akku läuft, kommt folgende Meldung: Mir geht es mittlerweile gar nicht mehr darum, das komplette System zu retten, sondern nur noch eine Access-Datenbank, die auf der lokalen Platte liegt und seit 2 Monaten nicht mehr gesichert wurde. Kann mir jemand weiterhelfen und sagen, wie ich Zugriff auf die SSD bekome?
  8. Es wäre schön (für mich zumindest) wenn es zB. hier einen fix oben platzieren Thread gäbe, in dem die verschiedenen Programme aufgeführt sind, um Win10 zu administrieren. Da wären zB. (Ohne dass die Reihenfolge einer Idee folgt!): Windows Taste + X > Ausführen > GPEDIT.MSC a) Computer Konfiguration\Administrative Templates\Windows Komponenten\Windows Update -> “Automatische Updates konfigurieren” auswählen und Nummer 2 selektieren zusätzlich kann man die Qualitätsupdates und/oder Funktionsupdates zurückstellen b) Computer Konfiguration\Administrative Templates\Windows Komponenten\Windows Update\Windows Update für Unternehmen -> Beim Empfang von Qualitätsupdartes auswählen und/oder ->Zeitpunkt für den Empfang von Vorabversionen und Funktionsupdates Windows Taste + X > Ausführen > SERVICES.MSC Dienste: eigene, von Windows, Programmen, ... Windows Taste + X > Ausführen > REGEDIT Automatische Zeiteinstellung, ... ... Da ich nur alle Jahre mich mal damit beschäftigen muss, vergesse ich immer wieder wie die genauen Zauberformeln sind, um die jeweiligen Programme erscheinen zu lassen. Vielleicht könnte da man auch für verschiedene Themen kleine HowTos hinterlegen, wie zum Windows update.. Nur so eine Idee...
  9. OL2016/Ex2010 - häufige Kennwortabfrage

    Hallo zusammen, ich habe hier an einigen Client (leider bei der GF) die Problematik, dass der Nutzer häufig zur Kennworteingabe aufgefordert wird. Eine Eingabe des Domänenkennwortes hilft hier leider nicht, auch ein Test mit AD-Domain.com\AD-Benutzername oder anderen Variationen hinterlässt nur mehr Verwirrung da das Fenster mal direkt wieder auftaucht und Outlook dann mal wieder für 5min zufrieden ist. Ich kann das ganze schlecht beschreiben, es tritt nur vereinzelt alle paar Wochen mal auf oder dann, wenn der GF sein Notebook mal wieder seit einer Woche nur im Standby/Aufwachen/Standby....-Betrieb nutzt. Nun hat ein Mitarbeiter erstmalig seit heute dieses Problem und ich kann mir einfach nicht erklären, woran das liegt. Er hat sein Notebook heute früh gestartet und hat nach 5min ein Fenster mit folgendem Wortlaut: Micorosoft Outlook Verbindung mit Vorname.Nachname@DomainDerAG.com wird hergestellt Eingabefenster mit o.a. Email-Adresse Eingabefenster mit Kennwort Button für "Anmeldedaten speichern" Drückt man hier auf Abbrechen, synchronisiert Outlook nicht und bleibt bei der Meldung "Kennwort erforderlich". Nun habe ich eben gesehen, dass es dann bei Senden/Empfangen einen Knopf gibt, der Exchange Kennwort eingeben o.ä. lautet. Drückt man diesen, baut Outlook die Verbindung auf. Outlook ist hier momentan sehr hartnäckig und kommt alle paar Minuten mit der Aufforderung. Hinweise die ggf. nützlich bei der Problemfindung sein könnten: a) Ein mögliches Problem in unserer Umgebung ist, dass die AD-Domain sowie der AD-Benutzername sich nicht mit der Email-Adresse oder der @DomainDerAG.com Bezeichnung deckt. Insofern könnte es ein Problem sein, dass das Kennwort-Fenster den voreingestellten Eintrag Vorname.Nachname@DomainDerAG.com anbietet. Dies haben wir aber seit ein paar Jahren ohne sonstige Probleme. b) Interessant ist auch, dass dem Nutzer danach eine Abfragefenster mit einer E-Mail-Adresse eines Nutzers angezeigt wurde, dessen Kontolöschung ich derzeit vorbereite. Die E-Mail-Adresse dieses Nutzers wird hierfür vorrübergehend auf Vorname.nachname.alt@DomainDerAG.com geändert und in einer Verteilerliste (Weiterleitung an eine Autoreply-Adresse) genutzt. Hier fragt man sich natürlich.. warum wird mir das angezeigt? Der Nutzer hat den Kalender des zu löschenden Benutzers in seiner Outlook-Kalenderliste eingeblendet -> Das wäre eine Idee, warum danach gefragt wird. Seit Löschung der Kalenderverknüpfung taucht dieses Abfragefenster nicht mehr auf. c) Der Vollständigkeit will ich erwähnen, dass unser Server sowie das Zertifikat nicht auf die DomainDerAG.com lauten. Die Email-Domain wurde durch den Verkauf unserer Firma 2015-16 geändert. Der Server ist immer noch über mail.altedomain.com erreichbar und liefert auch per SMTP Mails aus - Ohne Probleme Wir empfangen die Mails über einen Zentralen Dienstleister der die Zustellung ganz banal über einen LinuxServer an die verschiedenen Firmen verteilt. max.mustermann@DomainDerAG.com wird an Standort1 geroutet. maria.mustermann@DomainDerAG.com wird an Standort2 geroutet. d) Unsere Umgebung sieht wie folgt aus: Win10 1803 mit Office 2016 Exchange 2010 mit RU23 Vielen Dank für jeden Tipp. edit: Habe eben die Info bekommen, dass die Abfrage mit dem zu löschenden Nutzer auch nach Entfernung der Kalenderverknüpfung erscheint. Diese soll übrigens nicht mehr in den Exchange-Adresslisten angezeigt werden, die Änderung ist aber auch erst eine Std. alt. Ich erwähne es, weil es das erste mal ist, dass ich diese Kennwortabfragen irgendwie mit einer Konfiguration am System in Verbindung bringen kann.
  10. Hi, ich möchte gerne meine Rechner mit WDS installieren. Hierzu habe ich auf einem extra Server die Bereitstellungsdienste installiert. Ich habe auf dem DHCP Server die Option 66 (mit dem Servernamen des WDS Servers) und die Option 77 (Boot\x64\bootmgfw.efi) eingetragen Auf dem WDS habe ich unter "Startabbilder" die boot.wim eines vanilla Windows 10 1803 hinzugefügt. Wenn ich nun auf meinem Client PXE Starte, dann bekomme ich dort diese Meldungen: Google sagte ich soll das wim Image einmal mounten und wieder unmounten. Hat aber nichts gebracht Ich konnte bisher nicht rausfinden, wieso ich die 2. Meldung bekomme. Hat hier jemand eine Idee?
  11. Hallo Profis! Ich arbeite gerade an einer Lösung für das folgende Szenario. Unternehmen mit über 6000 Clients (Win7 - 10). Unterschiedliche Modelle, aber vorwiegend HP Geräte. Boot MBR, Legacy und UEFI (GPT). Wir sollen die Rechner fern installieren. Das klappt auch so weit. Um Boot Reihenfolge umzustellen, damit PC als erstes PXE bootet, verwenden wir HP Software. Nun klappt das auch nicht immer, besonders bei neuerem BIOS und ist auch sehr umständlich bei vielen Modellen. Ich habe mir folgendes ausgedacht. Bei MBR und Legacy Boots funktioniert das auch sehr gut. Mit diskpart schalte ich die erste (boot) Partition als inactive. Danach kann PC nicht mehr im Windows booten und läuft in PXE. Bei UEFI werden die Funktionen nicht unterstützt. Ich habe schon mit bcdedit verschiedene Variationen ausprobiert. Finde aber keine Lösung. Dabei soll auch berücksichtigt werden, wenn am Anfang was schief läuft, muss man in installierte Windows zurückkehren können. Bei der MBR Lösung kann ich die Partition active schalten und Windows ist wieder da. MfG
  12. Sehr geehrte Damen und Herren, nachdem ich einige Zeit recht erfolglos versuche dieses Problem selbst zu lösen muss ich nun hier um eure Expertenhilfe ersuchen! Google hilft mir nur bedingt, eventuell suche ich sogar nach den falschen Dingen :( Mein Problem: Wir hatten vor kurzem eine Serverumstellung und seitdem funktioniert die Suche in Outlook 2010 / Exchange 2016 offenbar nicht mehr richtig. Folgende Suchaufgabe ist gegeben: Max Mustermann (alles klar, findet er) (Steht in den Feldern Name und Nachname) Folgende Suchaufgabe: 21587 (diese Kundennummer steht im Feld Namenszusatz bei Max Mustermann) gibt unten stehende Fehlermeldung aus. Vor der Umstellung war es problemlos möglich nach Kundennummer, Name oder Nummer und Name in der Schnellsuche "Kontakt suchen" (rechts oben) zu suchen. Das ist nun leider nicht mehr möglich. Sucht man nun nach der Klientennummer bekommt man die Fehlermeldung "Der angeforderte Kontakt konnte nicht gefunden werden" zurück. Vervollständigt Outlook die Sucheingabe automatisch und ergänzt die Kundennummer automatisch gibt es keine Fehlermeldung - es passiert nichts. Der lokale Suchindex wurde bereits zurück gesetzt / neu aufgebaut, zu mehr Lösungsansätzen bin ich leider nicht gekommen. System: Windows Server 2016 16GB RAM Exchange 2016 Das Kontaktformular wurde mit den Entwicklertools stark überarbeitet - schon vor der Serverumstellung und die betroffenen Felder sind alle aus dem Orginalformular. Clients: Win 10 Outlook 2010 Eventuell hat hier jemand eine Idee für mich wie ich mein Problem lösen kann! Wäre wirklich dankbar!! Danke für eure Bemühungen! Mit freundlichen Grüßen Sbeans
  13. Hallo, ich bin ratlos, hoffe hier Hilfe erhalten zu können :/ Bin nicht nur hier neu hier im Forum, sondern in der Tat auch Windows Server unerfahren. Aber ich glaube, dass das Problem leichtwiegend sein sollte, und mit Eurer Hilfe ein Klacks. Situation: Kleines Netzwerk bestehend aus zwei PCs (ein win7, ein win10) und einem Server mit Windows Server 2008 R2. Der Server hat nur zwei Jobs: Zum einen dient er als gemeinsame Netzwerkfestplatte, zum anderen hostet er ein DATEV Programm, welches man benutzt, indem man sich von einem der PCs über die Remotedesktopverbindung zum Server einklinkt. Der Win7 PC macht auch alles wunderbar. Der Win10 PC tat es auch mal, jetzt nicht mehr. Seit dem 1709 Update, oder erst dem 1803, da bin ich mir nicht sicher, hat der Win10 PC aber keinen Zugriff mehr auf die Netzwerkfestplatte vom Server. Diese Festplatte ist aufm Arbeitsplatz zwar immernoch zu sehen, hat jedoch ein rotes Kreuz. Wenn man drauf zugreifen will, kommt das Benutzer/Passwort Fenster, dort ist aber bereits schon in roter Schrift notiert, dass er keine Verbindung zum Server herstellen kann. Denn genauen Wortlaut habe ich nicht mehr im Sinn, bin aber übermorgen wieder vor Ort und kann diesen bei Bedarf hier reinschreiben. Interessant ist, dass ich aber mit diesem Win10 PC weiterhin über die Remotedesktopverbindung eine Verbindung herstellen und diese wie gewohnt nutzen kann. Warum aber habe ich keinen Zugriff auf die Netzwerkfestplatte? Habe gegooglet wie wild, und nach allem was ich gelesen habe (was wegen meiner nicht vorhandenen Erfahrung mit Servern echt etwas überfordernd war), tippe ich als Laie mal entweder auf: A: Hat irgendwas mit der nun aus Windows 10 verbannten Heimnetzgruppe zu tun oder B: mit GPO's Liege ich da annähernd richtig? Wie soll ich da vorgehen? Wäre super super dankbar für winks :) Gruss, Kemot
  14. Hallo, mal eine Frage: Obwohl viel gelobt wird, dass andere Programme es besser können: ich fand heraus, dass das manuelle Beschriften von PDF-Dateien mit dem EDGE am "smoothesten" abläuft, die Schrift ist wunderbar weich und nicht so krakelig wie bei Adobe Reader oder anderen Programmen. Nur einen Haken hat das Ganze: Wenn ich eine handschriftliche Notiz in Adobe Reader hinzufüge sehe ich im Reader welcher User das wann gemacht hat. Bei EDGE sehe ich das nicht. Fügt EDGE diese Infos nicht ein oder kann man da in der Konfiguration noch etwas ändern? ich würde das gerne in Edge machen wegen der oben genannten Gründe.
  15. Hallo zusammen, ich hab schon einiges zum Thema recherchiert und gefunden aber ich will hier noch mal in der Runde nachfragen. Mir geht es darum, die Einstellungen App für W2K16 RDS Server für die Nutzer zu beschneiden. Das man den generellen Zugriff sperren kann ist mir bekannt aber mir geht es darum gezielte Menüpunkte zu deaktivieren bzw. für die Nutzer übrig zu lassen. Für Windows 10 gibt es eine enstprechende Einstellung in der GPO "Sichtbarkeit von Einstellungsseiten". Das wäre das ideale Werkzeug auch für den RDS Betrieb aber soweit ich das verstanden habe, gibt es diese Möglichkeit für den 2016 Server nicht... :-( Gibt es andere Möglichkeiten in dem Bereich was zu implementieren? Gruß und Danke Wolke
  16. Also meiner Meinung nach habe ich alles gemacht, um das automatische Update zu verhindern! Im Detail dazu später. TROTZDEM sehe ich gerade ein blaues Fenster: Wir haben ein neues Windows Update für Sie, geplant ist der Neustart um 18:45: Jetzt updaten, Später updaten ... Wie denn das??
  17. Hallo zusammen, wie für Viele andere auch, sind für mich die Lizenzbedingungen bzw. die notwendigen Lizenzen bei der Virtualisierung von Desktopbetriebssystemen nur schwer zu verstehen. Vielleicht kann mir jemand helfen und es mal verständlich erklären. Ich möchte auf unserem ESX-Cluster Windows Desktopbetriebssysteme, in diesem Fall Windows 10 Enterprise, installieren und verschiedene interne Nutzer/PCs darauf zugreifen lassen. Wir haben keine spezielle VDI-Infrastruktur, bislang laufen nur Server auf den ESX-Servern die über entsprechende Windows Datacenter Lizenzen lizenziert sind. Die Rechner der Nutzer selbst sind alle mit Windows Enterprise + SA lizenziert. Damit habe ich, soweit ich das verstanden habe auch die VDA Lizenz, richtig? Brauche ich für Windows 10 Installation auf dem Server noch eine eigene Lizenz und wenn ja welche und in welcher Anzahl? Windows Enterprise mit SA? Woher käme dann die Basislizenz, Windows Enterprise VL gibt es ja nur als Update? Wie verhält es sich hier mit der Lizenzmobilität, da die Instanz ja mal auf diesem und mal auf jenem ESX-Host laufen kann? Braucht der Client eine zusätzliche RDS-CAL um auf die Virtuelle Instanz zugreifen zu dürfen? Wie sieht die Situation aus, wenn externe dritte mit diesen virtuellen Instanzen arbeiten sollen? Ich kann nicht sagen, wie die Rechner dieser Leute lizenzsiert sind und wahrscheinlich ist das auch bedeutungslos, da wir die entsprechenden Lizenzen bereitstellen müssten. Was für Lizenzen muss sich einem externen (Vielleicht sogar wechselnde Geräte und Personen) an Lizenzen zuweisen, damit dieser eine solche virtuelle Windows 10 Instanz auf unseren Servern nutzen dürfte? VDA? RDP? Was wäre, wenn auch interne, nicht mit Windows Enterprise Lizenzierte Geräte auf diese Virtuellen Instanzen zugreifen können sollen, z.B. die MACs unserer DTP Abteilung oder vielleicht in Zukunft auch mal ein Thin-Client? Ist hierfür die VDA-Lizenz ausreichend und die richtige Wahl? Brauch ich hier eine zusätzliche RDS-CAL? Ist es überhaupt zulässig, dass von einem Rechner aus auf verschiedene visualisierte Windows 10 Instanzen zugegriffen wird? Gilt auch hier die maximale Anzahl von 4 Instanzen wie in der EULA von Windows Enterprise beschrieben? Und reicht es umgekehrt aus, auf eine Windows 10 Instanz von verschiedenen Rechnern aus (nicht gleichzeitig) zuzugreifen? Habe ich eventuell sogar noch etwas vergessen? Ich wäre sehr dankbar, wenn mir jemand meine Fragen mal verständlich beantworten könnte. Gruß Mark
  18. Hallo zusammen, ich habe bald die Ehre für ein junges Startup Unternehmen den Admin zu spielen und darf die komplette Struktur (Server, Netzwerk, Clients, etc.) aufbauen. Seit Tagen mache ich mir Gedanken wie ich am besten starten sollte. Benötige ich nur einen Windows 2016 Server auf dem ich alles installiere? Benötige ich mehrere Server auf denen jeweil ein Dienst läuft? VPN oder RDS? Soll der Server im Haus stehen oder in der Cloud? Derzeit tendiere ich zu folgendem Szenario: - 1 physikalischer Windows Server 2016 - 1 DC (Inklusive AD, DNS, DHCP) virtualisert - 1 Exchange Server virtualisert - 1 Fileserver virtualisert - 1 Printserver virtualisert Ca. 10 Windows Clients (7 oder 10) Wie würdet ihr vorgehen? Auch würde mich eure Meinung zum Thema Firewall und VPN interessieren. Softwarelösung? Hardwarelösung? Andere Idee? Viele Grüße Chris
  19. Ich will auch nicht, dass 'mein' Win10 Pro sich selbst updated (Basta!!) und zwar, weil es dann zu ungeplanten Re-Boots kommt, wobei bei mir laufende Prozesse unterbrochen werden! Ich hatte bereits das automatische Update "Deaktiviert" (allerdings ohne es auch im Scheduler zu deaktivieren). Gestern Nachmittag habe ich dann das Update gestartet und dann den PC neu gestartet und heute Nacht gegen 03:00 ist er (trotzdem) abgeschmiert (anderer Thread - wegen warum??) und hat sich selbst neu gestartet. :(( Gäbe es eine elegante Lösung für: Automatisches Update ist abgeschaltet komplett und für immer! Wenn es mir passt - immer am Wochenende zB. - starte ich das Update und mache einen Neustart. Ohne weitere Maßnahmen bleibt es bei: Kein automatisches Update und kein automatischer Neustart!! Oder muss ich ständig gegen Windows 10 kämpfen, d.h. nach dem meinem manuellen Update wieder automatisches Update abschalten und im Schduler deaktivieren - wäre doch ***isch!!
  20. Hallo, ich (Win 10 pro) hatte das automatische Windows-Update deaktiviert und manuell am Samstag das Update gestartet inkl. PC-Neustart. Trotzdem (?) hat sich heute mein PC heute Nacht um 3:00 neu- gestartet. Ich suche jetzt nach dem Grund und bin in der Ereignisanzeige auf Überraschendes gestoßen. (Die von der Ereignisanzeige angebotene Hilfe bei Windows führt mehrfach zu 404-Seiten - toller Service, gleich am Tage nach dem Update) In der Reihe der Meldungen nach dem Neustart steht: "Grund für das Herunterfahren: Kernel API" Ich finde so etwas (Kernel API Meldung) aber nicht? Unter den Kernel-Nachrichten finde ich immer nur diesen Fehler, der aber 1.) vorher nicht zum Crash führte und nach dem Re-Start wieder eingetragen wurde: "Die Windows-Richtlinie für Systemintegrität lässt das Laden der erforderlichen Systemdatei "\Windows\boot\resources\custom\bootres.dll" mit dem Fehlerstatus 0xC000000F nicht zu." Was mach ich den jetzt damit? Kann das der Grund für den Crash sein? Kann es sein, dass das entstand, weil ich das BIOS vom Motherboard upgedatet habe? Die letzten beiden Meldung bevor das Herunterfahren beginnt sind um 03:01:01: Der Server "Microsoft.OneConnect_5.1807.1991.0_x64__8wekyb3d8bbwe!App.AppXe8pdgw5syxe8pgccbk3mcn5hanwamr0e.mca" konnte innerhalb des angegebenen Zeitabschnitts mit DCOM nicht registriert werden. Der Server "microsoft.windowscommunicationsapps_16005.10325.20091.0_x64__8wekyb3d8bbwe!microsoft.windowslive.calendar.AppXwkn9j84yh1kvnt49k5r8h6y1ecsv09hs.mca" konnte innerhalb des angegebenen Zeitabschnitts mit DCOM nicht registriert werden. Dann ab 03:01:06 die ersten Meldungen vom Herunterfahren: 03:01:06: Benutzerabmeldebenachrichtigung für Programm zur Verbesserung der Benutzerfreundlichkeit 03:01:09: Der Dienst "Update Orchestrator Service" wurde mit folgendem Fehler beendet: Dieser Vorgang wurde wegen Zeitüberschreitung zurückgegeben. 03:02:35: Der Ereignisprotokolldienst wurde beendet. War das um 03:01:01 jetzt der Grund für das Herunterfahren? Wenn nicht wo soll ich suchen, was soll ich suchen? Wenn ja, wie kann ich das verhindern? Im Laufe des Hochfahrens sehe ich noch folgenden Fehler: Durch die Berechtigungseinstellungen für "Anwendungsspezifisch" wird dem Benutzer "NT-AUTORITÄT\SYSTEM" (SID: S-1-5-18) unter der Adresse "LocalHost (unter Verwendung von LRPC)" keine Berechtigung vom Typ "Lokal Start" für die COM-Serveranwendung mit der CLSID Windows.SecurityCenter.WscBrokerManager und der APPID Nicht verfügbar im Anwendungscontainer "Nicht verfügbar" (SID: Nicht verfügbar) gewährt. Die Sicherheitsberechtigung kann mit dem Verwaltungstool für Komponentendienste geändert werden. Was mache ich den damit? Und dann heute Morgen gegen 08 Uhr (kein Runter- und Hochfahren), da habe ich mich wohl als Admin eingeloggt, um das automatische Update zu deaktivieren: Fehler 12.08.2018 08:01:21 DistributedCOM 10001 Keine Fehler 12.08.2018 08:01:21 DistributedCOM 10001 Keine Fehler 12.08.2018 08:01:21 DistributedCOM 10001 Keine Fehler 12.08.2018 08:01:21 DistributedCOM 10010 Keine 10010: Der Server "Microsoft.Windows.ContentDeliveryManager_10.0.17134.1_neutral_neutral_cw5n1h2txyewy!App.AppXyvyv4mghdjas8j88defq0w1hc410kvzt.mca" konnte innerhalb des angegebenen Zeitabschnitts mit DCOM nicht registriert werden. Ein DCOM-Server konnte nicht gestartet werden: Microsoft.Windows.ContentDeliveryManager_10.0.17134.1_neutral_neutral_cw5n1h2txyewy!App.AppXw3qcpc7p849541dp39vvqd01bn7z9ybh.mca als Nicht verfügbar/Nicht verfügbar. Fehler: "298" Aufgetreten beim Start dieses Befehls: "C:\Windows\system32\backgroundTaskHost.exe" -ServerName:App.AppXmtcan0h2tfbfy7k9kn8hbxb6dmzz1zh0.mca 10001: Ein DCOM-Server konnte nicht gestartet werden: Microsoft.Windows.ContentDeliveryManager_10.0.17134.1_neutral_neutral_cw5n1h2txyewy!App.AppXw3qcpc7p849541dp39vvqd01bn7z9ybh.mca als Nicht verfügbar/Nicht verfügbar. Fehler: "298" Aufgetreten beim Start dieses Befehls: "C:\Windows\system32\backgroundTaskHost.exe" -ServerName:App.AppXmtcan0h2tfbfy7k9kn8hbxb6dmzz1zh0.mca 10001: Ein DCOM-Server konnte nicht gestartet werden: Microsoft.Windows.ContentDeliveryManager_10.0.17134.1_neutral_neutral_cw5n1h2txyewy!App.AppXw3qcpc7p849541dp39vvqd01bn7z9ybh.mca als Nicht verfügbar/Nicht verfügbar. Fehler: "0" Aufgetreten beim Start dieses Befehls: "C:\Windows\system32\backgroundTaskHost.exe" -ServerName:App.AppXmtcan0h2tfbfy7k9kn8hbxb6dmzz1zh0.mca 10001: Ein DCOM-Server konnte nicht gestartet werden: Microsoft.Windows.ContentDeliveryManager_10.0.17134.1_neutral_neutral_cw5n1h2txyewy!App.AppXw3qcpc7p849541dp39vvqd01bn7z9ybh.mca als Nicht verfügbar/Nicht verfügbar. Fehler: "0" Aufgetreten beim Start dieses Befehls: "C:\Windows\system32\backgroundTaskHost.exe" -ServerName:App.AppXmtcan0h2tfbfy7k9kn8hbxb6dmzz1zh0.mca Was bedeutet das, was mach ich jetzt denn damit? Letzte Frage, wie kann ich sauber die Verbindung zu OneDrive abschalten und das überhaupt de-installieren (Will ich nicht, brauch ich nicht, mag ich nicht!)?
  21. Ich habe eine Reihe von Raw-Dateien in ein Verzeichnis geschrieben. Der jew. Inhalt stammt aus 12 verschiedenen Log-Dateien. Diese raw-Dateien will ich jetzt der Reihe nach aufrufen und in csv-Dateien umkopieren: $stats = "D:\MT5` RemoteTester\Stats" $Raws = Get-ChildItem -path $stats -Filter *.raw foreach($raw in $Raws) { echo "file $raw" # => file 20180804.raw $fCsv = $stats+"\"+[String]$raw $fCsv.Replace(".raw", ".csv") echo $fCsv # => D:\MT5 RemoteTester\Stats\20180804.csv keine csv datei existiert bis jetzt echo (Test-Path $fCsv) # => D:\MT5 RemoteTester\Stats\20180804.raw HUUUUCH??? if ( Test-Path $fCsv ) { continue } # => continue als ob die csv-Datei existiert ... } Wie kriege ich das hin? Ich habe es mit [String] an verschiedenen Orten probiert - trotzdem lande ich immer wieder bei continue. Ich habe eben noch einmal das Verzeichnis kontrolliert. Es gibt keine csv-Datei nur 5 raw-Dateien. $fCsv ist eine neue Variable in diesem Skript. Ich bin ratlos!
  22. Hallo zusammen, ich verzweifle ein wenig. Ich habe an einigen PCs das Problem (Win 10, aktuell), dass der Explorer einfriert, wenn ein bestimmter Laufwerksbuchstabe vergeben wird. Soll heißen: Normalerweise ist's so : Netzlaufwerk F: zeigt auf "\\daten-v". An einigen wenigen Rechnern friert der Explorer aber ein sobald man ihn öffnet (Dieser PC / Übersicht). Ich kann einen rechtsklick auf den Explorer machen (wenn er noch geschlossen ist) und z.B. häufig verwendete Ordner öffnen die sich auch auf F: befinden. Dann kann ich auch weiter Verzeichnisse wechseln etc. bis hin zur Übersicht - kein Problem solange ich den Explorer nicht schließe und neu auf mache. Das Problem tritt nicht auf, wenn ich auf die selbe Resource einen anderen Laufwerksbuchstabe vergebe (anstelle von F: zum Beispiel Z:) F: auf einen anderen Server ('\\daten-q") funktioniert ebenfalls problemlos. Nur die Kombination F: auf "\\daten-v" klappt nicht (an vereinzelten Rechnern) Hat da jemand eine Idee zu? Windows sowie Netzwerkkartentreiber sind aktuell und die Rechner sind ganz neu. P.S. Mir ist noch aufgefallen, dass es als Administrator funktioniert, aber scheinbar beim "Normal-Anwender" Probleme gibt. Übergangsweise hab ich jetzt den FileCommander installiert um das problem zu umgehen - der funktioniert tadellos.
  23. Hallo Community, wir haben hier in der IT ein Problem, wo wir einfach keinen Grund, geschweige denn, eine Lösung für haben. Folgendes Szenario: Wir versuchen über einen Windows 7- oder Windows 10-Client (beide physikalisch) auf irgend einen Server (aktuell DCs) via RDP drauf zuzugreifen. Hin und wieder erscheint nach Eingabe des Servernamens und betätigen der Enter-Taste eine Fehlermeldung, die besagt: "Remotedesktopverbindung: Ein interner Fehler ist aufgetreten." - Die Session wird gar nicht erst aufgebaut. Im Ereignislos des Servers gibt es lediglich einen Eintrag unter: Anwendungs- und Dienstprotokolle - Microsoft - Windows - TerminalServices-RemoteConnectionManager - Admin. Darin ist folgendes enthalten: "Fehler: Der Remote-Sitzungshostserver hat eine große Anzahl von unvollständigen Verbindungen empfangen. Das System wird möglicherweise angegriffen." Als Ereignis-ID wird die 1006 genannt. Eine Recherche dazu ergab: nichts. Aktuell haben wir einen Workaround gefunden, der es uns zu mindest ermöglicht, auf die Maschinen drauf zu kommen. Remote wird der "Remotedesktopdienst" neu gestartet, anschließend kann eine RDP-Verbindung problemlos hergestellt werden. Da dies auf Dauer etwas lästig ist, und es bisher keinen Grund für diesen Fehler gibt, wollen wir natürlich herausfinden, warum genau das passiert, was passiert. Die Abhängigkeiten des Services habe ich schon überprüft, die laufen auch alle einwandfrei und geben keinerlei Hinweise auf einen Fehler. Ein paar Infos zu der Umgebung: Wir nutzen, wie anfangs bereits erwähnt, Windows 7, 8.1 und 10-Clients. Die Server laufen auf 2012 R2. Updates sind sowohl auf den Clients aus auch auf den Servern up-to-date. Wir befinden uns in einer Domäne (Domänenfunktionsebene: Server 2012 R2, Gesamtstrukturfunktionsebene: Server 2012), die über mehrere Standorte geht. Server als auch Clients sind beide in der Domäne. Pings gehen durch, Services, Ereignisse und diverse andere Funktionen lassen sich über den Windows-Clients remote anzeigen. Sollte ich irgend welche Infos vergessen haben, lasst es mich wissen. Diese reiche ich dann gerne nach. Vielen Dank schon mal im Voraus für eure Ideen, trotz der heißen Temperaturen! Schöne Grüße... Alex
  24. Windows 10 Updates verhindern

    Moin zusammen, ja, ich weiß, Windows sollte immer mit den aktuellen Updates versorgt werden. Da bin ich ganz Eurer Meinung. Gerade rief mich eine (zugegeben: paranoide) Bekannte an, die im Internet den Tipp gelesen hatte, dass man den Dienst "Windows Update" ("wuauserv") deaktivieren kann. Das hat sie auch getan. Nun hat aber Windows den Dienst wieder selbstständig aktiviert und ein Funktionsupdate installiert. Sie hat daraufhin eine Systemwiederherstellung auf einen Wiederherstellungspunkt ein paar Tage zuvor eingespielt und geprüft, ob der Dienst deaktiviert ist. Dem war so. Vorhin fing Windows wieder an, das gleiche Update zu installieren... Kennt Ihr einen Weg (außer den hier beschriebenen: https://www.deskmodder.de/wiki/index.php/Automatische_Updates_deaktivieren_oder_auf_manuell_setzen_Windows_10), der die Updates auch nachhaltig abschaltet? Bitte keine Grundsatzdiskussion, denn ich bin Eurer Meinung. Ich möchte der guten Frau einfach nur einen brauchbaren Tipp geben (Außer: Updates nicht deaktivieren) Vielen Dank schon mal im Voraus
  25. Hallo zusammen, ich bin gerade dabei mich etwas in Powershell einzuarbeiten, habe zwar mit Batch etwas Erfahrung aber die müsste ich auch erst wieder auffrischen und warum nicht gleich für Powershell. Als erstes will ich euch kurz Erklären was ich mit Powershell realisieren möchte. Wir haben viele Fillialen (Märkte) im Einsatz und wollen für alle Märkte die Kassensysteme neu installieren. Das Skript soll also beim Ausführen eine kleine GUI bereitstellen wo ich eine bestimmte Marktnummer eingebe und das Skript mir dann die richtigen Daten zu genau dieser Marktnummer aus einer CSV-Datei ausliest und als Einstellungen im Windows (10) setzt. Die CSV-Datei wird voraussichtlich so aufgebaut sein: Markt-Nr. ; Computername ; Domäne ; IP-Adresse ; Subnetzmaske : Gateway ; DNS ; DNS2 ; DNS3 ; DNS-Suffix Ich gehe davon aus dass dieses Skript etwas Zeit beim Erstellen in Anspruch nimmt, daher bin ich für jeden Hinweis und Tipp sehr Dankbar Vielen Dank schonmal im voraus und liebe Grüße Niklas
×