Zum Inhalt wechseln


Foto

Netzlaufwerkverbindungen verschwinden


  • Bitte melde dich an um zu Antworten
78 Antworten in diesem Thema

#1 joeauge

joeauge

    Junior Member

  • 67 Beiträge

 

Geschrieben 02. Juni 2006 - 07:20

Hallo zusammen,

nach langem erfolglosem googlen habe ich mich nun doch entschlossen mein Problem zu posten.
Die Umgebung: Domäne mit XP Clients und W2k3 als Server.
Per Login-Script erfolgt ein mappen verschiedener Netzlauflaufwerke:
net use L: /delete
net use L: \\Server\Freigabe /persistent:yes
...usw.

Da Phänomen ist, dass entweder schon nach dem Hochfahren nicht alle Laufwerke gemappt sind, bzw. das sie im laufendem Betrieb wieder verschwinden.
Es verschwinden aber nicht immer die gleichen Netzlaufwerke, es passiert auch nicht regelmäßig an den Clients. Manchmal hilft schon ein abmelden und wieder anmelden und es sind wieder alle Netzlaufwerkverbindungen wieder da, aber auch das hilft nicht immer.
Und das Phänomen tritt auch nicht bei allen Clients im Netz auf.

Ich hoffe, ich habe jetzt alles Notwendige geschrieben, damit mir jetzt jemand weiterhelfen kann.
Danke vorab!
Gruß ans Forum

Hajoe

#2 lefg

lefg

    Expert Member

  • 20.479 Beiträge

 

Geschrieben 02. Juni 2006 - 07:29

Hallo,

wurde die Gruppenrichtlinie zum Warten auf das Netzwerk bereits aktiviert?

http://www.microsoft...9.mspx?mfr=true

Betrifft das Problem den User oder den Client?

Das Messbare messen, das Nichtmessbare messbar machen. Galilei.

 

Diskutiere nicht mit ***en, denn sie ziehen dich auf ihr Niveau und schlagen dich dort mit Erfahrung! (Hab ich bei Tom abgeguckt)

 

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität. (Hab ich bei Daniel abgeguckt) https://de.wikipedia...rgo_propter_hoc

 

Absolutistischer“ Geschäftsführungs-Dogmatismus, der jedwede Empirie aus der „Werkstatt“ schlichtweg ignoriert , führt eben zumeist früher als später ….  (Hab ich von Klabautermann)


#3 Das Urmel

Das Urmel

    Gast

  • 2.657 Beiträge

 

Geschrieben 02. Juni 2006 - 08:03

net use L: /delete
net use L: \\Server\Freigabe /persistent:yes


Das ist kontraproduktiv.
net use ... /persistent:no <- wäre besser ;)

Ansonsten gehe dem Hinweis von lefg nach.
mfg
Das Urmel
..lesen und verstehen - das Manko etlicher
... ich denke dennoch drüber nach, ehrlich :)

#4 joeauge

joeauge

    Junior Member

  • 67 Beiträge

 

Geschrieben 02. Juni 2006 - 08:54

Hallo,

wurde die Gruppenrichtlinie zum Warten auf das Netzwerk bereits aktiviert?

Die Gruppenrichtlinie ist doch defaultmäßig aktiviert?? Oder nicht??

http://www.microsoft...9.mspx?mfr=true

Betrifft das Problem den User oder den Client?


Das verstehe ich nicht ganz. Der User logt sich am Client ein, dann wird das Script ausgeführt und dann werden die Mappings erstellt. Ich verstehe Deine Frage nicht :(


#5 joeauge

joeauge

    Junior Member

  • 67 Beiträge

 

Geschrieben 02. Juni 2006 - 08:57

Das ist kontraproduktiv.
net use ... /persistent:no <- wäre besser ;)

Ansonsten gehe dem Hinweis von lefg nach.


Warum ist das kontraproduktiv?
persistent:yes = Speichert alle hergestellten Verbindungen und stellt sie bei der nächsten Anmeldung wieder her.

persistent:no = Aktuelle und nachfolgende Verbindungen werden nicht gespeichert.

#6 FLOST

FLOST

    Board Veteran

  • 587 Beiträge

 

Geschrieben 02. Juni 2006 - 08:58

Passiert das dem gleichen User an mehreren Clients oder mehreren Usern am gleichen client?

Und bitte nicht fett!

#7 lefg

lefg

    Expert Member

  • 20.479 Beiträge

 

Geschrieben 02. Juni 2006 - 09:18


Das verstehe ich nicht ganz. Der User logt sich am Client ein, dann wird das Script ausgeführt und dann werden die Mappings erstellt. Ich verstehe Deine Frage nicht :(

Da Phänomen ist, dass entweder schon nach dem Hochfahren nicht alle Laufwerke gemappt sind,

Hallo,

ich reflektier auf diesen Teil der Beschreibung. Bei XP wird vom Standard her das netzwerk nicht gleich nach dem Start des Betriebssystems aktiviert wie bei 2k, sondern wesentlich später. Das kann sogar erst nach der (cached) Anmeldung des User geschehen.

Diese Verhalten zu ändern, dafür gibt es eine Richtlinie.

Ich empfehle, zuerst diese Richtlinie zu aktivieren, dann weiter zu sehen.

Allerdings deuten die weiteren Beschreibungen auf andere Fehler hin. Ich habe von solchen Erscheinungen schon öfters gelesen, kann mich an einen Registryeintrag autoreconnect oder so ähnlich erinnern. Mit dem wurde dann versucht das zu fixen. Normalerweise ist das aber nicht nötig.

Ich betreue mehrere, z.T. umfangreiche Netzwerke, in denen den Usern Netzlaufwerke gemappt werden per Batch, in keinem tritt dieses Phänomenen auf.

Betrifft das Problem eigentlich nur die Client-Server-Verbindung, oder tritt sie auch in Peer2Peer-Verbindungen auf?

Tritt das Problem bei allen oder nur bei einen Teil der Client-Server-Verbindungen auf?

Könnte das Problem von einem Switch herrühren, von einem Kabel zwischen zwei Switches in der Hirachie?

Wurde mal von einem Client ein Ping über längere Zeit auf den Server abgesetzt, geschaut, ob es zu einem Timout kommt?

Wie sind die Clients eigentlich erzeugt worden, handelt es sich da um Klones?

Funktioniert die Zeitsynchronosation zwischen PDC-Emulator und den Cliens eigentlich, haben die automatisch alle die gleiche Zeit? Oder muss da mit net time oder von Hand nachgeholfen werden?

Wie erhalten die Clients eigentlich die IP, statisch oder dynamisch. Gibt es da einen DHCP-Server, ist da eine sehr kurze Lease eingestellt, wird bei Adresswechsel auch den DNS sofort aktualisiert?

Das Messbare messen, das Nichtmessbare messbar machen. Galilei.

 

Diskutiere nicht mit ***en, denn sie ziehen dich auf ihr Niveau und schlagen dich dort mit Erfahrung! (Hab ich bei Tom abgeguckt)

 

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität. (Hab ich bei Daniel abgeguckt) https://de.wikipedia...rgo_propter_hoc

 

Absolutistischer“ Geschäftsführungs-Dogmatismus, der jedwede Empirie aus der „Werkstatt“ schlichtweg ignoriert , führt eben zumeist früher als später ….  (Hab ich von Klabautermann)


#8 lefg

lefg

    Expert Member

  • 20.479 Beiträge

 

Geschrieben 02. Juni 2006 - 09:36

Steht in den Ereignisanziegen etwas auffälliges?

Das Messbare messen, das Nichtmessbare messbar machen. Galilei.

 

Diskutiere nicht mit ***en, denn sie ziehen dich auf ihr Niveau und schlagen dich dort mit Erfahrung! (Hab ich bei Tom abgeguckt)

 

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität. (Hab ich bei Daniel abgeguckt) https://de.wikipedia...rgo_propter_hoc

 

Absolutistischer“ Geschäftsführungs-Dogmatismus, der jedwede Empirie aus der „Werkstatt“ schlichtweg ignoriert , führt eben zumeist früher als später ….  (Hab ich von Klabautermann)


#9 joeauge

joeauge

    Junior Member

  • 67 Beiträge

 

Geschrieben 02. Juni 2006 - 11:43

Passiert das dem gleichen User an mehreren Clients oder mehreren Usern am gleichen client?

Und bitte nicht fett!


Es passiert verschiedenen Usern an verschiedenen Clients, also User unabhängig.
Mit den Clients verhält es sich genauso.

Sorry, für den Fettdruck.

#10 joeauge

joeauge

    Junior Member

  • 67 Beiträge

 

Geschrieben 02. Juni 2006 - 11:53

Steht in den Ereignisanziegen etwas auffälliges?


Ja, da gibt es einen Eintrag:

Folgendes Skript konnte nicht ausgeführt werden: O:\netzneu.bat. Das System kann die angegebene Datei nicht finden.


Die Netzneu.bat ist das Loginscript mit net use....

#11 joeauge

joeauge

    Junior Member

  • 67 Beiträge

 

Geschrieben 02. Juni 2006 - 12:00

Hallo lefg,

vielen Dankerstmal für Deine Hilfe.
Ich werde Deinen vorletzten Kommentar jetz mal abarbeiten und mich dann wieder melden.
Ich empfehle, zuerst diese Richtlinie zu aktivieren, dann weiter zu sehen. - damit were ich erstmal anfangen.

#12 lefg

lefg

    Expert Member

  • 20.479 Beiträge

 

Geschrieben 02. Juni 2006 - 12:08

Ja, da gibt es einen Eintrag:

Folgendes Skript konnte nicht ausgeführt werden: O:\netzneu.bat. Das System kann die angegebene Datei nicht finden.


Die Netzneu.bat ist das Loginscript mit net use....

Ich interpretiere das mal so: Das Loginskript liegt auf einem Netzlaufwerk. Ist das richtig?
Das Netzlaufwerk ist aber noch nicht mapped. Das Batch soll aber die Netzlaufwerksverbindung erst herstellen. Als kann das Skript doch garnicht ausgeführt werden.

Das Loginskript einer Domäne gehört in die Freigabe NETLOGON der Domänencontroller.

Eine Möglichkeit den Aufruf zu konfigurieren ist der Eintrag des Dateinamens im Konto des Benutzers. Dort wird dann nur der Dateiname eingetragen: Login. Eine Pfadangabe, eine Namenserweiterung ist nicht nötig.

Eine weitere Möglichkeit ist die Verwendung der Gruppenrichtlinie zum Aufruf eines oder mehrerer Skripte auf verschiedenen OUs.

Das Messbare messen, das Nichtmessbare messbar machen. Galilei.

 

Diskutiere nicht mit ***en, denn sie ziehen dich auf ihr Niveau und schlagen dich dort mit Erfahrung! (Hab ich bei Tom abgeguckt)

 

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität. (Hab ich bei Daniel abgeguckt) https://de.wikipedia...rgo_propter_hoc

 

Absolutistischer“ Geschäftsführungs-Dogmatismus, der jedwede Empirie aus der „Werkstatt“ schlichtweg ignoriert , führt eben zumeist früher als später ….  (Hab ich von Klabautermann)


#13 joeauge

joeauge

    Junior Member

  • 67 Beiträge

 

Geschrieben 02. Juni 2006 - 12:41

Hier ist es folgt geregelt (und es funktioniert eigentlich auch immer, aber leider nicht immer):

Am DC: Group Policy Management -> hier gibt es für die User an der Domäne ein Loginscript:
Computerkonfiguration -> Windows-Einstellungen -> Skripts (Start/Herunterfahren) -> Start -> über die Eigenschaften von Start (rechte Maustast) kann man den Pfad zum Loginscript angeben, in diesem Fall O:\netzneu.bat.

#14 lefg

lefg

    Expert Member

  • 20.479 Beiträge

 

Geschrieben 02. Juni 2006 - 13:56

Hier ist es folgt geregelt (und es funktioniert eigentlich auch immer, aber leider nicht immer):

Am DC: Group Policy Management -> hier gibt es für die User an der Domäne ein Loginscript:
Computerkonfiguration -> Windows-Einstellungen -> Skripts (Start/Herunterfahren) -> Start -> über die Eigenschaften von Start (rechte Maustast) kann man den Pfad zum Loginscript angeben, in diesem Fall O:\netzneu.bat.

Eine Batch zum Mappen von Netzlaufwerken selbst auf ein Netzlaufwerk zu legen halte ich für falsch. Jeder erfahrene System- und Netzwerkadministrator wird mir da zustimmen. Welchen Sinn sollte solch eine Regelung auch haben?

Für Windows-Domänen gibt es auf den DCs das Verzeichnis Skripts als Freigabe Netlogon. Die Inhalte werden zwischen den DCs einer Domäne repliziert. Es ist eine UNC-Pfadangabe zu verwenden.

Das Messbare messen, das Nichtmessbare messbar machen. Galilei.

 

Diskutiere nicht mit ***en, denn sie ziehen dich auf ihr Niveau und schlagen dich dort mit Erfahrung! (Hab ich bei Tom abgeguckt)

 

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität. (Hab ich bei Daniel abgeguckt) https://de.wikipedia...rgo_propter_hoc

 

Absolutistischer“ Geschäftsführungs-Dogmatismus, der jedwede Empirie aus der „Werkstatt“ schlichtweg ignoriert , führt eben zumeist früher als später ….  (Hab ich von Klabautermann)


#15 joeauge

joeauge

    Junior Member

  • 67 Beiträge

 

Geschrieben 02. Juni 2006 - 22:53

Nun gut, ich lasse mich da gerne eines Besseren belehren. Ich werde es kommende Woche ausprobieren und berichten. Mich wundert es nur, dass es zu ca. 95% immer gut funktioniert hat.