Zum Inhalt wechseln


Foto

Problem mit Pixen(VPN)


  • Bitte melde dich an um zu Antworten
43 Antworten in diesem Thema

#31 Pixer

Pixer

    Newbie

  • 35 Beiträge

 

Geschrieben 30. März 2006 - 07:33

1) Ja die Pixen können sich pingen. Pix1 kann außerdem zum Server Pingen. Pix2 kann auch mit dem PC pingen.

2)PDM funktioniert noch nicht. Es macht einfach nichts es kommt auch keine Fehlermeldung.

3)beim vpn ist es das selber es passiert einfach nichts

Hier noch einmal die aufgaben stellung:

Baue eine Tunnel per Site to Site Verbindung zwischen der zwei Pix 501 von Cisco auf, so das der PC über beide Pixen ins Internet gelangt.


mfg Pixer

#32 s21it21

s21it21

    Member

  • 166 Beiträge

 

Geschrieben 30. März 2006 - 11:49

Hallo,

Versuchen wir es noch mal:

Wenn Du sagst "...es passiert einfach nichts..." kann Dir niemand helfen. Analysiere doch mal die LOG/syslog/Debug Messages. Irgendetwas müssen die zwei PIXen ausspucken (Meldungen, etc.).

Was heisst beim PDM, dass auch nichts passiert?? Du verbindest Dich via https auf die PIX. Bekommst Du einen Userlogin? Oder funktioniert nicht mal das. NIMM BITTE das Handbuch, da steht einfach drinen wie der PDM zu aktivieren geht!!
Sorry, das kann ja nicht so schwer sein!!!

LG

Martin
-----------------------------
IT-Security-Consultant
Checkpoint, CiscoPIX,IDS/IPS (ISS),Radware
Penetration-Tests,etc.
Checkpoint-Zertifiziert

#33 s21it21

s21it21

    Member

  • 166 Beiträge

 

Geschrieben 30. März 2006 - 12:05

Hallo!

Lies Dir das nochmal durch:
Site-to-Site-VPN zwischen zwei PIXEN:
http://www.cisco.com...080094761.shtml

Zum PDM:
Schau mal ob Du überhaupt einen PDM auf der PIX drauf hast. Das machst Du über die CLI im enable modus: "show ver". Dort siehst Du die Version vom PDM (wenn er installiert ist).

Wenn ja, dann aktivierst Du den so:

1) CLI einsteigen
2) in den enable modus wechseln
3) conf t eintippen (=configmodus)
4) http server enable (Webserver wird aktiviert)
5) pdm history enable (Logging für den PDM)
6) http 192.168.1.2 255.255.255.255 inside (hier wird der Host 192.168.1.2 am Inside-Interface erlaubt den PDM zu starten). Das kannst DU jetzt für Dich anpassen.

So und jetzt kannst Du via Broswer den PDM nutzen (aber NUR über das INSIDE Interface der Firewall!!!!!).

Mach das mal und dann melde Dich wieder (aber mit einer vernünftigen Fehlerbeschreibung *g*).

LG
Martin
-----------------------------
IT-Security-Consultant
Checkpoint, CiscoPIX,IDS/IPS (ISS),Radware
Penetration-Tests,etc.
Checkpoint-Zertifiziert

#34 Pixer

Pixer

    Newbie

  • 35 Beiträge

 

Geschrieben 30. März 2006 - 13:28

DANKE.
die seite hatte ich noch nicht gefunden gleich mal ausprobieren. ich hoffe es funzt.

bis denne

#35 Pixer

Pixer

    Newbie

  • 35 Beiträge

 

Geschrieben 31. März 2006 - 11:36

Mahlzeit s21it21,

Ich habe das jetzt von der Seite so in meine Pixen eingegeben! die Pixen können auch untereinander Pingen und ich kann von Pix1 zum server Pingen und vom Pc zur Pix2. mehr aber auch nicht. Ich habe keine ahnung warum ich nicht vom pc zum server Pingen kann.
Ich habe auch schon ausprobiert die Access-list zu änder (auf "permit any") ich dachte eigentlich dann muss auf jeden fall klappen weil die Pixen ja dann jeden durchlassen, aber falsch gedacht.
Wenn ich versuche vom Pc aus den Server anzupingen blinken die Lampen an beiden Pixen auch so als ob es tun würde, aber mein Pc sagt das er den Server nicht findet.

Könntest du mir bitte noch einen Tipp geben

schon mal danke

mfg Pixer

#36 Wordo

Wordo

    Board Veteran

  • 3.213 Beiträge

 

Geschrieben 31. März 2006 - 11:55

Post doch mal die aktuelle Konfiguration der PIXen

#37 Pixer

Pixer

    Newbie

  • 35 Beiträge

 

Geschrieben 31. März 2006 - 12:57

Pix1# show running-conf
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname Pix1
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.10.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list 102 permit any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.10.54 255.255.255.0
ip address inside 192.168.30.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (outside) 0 access-list 102
nat (inside) 0 access-list 102
route inside 0.0.0.0 0.0.0.0 192.168.30.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set chevelle esp-des esp-md5-hmac
crypto map transam 1 ipsec-isakmp
crypto map transam 1 match address 101
crypto map transam 1 set peer 192.168.20.1
crypto map transam 1 set transform-set chevelle
crypto map transam interface inside
isakmp enable inside
isakmp key ******** address 192.168.20.1 netmask 255.255.255.0
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:a37cd75fd3332de70e96422a8dba5a1b
: end

#38 Pixer

Pixer

    Newbie

  • 35 Beiträge

 

Geschrieben 31. März 2006 - 12:57

Pix2(config)# show running-conf
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname Pix2
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list 102 permit any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.20.1 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
nat (outside) 0 access-list 102
nat (inside) 0 access-list 102
route outside 0.0.0.0 0.0.0.0 192.168.30.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set toyota esp-des esp-md5-hmac
crypto map bmw 1 ipsec-isakmp
crypto map bmw 1 match address 101
crypto map bmw 1 set peer 192.168.30.1
crypto map bmw 1 set transform-set toyota
crypto map bmw interface outside
isakmp enable outside
isakmp key ******** address 192.168.30.1 netmask 255.255.255.0
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
Cryptochecksum:1f31f5b9bd42f1c8c6dd75fbde1578ea
: end

#39 Wordo

Wordo

    Board Veteran

  • 3.213 Beiträge

 

Geschrieben 31. März 2006 - 13:18

Die PIXen koennen sich mit der Konfiguration pingen? Also entweder steh ich total aufm Schlauch oder ich versteh die Welt nicht mehr:

PIX 1
ip address outside 192.168.10.54 255.255.255.0
ip address inside 192.168.30.1 255.255.255.0

PIX 2.
ip address outside 192.168.20.1 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0

Mit 4 verschiendenen IP's ind 4 verschiedenen Netzen .. das klappt doch nicht. Und das Gateway von PIX2 liegt in nem Netz von PIX1 .. wie soll das gehn?

#40 Pixer

Pixer

    Newbie

  • 35 Beiträge

 

Geschrieben 31. März 2006 - 13:33

Wie soll ich die Netze den deiner meinung nach aufbauen??

#41 czappb

czappb

    Senior Member

  • 384 Beiträge

 

Geschrieben 31. März 2006 - 14:06

Bitte, es tut schon weh das zu lesen.

Tu dir und dem Rest einen gefallen:
Fang doch erstmal mit dem gehen an, bevor du fliegen willst!
Klartext: Versteh erstmal TCP/IP, Subnetze, routing & co bevor du anfängst einen VPN aufzubauen.

Wenn die Frage "Wie soll ich die Netze den deiner meinung nach aufbauen??" dein Ernst ist, kann ich dir nur raten Grundlagen aufbauen!

#42 Wordo

Wordo

    Board Veteran

  • 3.213 Beiträge

 

Geschrieben 31. März 2006 - 14:19

Das kommt auf die Verkabelung an! Wo stehen die beiden PIXen (physikalisch)? Nebeneinander am selben Switch? Haengt ein Router dazwischen? Produktiv koennen sie ja nich sein .. sonst waer bei dir bestimmt die Hoelle los ;)

#43 czappb

czappb

    Senior Member

  • 384 Beiträge

 

Geschrieben 31. März 2006 - 14:31

Naja also wenn ich die bisherigen Einträge gelesen habe mit einem Switch, die Routen in den configs sind auch etwas wirr...

die eine defaultroute auf sich selber
die andere defaultroute auf eine ip in einem anderen subnetz

... daher mein Posting.

#44 Wordo

Wordo

    Board Veteran

  • 3.213 Beiträge

 

Geschrieben 31. März 2006 - 14:36

Ich gebs glaub ich auch auf .. da kann man nich viel machen :D