Zum Inhalt wechseln


Foto

Monitor ausschalten 20 min. -per gruppenrichtlinie ändern-.


  • Bitte melde dich an um zu Antworten
11 Antworten in diesem Thema

#1 5232joe

5232joe

    Member

  • 345 Beiträge

 

Geschrieben 07. Februar 2005 - 13:21

Hallo
W2k Server
Kann man per Gruppenrichtlinie die Energieverwaltung(Energieschema) ändern.
z.b. Monitor ausschalten 20 min. etc...

Hab mal unter www.gruppenrichtlinien.de geschaut, leider nichts gefunden.
DANKE DANKE
Gruss Hannes

#2 saracs

saracs

    Expert Member

  • 2.850 Beiträge

 

Geschrieben 07. Februar 2005 - 13:53

hi!

unter gruppenrichlinien.de gibt es doch ein adm template für energieschemen. oder suchst du etwas anderes?

verrat uns doch am besten was genau du wie geändert haben willst ;)

gruss saracs

#3 5232joe

5232joe

    Member

  • 345 Beiträge

 

Geschrieben 07. Februar 2005 - 14:02

Monitor ausschalten sollte auf NIE stehen.
Festplatten ausschalten sollte auf NIE stehen.
Standby ausschalten sollte auf NIE stehen.

Egal welches Energieschema ausgewählt wurde.

Wird dies unter W2k3 Server unterstützt???

DANKE
Gruss Hannes

#4 saracs

saracs

    Expert Member

  • 2.850 Beiträge

 

Geschrieben 07. Februar 2005 - 14:39

hi!

hast du dir eigentlich mal die energieschemen und oder das adm template angesehen?
das schema "presäntation" erfüllt genau deine anforderungen und das template steht auf der von dir genannten seite!

gruss saracs

#5 MichaStgt

MichaStgt

    Member

  • 195 Beiträge

 

Geschrieben 07. Februar 2005 - 18:26

so ich hab die letzen paar stunden versucht herauszufinfen wo sich die Infos in der Reg hinterlegt, jedoch ohne erfolg *g*.

Ich hab was für die Gefunden:

; ADM Template von http://www.gruppenrichtlinien.de
; Autor Norbert Fehlauer
; Veränderungen, u.A. Entfernung des EXPLAIN Parts für 
; NT4 Kompatibilität und Übersetzung, Anpassung an 
; GruRiLi.de-Vorgabe durch Mark Heitbrink


CLASS USER

CATEGORY "Energieoptionen"

	POLICY "Aktivierung der Ernergiesparoptionen"
	KEYNAME "Control Panel\PowerCfg"

		PART "Auswahl des Energieschemas" DROPDOWNLIST
		KEYNAME "Control Panel\PowerCfg"
		VALUENAME "CurrentPowerPolicy"	REQUIRED NOSORT	
			ITEMLIST
			  NAME "Desktop"		     VALUE "0"
			  NAME "Tragbar/Laptop"	   	     VALUE "1"
			  NAME "Präsentation"		     VALUE "2"
			  NAME "Dauerbetrieb"		     VALUE "3"
			  NAME "Minimaler Energieverbrauch"  VALUE "4"
			  NAME "Minimale Batteriebelastung"  VALUE "5"
			END ITEMLIST
		END PART 
		
		PART "DESKTOP:" TEXT END PART
		PART "Dieses Schema eignet sich für die meisten Desktopcomputer, die ständig" TEXT END PART
		PART "mit der Spannungsversorgung verbunden sind." TEXT END PART
		PART " " TEXT END PART
		PART "TRAGBAR/LAPTOP:" TEXT END PART
		PART "Dieses Schema verlängert die Batterielebensdauer bei tragbaren Computern." TEXT END PART
		PART " " TEXT END PART
		PART "PRÄSENTATION:" TEXT END PART
		PART "Dieses Schema lässt den Monitor bei Präsentationen eingeschaltet." TEXT END PART
		PART " " TEXT END PART
		PART "DAUERBETRIEB:" TEXT END PART
		PART "Dieses Schema lässt den Computer in eingeschaltetem Zustand, so dass" TEXT END PART 
		PART "auf diesen vom Netzwerk zugegriffen werden kann. Verwenden Sie dieses" TEXT END PART 
		PART "Schema, wenn Sie nicht über Hardware verfügen, die es erlaubt, den Computer" TEXT END PART 
		PART "vom Netzwerk aus einzuschalten." TEXT END PART
		PART " " TEXT END PART
		PART "MINIMALER ENERGIEVERBRAUCH:" TEXT END PART
		PART "Dieses Schema lässt den Computer an und optimiert ihn für hohe Leistung." TEXT END PART
		PART " " TEXT END PART
		PART "MINIMALE BATTERIEBELASTUNG" TEXT END PART
		PART "Dieses Schema spart am meisten Energie." TEXT END PART

	END POLICY

END CATEGORY



das in eine *.adm speicher, template importieren.
Ansicht -> Filterung -> „Haken“ entfernen bei => Nur vollständig verwaltbare Richtlinieneinstellungen anzeigen

Dann hast du was du willst, naja fast...

genau diese infos hab ich mit regmon nicht rausfinden kann, wo sich der mist einträgt zb:

Monitor 20 Minuten rest aus..

Aber hoffe das hilft mal weiter

gruss
Red Hat Certified Engineer Certificate #: 803004270813193
MCSE 2003, MCSA + M 2003, MCITP EA"Denken ist schwer, darum urteilen die meisten."
Carl Gustav Jung (schweiz. Psychoanalytiker, 1875-1961)

#6 saracs

saracs

    Expert Member

  • 2.850 Beiträge

 

Geschrieben 07. Februar 2005 - 20:04

hi!

genau das steht unter gruppenrichtlinien.de!

hier zu finden: http://www.gruppenri...powerscheme.txt

gruss saracs

btw: in der registry wird die einstellung hier hinterlegt!


[HKEY_CURRENT_USER\Control Panel\PowerCfg]
"CurrentPowerPolicy"="0"
mögliche werte sind:

0 = desktop
1 = laptop
2 = präsentation
3 = dauerbetrieb
4 = minimaler energieverbrauch
5 = minimale batteriebelastung


#7 MichaStgt

MichaStgt

    Member

  • 195 Beiträge

 

Geschrieben 07. Februar 2005 - 20:15

habs ausbrobiert,
DC Win2k3
Client WinXPSP2

funtzt net...

Workaround währe mit einer WMI abfrage , und dem Regkey HKEY_CURRENT_USER\Control Panel\PowerCfg manuell über ein Script auf den Wert deiner Wahl zu ändern, ist zwar nicht so dolle... aber naja
Red Hat Certified Engineer Certificate #: 803004270813193
MCSE 2003, MCSA + M 2003, MCITP EA"Denken ist schwer, darum urteilen die meisten."
Carl Gustav Jung (schweiz. Psychoanalytiker, 1875-1961)

#8 saracs

saracs

    Expert Member

  • 2.850 Beiträge

 

Geschrieben 07. Februar 2005 - 20:27

ich hab zwar keine ahnung was du ausprobiert hast aber das ist das adm template und der regkey wo die einstellung definitiv hinterlegt wird ;)

was du nicht beachtet hast ist folgendes:

der obige regkey steuert nur den schemennamen übernimmt aber nicht die werte die für das schema hinterlegt sind. um das gesamte schema mit einstellungen zu ändern musst du noch zusätzlich folgenden key anpassen:

[HKEY_CURRENT_USER\Control Panel\PowerCfg\PowerPolicies] <--\0 - 5 für das gewünschte schema angeben

"Policies"=hex:<-hier wird im hex die einstellung hinterlegt

wenn du den wert für policies nicht änderst kann es natürlich nicht funktionieren ;)

gruss saracs

#9 MichaStgt

MichaStgt

    Member

  • 195 Beiträge

 

Geschrieben 07. Februar 2005 - 20:32

Der Key CurrentPowerPolicy in [HKEY_CURRENT_USER\Control Panel\PowerCfg] ist dezimal nicht Hex ;)


aber da hast du mich auf was gebracht:

C:\Dokumente und Einstellungen\Administrator.TRADERS>gpresult
INFORMATION: Benutzer "TRADERS\Administrator" hat keine RSOP-Daten.

O_o ... naja wird sonst Off topic *g*
Red Hat Certified Engineer Certificate #: 803004270813193
MCSE 2003, MCSA + M 2003, MCITP EA"Denken ist schwer, darum urteilen die meisten."
Carl Gustav Jung (schweiz. Psychoanalytiker, 1875-1961)

#10 saracs

saracs

    Expert Member

  • 2.850 Beiträge

 

Geschrieben 07. Februar 2005 - 20:36

[HKEY_CURRENT_USER\Control Panel\PowerCfg\PowerPolicies] <--\0 - 5 für das gewünschte schema angeben

"Policies"=hex:<-hier wird im hex die einstellung hinterlegt


HEX nix dezimal, lies mal genau was ich geschrieben habe ;) oder schau dir einfach mal den regzweig genau an!

gruss saracs

#11 MichaStgt

MichaStgt

    Member

  • 195 Beiträge

 

Geschrieben 07. Februar 2005 - 22:05

das thema hat mich jetzt nicht in Ruhe gelassen :)

Also, der WinXP SP2 zieht keine GPO, keine ahnung waru,
Der WinXPSP1 zieht die GPO, dort geht das mit der Energieverwaltung über die Gruppenrichtlinie 1a.

Zum Thema HEX und DEZ, du meinst allso alle Werte in einer Policy müssen in HEX sein?
Abgesehen davon das die 5 DEZ auch 5 im HEX ist, ich habe das Template so wie es oben steht importiert, und es geht Super.

Habe ich was falsch verstanden saracs?
Dann bitte ich um Aufklärung ;)

Danke und Gruss
Red Hat Certified Engineer Certificate #: 803004270813193
MCSE 2003, MCSA + M 2003, MCITP EA"Denken ist schwer, darum urteilen die meisten."
Carl Gustav Jung (schweiz. Psychoanalytiker, 1875-1961)

#12 saracs

saracs

    Expert Member

  • 2.850 Beiträge

 

Geschrieben 07. Februar 2005 - 23:29

hi!

wir haben da ein wenig aneinander vorbei geschrieben :(

ich meine diesen wert hier:

"Policies"=hex:

hier werden die einstellungen in HEX hinterlegt bezüglich dauer monitor festplatten etc...
ich meine nicht den wert für das schema! ;)

gruss saracs