Zum Inhalt wechseln


Foto

kritischer Fehler Active Directory (4015)


  • Bitte melde dich an um zu Antworten
13 Antworten in diesem Thema

#1 Stoertebeker

Stoertebeker

    Junior Member

  • 65 Beiträge

 

Geschrieben 09. Juni 2004 - 08:21

Hi all,

Ich bekomme im Ereignisprotokoll die Fehlermeldung (Fehlercode 4015), DNS habe einen kritischen Fehler im Active Directory ermittelt. Es folgen 2 weitere Fehlermeldungen bezüglich Aufzählung der Verzeichnisdienste,3 Minten später kommt dann die Meldung, DNS gestartet. Wenn ich den Dienst in der Dienste-Konsole von Hand beende und neu starte, kommt keine Fehlermeldung.

Ein nslookup ergibt
*** Der Servername für die Adresse 172.16.10.3 konnte nicht gefunden werden: Non-existent domain
Standardserver: UnKnown
Address: 172.16.10.3

Fällt jemandem etwas dazu ein?

Gruss
Stoertebeker

#2 gr@mlin

gr@mlin

    Expert Member

  • 1.750 Beiträge

 

Geschrieben 09. Juni 2004 - 09:17

hi,

habt ihr den server auf w2k3 upgegradet?

schau mal hier: http://www.eventid.n...rce=DNS&phase=1

gruss, gr@mlin
#der sinn des lebens ist, den unsinn des lebens zu erkennen.

#3 Stoertebeker

Stoertebeker

    Junior Member

  • 65 Beiträge

 

Geschrieben 09. Juni 2004 - 09:33

Nein, kein Update, aber Dein Link hat mich auf folgenden Text verwiesen:

"MS PSS reports this error may occur in a single-server environment, during server startup, for AD-integrated DNS zones. Apparently, DNS is starting before AD is ready to answer queries, and DNS cannot wait for AD to start since AD needs DNS. PSS reports the error can be ignored, as the DNS zones will load as soon as AD is ready. PSS said that switching to a standard (not AD-integrated) zone would work around the problem."

Das erklärt die Fehler im Ereignisprotokoll, die offenbar tatsächlich ignoriert werden können. Hat vielleicht noch jemand eine Idee zu der Tatsache, dass nslookup non-existent Domain ausgibt? Zum Zeitpunkt, wenn ich nslookup ausführe läuft der DNS-Dienst ja schließlich.

btw. Wie füge ich in diesem Board einen Text als Quote in dem hübschen weißen Fenster ein?

#4 gr@mlin

gr@mlin

    Expert Member

  • 1.750 Beiträge

 

Geschrieben 09. Juni 2004 - 10:08

btw. Wie füge ich in diesem Board einen Text als Quote in dem hübschen weißen Fenster ein?

http://www.mcseboard...p?action=bbcode

gruss, gr@mlin
#der sinn des lebens ist, den unsinn des lebens zu erkennen.

#5 bienchen

bienchen

    Senior Member

  • 407 Beiträge

 

Geschrieben 09. Juni 2004 - 10:14

Hallo zusammen,

kriege zwar keine Meldung im Eventlog, aber auf den Clients bei nslookup:

Ein nslookup ergibt
*** Der Servername für die Adresse XXX.xxx.XXX.xxx konnte nicht gefunden werden: Non-existent domain
Standardserver: name
Address: XXX.xxx.XXX.xxx

was kann die Ursache sein???

Danke bienchen

#6 Stoertebeker

Stoertebeker

    Junior Member

  • 65 Beiträge

 

Geschrieben 12. Juni 2004 - 08:26

@Bienchen: Hast Du denn mal auf dem Server nslookup ausgeführt? Gibts da nicht einen ähnlichen Fehler?

#7 grizzly999

grizzly999

    Board Veteran

  • 17.691 Beiträge

 

Geschrieben 12. Juni 2004 - 08:46

Ein nslookup ergibt
*** Der Servername für die Adresse XXX.xxx.XXX.xxx konnte nicht gefunden werden: Non-existent domain
Standardserver: name
Address: XXX.xxx.XXX.xxx

was kann die Ursache sein???

Keine Reverse-LookupZone..... ;)

grizzly999

Aber bitte keine Overtakes, das verwässert den Originalthread und führt meist zu Verwirrungen https://www.mcseboar...ules.php?s=#nr7
MVP [Windows Server - Directory Services]
www.ServerHowTo.de -Das MCSEboard.de HowTo Projekt ist online!

#8 bienchen

bienchen

    Senior Member

  • 407 Beiträge

 

Geschrieben 14. Juni 2004 - 06:53

Hallo Leute,

tut mir leid, ich habe vergessen zu schreiben, dass das Problem bei mir gelöst ist:

die Reverse-LookupZone war natürlich da, aber komischerweiser war der DNS Server da nicht als Pointer eingetragen, ich dachte das passiert automatisch, aber wie auch immer... nachdem ich ihn da eingetragen habe sieht alles sehr gut aus.

Danke für die Hilfe....

Gruß Bienchen

#9 bienchen

bienchen

    Senior Member

  • 407 Beiträge

 

Geschrieben 14. Juni 2004 - 06:54

Original geschrieben von Stoertebeker
@Bienchen: Hast Du denn mal auf dem Server nslookup ausgeführt? Gibts da nicht einen ähnlichen Fehler?




Auf dem Server war dasselbe, aber jetzt nicht mehr...

#10 Stoertebeker

Stoertebeker

    Junior Member

  • 65 Beiträge

 

Geschrieben 15. Juni 2004 - 09:49

Hurra,

die Einrichtung der Reverse-Lookup-Zone hat das non-existent domain Problem gelöst. Bleibt aber der angebliche kritische Fehler im Active Directory (Quelle DNS, Fehlerkennung 4015). Hat jemand dazu eine Lösungsidee?

Gruss
Stoertebeker

#11 bienchen

bienchen

    Senior Member

  • 407 Beiträge

 

Geschrieben 15. Juni 2004 - 11:23

Bei uns gabs das Problem auch, nachdem wir aber eine Forward-Lookupzone _msdcs.deinedomäne.de eingerichtet haben (dann etwas warten, booten) war die Meldung weg.

Gruß Bienchen

#12 sega2003

sega2003

    Newbie

  • 44 Beiträge

 

Geschrieben 03. November 2004 - 13:00

Original geschrieben von Stoertebeker


... Bleibt aber der angebliche kritische Fehler im Active Directory (Quelle DNS, Fehlerkennung 4015). Hat jemand dazu eine Lösungsidee?



hi,

leider auch keine Lösung.
Wir haben 10 DC's W2k SP4 und einer davon meckert.

Im EventLog stehen sporadisch - nicht regelmäßig - aber
mindestens 3-5 mal hintereinander folgende Events:

DNS-Server hat einen kritischen Fehler im Verzeichnisdienst ermittelt. Stellen Sie sicher, dass das Active Directory ordnungsgemäß funktioniert. Die Ereignisdaten enthalten den Fehlercode.

In den Daten steht:
0000: 22 00 00 00 "...

Hat noch wer eine Idee ?

,
sega2003

#13 Stefan.Haegele

Stefan.Haegele

    Member

  • 168 Beiträge

 

Geschrieben 03. November 2004 - 16:47

Hatte auch diesen Fehler in unregelmäßigen Abständen.
Habe dann festgestellt, dass dieser Fehler immer dann auftrat, wenn der Server beendet wurde.

Seitdem geben ich vor dem Herunterfahren immer "net stop dns" ein (unter ausführen) und habe seitdem KEINE Probleme mehr.

Vermute mal, dass der DNS-Server in dem Moment des Herunderfahrens noch Daten aus/in das AD schreiben/lesen möchte, das AD aber nicht mehr verfügbar ist (quasi den Ast absägt, auf welchem er sitzt)

Stefan

#14 sega2003

sega2003

    Newbie

  • 44 Beiträge

 

Geschrieben 03. November 2004 - 17:02

Original geschrieben von Stefan.Haegele
Hatte auch diesen Fehler in unregelmäßigen Abständen.
Habe dann festgestellt, dass dieser Fehler immer dann auftrat, wenn der Server beendet wurde.

Seitdem geben ich vor dem Herunterfahren immer "net stop dns" ein (unter ausführen) und habe seitdem KEINE Probleme mehr.
...


Danke für den Hinweis.

Trifft leider nicht zu, da der Server(DC) selten rebootet wird.
Ausserdem gibt es täglich ca. 100 Event-Einträge.


;
sega2003