Zum Inhalt wechseln


Foto

Exchange 2016 -> 2010 Coexist: OWA/ECP Proxy wirft plötzlich HTTP Error 500

Exchange

  • Bitte melde dich an um zu Antworten
24 Antworten in diesem Thema

#16 MrCocktail

MrCocktail

    Board Veteran

  • 1.226 Beiträge

 

Geschrieben 28. Oktober 2017 - 11:43

Wie oben geschrieben, ist auf dem 2016er "versehentlich" (per WSUS) die 4.7 gelandet. Ich habe gestern ein Rollback auf die 4.6.2 ausgeführt.

Auf dem 2010er läuft ebenfalls die 4.7, dort habe ich sie nicht deinstalliert.

 

und dann wunderst du dich, dass etwas nicht geht?

4.7 und 2010 ist ebenfalls eine sehr doofe Idee



#17 Daniel-H

Daniel-H

    Junior Member

  • 131 Beiträge

 

Geschrieben 28. Oktober 2017 - 12:11

und dann wunderst du dich, dass etwas nicht geht?

4.7 und 2010 ist ebenfalls eine sehr doofe Idee

 

Danke für Deinen Einwand, aber ja, wundere ich mich in der Tat!

Zu den Fakten:

1. Habe ich ja erst vorhin festgestellt, das dort 4.7 installiert wurde

2. Wusste ich bislang nur von einer Inkompatibilität zu Exchange 2016. Das sich das auf ALLE Exchange Server bezieht, war mir bis eben neu.

3. Gemäß https://technet.micr...exchg.150).aspx nutzt der 2010er ohnehin nur NET 3.5, auch wenn eine neuere parallel installiert ist.

4. Haben sich beide Server wochenlang nicht an NET 4.7 gestört (4.7 wurde am 30.6. installiert, die Probleme traten erstmals am 24.10. auf)

5. Hat MS zwar eine Empfehlung ausgesprochen 4.7 nicht auf Exchange zu installieren, aber nur mit der Begründung, dass die Kompatibilitätstests noch nicht abgeschlossen sind. Bis heute wurden damit aber m.E. keine Probleme gemeldet (ich Wette eine Menge Admins haben nicht bemerkt, dass es auf ihrem Exchange automatisch installiert wurde).

6. Kann ich auf einem produktiven 2008R2 nicht mal eben testweise ein Downgrade von 4.7 auf 4.5 machen, ohne vorher Abhängigkeiten zu anderen Komponenten genau zu prüfen.

7. Schickt der 2016 beim Auftreten des Fehlers gar keine Pakete an den 2010er, also warum sollte dann das NET auf dem 2010er für den Fehler verantwortlich sein?

 

Ich werde natürlich trotzdem prüfen, ob ich ein NET Downgrade auf dem 2010er machen kann um der Empfehlung von MS zu genügen, aber es würde mich aufgrund der genannten Fakten stark wundern, wenn das Problem damit in Zusammenhang steht.

 

Gruß

Daniel


MCTS Win7, MCSA-M, MCSE
Done: 70-270, 70-290, 70-291, 70-284, 70-285, 70-293, 70-294, 70-680

#18 NorbertFe

NorbertFe

    Expert Member

  • 30.802 Beiträge

 

Geschrieben 28. Oktober 2017 - 12:32

und dann wunderst du dich, dass etwas nicht geht?
4.7 und 2010 ist ebenfalls eine sehr doofe Idee

Nein, das ist egal, weil Exchange 2010 net 2.0 und 3.5 nutzt. Die 4.x werden ignoriert.
Zu 5. doch es wurden Probleme gemeldet. Ob die jedoch überall auftreten ist eine andere sache. Geh davon aus, dass es einen Grund hat, warum sie erst 4.7.1 unterstützen werden.

Bearbeitet von NorbertFe, 28. Oktober 2017 - 12:30.

Make something i***-proof and they will build a better i***.


#19 MrCocktail

MrCocktail

    Board Veteran

  • 1.226 Beiträge

 

Geschrieben 28. Oktober 2017 - 13:00

Nein, das ist egal, weil Exchange 2010 net 2.0 und 3.5 nutzt. Die 4.x werden ignoriert.
Zu 5. doch es wurden Probleme gemeldet. Ob die jedoch überall auftreten ist eine andere sache. Geh davon aus, dass es einen Grund hat, warum sie erst 4.7.1 unterstützen werden.

 

Hi,

 

ich habe dennoch 2 Fälle einer Koexistenz gehabt, wo es zu Problemen kam, auch wenn es eigentlich nicht sein darf ...

Wir empfehlen einfach unseren Kunden, 4.7 erst gar nicht zu installieren.

 

Gruß

J



#20 Daniel-H

Daniel-H

    Junior Member

  • 131 Beiträge

 

Geschrieben 28. Oktober 2017 - 13:16

Ein Mittschnitt der Kommunikation auf dem Ex2016 zeigt im Falle des OWA-Zugriffs folgenden Ablauf (mehrfach reproduziert):

 

Client <> Ex2016: HTTPS
EX2016 <> DC: Kerberos AS-REQ/REP und TGS-REQ/REP
Client <> Ex2016: https
EX2016 <> Ex2010: LDAP
EX2016 <> DC: LDAP
Client <> Ex2016: HTTPS -> Error 500

 

Es wird also kein HTTPS zwischen den beiden Exchange ausgetauscht.
 


Hi,

 

ich habe dennoch 2 Fälle einer Koexistenz gehabt, wo es zu Problemen kam, auch wenn es eigentlich nicht sein darf ...

Wir empfehlen einfach unseren Kunden, 4.7 erst gar nicht zu installieren.

 

Gruß

J

Aus Interesse: In den beiden Fällen war eine falsche NET Version die Ursache?


MCTS Win7, MCSA-M, MCSE
Done: 70-270, 70-290, 70-291, 70-284, 70-285, 70-293, 70-294, 70-680

#21 MrCocktail

MrCocktail

    Board Veteran

  • 1.226 Beiträge

 

Geschrieben 28. Oktober 2017 - 13:26

Aus Interesse: In den beiden Fällen war eine falsche NET Version die Ursache?

 

Ob Ursache kann ich nicht beurteilen, wir haben nur 4.7 sauber deinstalliert und die Zugriffe waren wieder möglich.

Allerdings haben wir das auf

  • Allen Exchange Servern
  • Allen DCs

durchgeführt, was die Kollegen noch gemacht haben, entzieht sich meiner Kenntnis.



#22 Daniel-H

Daniel-H

    Junior Member

  • 131 Beiträge

 

Geschrieben 31. Oktober 2017 - 21:54   Lösung

Problem dank TechNet Forum endlich gelöst. Und es war nicht das .NET 4.7 schuld ;) Meine Angleichung der InternalUrls an die ExternalUrls (Split-DNS) auf dem Ex2010 führte zu dem Problem!

Identisch konfigurierte URLs auf beiden Exchange stellt wohl kein Problem dar, wenn man sofort die internen DNS-Einträge auf den Ex2016 zeigen lässt. Wer aber wie ich vorher gerne noch einige Tests machen möchte ohne die OWA-Zugriffe aller User über den Ex2016-Proxy laufen zu lassen, muss auf dem Ex2010 unbedingt die echte FQDN des Server als InternalURL eintragen.

Änderung vorgenommen und ECP und OWA funktionierten sofort. (PS: Natürlich nicht vergessen vorher im Exch2010 IIS /owa Verzeichnis Windowsauthentifizierung mit NTLM zu aktivieren).

 


MCTS Win7, MCSA-M, MCSE
Done: 70-270, 70-290, 70-291, 70-284, 70-285, 70-293, 70-294, 70-680

#23 Dr.Melzer

Dr.Melzer

    Moderator

  • 26.261 Beiträge

 

Geschrieben 01. November 2017 - 06:23

Problem dank TechNet Forum endlich gelöst.

Das ist schön. :-)

 

Magst du uns bitte noch den Link zu dem Thread im TechNet Forum hier rein posten. Wenn jemand diesen Thread findet uns das gleiche Problem hat, freut er sich sicher über den Link zur Lösung. ;-)


Never argue with an idíot, they drag you down to their level and beat you with experience!

#24 Daniel-H

Daniel-H

    Junior Member

  • 131 Beiträge

 

Geschrieben 01. November 2017 - 08:26

Das ist schön. :-)

 

Magst du uns bitte noch den Link zu dem Thread im TechNet Forum hier rein posten. Wenn jemand diesen Thread findet uns das gleiche Problem hat, freut er sich sicher über den Link zur Lösung. ;-)

 

 Coexist EX2016 / EX2010: OWA / ECP fails with HTTP ERROR 500 for EX2010 Mailboxes


MCTS Win7, MCSA-M, MCSE
Done: 70-270, 70-290, 70-291, 70-284, 70-285, 70-293, 70-294, 70-680

#25 Dr.Melzer

Dr.Melzer

    Moderator

  • 26.261 Beiträge

 

Geschrieben 01. November 2017 - 11:51

Danke.- :-)


Never argue with an idíot, they drag you down to their level and beat you with experience!