Zum Inhalt wechseln


Foto

Keine Verbindung zu Exchange 2016 über Outlook 2013


  • Bitte melde dich an um zu Antworten
7 Antworten in diesem Thema

#1 numx

numx

    Member

  • 259 Beiträge

 

Geschrieben 17. Oktober 2017 - 19:30

Hallo,

 

ich bekomme derzeit bei einem Client (Windows 10 1703 mit Outlook 2013 SP1) immer diese Melldung wenn ich eine Verbindung zum Exchnage aufbauen will.

 

"Es steht keine Verbindung mit Microsoft Exchange zur Verfühung. Outlook muss im Onlinemodus oder verbunden sein, um diesem Vorgang abzuschließen."

 

 

Die anderen Windows 10 Clients mit dem selben Outlook funktionieren. Eine Unterschied zwischen den Clients gibt es aber unzwar läuft der Client auf dem es nicht funktioniert auf einem Server 2016 Hyper-V Host. Eine Active Sync Verbindung klappt aber weder über Autodiscover noch über manuell klappt es. Der Autodiscover Test läuft auch sauber durch.

 

Im Netz findet man ja viele Ursachen für diese Fehlermeldung aber ich denke ich habe schon alle durch probiert. Ich habe den Client auch schon mal neu installiert und nur das Outlook drauf installiert. Kein Erfolg

 

DNS bzw. nslookup Test auch Erfolgreich, Ping auch und der Aufruf über OWA auch bzw. ohne Zertifikatsmeldung. Es handelt sich um ein Zertifikat einer öffentlichen CA. Alle anderen Clients mit Win10 und Outlook 2013 laufen auch.

 

 

Bin irgendwie ratlos was man noch testen könnte.

 

 

 

 

 

 

 



#2 TheCracked

TheCracked

    Board Veteran

  • 807 Beiträge

 

Geschrieben 18. Oktober 2017 - 07:35

Hast du dir mal deinen v-switch im Hyper-V angesehen?

Vielleicht gibts da ne ACL o.ä. wo das unterbindet..

 

Hast du es schon mal mit einem anderen User/Postfach getestet?



#3 MurdocX

MurdocX

    Board Veteran

  • 584 Beiträge

 

Geschrieben 18. Oktober 2017 - 08:16

Funktioniert der Zugriff auf Freigaben des Exchange?


Mit freundlicher Unterstützung
Jan


#4 numx

numx

    Member

  • 259 Beiträge

 

Geschrieben 18. Oktober 2017 - 08:34

Hallo,

 

@TheCracked, es sind keine ACLs gesetzt und mit anderen Postfächern tritt der gleiche Fehler auf

 

@MurdocX, ich teste es heute Abend mal, habe derzeit keinen Zugriff auf das System. Gebe dann aber bescheid.



#5 numx

numx

    Member

  • 259 Beiträge

 

Geschrieben 18. Oktober 2017 - 19:24

@MurdocX, der Zugriff auf Freigaben im Exchange funktioniert.

 

Hat noch jemand eine Idee?


so ich habe es hin bekommen.

 

kurz zu nochmal zu meiner Umgebung. Ich habe einen Exchange 2016 und eine Domänencontroller (auch Server 2016) bzw. den einen Windows 10 Client auf einem Hyper-V Server als VMs am laufen. Alle drei VMs laufen in einem Testnetz an einem VSwitch der im Privat Modus läuft sprich die virtuellen Maschinen haben nur untereinander Kontalt aber nicht zum VM Host und auch nicht nach Extern. Der Windows 10 Client hat per DHCP seine IP vom DC bekommen. Mit diesen Infos konnte er sich als auch den DC sowie den Exchange Server vorwärts und rückwärts per DNS auflösen. Der Zugriff auf OWA per HTTP vom Client aus funktionierte auch und es gab auch keine Zertifikatsmeldung. Freigegebene Ordner die ich zum Test auf dem Exchange angelegt habe konnten beim Client auch ohne Probleme verbunden werden. Wie gesagt es funktioniert alles außer die Outlook Verbindung zum Exchange vom Client aus. Es funktioniert per Autodiscover als auch manuell nicht. 

 

Jetzt kommt es. Ich habe den VSwitch einmal von Privat auf Extern gestellt das somit alle VMs (Client, DC und Exchange) Verbindung mit dem Internet hatten. Ab diesem Zeitpunkt klappte die Verbindung von Outlook per Autodiscover zum Exchange. Es scheint so als wenn Outlook irgendwas im Internet abfragt evtl. etwas zum Zertifikat. Dann stellt sich mir die Frage was wird abgefragt und wie kann man das unterbinden bzw. auch ohne Internet eine Verbindung von Outlook zum Exchange betreiben. Die DNS Auflösung am Client funktioniert auch super sprich der DNS Name des Exchnage Servers der auch extern benutzt wird wird sauber zum interne Exchnage aufgelöst sprich bei nslookup wird auch der Exchange-Server Name der intern und extern verwendet wird sauber nach intern aufgelöst. Sobald der Client extern ist wird natürlich der externe Name oder besser gesagt die öffentliche IP genutzt. Daher denke ich nicht das es was mit DNS zu tun hat sondern irgendwas mit dem Zertifkat oder dem vSwitch im Privatmodus.


Bearbeitet von numx, 18. Oktober 2017 - 19:26.


#6 numx

numx

    Member

  • 259 Beiträge

 

Geschrieben 20. Oktober 2017 - 14:14

kann sich keiner das geschilderte Phänomen erklären?

#7 Doso

Doso

    Board Veteran

  • 2.491 Beiträge

 

Geschrieben 20. Oktober 2017 - 17:00

In meinem abgeschotteten Testnetz hatte ich keine Probleme mit Outlook Verbindungen bei Exchange 2016 CU 3 /DC auf 2012R2.



#8 numx

numx

    Member

  • 259 Beiträge

 

Geschrieben 22. Oktober 2017 - 22:24   Lösung

so ich konnte das Problem lösen.

 

Da meine Testumgebung kein Internet hat aber (jetzt kommts) Outlook beim Start im Standard den im PC eingestelletn Gateway anpingt bzw. beim fehlschlagen des Ping Outlook nicht mit dem Exchange verbindet kam nie eine Verbindung bei mir zustande.

 

Bis Outlook 2013 kann man das mit dem folgenden Registry Eintrag lösen solte man noch RPCoHTTPS (beim Mapi siehe Outlook 2016 Erklärung) benutzen.

 

HKEY_CURRENT_USER\ Software\ Microsoft\ Office\ [Version] \ Outlook\ RPC\

 

REG_DWORD DefConnectOpts  = 0

 

1 Verbindung über Standardgateway(Standard)

 

0 Ohne Standardgateway

 

Bei Outllok 2016 (mit MAPIoHTTPS) gibt es den Schalter nicht mehr aber da es sich nur um einen Ping Test handelt kann man dann in den Gatewayeinstellungen eine beliebig pingbare IP eintragen. Im Anschluss startet Outlook wir gewohnt und verbindet sich auch ganz normal.

 

 

Was der Sinn dieser Einstellung (Gatewaycheck beim Outlookstart) soll habe ich noch nicht nachlesen können wenn es überhaupt einen Sinn dafür gibt.


Bearbeitet von numx, 22. Oktober 2017 - 22:27.