Zum Inhalt wechseln


Foto

Exchange 2016 lehnt E-Mail ab wenn eine E-Mail Adresse ungültig


  • Bitte melde dich an um zu Antworten
27 Antworten in diesem Thema

#1 Doso

Doso

    Board Veteran

  • 2.490 Beiträge

 

Geschrieben 18. September 2017 - 19:32

Ich habe dieses Jahr auf Exchange 2016 migriert. Wenn eine externe E-Mail mehrere Empfänger enthält und auch nur eine Adresse davon ungültig ist, wird die gesamte E-Mail abgelehnt. Beispiel: 30 Empfänger erhalten eine E-Mail aus einer Mailing Liste. eine Adresse ist ungültig da der Nutzer in Rente gegangen ist und sein Postfach gelöscht wurde, keiner erhält die E-Mail. Extern gibt es dann bei allen Empfängern:
 
550 5.1.10 RESOLVER.ADR.RecipientNotFound; Recipient not found by SMTP address lookup (in reply to end of DATA command)
 
Exchange 2010 hat sich noch nicht so verhalten. Hier jemand eine Idee was das sein könnte? Ich habe so gar keine Ahnung wie ich das beheben könnte.

Bearbeitet von Doso, 18. September 2017 - 19:45.


#2 NorbertFe

NorbertFe

    Expert Member

  • 30.823 Beiträge

 

Geschrieben 18. September 2017 - 19:50   Lösung

Hallo,

das ist bekannt und dokumentiert. Ein Grund, warum die Empfängerprüfung quasi sinnfrei auf einem Mailboxserver ist (so wie viele andere Spamfilterfunktionen von MS). Da hilft nur Edge Server davor, oder eine sinnvolle Alternative auf dem Exchange (ich würde www.vamsoft.com empfehlen).
https://technet.micr...exchg.160).aspx

Although the Recipient Filter agent is available on Mailbox servers, you shouldn't configure it. When recipient filtering on a Mailbox server detects one invalid or blocked recipient in a message that contains other valid recipients, the message is rejected. If you install the antispam agents on a Mailbox server, the Recipient Filter agent is enabled by default. However, it isn't configured to block any recipients. For more information, see Enable antispam functionality on Mailbox servers.


Bye
Norbert

Make something i***-proof and they will build a better i***.


#3 numx

numx

    Member

  • 255 Beiträge

 

Geschrieben 18. September 2017 - 20:19

Hallo Norbert,

 

wenn man den Antispam Agent aber auf dem Server ausschaltet dann sollte das oben genannte Problem nicht auftreten oder sehe ich das falsch?



#4 NorbertFe

NorbertFe

    Expert Member

  • 30.823 Beiträge

 

Geschrieben 18. September 2017 - 20:23

Ja, aber dann hat man eben auch keine Empfängerprüfung (auch doof) ;)

Make something i***-proof and they will build a better i***.


#5 Doso

Doso

    Board Veteran

  • 2.490 Beiträge

 

Geschrieben 18. September 2017 - 20:27

Set-RecipientFilterConfig -Enabled $false
Disable-TransportAgent "Recipient Filter Agent"
MSExchangeTransport neu gestartet
 
Die Empfängerprüfung ist bei uns nicht nötig und war eigentlich deaktiviert, darauf den Transportagenten abzuschalten bin ich nicht gekommen.
 
Jetzt gehen die Mails durch. Danke Norbert, da wäre ich alleine nie drauf gekommen.


#6 NorbertFe

NorbertFe

    Expert Member

  • 30.823 Beiträge

 

Geschrieben 18. September 2017 - 20:47

Dann ist die Frage, warum du die Antispam Agents überhaupt auf dem Mailboxserver installiert hast. ;)

Make something i***-proof and they will build a better i***.


#7 numx

numx

    Member

  • 255 Beiträge

 

Geschrieben 18. September 2017 - 20:57

vielleicht bessert MS ja hier noch nach und es kommt weningstens die Mail bei den vorhanden Empfängern an.



#8 NorbertFe

NorbertFe

    Expert Member

  • 30.823 Beiträge

 

Geschrieben 18. September 2017 - 20:58

Das wird nicht nachgebessert. Die Lösung von MS steht ja oben im Artikel: Verwenden Sie Edge Server Role oder Exchange Online Protection.

Bye
Norbert

Make something i***-proof and they will build a better i***.


#9 Doso

Doso

    Board Veteran

  • 2.490 Beiträge

 

Geschrieben 18. September 2017 - 21:16

Dann ist die Frage, warum du die Antispam Agents überhaupt auf dem Mailboxserver installiert hast. ;)

 

Weil die auf Exchange2010 auch schon drauf waren... 



#10 NorbertFe

NorbertFe

    Expert Member

  • 30.823 Beiträge

 

Geschrieben 18. September 2017 - 21:19

Du meinst "das haben wir schon immer so gemacht"? :) Also eigentlich kannst du die komplett deinstallieren, da der einzig sinnvolle Agent vor fast einem Jahr auch eingestellt wurde (Content Filter Agent) und keine Updates mehr erhält.
Also nimm dir uninstall-antispamagents und dann ist Ruhe. Wenn du sowieso vor dem Exchange einen Spamfilter hast, sind alle anderen Agents ziemlich sinnfrei (selbst wenn sie funktionieren würden).

Bye
Norbert

Make something i***-proof and they will build a better i***.


#11 Doso

Doso

    Board Veteran

  • 2.490 Beiträge

 

Geschrieben 19. September 2017 - 09:27

Wir haben mit  SpamAssassin einen Filter davor. Nur bin ich immer noch nicht dazu gekommen mich mit Transportregel zu beschäftigen, um dann die dann die SCLs so umschreibt das Outlook auch was damit anfangen kann.



#12 Dukel

Dukel

    Board Veteran

  • 9.298 Beiträge

 

Geschrieben 19. September 2017 - 09:33

 

New-TransportRule -Name Spam -SetSCL 9 -HeaderMatchesMessageHeader 'X-Spam' -HeaderMatchesPatterns {Yes}


Stop making stupid people famous.


#13 Doso

Doso

    Board Veteran

  • 2.490 Beiträge

 

Geschrieben 19. September 2017 - 11:13

Danke Dukel!



#14 NorbertFe

NorbertFe

    Expert Member

  • 30.823 Beiträge

 

Geschrieben 19. September 2017 - 11:35

Dann muss dieser Transport Agent aber auch höher als der Content Filter Agent liegen afair.

Make something i***-proof and they will build a better i***.


#15 massaraksch

massaraksch

    Newbie

  • 152 Beiträge

 

Geschrieben 20. September 2017 - 14:43

Eigentlich müßte MS ja auch nichts "verbessern". Sie sollten einfach nur gewohnte Features nicht "verschlechtern".

 

Der Recipient Filter funktionierte schließlich bis Ex2010 noch korrekt auch bei mehreren Empfängern. Naja, "Produktpolitik"...


mfg, massaraksch