Zum Inhalt wechseln


Foto

IIS und WebServer auf ReadyNAS


  • Bitte melde dich an um zu Antworten
6 Antworten in diesem Thema

#1 Grzesiek

Grzesiek

    Senior Member

  • 373 Beiträge

 

Geschrieben 12. September 2017 - 12:46

Ich habe auf einen Netgear-NAS einen WebServer laufe. Aus dem Internet ist die Seite auch erreichbar, da der Router den Port 80 direkt an den NAS weitergibt. Rufe ich die Adresse aus dem lokalen Netz auf, schaltet sich direkt der IIS ( WebServer ) davor und meint die Seite sei nicht verfügbar.

 

Kann ich es dem IIS abgewöhnen ?



#2 testperson

testperson

    Board Veteran

  • 4.510 Beiträge

 

Geschrieben 12. September 2017 - 12:55

Hi,

 

wie rufst du denn die WebSite auf?

Heißt deine AD-Domäne evtl. genau wie die öffentliche Domain / Internetseite?

 

Gruß

Jan


Good morning, that's a nice TNETENNBA!

#3 Grzesiek

Grzesiek

    Senior Member

  • 373 Beiträge

 

Geschrieben 12. September 2017 - 13:15

die interne heißt  internedomain.local

 

von extern  http://server.meined...n.de/webseite, extern klappt es auch problemlos. Über den lokalen Namen ready-nas/webseite  klappt es auch intern.

 

Die Meldung:

Serverfehler in der Anwendung "DEFAULT WEB SITE" HTTP-Fehler 404.0 - Not Found Die gesuchte Ressource wurde entfernt oder umbenannt, oder sie steht vorübergehend nicht zur Verfügung.

 

Es ist ein SBS 2011 Server



#4 Dukel

Dukel

    Board Veteran

  • 9.244 Beiträge

 

Geschrieben 12. September 2017 - 13:17

Wenn es von extern und von intern klappt wo ist dann das Problem?

Was rufst du auf, so das der Fehler kommt?

 

Was hat das NAS mit dem SBS zu tun?


Stop making stupid people famous.


#5 zahni

zahni

    Expert Member

  • 16.376 Beiträge

 

Geschrieben 12. September 2017 - 15:05

Vermutlich ist der interne DNS-Name des SBS identisch  mit  dem externen DNS-Namen.

 

Suche  bei Google  mal nach "Split  DNS".


Wen du nicht mit Können beeindrucken kannst, den verwirre mit Schwachsinn!


#6 Grzesiek

Grzesiek

    Senior Member

  • 373 Beiträge

 

Geschrieben 12. September 2017 - 15:58

Das Problem ist wenn jemand aus dem netzwerk wo der SBS und der NAS hängt die Seite über die externe Adresse aufrufen will, wird es nicht gefunden, da der Webserver von dem SBS angesprochen wird.

Auf dem NAS läuft ein Webserver mit PHP und dieser im gleichen Netzwerk hängt.

 

der interne Name von SBS ist: KCMSERVER.kcm.local   extern   server.meinedomain.de

 

NAS wurde auch ins AD aufgenommen.



#7 testperson

testperson

    Board Veteran

  • 4.510 Beiträge

 

Geschrieben 12. September 2017 - 16:38

Dann erstelle für extern einen neuen Record <wasauchimmer>.deinedomain.de der ebenfalls auf deine öffentliche IP zeigt und intern erstellst du eine Hostzone <wasauchimmer>.deinedomain.de mit der internen IP des NAS.

Dann müssen die User die Web Seite halt nur über <wasauchimmer>.deinedomain.de aufrufen.

 

Wenn es immer noch um das geht, solltest du nochmal über einen Reverse Proxy oder eine weitere öffentliche IP nachdenken und das ganze per https absichern.


Good morning, that's a nice TNETENNBA!