Zum Inhalt wechseln


Foto

Exchange - verknüpftes Postfach


  • Bitte melde dich an um zu Antworten
5 Antworten in diesem Thema

#1 dataKEKS

dataKEKS

    Junior Member

  • 195 Beiträge

 

Geschrieben 08. August 2017 - 12:36

Hallo Kollegen!

 

Nachdem unser Exchange Server mit nunmehr sechs Jahren ja doch ein ordentliches Alter hat sitzen wir aktuell an der Ablösung. Er kommt ganz ursprünglich von 2003, wurde auf 2010 migriert und jetzt läuft im Moment der Umzug auf Exchange 2016. Dabei sind mir mehrere Postfächer aufgefallen die als Postfach nicht auf Benutzer sondern verknüpft stehen.

 

Jetzt habe ich schon einiges gesucht und bin über verschiedene Ansätze gestolpert:

 

- Postfach deaktivieren und neu verbinden

- Set-Mailbox %Name% -Type Regular

 

Am Liebsten wäre es mir ohne Deaktivierung aus zu kommen weswegen ich die Idee mit Typwechsel sympatisch finde, nur leider funktioniert das nicht, es erscheint der Fehler:

 

Das Konvertieren des Postfachs "Benutzername" von Typ "LinkedMailbox" in Typ "UserMailbox" wird nicht unterstützt.

 

Wie geht ihr sowas an? Da es ausgerechnet das Postfach vom Boss ist liegt mir das Thema gerade schwer im Magen....

 

 

 

Gruß

Norbert



#2 NilsK

NilsK

    Expert Member

  • 12.334 Beiträge

 

Geschrieben 08. August 2017 - 12:55

Moin,

 

wenn es Linked Mailboxes gibt, gibt es ja offenbar einen separaten Forest. Was ist denn damit geplant?

 

Gruß, Nils


Nils Kaczenski

MVP Cloud and Datacenter Management
... der beste Schritt zur Problemlösung: Anforderungen definieren!

Kostenlosen Support gibt es nur im Forum, nicht privat!


#3 NorbertFe

NorbertFe

    Expert Member

  • 30.605 Beiträge

 

Geschrieben 08. August 2017 - 14:08

Nicht zwingenderweise. Ich hatte das auch schon bei diversen Kunden gesehen, dass da irgendwann mal das Attribut (LinkedMasterAccount) gefüllt war und schon zeigt Exchange das an. Wie genau das da reingekommen ist, war meist nicht mehr nachzuvollziehen. Aber im Endeffekt ist der obige Weg ja grundsätzlich richtig. Ich verstehe die "Bedenken" nicht. Wenn die Mailbox Retention Time auf der DB nicht 0 ist, kann da nichts passieren. Und falls doch, hat man vorher gefälligst ein Backup gemacht. Alternativ: set-user user1 -LinkedMasterAccount $null (https://www.msxfaq.d...nkedmailbox.htm)

Bearbeitet von NorbertFe, 08. August 2017 - 14:09.

Make something i***-proof and they will build a better i***.


#4 dataKEKS

dataKEKS

    Junior Member

  • 195 Beiträge

 

Geschrieben 08. August 2017 - 14:46   Lösung

Hallo Nils, Hallo Norbert!

 

War wirklich nur ein AD, kein Witz. 

 

Der Tip über die Powershell wie in Frank von der MSX FAQ gelistet hat war die Lösung.

 

# Linked mailbox in usermailbox verwandeln
[PS] C:\>set-user user1 -LinkedMasterAccount $null'

 

Ich danke euch, war mal wieder mit Blindheit geschlagen :-)

 

Gruß

Norbert



#5 NilsK

NilsK

    Expert Member

  • 12.334 Beiträge

 

Geschrieben 08. August 2017 - 14:47

Moin,

 

OK, diese Besonderheit war mir nicht bekannt. Gut, dass es sich so lösen ließ.

 

Vor allem wollte ich mit meiner Nachfrage sichergehen, dass nicht ein Teil der Umgebung bei der Problembearbeitung übersehen wird. Wäre ja nicht das erste Mal, dass sowas passiert.

 

Gruß, Nils


Nils Kaczenski

MVP Cloud and Datacenter Management
... der beste Schritt zur Problemlösung: Anforderungen definieren!

Kostenlosen Support gibt es nur im Forum, nicht privat!


#6 dataKEKS

dataKEKS

    Junior Member

  • 195 Beiträge

 

Geschrieben 08. August 2017 - 16:25

So wie ich das bislang eingrenzen konnte kommt das wohl nur bei wirklich alten Postfächern vor die auch schon mal die eine oder andere Migration mitgemacht haben. Im aktuellen Fall waren es sechs von 83 Postfächern, und das waren alles Postfächer der ersten Stunde, laut AD Konto waren sie alle im Januar 2006 angelegt worden, also wirklich noch auf dem Exchange 2003....

 

Gruß

Norbert