Zum Inhalt wechseln


Foto

EX2013 Austausch Zertifikat


  • Bitte melde dich an um zu Antworten
Eine Antwort in diesem Thema

#1 Hippo

Hippo

    Junior Member

  • 193 Beiträge

 

Geschrieben 01. August 2017 - 10:14

Hallo zusammen,

ich habe ein Problem bei der Aktualisierung meines Geotrust Zertifikats.

 

Aufgrund der fehlenden Chrome Akzeptanz wurden wir aufgefordert unser Exchange 2013 Zertifikat auszutauschen.

https://knowledge.symantec.com/support/ssl-certificates-support/index?page=content&id=ALERT2386

 

Das neue Zertifikat habe mit dem alten CSR beantragt und von PSW-Group erhalten.

 

Anschließend habe ich im EAC unter Zertifikate, bei dem bestehenden Zertifikat auf "Erneuern" geklickt und ein weiterer Zertifikateintrag ist erschienen. 

Bei dem neuen Zertifikateintrag bin ich auf "Abschließen" gegangen und habe das neu erhaltene Zertifikat ausgewählt. In der MMC ist das Zertifikat nun unter "Eigenen Zertifikate" zusehen.

Im EAC steht es aber immer noch als "Ausstehenden Anforderung".

 

Mit dem Powershellbefehl „get-exchangecertificate | fl thumbprint,CertificateDomains sehe ich auch das neue Zertifikat mit den richtigen Domänen.

 

Starte ich nun den Befehl "enable-exchangecertificate -thumbprint xxx -services smtp,iis,imap,pop" mit dem Thumbprint des neuen Zertifikats, erhalte ich die Fehlermeldung: "Ein spezieller RPC-Fehler ist auf Server SRV-EXCH02 aufgetreten: Das Zertifikat mit dem Fingerabdruck 'xxx' wurde nicht gefunden. …“

 

Kann mir jemand weiterhelfen?



#2 Hippo

Hippo

    Junior Member

  • 193 Beiträge

 

Geschrieben 02. August 2017 - 14:20   Lösung

Ich weiß jetzt warum ich die Fehlermeldung bekomme, habe aber leider keine Ahnung woran das liegen könnte.

 

Der Thumbprint unterscheidet sich, ob ich mit der Powershell  oder mit der MMC mir das Zertifikat ansehe. Was eigentlich bedeutet, dass es unterschiedliche Zertifikate sein müssen????

 

Woran kann das liegen?

 

Wenn ich das Zertifikat ohne das EAC, nur mit der MMC importiere, sollte es dann auch mit dem Befehl  get-exchangecertificate in der Powershell zu sehen sein?


Ok, der Fehler war "...(Begründung: PrivateKeyMissing)..."

 

Nachdem ich mit Certutil das repariert habe, wurde das Zertifikat richtig angezeigt.