Zum Inhalt wechseln


Foto

PS ISE Befehl für MSONLINE geht nicht :-(

Exchange

  • Bitte melde dich an um zu Antworten
2 Antworten in diesem Thema

#1 Sommer2016

Sommer2016

    Newbie

  • 60 Beiträge

 

Geschrieben 26. Juni 2017 - 11:32

Hi. ich wollte mich mit meinem O365 Tenant verbinden über ein Script von meinem DC. Der Script lautet : 

 

//

Import-Module MSONLINE
$cred - Get-Credential -Username admin@xxxxx.onmicrosoft.com -Message "PW"
Connect-MsolService -Credential $cred
Get-Msoluser
//
 
Ich bekomme folgende Fehlermeldung : 
 
//
In C:\Users\Administrator\Desktop\SignInOffice365.ps1:3 Zeichen:8
+ $cred - Get-Credential -Username xxx@xxxx.onmicrosoft.com ...
+        ~
Sie müssen nach dem Operator "-" einen Wertausdruck bereitstellen.
In C:\Users\Administrator\Desktop\SignInOffice365.ps1:3 Zeichen:9
+ $cred - Get-Credential -Username admin@xxxxxx.onmicrosoft.com ...
+         ~~~~~~~~~~~~~~
Unerwartetes Token "Get-Credential" in Ausdruck oder Anweisung.
    + CategoryInfo          : ParserError: (:) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : ExpectedValueExpression
//
 

Zuvor habe ich Microsoft Online Services-Anmelde-Assistent und Azure Active Directory Connection installiert.

Ich habe von der Schulung ein Screenshot, wo ich es genau so eingegeben habe und wo es auch funktioniert hat. Weiß jemand, was ich falsch mache? Vielen Dank schonmal



#2 testperson

testperson

    Board Veteran

  • 4.510 Beiträge

 

Geschrieben 26. Juni 2017 - 11:38   Lösung

Hi,

 

du hast nach dem $cred ein Minus (-). Da sollte vermutlich ein Gleichheitszeichen (=) hin.

 

Gruß

Jan


Good morning, that's a nice TNETENNBA!

#3 Sommer2016

Sommer2016

    Newbie

  • 60 Beiträge

 

Geschrieben 26. Juni 2017 - 11:43

und schon gehts... sorry, wie peinlich,,,^^