Zum Inhalt wechseln


Foto

Win7 IIS7 FTP - User zieht falsche Rechte

IIS

  • Bitte melde dich an um zu Antworten
2 Antworten in diesem Thema

#1 Gruby

Gruby

    Newbie

  • 2 Beiträge

 

Geschrieben 31. Januar 2017 - 16:51

Hallo zusammen,

 

ich lasse einen Heimserver auf Win7 mit IIS7 laufen. Nutze ihn als FTP im LAN.

 

Server:

Win 7 Home Premium, SP1, 64bit

IIS7

 

Clients:

Win 7 Home Premium, SP1, 64bit

Win 8.1, 64bit

Win 10 Professional, 64bit

 

Nun zu meinem Problem:

Server: Win 7 hat Benutzerkonto "1" (Standard, abgespeckter Admin-Account) und Benutzerkonto "2" (Share-Account, für die Clients) - und natürlich Admin-, Guest-Account... -

Alle Clients: nutzen Benutzerkonto "2" um sich mit dem FTP zu verbinden.

 

- Client Win 7, Win 10: haben keine Probleme auf dem FTP.

 

- Client Win 8: der client verbindet sich mit Benutzerkonto "2" am FTP, funktioniert (auch die Verknüpfung des Netzlaufwerkes bezieht sich auf ftp://2@server).Im Root des Servers sehe ich jedoch sämtliche Verzeichnisse mit ftp:// 1@server/verzeichnis. D.h.: ich muss anschließend nochmal Benutzer "1" anmelden, um Dateien zu öffnen, etc. Das, wie ihr euch sicher denken könnt, mir nicht passt. Ich finde auch keine Option im Win GUI nochmal Benutzer "2" zu forcen. Die Oberfläche will strikt Benutzer "1".

 

Die FTP-Site bezieht sich auf ein Laufwerk, wessen Besitzer explizit Benutzer "2" ist.

Ich nutze keine 3rd Party Tools oder einen 3rd Party FTP-Client. Dies ist auch keine Lösung für mein Problem.

Ein connect via .bat ist nicht gewünscht und ebenfalls keine Lösung.

Reboot, check. Stecker drin, check.

Im IIS in den aktiven FTP-Verbindungen, finde ich keine Option für den Client Win 8, um ihm zu erklären, dass er nach dem Verbinden auch weiterhin Benutzer "2" nutzen soll.

Ich musste in Vergangenheit auf allen Clients mal mit Benutzer "1" verbinden - Testzwecke -, habe diese Verbindung aber anschließend gelöscht und die gewünschte Verbindung mit Benutzer "2" via "Netzwerkadresse hinzufügen" angelegt. Ich nehme an, hier liegt der Fehler.

 

Wie bekomme ich den Client Win 8 nun dazu, dass er nach dem Verbinden weiterhin mit Benutzer "2" auf die Verzeichnisse und Dateien zugreift?

 

 

PS: Ja, Win7 ist nicht gut für solche Zwecke. Hab aber leider nur ein sehr eng bemessenes Budget zur Verfügung und es wird definitiv nichts mehr für Software aufgewendet. Es muss Win7 mit IIS7 sein. Ist auch nicht gerade meine Traumplattform.

 

Edit: Ja, die Verbindung ("Netzwerkadresse hinzufügen") habe ich bereits diverse Male gelöscht und auf die Richtigkeit geprüft. Stimmt leider alles.

 

 

Freundliche Grüße

Gruby


Bearbeitet von Gruby, 31. Januar 2017 - 16:57.


#2 zahni

zahni

    Expert Member

  • 16.390 Beiträge

 

Geschrieben 31. Januar 2017 - 17:03

Darf ich fragen, warum "FTP" genutzt wird? Zumal sich "zu Hause" die Heimnetzwerk-Funktion anbietet.


Wen du nicht mit Können beeindrucken kannst, den verwirre mit Schwachsinn!


#3 Gruby

Gruby

    Newbie

  • 2 Beiträge

 

Geschrieben 02. Februar 2017 - 11:44

Hi Zahni,

 

der FTP wird von ab und an von außen genutzt.


Lösung:
Private Daten im IE gelöscht. Eigentlich ganz einfach.

Vielen Dank für eure Hilfe.





Auch mit einem oder mehreren der folgenden Tags versehen: IIS