Zum Inhalt wechseln


Foto

Server 2012R2 Event-ID 36888 Schannel


  • Bitte melde dich an um zu Antworten
5 Antworten in diesem Thema

#1 H. Hennig

H. Hennig

    Junior Member

  • 196 Beiträge

 

Geschrieben 18. Januar 2017 - 09:32

Hallo,

ich suche seit Tagen im Internet, finde aber nichts wirklich aussagefähiges zu folgendem Problem.

 

- Server 2012R2, DC, DNS, DHCP, Printserver, IIS, Hyper-V, aktueller Updatestand

 

Das Systemprotokoll wird, teilweise mehrmals je Minute mit folgendem Fehler gefüllt:

"Es wurde eine schwerwiegende Warnung generiert und an den Remoteendpunkt gesendet. Dies kann dazu führen, dass die Verbindung beendet wird. Die schwerwiegende Warnung hat folgenden für das TLS-Protokoll definierten Code: 20. Der Windows-SChannel-Fehlerstatus lautet: 960."

Die in den Details unter "Execution" aufgeführte Prozess-ID gehört zu lsass.exe, der dazugehörige Dienst ist "Vaultsvc".

 

Dazu kommt, dass im Netzwerk verschiedene Benutzer klagen, dass einige Anwendungen oder der komplatte PC abstürzen, bzw. einfrieren. Das kommt im ganzen Netzwerk (10 PCs) pro Tag ca. 2* an unterschiedlichen PCs vor. Passiert ist es schon an allen PCs. Es ist kein PC besonders häufig betroffen.

Ich kann nicht nachvollziehen ob die Abstürze mit dem Schannelproblem zusammenhängen und will daher ersteinmal die Schannelgeschichte erledigen.

 

Zum Schannelfehler habe ich viele Posts im Internet gefunden, aber kaum etwas bei dem der Fehler schließlich behoben werden konnte. Die Bandbreite geht von Zertifikatsfehlern bis zur Deinstallation diverser Updates, Anpassung der Default Domain Policy und Registrypatches. Ich möchte jedoch nicht mit allen möglichen Versuchen im dunkeln fischen um zu hoffen, das irgend etwas hilft (es handelt sich schließlich um ein produktives System).

 

Hat jemand irgendeinen Tipp und / oder konnte in einer ähnlichen Serverumgebung so ein Problem schon einmal lösen?

 

Grüße

 

H.H.



#2 testperson

testperson

    Board Veteran

  • 4.637 Beiträge

 

Geschrieben 18. Januar 2017 - 09:36

Hi,

- Server 2012R2, DC, DNS, DHCP, Printserver, IIS, Hyper-V, aktueller Updatestand

das heißt der Server läuft virtuell als Hyper-V VM oder heißt das, der Server ist DC, DNS, DHCP, Printerserver, IIS und Hyper-V und es werden darauf VMs virtualisiert?

 

Gruß

Jan


Good morning, that's a nice TNETENNBA!

#3 H. Hennig

H. Hennig

    Junior Member

  • 196 Beiträge

 

Geschrieben 18. Januar 2017 - 09:45

Der Server hat alle angegebenen Rollen. Es läuft eine VM (Auch einer Server 2012R2 - bei dem dieses Problem nicht auftritt).



#4 testperson

testperson

    Board Veteran

  • 4.637 Beiträge

 

Geschrieben 18. Januar 2017 - 09:54

Temporär einen Server hinstellen, zum DC promoten, FSMO Rollen übertragen, DHCP + Printserver + VM exportieren alten DC demoten.

Vorhandenen Server neu installieren, Hyper-V Rolle aktivieren,

  • VM1 aufsetzen und zum DC promoten, FSMO Rollen übertragen, DHCP installieren und importieren;
  • VM2 importieren;
  • VM3 IIS installieren;
  • VM4 Printserver + Fileserver(?) oder eben mit in VM1;

jetzt ggfs. anfangen Fehler zu beheben.


Good morning, that's a nice TNETENNBA!

#5 H. Hennig

H. Hennig

    Junior Member

  • 196 Beiträge

 

Geschrieben 18. Januar 2017 - 10:12

@testperson

 

Vielen Dank für die Antwort. Es handelt sich um ein kleines Netzwerk, wie gesagt 10 PCs. Physikalisch ist ein Server2012R2 mit den oben angegebenen Rollen installiert. Die VM wurde aufgesetzt, um einer Betriebswirtschaftlichen Software einen eigenen Server zu geben. IIS läuft nur wergen der Verwaltungskonsole der Virenschutzlösung. Hier könnte ich notfalls auf Apache wechseln, habe aber bisher lieber IIS genommen. Ähnliche Konfigurationen haben wir auch bei anderen Kunden laufen, allerdings unter Server 2008R2.

Aus meiner Sicht wäre eine komplette Virtualisierung zwar sehr elegant, aber hier nicht wirklich notwendig.

Sehe ich es aber richtig, dass das Problem in Richtung IIS vermutet wird?

 

H.H.



#6 testperson

testperson

    Board Veteran

  • 4.637 Beiträge

 

Geschrieben 18. Januar 2017 - 10:29

Ähnliche Konfigurationen haben wir auch bei anderen Kunden laufen, allerdings unter Server 2008R2.

Das machts nicht besser. Meine obigen Schritte würde ich dann auch für die anderen Kunden empfehlen.

 

Ich bin dann aber raus hier.


  • NorbertFe gefällt das
Good morning, that's a nice TNETENNBA!