Zum Inhalt wechseln


Foto

Nach Neuinstallation von Exchange können Terminänderungen nicht Versand werden

Windows Server 2012 R2 Exchange

  • Bitte melde dich an um zu Antworten
14 Antworten in diesem Thema

#1 Scorp1337

Scorp1337

    Junior Member

  • 148 Beiträge

 

Geschrieben 04. Januar 2017 - 18:52

Liebe MCSE Community,

 

aus noch unerfindlichen Gründen mussten wir unseren 2013er Exchange Server beerdigen. Glücklicherweise konnten wir sämtliche Daten aus VEEAM (Backup) und den Outlooks sichern.

 

Nach dem wir einen neuen Server aufgesetzt hatten, haben wir alle Postfächer, mit den noch existierenden Usern, neu angelegt.

Soweit so gut, anschließend wurden alle Outlookprofile neu eingerichtet, sodass schonmal Mailempfang- und versand möglich wurde.

 

Die Kontakte haben wir mit Drag & Drop, aus den inzwischen angebundenen PST-Dateien, in die Postfächer verschoben. Die E-Mails, Aufgaben etc. spielen hier erst mal keine Rolle.

 

Jetzt zum eigentlichen Thema: Die Termine und Besprechungen haben wir in den Kalender des jeweiligen Postfaches importiert (über Outlook > Öffnen > PST Import > in den ausgewählten Ordner).

Das Problem ist Folgendes: Wenn ein Organisator einer Besprechung eine Änderung vornimmt, und diese dann an die Teilnehmer verschickt werden soll, bekommt man Postmaster-Rückmeldungen, dass man für das Senden im Auftrag von nicht berechtigt wäre. Dies gilt für interne sowie externe Teilnehmer.

 

Auffällig ist, dass wenn solch ein Termin weitergeleitet wird, wird angezeigt, dass man im Auftrag von sich selbst senden würde. Siehe Screenshot.

 

Wir vermuten, dass die Ursache folgende ist: Organisator-E-Mail ist identisch, die GUID des Postfaches aber nicht.

(vergleichbar mit dem Fehler, wenn die E-Mailadresse eines Kollegen nicht aufgelöst werden kann und man diese dann aus dem Verlauf löschen muss, damit sie korrekt aufgelöst wird.).

 

Ich habe mal einen Screenshot angehangen... im Prinzip will der Organisator Müller, Hans seinen Termin nach Import in seinen Kalender anpassen. Da das nicht ging, wollte er ihn an die Teilnehmer weiterleiten und ihnen mitteilen, dass der Termin neu angelegt wird. Es wird bei Von angezeigt, dass Müller, Hans im Auftrag von Müller, Hans senden würde...

Angehängte Datei  exch-calendar-error-after-import.jpg   43,8K   0 Mal heruntergeladen

 

Meine Frage:

Kann man diesen Fehler beheben? Kann man die Organisatoren der Besprechungen neu setzen lassen?

 

#Brainfuck

Happy New Year,

 

Norman



#2 NorbertFe

NorbertFe

    Expert Member

  • 30.838 Beiträge

 

Geschrieben 04. Januar 2017 - 18:57

Guten Abend,
Ich überlege grad, ob das viel Aktionismus war, oder wirklich die letzte Möglichkeit. Aber so wie sich das liest, habt ihr den Exchange komplett aus dem ad geworfen. Falls das so sein sollte wirst du nicht mehr viel Freude haben an diesen geschilderten Problemen, denn genau sowas passiert bei pst Importen. Du kannst schauen, dass du die x500 Adressen nachpflegst, damit das noch irgendwie zu retten ist. Aber ich bezweifle, dass das in diesem Fall wirklich helfen wird.
https://www.frankysw...tion-550-5-1-1/

Bye
Norbert

Make something i***-proof and they will build a better i***.


#3 testperson

testperson

    Board Veteran

  • 4.602 Beiträge

 

Geschrieben 04. Januar 2017 - 18:59

Hi,

 

war der Exchange auch DC und ihr habt unterm Strich _alles_ neu gemacht?

 

Gruß

Jan


Good morning, that's a nice TNETENNBA!

#4 NorbertFe

NorbertFe

    Expert Member

  • 30.838 Beiträge

 

Geschrieben 04. Januar 2017 - 19:09

Vermutlich, würde ich sagen. Deswegen stellt sich die Frage was und wie mit veeam gesichert wurde. Nur selbst mit dieser Info wird wahrscheinlich keiner eine erneute Wiederherstellung durchführen, oder doch?

Make something i***-proof and they will build a better i***.


#5 testperson

testperson

    Board Veteran

  • 4.602 Beiträge

 

Geschrieben 04. Januar 2017 - 19:36

Tja, puh.. Also kommt halt drauf an ;)

 

Nur für den Fall, dass der Exchange nicht DC war, würde ich am Restoreprozess zweifeln wollen (Was aber jetzt auch nicht wirklich weiterhilft). Und dann ggfs. halt doch auf vor dem Crash restoren und dann aus dem "Jetzt" das Neue zurückholen. Oder eben auch nicht.

 

Ansonsten eben, wie von dir verlinkt bzw. bei Frankys Web beschrieben.


Good morning, that's a nice TNETENNBA!

#6 Scorp1337

Scorp1337

    Junior Member

  • 148 Beiträge

 

Geschrieben 04. Januar 2017 - 19:51

Danke für die schnellen Antworten!

Der alte Exchange war nicht DC. Aus VEEAM haben wir die Postfächer einzeln in PSTs exportiert (zur Sicherheit auch aus Outlook).

Das mit den x500 Adressen schaue ich mir an (bin gerade unterwegs).

Details zur ursprünglichen Problematik kann ich nachliefern, wir hatten Postfächer in neue DBs verschoben, was nicht half... Chef hat dann aktionistisch Neuaufsetzen angeordnet.

#7 Doso

Doso

    Board Veteran

  • 2.491 Beiträge

 

Geschrieben 04. Januar 2017 - 20:24

Das ist afair eines der Probleme die man hat wenn man einen Exchange Server über so Bastelei wiederherstellt und das nicht richtig macht. Keine Ahnung was man dagegen macht, aber X500 nachtragen könnte eine Option sein. Aber da werdet ihr noch viel Freude haben mit. Schon mal versucht auf eine alte E-Mail zu antworten?



#8 Scorp1337

Scorp1337

    Junior Member

  • 148 Beiträge

 

Geschrieben 04. Januar 2017 - 20:26

Nachtrag: Wir hatten bereits am 14. Dez das Problem, dass 2 Postfächer kontinuierlich in die Quarantäne verschoben worden sind - später weitere Postfächer. Alle Versuche die Mailboxen bzw. Datenbanken zu reparieren sind zwar anfänglich erfolgreich gewesen, dann aber erneut in Abstürze resultiert.

 

Jetzt jedenfalls haben wir einen frisch aufgesetzten Exchange 2013 CU15 auf Win Srv 2012 R2, um die 60 Postfächer mit 50 Nutzern. Alle Outlookprofile und Postfächer sind neu erzeugt - E-Mails sollen nicht importiert werden.

 

PS: Nachtrag: Habe angefangen den Franky's Web Beitrag zu lesen/überfliegen... ja - macht alles Sinn. Passt wie die Faust auf's Auge! Mal sehen wie's morgen weiter geht, oder ob hier jemand noch etwas beisteuern kann.

@Doso: Alte E-Mails sind beantwortbar, insofern externe Absender sie verfasst haben, oder? Zumal wir das neue System ab 22.12. hatten............ alt verstehen die User hier auch als alt. Die Verläufe der intern angeschriebenen Adressen is eher problematisch



#9 NorbertFe

NorbertFe

    Expert Member

  • 30.838 Beiträge

 

Geschrieben 04. Januar 2017 - 20:36

Aktionismus ist in solchen Fällen selten eine gute Idee (auch nicht, wenn es den Chef befällt). Leider wird in meist eher Verlust von Informationen und Meta-Informationen in Kauf genommen, als das Problem zu analysieren und korrekt zu lösen.
Dann berichte mal, was sich noch so ergibt.

Bye
Norbert

Make something i***-proof and they will build a better i***.


#10 Scorp1337

Scorp1337

    Junior Member

  • 148 Beiträge

 

Geschrieben 05. Januar 2017 - 09:01

Wir versuchen den Ansatz: Alte Version (vor der Neuinstallation) des DC in eine Sandbox wiederherstellen, dann die ExchangeLegacyDNs extrahieren und als x500-Adressen bei den Postfächern hinterlegen.



#11 NorbertFe

NorbertFe

    Expert Member

  • 30.838 Beiträge

 

Geschrieben 05. Januar 2017 - 09:25

Wie wurde denn der Exchange gesichert?

Make something i***-proof and they will build a better i***.


#12 Scorp1337

Scorp1337

    Junior Member

  • 148 Beiträge

 

Geschrieben 05. Januar 2017 - 14:07

Die alten LegacyDNs als x500 Adressen den Postfächern hinzuzufügen scheint geholfen zu haben...

 

Der Exchange wurde und wird mit VEEAM Backup & Replication 9 inkl application aware processing gesichert.



#13 NorbertFe

NorbertFe

    Expert Member

  • 30.838 Beiträge

 

Geschrieben 05. Januar 2017 - 14:33

Und warum wurde er dann nicht aus dem Backup wiederhergestellt? Hilft dir zwar überhaupt nicht jetzt, aber bisschen merkwürdig ist das schon, oder?

Make something i***-proof and they will build a better i***.


#14 Scorp1337

Scorp1337

    Junior Member

  • 148 Beiträge

 

Geschrieben 06. Januar 2017 - 08:16

Aktionismus. Ich selbst würde auch oftmals andere Lösungen ansetzen, nur leider bin ich kein Chef ;-)

Wir haben auf jedenfall aus dem Vorfall gelernt.

 

Nochmal zur x500: Hat jedes Postfach nur eine x500 Adresse, oder führt die Angabe einer X500 Adresse dazu, dass die neue auf dem neuen Server nicht mehr gültig ist?

Und: Es scheint korrekt, dass es , / +2C am Ende bei manchen Usern gibt..?! :D



#15 Doso

Doso

    Board Veteran

  • 2.491 Beiträge

 

Geschrieben 11. Januar 2017 - 16:55

Ihr habt wegen sowas eure Exchange Server zersägt und fangt neu an?

 

Wow - sehr mutig  :cry:

 

Wünsche euch nicht viel Glück, ich glaube ihr werdet es brauchen.





Auch mit einem oder mehreren der folgenden Tags versehen: Windows Server 2012 R2, Exchange