Zum Inhalt wechseln


Foto

HyperV-Failovercluster - Unterschiedliche Microsoft DSM Versionen, deswegen Clustervalidation-Fehler


  • Bitte melde dich an um zu Antworten
7 Antworten in diesem Thema

#1 Christoph_A4

Christoph_A4

    Junior Member

  • 201 Beiträge

 

Geschrieben 07. November 2016 - 13:03

Hallo,

 

ich bin dabei unseren HyperV-Cluster auf die Nodes 9 und 10 zu erweitern.

Leider stellt sich beim validation check heraus, dass es zwischen den Multipath DSM Treiber (MS) einen mismatch gibt. Nodes 1 bis 8 haben die QFE number 18217, Nodes 9 und 10 die QFE number: 16384.

 

Ich habe mich umfangreich mit dieser Problematik beschäftigt, komme aber zu keiner zufriedenstellenden Lösung. Wir arbeiten mit einem IBM Storage und dem dazugehörigen „SDDDSM“ als Multipathingtreiber, der auf den MS-DSM (welcher das Problem meldet) aufbaut, bzw. diesen mitnutzt.

 

Als Hintergrund noch wichtig, da immer wieder auf den Update-Stand hingewiesen wird: Wir arbeiten zwar mit unserem eigenen WSUS-Server, ich habe die MS-Updates natürlich zusätzlich jeweils mit Microsoft auch nochmal direkt abgeglichen. Die Nodes sind auf einem identischen Stand.

 

Hier die Fehlermeldung des Validationchecks. Siehe Anhang.

 

 

 

 

 

Angehängte Dateien



#2 Dunkelmann

Dunkelmann

    Expert Member

  • 1.862 Beiträge

 

Geschrieben 07. November 2016 - 14:40

Moin,

 

ich behaupte mal, Dir fehlen noch Updates.

 

Build 6.3.9600.16384 ist das RTM

Build 6.3.9600.17415 ist "mit Update" (April 2014)

 

Build .18217 stammt vermutlich aus Januar 2016

https://support.microsoft.com/en-us/kb/3121261


Keep It Small - Keep It Simple


#3 Doso

Doso

    Board Veteran

  • 2.453 Beiträge

 

Geschrieben 07. November 2016 - 14:50

Bringe deine Nodes auf den gleichen Versionsstand und die Meldung verschwindet.. DSM vom Hersteller (IBM) und gleichen Update Stand bei den Windows Updates (Standard MPIO Microsoft).



#4 Christoph_A4

Christoph_A4

    Junior Member

  • 201 Beiträge

 

Geschrieben 08. November 2016 - 10:19

Moin,

 

ich behaupte mal, Dir fehlen noch Updates.

 

Build 6.3.9600.16384 ist das RTM

Build 6.3.9600.17415 ist "mit Update" (April 2014)

 

Build .18217 stammt vermutlich aus Januar 2016

https://support.microsoft.com/en-us/kb/3121261

 

Hi,

 

schade, "The Update is not applicable to your computer".

Darf ich fragen, wie du auf die verschiedenen Updates gekommen bist? Ich habe zu den QFE-Versionen keinerlei Bezug zu irgendwelchen Updates finden können.



#5 Dunkelmann

Dunkelmann

    Expert Member

  • 1.862 Beiträge

 

Geschrieben 08. November 2016 - 12:33

Wegen eigener Cluster Störungen durfte ich mich die letzten Monate öfters durch diverse KB Artikel wühlen und eine kleine Historie der Updates und deren Wirkung bzw. Nicht-Wirkung führen.

 

Diese beiden Artikel im speziellen:

https://support.micr...n-us/kb/2920151

https://support.micr...n-us/kb/3135020

 

In den meisten Artikeln gibt es Angaben zu Datei, Buildnummer und Releasedatum.


Keep It Small - Keep It Simple


#6 Christoph_A4

Christoph_A4

    Junior Member

  • 201 Beiträge

 

Geschrieben 18. November 2016 - 12:46

Hallo Dunkelmann,

 

Problem ist gelöst. Es lag wirklich an fehlenden Quartalsupdates, auf deren Basis neue Updates angeboten wurden.

 

Im Konkreten, falls es interessiert:

 

1. Windows8.1-KB3021910-x64

2. Windows8.1-KB2919355-x64

3. Windows8.1-KB3121261-v2-x64



#7 Dunkelmann

Dunkelmann

    Expert Member

  • 1.862 Beiträge

 

Geschrieben 18. November 2016 - 19:22

Danke für die Rückmeldung :)


Bearbeitet von Dunkelmann, 18. November 2016 - 19:22.

Keep It Small - Keep It Simple


#8 heuchler

heuchler

    Senior Member

  • 394 Beiträge

 

Geschrieben 10. April 2017 - 09:15

Eine Frage dazu:

Konntest Du die Updates einzeln auf den Server aktualisieren und die VMs trotz ungleichen Standes verschieben?
Ich habe nämlich gerade folgendes Problem:

Hosts HyperV01 und HyperV02 sind auf Stand 18217.
HyperV03 sollte nun neu rein.
Hier ist jedoch durch Updates das Build 18592 installiert (also neuer).
Der Cluster Validation Test schlägt fehl.

Idee: HyperV02 aktualisieren, Rollen von HV01 auf HV02, dann HV01 aktualisieren...
ABER: ich habe etwas bammel dass dann die Migration zwischen HV01/HV02 nicht klappt bzw, die Rollen runtergefahren werden müssen... das wäre suboptimal.

Vielen Dank und Grüße!

Edit: Zur Auflösung:

Das DSM Versionsupdate 18592 wird entweder mit seltsam anmutenden INTEL SYSTEM Update oder dem neuesten Vorschau Update installiert.
Leider hat es jemand zu gut gemeint und eben auch diese draufgepackt - naja.
Nachdem ich nun ein weiterer HV aktualisiert wurde, konnte dieser auch Live migriert werden.
Schlussendlich schlägt also "erstmal" nur Cluster Validation fehl - die Umgebung bleibt jedoch produktiv.
Wenn nun der letzte Server aktualisiert wird dann sollte alles laufen.

 


Bearbeitet von heuchler, 11. April 2017 - 07:23.