Zum Inhalt wechseln


Foto

Zertifikate bei Anmeldung an SQL Server


  • Bitte melde dich an um zu Antworten
5 Antworten in diesem Thema

#1 ssd_rider

ssd_rider

    Senior Member

  • 332 Beiträge

 

Geschrieben 05. November 2016 - 16:39

Hallo zusammen,

 

ich habe heute einen SQL Server 2016 installiert.

Dabei habe ich ein Login erstellt für einen AD Benutzer mit sysadmin-Rechten.

 

Als ich mich mit diesem Benutzer anmelden wollte, kam eine Fehlermeldung bezüglich einem Zertifikatsfehler
(siehe Anhang).

 

Ich weiß mit dieser Fehlermeldung absolut nichts anzufangen, da ich mir nicht vorstellen kann, was die Anmeldung 

an dem SQL Server damit zu tun hat.

 

Es gibt noch eine CA in der Domäne aber für den User kein Benutzerzertifikat.

 

MfG

Angehängte Dateien


Im Zweifelsfall - Tu es!  - Grace Hopper

 


#2 Dunkelmann

Dunkelmann

    Expert Member

  • 1.860 Beiträge

 

Geschrieben 06. November 2016 - 18:26

Moin,

 

vermutlich hat sich der SQL ein selbstsigniertes Zertifikat erstellt und sichert damit die Verbindung.

 

Ist die Option 'Encrypt Connection' im SQL Management Studio aktiviert? Kannst Du Dich verbinden, wenn Du die Option deaktivierst?


Keep It Small - Keep It Simple


#3 OliverHu

OliverHu

    Senior Member

  • 790 Beiträge

 

Geschrieben 07. November 2016 - 06:16

Moin,

 

ich habe jetzt zwar keinen SQL Server 2016 zur Verfügung, aber ich denke im Konfigurations Manager -> SQL Server-Netzwerkkonfiguration -> Eigenschaften Protokolle ist Verschlüsselung erzwingen aktiviert?


Viele Grüße!

#4 Sunny61

Sunny61

    Expert Member

  • 21.697 Beiträge

 

Geschrieben 07. November 2016 - 07:48

Wenn die Verschlüsselung auf erzwingen steht, muss man den FQDN angeben um sich zu verbinden.

 

SQL01.domain.TLD


Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#5 ssd_rider

ssd_rider

    Senior Member

  • 332 Beiträge

 

Geschrieben 07. November 2016 - 08:28

Also standardmäßig ist meines Wissens nach diese Option verneint, also dass kein Verschlüsselung erzwungen wird. 

Ich habe da auch nichts umgestellt. 


Im Zweifelsfall - Tu es!  - Grace Hopper

 


#6 Sunny61

Sunny61

    Expert Member

  • 21.697 Beiträge

 

Geschrieben 07. November 2016 - 11:00

Schau doch mal nach, was eingestellt ist. Probier es doch mal mit dem FQDN, funktioniert das?


Gruppenrichtlinien: http://www.gruppenrichtlinien.de/