Zum Inhalt wechseln


Foto

Problem: SBS 2008 bleibt nach Entfernen der Hyper-V Rolle bei der Konfiguration von Updates hängen

Windows Server 2008 SBS - Small Business Server

  • Bitte melde dich an um zu Antworten
8 Antworten in diesem Thema

#1 rally200_hh

rally200_hh

    Newbie

  • 3 Beiträge

 

Geschrieben 30. August 2016 - 09:39

Hallo zusammen,

 

ich habe folgendes Problem:

 

Nachdem es mir nicht gelungen ist, eine VM mit einem lauffähigen WIN7 zu konfigurieren, habe ich heute morgen die Hyper-V Rolle wieer von unserem SBS 2008 deinstalliert. Das hat auch geklappt; nach dem Neustart will der Server neue Updates konfigurieren und bleibt dabei hängen (siehe Schreen). Das geht jetzt schon 2 Stunden so.

 

Glücklicherweise starten sonst aller Dienste (DNS, AD, DHCP, Exchange, etc.) normal. Nur auf den Desktop komme ich nicht.

 

Hat jemand einen Tipp, wie das behoben werden kann oder was ich nun machen muss?

 

Bin für jeden Tipp dankbar...

 

Beste Grüsse,

Michael

Angehängte Dateien

  • Angehängte Datei  screen.JPG   20,3K   0 Mal heruntergeladen


#2 Dukel

Dukel

    Board Veteran

  • 9.313 Beiträge

 

Geschrieben 30. August 2016 - 09:49

Ich hoffe der Server ist nicht Produktiv. Auf einem SBS installiert man nicht einfach so einen Hyper-V und deinstalliert wieder.

 

Hast du ein Backup von vor der ganzen Geschichte?

Versuchst du auf die Gui per RDP oder Lokal zu kommen?


Stop making stupid people famous.


#3 NilsK

NilsK

    Expert Member

  • 12.475 Beiträge

 

Geschrieben 30. August 2016 - 10:05

Moin,

 

ich würde das noch mal deutlicher sagen:

 

Hyper-V installiert man NIE, NIE, NIE parallel zu anderen Rollen!

 

Hyper-V ist keine Anwendungssoftware wie VirtualBox oder VMware Player. Es ist ein Hypervisor, der den gesamten Systemaufbau verändert.

 

[Warum der Hyper-V-Host keine (!) weiteren Dienste ausführen sollte | faq-o-matic.net]
http://www.faq-o-mat...usfhren-sollte/

 

Der sinnvollste Weg wäre jetzt, das aktuellste Backup des Systems wiederherzustellen.

 

Gruß, Nils


Nils Kaczenski

MVP Cloud and Datacenter Management
... der beste Schritt zur Problemlösung: Anforderungen definieren!

Kostenlosen Support gibt es nur im Forum, nicht privat!


#4 rally200_hh

rally200_hh

    Newbie

  • 3 Beiträge

 

Geschrieben 30. August 2016 - 10:25

Hallo und Danke für die schnellen Antworten.

 

Ich versuche derzeit über RDP auf das System zu kommen,  da der Server am Remotestandort steht.

 

Doch, der Server ist leider produktiv ....

 

Gibt es keinen Trick über die Konsole / abgesicherten Modus an das System zu kommen und das zu fixen?

 

Backup ist zwar vorhanden, wird aber schwierig....

 

Beste grüsse,

Michael



#5 NilsK

NilsK

    Expert Member

  • 12.475 Beiträge

 

Geschrieben 30. August 2016 - 10:58

Moin,

 

wie sollen wir dir aus der Ferne sagen, warum die Updates hängenbleiben?

 

Natürlich könntest du versuchen, in den abgesicherten Modus zu starten und herauszufinden, was das Problem ist. Dafür wirst du aber lokal arbeiten müssen. Und vielleicht kriegst du das Problem nicht behoben.

Ich denke schon, dass du rechtzeitig mit einem Restore anfangen solltest.

 

Gruß, Nils

PS. und dass man auf einem Produktionssystem nicht herumspielt oder Sachen "mal ausprobiert", hast du jetzt hoffentlich gelernt.


Nils Kaczenski

MVP Cloud and Datacenter Management
... der beste Schritt zur Problemlösung: Anforderungen definieren!

Kostenlosen Support gibt es nur im Forum, nicht privat!


#6 PowerShellAdmin

PowerShellAdmin

    Board Veteran

  • 1.136 Beiträge

 

Geschrieben 30. August 2016 - 11:09

Also die Fehlerbehandlung nehme ich üblicherweise im Testlab/Sandbox vor, genau wie die vorsorglichen Tests.
Da es sich wahrscheinlich um ein physikalisches Einzelsystem handelt, ist ein Restore auch nicht sehr angenehm.

Zur Problemlösung würde ich zeitnah einen critical case bei Microsoft eröffnen, aber hierfür solltest du auch vor Ort sein.
Hört sich ziemlich ekelig an...

Alternativ vor Ort fahren, recherchieren und testen.

Ansonsten:
Daten sichern!!! (ganz wichtig welche...)
Restore
Differenzen einspielen.

Möge die Macht der PS mit Dir sein.


#7 Sunny61

Sunny61

    Expert Member

  • 22.249 Beiträge

 

Geschrieben 30. August 2016 - 11:13

ich würde das noch mal deutlicher sagen:
 
Hyper-V installiert man NIE, NIE, NIE parallel zu anderen Rollen!


Und erst recht nicht mit einem SBS spielen! :)
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#8 NilsK

NilsK

    Expert Member

  • 12.475 Beiträge

 

Geschrieben 30. August 2016 - 12:32

Moin,

 

Zur Problemlösung würde ich zeitnah einen critical case bei Microsoft eröffnen, aber hierfür solltest du auch vor Ort sein.
 

 

ich denke, den Zeitverzug kann er sich sparen. Da Hyper-V auf einem SBS nicht supported ist, gehe ich davon aus, dass Microsofts Support da auch nicht hilft.

 

Gruß, Nils


Nils Kaczenski

MVP Cloud and Datacenter Management
... der beste Schritt zur Problemlösung: Anforderungen definieren!

Kostenlosen Support gibt es nur im Forum, nicht privat!


#9 rally200_hh

rally200_hh

    Newbie

  • 3 Beiträge

 

Geschrieben 30. August 2016 - 14:20

Moin,

 

zunächst herzlichen Dank für die Antworten. War über die Mittagszeit vor Ort im Büro beim Serverstandort. Leider ist auch auf der Managementkonsole die Ubdatemeldung drauf und ich kann nicht nicht einloggen.

 

Werde mich dann zeitnah an das Rückspielen des Backups machen müssen (habe glücklicherweise ein rel. aktuelles).

 

Beste Grüsse,

Michael


Hallo zusammen,

 

das Thema ist gelöst :-)

 

Nachdem der Server (Primergy RX300 S6 mit Hexacore Xenon und 32 GB RAM) immerhin ca. 6 Stunden gebraucht hat, um die Hyper-V Rolle zu entfernen, funktioniert alles wieder einwandfrei. Die Protokolle sind ok und ohne Fehler.

 

Deshalb mein Tipp: Einfach einige Stunden warten und hoffen. Es kann sehr lange dauern :-)

 

Dieses Topic kann somit auf "gelöst" gesetzt werden.

 

Vielen Dank und beste Grüsse,

Michael





Auch mit einem oder mehreren der folgenden Tags versehen: Windows Server 2008, SBS - Small Business Server