Zum Inhalt wechseln


Foto

1-2 mal die Woche IOPS (durchsch. Datenträ.- Wartesch.) von 2-10 für ca. 3 Std.

Windows Server 2012 R2 Hyper-V

  • Bitte melde dich an um zu Antworten
5 Antworten in diesem Thema

#1 Bruchstein

Bruchstein

    Newbie

  • 17 Beiträge

 

Geschrieben 23. August 2016 - 08:53

Der Hyper-V Host (2012R2) hat für 5 VM’s (2x mit SQL) ein RAID 50 mit 8 SATA. Der Raid-Controller ist ein LSI9271 mit BBU. RAID-Status ist optimal. Konsistenz ok. RAM Reserve für den Host 8 GB. Host-Prozessorauslastung max. 1-5 %. VM-Datenträger sind (zur Zeit noch) alle dynamisch.

 

Leider kann ich für die Last keinen speziellen Verursacher ausmachen. Es kommt aber jedes Mal (aber nicht immer) morgens nach der VM-Sicherung durch Altaro vor. Der Host ist in der genannten Zeit faktisch nicht mehr erreichbar.

 

Ob so eine Datenträgerabbildung Reorganisationsprozesse im Nachgang auf dem Datenträger hervorrufen können weiß ich nicht. Nach 2-3 Std. ist der Spuk vorbei und die durchsch. Warteschlange liegt anschließend im Mittel bei 0,5 – 1

 

Es sind nur 30 Clients, davon jedoch einige Workstations mit CAD, DMS, ECM und ERP.

 

Ich würde mal dazu gern Eure Ideen hören. Rein aus Interesse. Ich bin kein reiner Admin, eher so nebenberuflich. So zwischen Suppe und Kartoffeln. Kleiner „Mittelstand“ halt. Von daher kann ich mit allerlei Ratschlägen umgehen.

 

Um der generell grenzwertigen Auslastung entgegen zu wirken werden wir einen neuen Host bereitstellen mit  einem Raid 10 mit 2x 5 SAS, BBU und CacheCade mit 2 SSD für die VM’s

Ich nehme an das sollte reichen für die Spatzen.

 

Gruß

Olaf



#2 Doso

Doso

    Board Veteran

  • 2.461 Beiträge

 

Geschrieben 23. August 2016 - 13:18

Kannst du die IOPS Spitze einem gewissen Zeitfenster zuordnen? Es gibt einige Sachen die führen so Wartungsarbeiten durch. Ich kenne das z.B. von Exchange und DPM. Die machen dann einmal Nachts Aufräumarbeiten. Löschen verwaiste Postfächer, defragmentieren die Datenbank, löschen mittlerweile gesicherter Transaktionslog und so Krams halt. Das Fenster hierfür kann man meist konfigurieren.

 

Habt ihr ggf. einen Virenscanner installiert der dann nach dem Backup nochmal alle Dateien anschaut oder sowas?



#3 Dunkelmann

Dunkelmann

    Expert Member

  • 1.862 Beiträge

 

Geschrieben 23. August 2016 - 14:54

Moin,

 

RAID50 mit 8 SATA ist keine optimale Konfiguration; schlechte Performance, fehlernafällig.

 

Ich würde zunächst prüfen, ob die eingesetzten SQL Versionen dynamische Disks unterstützen.

 

Ein anderer Punkt ist das Backup:

Hier würde ich die VM zu verschiedenen Zeiten sichern und so für etwas Lastverteilung sorgen.

Bspw. erste VM um 20:00, die nächste um 21:00 usw.

Ein Backup erzeugt einen temporären Snapshot der VM. Je mehr aktive Snapshots parallel auf dem System liegen um so mehr Leistung benötigt das Diskarray.


Keep It Small - Keep It Simple


#4 Bruchstein

Bruchstein

    Newbie

  • 17 Beiträge

 

Geschrieben 24. August 2016 - 05:37

@Doso

Ich hatte zum Zeitpunkt der hohen Last nachgeschaut. Außer das die Systemdienste $Mft (NTFS Mastertabelle) und $LogFile (NTFS Volumeprotokoll) ganz oben mit dabei waren war nichts spezielles zu sehen.

 

@Dunkelmann

Werde im Altaro für jede VM ein Zeitfenster einrichten. (Diesen Punkt finde ich in Altaro auch etwas unglücklich gelöst. Die sollten die Job's automatisch verzögern oder eine Einstellmöglichkeit für eine Zeitverzögerung bieten.) 



#5 NilsK

NilsK

    Expert Member

  • 12.346 Beiträge

 

Geschrieben 24. August 2016 - 06:41

Moin,

 

Ein Backup erzeugt einen temporären Snapshot der VM. Je mehr aktive Snapshots parallel auf dem System liegen um so mehr Leistung benötigt das Diskarray.

 

und das könnte durchaus die Ursache sein: Die Snapshots Checkpoints werden ja live zusammengeführt, wenn sie gelöscht werden. Und das erzeugt natürlich Disk-IO.

 

Gruß, Nils


Nils Kaczenski

MVP Cloud and Datacenter Management
... der beste Schritt zur Problemlösung: Anforderungen definieren!

Kostenlosen Support gibt es nur im Forum, nicht privat!


#6 Dominik Weber

Dominik Weber

    Member

  • 299 Beiträge

 

Geschrieben 01. September 2016 - 12:23   Lösung

Hast du die neuste Version von Altaro Hyper-V Backup installert ? In einer der letzten Versionen wurde eine grössere Änderung vorgenommen.

 

Es wurde auf CBT (Changed Block Tracking) gewechselt was einen massiven Geschwindikeitsvorteil bei der Sicherung der Maschinen zur Folge hatte