Zum Inhalt wechseln


Foto

Noch zwei Fehlermeldungen nach der Migration


  • Bitte melde dich an um zu Antworten
75 Antworten in diesem Thema

#31 tesso

tesso

    Board Veteran

  • 2.233 Beiträge

 

Geschrieben 04. Mai 2016 - 16:18

Ich könnte die db trotzdem löschen. biggrin.gif



#32 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 04. Mai 2016 - 16:20

Ja ich weiß, aber damit wären wir dann wieder beim rtfm;)

Make something i***-proof and they will build a better i***.


#33 horst_stef

horst_stef

    Junior Member

  • 91 Beiträge

 

Geschrieben 04. Mai 2016 - 16:31

Nein das ist der neue ex2016
Und die Meldung sagt uns dann war? ;-)

#34 tesso

tesso

    Board Veteran

  • 2.233 Beiträge

 

Geschrieben 04. Mai 2016 - 16:59

Ich vermute dir fehlt eine Systemmailbox. Wo ist die genaue Fehlermeldung dazu? Dort müsste sich der Name finden.



#35 horst_stef

horst_stef

    Junior Member

  • 91 Beiträge

 

Geschrieben 05. Mai 2016 - 09:01

Ich versuche das Ganze mal bestmöglich zusammenzufassen.

Ich habe in meinem AD folgende deaktivierte System-Mailboxes.

 

 

DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}

Exchange Online-ApplicationAccount

FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042

Mailbox1 (Ist für Public Folder)

Migration.8f3e7716-2011-43e4-96b1-aba62d229136

SystemMailbox{1f05a927-7d53-479d-b99f-5d4efa7e7547}

SystemMailbox{8cc370d3-822a-4ab8-a926-bb94bd0641a9}

SystemMailbox{8cc370d3-822a-4ab8-a926-bb94bd0641a9}

SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}

 

Get-Mailbox -Arbitration liefert mir zurück:

 

 

Name                      Alias                ServerName       ProhibitSendQuota
----                      -----                ----------       -----------------
SystemMailbox{bb558c35... SystemMailbox{bb5... mailsrv01     Unlimited
SystemMailbox{e0dc1c29... SystemMailbox{e0d... mailsrv01     Unlimited
Migration.8f3e7716-201... Migration.8f3e771... mailsrv01     Unlimited
FederatedEmail.4c1f4d8... FederatedEmail.4c... mailsrv01     Unlimited

 

Will ich nun diese System-Mailbox aktivieren, bekomme ich den besagten Fehler:

 

 

[PS] C:\Users\administrator.Domain\Desktop\Ex2016>Enable-Mailbox -Arbitration "SystemMailbox{1f05a927-6a9b-4101-abd2-70
838d0c8e86}"
Der Vorgang konnte nicht ausgeführt werden, weil das Objekt 'SystemMailbox{1f05a927-6a9b-4101-abd2-70838d0c8e86}'
nicht auf 'DC' gefunden wurde.
    + CategoryInfo          : NotSpecified: ( :) [Enable-Mailbox], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : [Server=Ex2016,RequestId=66431488-4e3a-44b1-b2b6-3a73dea1a87f,TimeStamp=04.05.2016
    15:53:59] [FailureCategory=Cmdlet-ManagementObjectNotFoundException] 25CC1A8E,Microsoft.Exchange.Management.Recip
  ientTasks.EnableMailbox
    + PSComputerName        : FQDN Ex2016

 

Die Mailbox ist ja laut AD vorhanden...

 

Nun zu den Fehlermeldungen, die sich allesamt im Application log befinden:

 

error id 3054 MSExchangeApplicationLogic

 

 

Szenario: ProcessOrgExtensions. Das Organisationspostfach für "domain1" konnte nicht abgerufen werden.

 

Ich habe insgesamt 3 Domains auf dem Mailserver und die Meldungen gibt es entsprechend auch noch für "domain2" und "domain3".

 

error id 65535

 

 

<TraceRecord xmlns="http://schemas.micro...nt/TraceRecord"Severity="Error"><TraceIdentifier>http://msdn.microsoft.com/de-DE/library/System.ServiceModel.Diagnostics.ThrowingException.aspx</TraceIdentifier><Description>Eine Ausnahme wird ausgelöst.</Description><AppDomain>/LM/W3SVC/2/ROOT/owa-2-131068747791742371</AppDomain><Exception><ExceptionType>System.Runtime.Serialization.SerializationException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType><Message>Fehler beim Deserialisieren des Objekts "vom Typ Microsoft.Exchange.Clients.Owa2.Server.Core.FindConversationParameters". Unerwartetes Zeichen 'u'.</Message><StackTrace>   bei System.Runtime.Serialization.XmlObjectSerializer.ReadObjectHandleExceptions(XmlReaderDelegator reader, Boolean verifyObjectName, DataContractResolver dataContractResolver)
   bei System.Runtime.Serialization.Json.DataContractJsonSerializer.ReadObject(XmlDictionaryReader reader)
   bei Microsoft.Exchange.Clients.Owa2.Server.Core.UserContextUtilities.DeserializeTypeFromJson[T](String jsonString)
   bei Microsoft.Exchange.Clients.Owa2.Server.Core.SessionDataParallelRequestExecutor.GetTypeFromRequestHeader[T](HttpRequest request, String headerName)
   bei Microsoft.Exchange.Clients.Owa2.Server.Web.SessionDataHandler.&amp;lt;StartRequestProcessing&amp;gt;d__2b.MoveNext()
   bei Microsoft.Exchange.Common.AsyncEnumerator.Advance()
   bei Microsoft.Exchange.Common.AsyncEnumerator.&amp;lt;&amp;gt;c__DisplayClass7.&amp;lt;GetAsyncCallback&amp;gt;b__6(IAsyncResult ar)
   bei Microsoft.Exchange.Net.BasicAsyncResult.Complete(Boolean completedSynchronously)
   bei Microsoft.Exchange.Services.Core.Types.BaseServiceTask`1.CompleteWCFRequest(Exception exception)
   bei Microsoft.Exchange.Services.Core.Types.BaseServiceTask`1.FinishRequest(String logType, TimeSpan queueAndDelayTime, TimeSpan totalTime, Exception exception)
   bei Microsoft.Exchange.Services.Core.Types.ServiceTask`1.InternalComplete(TimeSpan queueAndDelayTime, TimeSpan totalTime)
   bei Microsoft.Exchange.Services.Core.Types.BaseServiceTask`1.Complete(TimeSpan queueAndDelayTime, TimeSpan totalTime)
   bei Microsoft.Exchange.WorkloadManagement.WrappedTask.Complete()
   bei Microsoft.Exchange.WorkloadManagement.UserWorkloadManager.CompleteTask(WrappedTask wrapper)
   bei Microsoft.Exchange.WorkloadManagement.UserWorkloadManager.Execute(WrappedTask wrapper, Boolean synchronously)
   bei Microsoft.Exchange.WorkloadManagement.UserWorkloadManager.&amp;lt;&amp;gt;c__DisplayClass6.&amp;lt;SubmitTask&amp;gt;b__2()
   bei Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(Action tryDelegate, Func`2 filterDelegate, Action`1 catchDelegate)
   bei Microsoft.Exchange.WorkloadManagement.UserWorkloadManager.SendWatsonReportOnUnhandledException(Action methodDelegate)
   bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   bei System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   bei System.Threading.ThreadPoolWorkQueue.Dispatch()
</StackTrace><ExceptionString>System.Runtime.Serialization.SerializationException: Fehler beim Deserialisieren des Objekts "vom Typ Microsoft.Exchange.Clients.Owa2.Server.Core.FindConversationParameters". Unerwartetes Zeichen 'u'. ---&amp;gt; System.Xml.XmlException: Unerwartetes Zeichen 'u'.
   bei System.Xml.XmlExceptionHelper.ThrowXmlException(XmlDictionaryReader reader, XmlException exception)
   bei System.Runtime.Serialization.Json.XmlJsonReader.ReadAttributes()
   bei System.Runtime.Serialization.Json.XmlJsonReader.Read()
   bei System.Xml.XmlBaseReader.IsStartElement()
   bei System.Xml.XmlBaseReader.IsStartElement(XmlDictionaryString localName, XmlDictionaryString namespaceUri)
   bei System.Runtime.Serialization.Json.DataContractJsonSerializer.InternalIsStartObject(XmlReaderDelegator reader)
   bei System.Runtime.Serialization.Json.DataContractJsonSerializer.InternalReadObject(XmlReaderDelegator xmlReader, Boolean verifyObjectName)
   bei System.Runtime.Serialization.XmlObjectSerializer.ReadObjectHandleExceptions(XmlReaderDelegator reader, Boolean verifyObjectName, DataContractResolver dataContractResolver)
   --- Ende der internen Ausnahmestapelüberwachung ---</ExceptionString><InnerException><ExceptionType>System.Xml.XmlException, System.Xml, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType><Message>Unerwartetes Zeichen 'u'.</Message><StackTrace>   bei System.Xml.XmlExceptionHelper.ThrowXmlException(XmlDictionaryReader reader, XmlException exception)
   bei System.Runtime.Serialization.Json.XmlJsonReader.ReadAttributes()
   bei System.Runtime.Serialization.Json.XmlJsonReader.Read()
   bei System.Xml.XmlBaseReader.IsStartElement()
   bei System.Xml.XmlBaseReader.IsStartElement(XmlDictionaryString localName, XmlDictionaryString namespaceUri)
   bei System.Runtime.Serialization.Json.DataContractJsonSerializer.InternalIsStartObject(XmlReaderDelegator reader)
   bei System.Runtime.Serialization.Json.DataContractJsonSerializer.InternalReadObject(XmlReaderDelegator xmlReader, Boolean verifyObjectName)
   bei System.Runtime.Serialization.XmlObjectSerializer.ReadObjectHandleExceptions(XmlReaderDelegator reader, Boolean verifyObjectName, DataContractResolver dataContractResolver)</StackTrace><ExceptionString>System.Xml.XmlException: Unerwartetes Zeichen 'u'.
   bei System.Xml.XmlExceptionHelper.ThrowXmlException(XmlDictionaryReader reader, XmlException exception)
   bei System.Runtime.Serialization.Json.XmlJsonReader.ReadAttributes()
   bei System.Runtime.Serialization.Json.XmlJsonReader.Read()
   bei System.Xml.XmlBaseReader.IsStartElement()
   bei System.Xml.XmlBaseReader.IsStartElement(XmlDictionaryString localName, XmlDictionaryString namespaceUri)
   bei System.Runtime.Serialization.Json.DataContractJsonSerializer.InternalIsStartObject(XmlReaderDelegator reader)
   bei System.Runtime.Serialization.Json.DataContractJsonSerializer.InternalReadObject(XmlReaderDelegator xmlReader, Boolean verifyObjectName)
   bei System.Runtime.Serialization.XmlObjectSerializer.ReadObjectHandleExceptions(XmlReaderDelegator reader, Boolean verifyObjectName, DataContractResolver dataContractResolver)</

 

Die könnte aber eher mit der error ID 106 MSExchange Common zusammenhängen, da diese im Log immer nacheinander kommen.

 

Außer diesen drei Meldungen passt alles im Log.

 

Den Server hatte ich die Nacht auch noch einmal neugestartet, das hat aber hinsichtlich der Meldungen nix gebracht.

Fehler oder Warnungen mit Verweis auf den deinstallierten Exchange 2010 gibt es ebenso keine mehr.

 

Die System-Mailbox konnte enabled werden, ich bekomme allerdings immer noch den Fehler mit Organisationspostfach, allerdings nur noch für eine Domain und nicht mehr für alle drei.

 

 

[PS] C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft Exchange Server 2016>get-mailbox -arbitration

Name                      Alias                ServerName       ProhibitSendQuota
----                      -----                ----------       -----------------
SystemMailbox{1f05a927... SystemMailbox{1f0... mailsrv01     Unlimited
SystemMailbox{bb558c35... SystemMailbox{bb5... mailsrv01     Unlimited
SystemMailbox{e0dc1c29... SystemMailbox{e0d... mailsrv01     Unlimited
Migration.8f3e7716-201... Migration.8f3e771... mailsrv01     Unlimited
FederatedEmail.4c1f4d8... FederatedEmail.4c... mailsrv01     Unlimited
SystemMailbox{8cc370d3... SystemMailbox{8cc... mailsrv01     Unlimited
 

 

Vielen Dank für eure Hilfe.


Bearbeitet von horst_stef, 05. Mai 2016 - 13:06.


#36 massaraksch

massaraksch

    Newbie

  • 152 Beiträge

 

Geschrieben 05. Mai 2016 - 13:26

Hi,

 

Leichen vom alten Server?

 

Kannst mal in der Powershell nach Objekten suchen, die den alten Exchangeserver drinhaben:

([adsisearcher]"msexchhomeservername=*ALTERSERVERNAME*").findall() | select -ExpandProperty Properties | select {$_.name},{$_.msexchhomeservername} | fl

Geht natürlich auch in der AD-Benutzerverwaltung (LDAP-Suche, Attribute anschauen)

 

Und wenn du dich dann traust, wirf sie weg ;)


mfg, massaraksch

#37 horst_stef

horst_stef

    Junior Member

  • 91 Beiträge

 

Geschrieben 05. Mai 2016 - 14:04

Danke Dir, da wird nix gefunden.



#38 tesso

tesso

    Board Veteran

  • 2.233 Beiträge

 

Geschrieben 05. Mai 2016 - 15:05

Du probierst eine andere Mailbox zu aktivieren. Vergleiche mal genau

 

Versuch

enable-mailbox -arbitration "SystemMailbox{1f05a927-7d53-479d-b99f-5d4efa7e7547}"


#39 horst_stef

horst_stef

    Junior Member

  • 91 Beiträge

 

Geschrieben 05. Mai 2016 - 15:53

Grad im Log gesehen, dass jetzt der error auch wieder mit einer anderen Domain drinnen war.

 

Ich hatte die von dir genannte Mailbox auch bereits enabled. Die steht ja auch im AD drinnen (siehe oben)

 

Wenn ich diese Mailbox aktivieren will kommt folgendes:

 

 

[PS] C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft Exchange Server 2016>enable-mailbox -arbitration "Sy
stemMailbox{1f05a927-7d53-479d-b99f-5d4efa7e7547}"
Dieser Task unterstützt keine Empfänger dieses Typs. Der angegebene Empfänger
domain.local/Users/SystemMailbox{1f05a927-7d53-479d-b99f-5d4efa7e7547} ist vom Typ UserMailbox. Stellen Sie sicher,
dass dieser Empfänger dem für diesen Task erforderlichen Empfängertyp entspricht.
    + CategoryInfo          : InvalidArgument: (domain.local/U...f-5d4efa7e7547}:RecipientIdParameter) [Enable-Mailbo
   x], RecipientTaskException
    + FullyQualifiedErrorId : [Server=MAILSRV01,RequestId=aed52440-0e1f-40b1-aa1a-c4ca540e6f88,TimeStamp=05.05.2016
    15:52:10] [FailureCategory=Cmdlet-RecipientTaskException] D02437CA,Microsoft.Exchange.Management.RecipientTasks.E
  nableMailbox
    + PSComputerName        : FQDN


Bearbeitet von horst_stef, 05. Mai 2016 - 16:10.


#40 tesso

tesso

    Board Veteran

  • 2.233 Beiträge

 

Geschrieben 05. Mai 2016 - 16:30

Kann es sein, daß die System Mailbox eine normale Mailbox und keine Arbitration ist? Wenn ja, dann Postfach entfernen disable-mailbox und die Arbitration aktivieren.


Bearbeitet von tesso, 05. Mai 2016 - 16:30.


#41 horst_stef

horst_stef

    Junior Member

  • 91 Beiträge

 

Geschrieben 05. Mai 2016 - 18:16

Nein.kann nicht sein. Die wird nicht angezeigt bei den mailboxes. Das ist schon eine arbitration.
Aber ich hab ja vier System Mailboxes. Ist das normal?

#42 tesso

tesso

    Board Veteran

  • 2.233 Beiträge

 

Geschrieben 05. Mai 2016 - 18:19

Die Fehlermeldung sagt doch Typ Usermailbox. Also schau noch einmal nach. Nimm die Powershell.

#43 horst_stef

horst_stef

    Junior Member

  • 91 Beiträge

 

Geschrieben 05. Mai 2016 - 18:40

Ja das teil ist im ad in der ou users.
Was soll ich genau machen?
Via powershell den mailbox type ändern?

#44 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 05. Mai 2016 - 19:19

Du sollst sie einmal Disablen. Wenn das nicht geht löschen und neu anlegen.

Make something i***-proof and they will build a better i***.


#45 tesso

tesso

    Board Veteran

  • 2.233 Beiträge

 

Geschrieben 05. Mai 2016 - 19:20

Ich schrieb es doch schon. Du sollst dad Postfach deaktivieren disable-mailbox und dann die Arbitrationmailbox aktivieren.

Langsam wird es mit dir anstrengend. Du scheinst keine Ahnung von Exchange zu haben. Tue uns und vor allem dir den Gefallen und befasse dich mit dem Produkt.
Einfach nur weiter klicken bringt dich bei Exchange nicht ans Ziel.
  • NorbertFe gefällt das