Zum Inhalt wechseln


Foto

Langsame SQL-Datenbank (Sage) - Fehlerquelle finden?


  • Bitte melde dich an um zu Antworten
5 Antworten in diesem Thema

#1 Albatroszwei

Albatroszwei

    Newbie

  • 8 Beiträge

 

Geschrieben 03. April 2016 - 14:10

Hallo MCSE-Gemeinde,

wir haben bei uns Sage OfficeLine im Einsatz. Die aktuelle DB ist ca 8 GB groß und ist bei Berichten extrem langsam. Andere Sachen in der Sage gehen normal schnell.

Ich habe bisher die Indizes neu erstellt - dies gab allerdings nur einen kleinen Geschwindigkeitsschub.

Habt ihr noch eine Idee?

 

Gruß

Albatros



#2 lefg

lefg

    Expert Member

  • 20.479 Beiträge

 

Geschrieben 03. April 2016 - 14:42

Moin,

 

wurde schon beim Hersteller geschaut, gibt es eine FAQ? Wurde eine Supportanfrage gemacht?


Das Messbare messen, das Nichtmessbare messbar machen. Galilei.

 

Diskutiere nicht mit ***en, denn sie ziehen dich auf ihr Niveau und schlagen dich dort mit Erfahrung! (Hab ich bei Tom abgeguckt)

 

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität. (Hab ich bei Daniel abgeguckt) https://de.wikipedia...rgo_propter_hoc

 

Absolutistischer“ Geschäftsführungs-Dogmatismus, der jedwede Empirie aus der „Werkstatt“ schlichtweg ignoriert , führt eben zumeist früher als später ….  (Hab ich von Klabautermann)


#3 Nobbyaushb

Nobbyaushb

    Board Veteran

  • 2.629 Beiträge

 

Geschrieben 03. April 2016 - 14:46

Dazu müsste man mehr Informationen haben.

 

- wie ist die Anbindung der Clients an den SQL - Gigabit-LAN?

- bei größeren Installationen (nach meiner Erinnerung, lange her...) war der Anwendungs-Server vom SQL getrennt, wie ist da die Verbindung (wenn denn so...)

- ist der Server physisch oder VM, was sit für ein Storage drunter

- liegt die SQL-DB auf einer separaten Platte / Volumen?

- sieht man Last auf dem SQL bei Abfragen I/O (Stichwort Perfmon..)

- ....

 

;)


Mfg aus Bremen

 

Norbert (der andere :))

MVP Exchange Server


#4 Albatroszwei

Albatroszwei

    Newbie

  • 8 Beiträge

 

Geschrieben 05. April 2016 - 06:47

Hallo,

wir stehen schon mit Sage bzw. Sage-Platin-Partnern in Kontakt - allerdings sind die auch nicht die Schnellsten! :-)

 

Die Clients sind mit Gigabit am Netz angeschlossen.

Bei uns ist es ebenfalls so - Anwendungs-Server und SQL-Server sind getrennt. Die DB liegt auf einer separaten Platte. Beide Server sind physisch. Auf dem Server laufen auch noch andere DBs die solche Effekte nicht haben!

Dieses Zeitmanko tritt tatsächlich nur bei größeren Berichten auf.



#5 PowerShellAdmin

PowerShellAdmin

    Board Veteran

  • 1.135 Beiträge

 

Geschrieben 05. April 2016 - 07:03

Wird als DBMS ein MS-SQL Server eingesetzt ?

 

Auf einem Azure System konnte ich die Query Performance auf einem SQL Server 2014 immerhin verdoppeln

(Achtung gilt nur für den SQL Server 2014 - Das Ganze nicht direkt in der Produktion umsetzen).

 

Prüfung der Ursprungsperformance via sql Query Stress 0.9.7 und nach den Optimierungen erneut prüfen.

https://www.mssqltip...ry-stress-tool/

Hier ruft man eine möglichst auslastende Prozedur in der DB aus und lässt diese z.B. 1000-10000 durchlaufen und merkt sich den Mittelwert.

 

Optimierungs Möglichkeiten:

-Compatiblity Level der Datenbank auf neustes setzen (z.B. SQL Server 2014(120)

=> Erst dadurch greifen diverse Performance Verbesserungen im jeweiligen SQL Server

 

Bei SQL Server 2014 z.B:

-kleine SSD im Server montieren

=> Funktion Speicher für Temporäre DB & Bufferpool (http://searchsqlserv...ion/buffer-pool)

 

 

-Temporäre DB auf SSD auslagern:

USE MASTER 


GO 


ALTER DATABASE tempdb MODIFY FILE (NAME= tempdev, FILENAME= 'D:\sqlcache\tempdb.mdf') 

GO 

-Bufferpool aktivieren (Achtung ! Bufferpool darf maximal die vierfache (bei der Standard-Edition) Größe des Arbeitsspeichers betragen, ansonsten startet der SQL Server nicht mehr).

Beim SQL Server 2014 Express liegt das Limit wohl sogar bei nur 1GB.

Falls der SQL Service nicht mehr startet, muss man den Bufferpool wieder via SQLCMD deaktivieren und im Anschluss mit den geringeren Werten wieder aktivieren.

--enable Buffpool 

USE master  

GO 


ALTER SERVER CONFIGURATION  

SET BUFFER POOL EXTENSION ON 

    (FILENAME = 'D:\sqlcache\SQL2014.BPE', SIZE = 16 GB); 

GO 


Bearbeitet von PowerShellAdmin, 05. April 2016 - 08:37.

Möge die Macht der PS mit Dir sein.


#6 zahni

zahni

    Expert Member

  • 16.389 Beiträge

 

Geschrieben 05. April 2016 - 08:21

Wartungsplan (Neuindizierung, Statistiken) ausführen.

Neue Indizes müssen zu den Queries passen. Da ein Admin die nicht kennt, hilft nur

 

https://msdn.microso...v=sql.110).aspx

 

Zur Bufferpool Extension:

 

Erstmal lesen, was das ist:  https://msdn.microso...v=sql.120).aspx


Bearbeitet von zahni, 05. April 2016 - 08:23.

Wen du nicht mit Können beeindrucken kannst, den verwirre mit Schwachsinn!