Zum Inhalt wechseln


Foto

Exchange Unterstützung für TLS 1.2?

Exchange

  • Bitte melde dich an um zu Antworten
53 Antworten in diesem Thema

#31 djinty

djinty

    Newbie

  • 7 Beiträge

 

Geschrieben 16. Februar 2015 - 15:07

Ich bin dran. Du kannst aber gern MS direkt um Rat fragen. ;)

 

Hi, das Windows Update KB2992611 hat mein Problem gelöst. Danke dennoch für deine Mühen.



#32 bill_mustermann

bill_mustermann

    Senior Member

  • 419 Beiträge

 

Geschrieben 16. Februar 2015 - 15:34

Hi, das Windows Update KB2992611 hat mein Problem gelöst. Danke dennoch für deine Mühen.

 

welches problem genau? Kann dein Exchange jetzt TLS 1.2?

 

gruesse



#33 djinty

djinty

    Newbie

  • 7 Beiträge

 

Geschrieben 17. Februar 2015 - 08:06

welches problem genau? Kann dein Exchange jetzt TLS 1.2?

 

gruesse

 

Mein Problem bezog sich auf HTTPS nicht SMTP. Also ja man kann jetzt TLS 1.2 Verbindungen über ActiveSync herstellen.

SMTP vermutlich aufgrund des Patchlevels nicht. Sorry, dass ich hierzu erstmal nichts beitragen kann.



#34 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 25. Februar 2015 - 20:24

Hallo,
 
ich habe nun das Update auf CU7gemacht. Direkt von CU3 auf CU7. Leider ist TLS1.1 und 1.2 immer noch nicht aktiviert bzw. funktioniert nicht. Was mache ich nun?
 
gruesse


So, was lange währt... ;)
Ich hab grad die Info von MS bekommen, dass dort wohl intern was falsch kommuniziert wurde. TLS 1.1 und TLS 1.2 soll mit CU8 kommen.

Dann testen wir in ein paar Wochen nochmal. ;)

Bye
Norbert

PS: die von mir geposteten Links oben auf CU7 sollen wohl noch entsprechend korrigiert werden.

Bearbeitet von NorbertFe, 25. Februar 2015 - 20:24.

Make something i***-proof and they will build a better i***.


#35 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 17. März 2015 - 16:08

Hi,

so lt. http://support.micro...n-us/kb/3029667 sogar als Backport für Exchange 2010 jetzt in SP3 Rollup 9 enthalten.

Ob es in CU8 für 2013 funktioniert kann ich nachher mal testen:
http://blogs.technet...erver-2013.aspx

Bye
Norbert

Make something i***-proof and they will build a better i***.


#36 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 17. März 2015 - 22:15

So noch als Ergänzung:

Sieht soweit ganz gut aus auf einem 2013CU8
  * TLSV1_2 Cipher Suites:
      Preferred:                       
                 ECDHE-RSA-AES256-SHA384       ECDH-384 bits  256 bits      Timeout on SMTP NOOP               
      Accepted:                        
                 ECDHE-RSA-AES256-SHA384       ECDH-384 bits  256 bits      Timeout on SMTP NOOP               
                 ECDHE-RSA-AES256-SHA          ECDH-384 bits  256 bits      Timeout on SMTP NOOP               
                 AES256-SHA                    -              256 bits      Timeout on SMTP NOOP               
                 ECDHE-RSA-AES128-SHA256       ECDH-384 bits  128 bits      Timeout on SMTP NOOP               
                 ECDHE-RSA-AES128-SHA          ECDH-256 bits  128 bits      Timeout on SMTP NOOP               
                 DES-CBC3-SHA                  -              112 bits      Timeout on SMTP NOOP               
                 AES128-SHA                    -              128 bits      250 2.0.0 OK                       

  * TLSV1_1 Cipher Suites:
      Preferred:                       
                 ECDHE-RSA-AES256-SHA          ECDH-384 bits  256 bits      250 2.0.0 OK                       
      Accepted:                        
                 ECDHE-RSA-AES256-SHA          ECDH-384 bits  256 bits      Timeout on SMTP NOOP               
                 AES256-SHA                    -              256 bits      Timeout on SMTP NOOP               
                 ECDHE-RSA-AES128-SHA          ECDH-256 bits  128 bits      Timeout on SMTP NOOP               
                 AES128-SHA                    -              128 bits      Timeout on SMTP NOOP               
                 DES-CBC3-SHA                  -              112 bits      Timeout on SMTP NOOP               

  * TLSV1 Cipher Suites:
      Preferred:                       
                 ECDHE-RSA-AES256-SHA          ECDH-384 bits  256 bits      Timeout on SMTP NOOP               
      Accepted:                        
                 AES256-SHA                    -              256 bits      Timeout on SMTP NOOP               
                 ECDHE-RSA-AES128-SHA          ECDH-256 bits  128 bits      Timeout on SMTP NOOP               
                 DES-CBC3-SHA                  -              112 bits      Timeout on SMTP NOOP               
                 ECDHE-RSA-AES256-SHA          ECDH-384 bits  256 bits      250 2.0.0 OK                       
                 AES128-SHA                    -              128 bits      250 2.0.0 OK                       

  * SSLV3 Cipher Suites:
      Server rejected all cipher suites.



Auch in Exchange 2010 SP3 RUP 9 funktioniert TLS 1.1 und 1.2 ;)

Make something i***-proof and they will build a better i***.


#37 bill_mustermann

bill_mustermann

    Senior Member

  • 419 Beiträge

 

Geschrieben 18. März 2015 - 06:51

Hallo,

 

super :) Ich werde das CU8 entweder heute abend oder am Wochenende installieren.

 

Da fällt mir gerade eine Frage ein:

 

Wir haben das Limit für Dateianhänge mühsam in gefühlten tausend Dateien erhöht. Wird das mit dem CU8 wieder überschrieben?

 

gruesse BiLL



#38 tesso

tesso

    Board Veteran

  • 2.233 Beiträge

 

Geschrieben 18. März 2015 - 07:00


Wir haben das Limit für Dateianhänge mühsam in gefühlten tausend Dateien erhöht. Wird das mit dem CU8 wieder überschrieben?

 

Da ja im Prinzip ein neuer Exchange über den alten installiert wird, gehe ich mal davon aus, das die Dateien überschrieben werden.



#39 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 18. März 2015 - 07:00

Ich würde sagen ja

Make something i***-proof and they will build a better i***.


#40 bill_mustermann

bill_mustermann

    Senior Member

  • 419 Beiträge

 

Geschrieben 19. März 2015 - 09:13

Hallo,

 

CU8 ist installiert. Ich kann nun auch bestätigen das TLS1_1 und TLS1_2 funktioniert.

 

Leider habe ich vorher nicht aufmerksam genug gelesen :( Hab einfach das CU8 Setup ausgeführt und vorher NICHT das AD vorbereitet wie hier beschrieben:

 

https://technet.micr...exchg.150).aspx

 

Das ist mir erst nach der Installationn aufgefallen und jetzt habe ich das nachträglich gemacht.

 

Meine Versionsnummer ist nun die

 

15.00.1076.009 nicht 15.00.1076.006

 

Muss ich jetzt die Installation nochmal drüberbüglen? Und wenn ja wie?

 

gruesse BiLL



#41 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 19. März 2015 - 09:45

Wenn du das nicht vorher manuell durchführst, regelt das CU8 das einfach mit. Vorausgesetzt der der das Update durchführt ist auch in der Gruppe der Schemaadmins. Manuell mußt du hinterher nix mehr machen. Dann ist schon alles passiert.

Bye
Norbert

Make something i***-proof and they will build a better i***.


#42 bill_mustermann

bill_mustermann

    Senior Member

  • 419 Beiträge

 

Geschrieben 19. März 2015 - 10:15

Hi,

 

das dachte ich auch, aber nach dier Installation von CU8 hatte ich 15.00.1044.025 im ADSI Editor. Erst nachdem ich jetzt danach das AD prepared habe wie in der Doku habe ich jetzt die richtige Nummer.

 

Ich habe das mit meinem User gemacht welcher Domänen Admin ist und somit auch Schema Admin

 

gruesse


Bearbeitet von bill_mustermann, 19. März 2015 - 10:16.


#43 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 19. März 2015 - 11:38

https://technet.micr...exchg.150).aspx zeigt aber doch, dass Exchange CU7 und CU8 identische Versionsnnummern besitzt. Also hat sich da auch nichts geändert. Oder von welcher Version kamst du?
Und mein AD ohne die manuell durchgeführte Erweiterung zeigt:

rangeUpper
----------
15312 (Entspricht deinem Link nach CU7 _und_ CU8)

Schön, dass auch wieder Unterschiede zwischen deutscher und englischer TAbelle bestehen:
https://technet.micr...exchg.150).aspx
https://technet.micr...exchg.150).aspx

Das was du meinst dürfte die MSExchProductID der Org sein. Die wird in der Tat nur bei manuellem Ausführen von


setup.exe /prepareAd /IAcceptExchangeServerLicenseTerms
aktualisierst. Ich bezweifle aber, dass das einen negativen Effekt haben dürfte:
http://www.get-excha...ad-preparation/

Bye
Norbert

Da ja im Prinzip ein neuer Exchange über den alten installiert wird, gehe ich mal davon aus, das die Dateien überschrieben werden.


Korrekt. Übrigens auch hier erwähnt:
http://blogs.technet...8-released.aspx

Note that customised configuration files are overwritten on installation. Make sure you have any changes fully documented!


Bye
Norbert

Bearbeitet von NorbertFe, 19. März 2015 - 11:37.

Make something i***-proof and they will build a better i***.


#44 bill_mustermann

bill_mustermann

    Senior Member

  • 419 Beiträge

 

Geschrieben 19. März 2015 - 11:48

Hallo,

 

alles klar, dann sollte ja alles OK sein bei mir :)

 

Und wann wird TLS1_1 und 1_2 für IMAP funktionieren? Das tut es nämlich nicht nach CU8. Nur für SMTP funktioniert es.

 

Danke

 

gruesse BiLL


Bearbeitet von bill_mustermann, 19. März 2015 - 11:55.


#45 NorbertFe

NorbertFe

    Expert Member

  • 30.604 Beiträge

 

Geschrieben 19. März 2015 - 12:00

Kann ich dir nicht sagen. Ich kann aber gern mal intern nachfragen. Hast du mit sslyze getestet? Falls ja, dann poste doch mal kurz den Aufruf, dann geht's evtl. schneller. :)

Bye
Norbert

Make something i***-proof and they will build a better i***.