Zum Inhalt wechseln


Foto

2012 R2 RDS - extreme Druckerprobleme


  • Bitte melde dich an um zu Antworten
160 Antworten in diesem Thema

#31 Borninger

Borninger

    Newbie

  • 14 Beiträge

 

Geschrieben 15. Oktober 2014 - 10:06

Hallo,

uns plagen die gleichen, nervigen Druckprobleme......

 

@oburger: Hat der Fix eure Probleme behoben? Der kam mit dem "zweiten" August Rollup, das ist doch richtig,oder?

 

Kann jemand anderes noch etwas dazu sagen, der Kontakt mit dem $upport hatte?

 

Gruß

Marius


Bearbeitet von Borninger, 15. Oktober 2014 - 12:19.


#32 oburger

oburger

    Newbie

  • 13 Beiträge

 

Geschrieben 15. Oktober 2014 - 11:06

Hallo Marius,

 

ja, nach aktuellem Stand und Tests konnte dieser die Druckerprobleme beseitigen.

 

Gruß Oburger



#33 Borninger

Borninger

    Newbie

  • 14 Beiträge

 

Geschrieben 16. Oktober 2014 - 09:23

Hallo,

 

na dann drück ich mal die Daumen, dass es so bleibt ;-)! Bei uns ist das Rollup schon drauf....Probleme bleiben die gleichen :-(....

 

Haben die anderen inzwischen mal weitere Rückmeldung seitens MS bekommen?

 

Habe eben mal wieder einen neuen Drucker als Admin vom Printserver verbunden und anschließend sehe ich überhaupt keine Netzwerkdrucker mehr unter Drucker&Geräte, mit Get-Printer bekomme ich jedoch alle samst angezeigt. gleiches gilt für bsp. Word....... Spooler neustart ohne Lösung.....werd ich mal wieder manuell Hand anlegen müssen.....

 

Das macht echt kein Spass mit 2012R2 RDSH. Da lobe ich mir einen vollgepatchten 2008 R2 RDS!!

Wobei der Kampf bei 2008 ja ein ähnlicher war.

 

Werde dann auch mal bei MS einen Call aufmachen, hilft ja alles nix!

 

In diesem SInne: Frohes Drucken.... :-) :-)

 

Gruß Marius



#34 ITRegina

ITRegina

    Newbie

  • 6 Beiträge

 

Geschrieben 17. Oktober 2014 - 07:34

Hallo,

 

offenbar macht dieses Problem Microsoft seit längerem zu schaffen und es gibt bisher keine greifende und vor allem dauerhafte Lösung.

Beim Kunden muß es natürlich laufen, sonst gibt es irgendwann Ärger, weil bei denen die Kohle nicht mehr kommt und auch für den Admin kein Geld mehr da ist.

Ich habe mir inzwischen damit geholfen, dass ich mich vom ganzen Easyprint- und GPO-debakel losgelöst habe und mit Erfolg Slimprinter einsetze.

Eigentlich sollte man ja erwarten, dass man für von Microsoft versprochene Funktionen nicht noch bei Dritten dazubezahlen muß, aber die nun eingetretene Ruhe in Sachen drucken war es wert!

Bisher konnte ich auch keine Probleme mehr bei Crossplattform-Verbindungen feststellen. Egal ob Server 2003,2008R2 oder 2012 und egal an welchem Client (habe welche noch mit XP, aber auch Win8,Win8 und Win81. zu, Teil X64, sonst X86), es geht 1A!

Vielleicht ist es ja auch für Euch eine Lösung.

 

Gruß IT-Regina



#35 oburger

oburger

    Newbie

  • 13 Beiträge

 

Geschrieben 03. November 2014 - 09:15

Hallo,

 

nochmal ein Feedback zu dem Druckerproblem. Wir haben zwei RDP-Server in Betrieb. Auf beiden ist der Hotfix installiert, einer wird ansonsten mit ursprünglicher Standardkonfiguration ohne Updates betrieben, der Andere wurde mit Updates versorgt. Die Probleme am versorgten RDP-Server gingen sofort wieder los, jedoch in etwas reduziertem Ausmaß. Ich denke das ist auch die Erklärung dafür, warum das Hotfix nach vollem Rollup nichts mehr bringt. Aber auch am Anderen RDP-Server fangen die Probleme so langsam wieder an, heute kam der erste User bei dem der Standarddrucker nicht mehr korrekt gesetzt wurde.

 

Bei euch inzwischen eine Veränderung?

 

Gruß


Bearbeitet von oburger, 03. November 2014 - 09:30.


#36 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 513 Beiträge

 

Geschrieben 03. November 2014 - 15:23

Also ich habe leider aufgegeben. Microsoft konnte nicht Helfen, das Ticket ist erfolglos geschlossen. Problem war das ich nicht mehr länger warten konnte, der Kontakt zu Microsoft war Anfangs noch rege,.. Als aber scheinbar langsam die Ideen ausgingen hat man auch mal ein paar Tage auf Antworten oder neue Anweisungen gewartet und das ging einfach nicht mehr, beim Kunden ist Drucken essentiell wichtig.

Hab nun die drucker lokal installiert, ist echt keine schöne Lösing denn wenn sich was ändert muss ich in der Gesamten Farm jeden RDS selber anfassen aber anders ist es eben scheinbar nicht möglich.

Mich wundert einfach nur das sich da so wenig tut seitens Microsoft, 2012 R2 ist ja nicht mehr ganz neu und die Proböemfälle im Interbet häufen sich.

#37 DerBursche

DerBursche

    Newbie

  • 1 Beiträge

 

Geschrieben 13. November 2014 - 08:24

Hallo Forum,

 

bin neu hier und auch auf der Suche nach einer Lösung zum vorliegenden Problem (bin durch googeln auf den Beitrag gestoßen).

Will das ganze hier nochmal zum leben erwecken.

Scheint wirklich ein Bug in Ts 2012 R2 zu sein.

Habe absolut identische Symptome:

- mehrfach angezeigte Drucker unter Geräte u. Drucker (obwohl Drucker in Anwendungen nur einmal vorhanden sind)

- übern Tag aus der Konfiguration verschwindende Drucker

- bei anmeldung am Remote sich nicht verbindende Drucker

 

War schon im kontakt mit dem Serverkompetenzclub, die das mit den mehrfachen Druckern bestätigen konnten. Mehr habe ich sonst bisher nicht gehört.

 

Derzeit arbeite ich mit Start-/Anmeldeskripten beim Kunden (con2prt), was soweit gut funktioniert (irgendwie bekomme ich es grundsätzlich mit GPO nicht hin, wenn hier jemand ne gute Howto für mich hat, wäre ich dankbar :-) ).

Aber das mit GPO scheint ja auch nicht recht zu funktionieren.

 

Als Workaround, bis MS hier ne Lösung hat (falls es nicht bereits eine gibt, dann möge man mir diese bitte mitteilen), habe ich bei den Usern (scheint bei mir irgendwie nur einzelne zu betreffen, die unterm Tag die Drucker verlieren) am Desktop ne Verknüpfung zu der entsprechenden User-Batch unter Netlogon am AD-Server angelegt. Wenn man diese ausführt, sind die Drucker anschließend wieder vorhanden. Als alternative habe ich an allen Desktops noch eine Verknüpfung zur sauberen Abmeldung am TS angelegt (ist ja recht toll gemacht bei 2012 R2 u. 8.1 mit herunterfahren, abmelden etc.). Nach erneuter wiederanmeldung sind die Drcuker (zu 90%) auch wieder sauber verbunden.

Der Anzeigefahler unter Geräte u. Drucker besteht trotzdem.

Dieser Workaround behebt erstmal die Symptome, aber nicht das Problem.

 

Meine Vermutung ist, dass es hier Probleme gibt, wenn man einen extra Printserver verwendet (bei uns Server7; alles VM's) und vom Terminalserver aus (z.B. Server 4 oder 6) auf die freigegebenen Drucker zugreift, also diese je User entspr. zuweist u. verwendet.

Sollte jemand die Möglichkeit einer Testumgebung haben, wäre es interessant zu wissen, was passiert, wenn man die Drucker je Terminalserver direkt unter Geräte und Drucker hinzufügt und nicht vom Terminal aus der Drucker vom Printserver verbindet.

 

Sollte es bereits andere Lösungen geben, wäre es gu, diese hier zu erfahren.

 

Danke.

 

Gruß

 

DerBursche



#38 Borninger

Borninger

    Newbie

  • 14 Beiträge

 

Geschrieben 18. November 2014 - 20:34

Hallo zusammen,

 

ich bin ja fast schon etwas beruhigt, dass sich hier immer mehr Leute mit den Problemen melden! Ich habe mich dann doch gegen einen Support Case bei MS entschieden und wir haben auf einer RDS Farm mit 3 RDS Hosts alle Drucker heute lokal installiert.

Morgen werden wir sehen, wie sich das ganze verhält!

Es ist auf jeden Fall sicher, dass das ganze bei Druckern auftritt, die über einen Printserver verbunden sind. Wir haben hier lange getestet und wirklich die mysteriösesten Phänomene festgestellt.

 

Das wird wieder ein paar Monate so gehen, bis MS genug Infos dazu hat um was zu basteln......

 

Gruß Marius



#39 Thanquol

Thanquol

    Senior Member

  • 471 Beiträge

 

Geschrieben 19. November 2014 - 17:24

Was mir spontan beim durchlesen der Probleme hier einfällt, ist dieser KB Artikel: http://support.micro....com/kb/2871131

Vielleicht ist das ja ein Wink in die richtige Richtung?

 

Gruß

Florian


I'm a freak, and I love it!!! :D :D :D
MCP: 72-270,72-290

#40 twenty

twenty

    Senior Member

  • 410 Beiträge

 

Geschrieben 03. Dezember 2014 - 07:50

Hallo!

 

Auch bei mir tauchen die oben genannten Symptome auf. Der KB2871131 hat bei mir nicht geholfen. Dieses Update wurde beim Installationsversuch vom System abgelehnt. Auf den Remote Desktop Session Hosts, wurden alle Updates und Hotfixes (KB2887595-v2) installiert. Diese bringen leider keine Besserung.

 

Bei mir ist der Registry Pfad, wie in diesem KB Artikel beschrieben "HKEY_Users\.DEFAULT\Printers\DevModes2", leer.

 

Gibt es in der Zwischenzeit neue Erkenntnisse?

 

Gruß Twenty



#41 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 513 Beiträge

 

Geschrieben 03. Dezember 2014 - 08:48

Hallo,

Kurzer Zwischenstand. Da Microsoft in unseren Support Case die Probleme nicht lösen konnte, habe ich mich beim Kunden entschieden die Drucker lokal zu installieren auf den 3 RDS Host.

Auch wenn das keine schöne Lösung ist, dafür habe ich endlich Ruhe! Keine 20 Anrufe am Tab mehr das ein Drucker nicht da ist oder ein Drucker einfach nicht Druckt.

Also ein wenig erschreckend finde ich das schon das sich in der Richtung immernoch nichts getan hat.

#42 twenty

twenty

    Senior Member

  • 410 Beiträge

 

Geschrieben 03. Dezember 2014 - 08:58

Danke für die Rückmeldung. Dann kann ich mir einen weiteren MS Case ersparen.

 

Gruß Wolfgang



#43 sheeva

sheeva

    Newbie

  • 64 Beiträge

 

Geschrieben 08. Januar 2015 - 10:50

ich habe leider ähnliche probleme

 

wir wollten von ts 2003 (printserver 2008) auf ts 2012r2 (printserver 2012r2) migrieren.

unter 2003 hat alles relativ problemlos funktioniert - unter 2012r2 häufen sich nun die probleme mit den druckern.

  • mehrfache anzeige der drucker in der systemsteuerung
  • standarddrucker-häckchen verschwindet willkürlich
  • drucken aus ms word oder anderen anwendungen (adobe reader z.B.) nicht möglich

 

Unter Systemsteuerung>Geräte und Drucker wird ein Wirrwarr an Druckern aufgelistet. Doppelte Einträge, manchmal der Drucker in Großbuchstaben u. manchmal nicht, "Geist-Drucker" vom alten Printserver, etc.

Die meisten Ghost-Drucker kann ich dann per Hand löschen, bei anderen hingegen klappt das nicht mit der Meldung "unzureichend Rechte" (trotz Admin Konto).

 

Unter der alten klassischen Druckeransicht (aufrufbar über den Pfad C:\Windows\explorer.exe /e,::{2227A280-3AEA-1069-A2DE-08002B30309D}) sieht hingegen alles i.O. aus. Keine doppelten Einträge oder ähnliches, aber die o.g. Probleme bestehen leider trotzdem.

 

ich habe so ziemlich alles ausprobiert was hier im thread und auch sonst unter google zu finden ist. wenn ich die RDS-Hosts komplett von allen Druckern bereinige (treiber löschen, registry-pfade ausmisten, etc.), dann funktioniert es auch wieder eine zeit lang. aber die probleme kommen früher oder später trotzdem wieder.

 

Folgende Aktionen konnte die Probleme wenigstens für ein paar Tage eindämmen: http://digitalzombie...012/#resolution

 

ich kann die o.g. probleme auch nciht gezielt reproduzieren; die treten komplett willkürlich bei unterschiedlichsten benutzern auf.

 

auch habe ich die einbindung der drucker sowohl über GPP, GPO u. logon-scripts versucht - leider alles ohne erfolg.

 

spiele nun auch mit dem gedanken die drucker lokal auf den RDS-Hosts zu installieren :/


Bearbeitet von sheeva, 08. Januar 2015 - 12:03.

something to pondor:
the early bird gets the worm,
but the second mouse gets the cheese!

Status:MCP, MCTS, MCTIP, MCSA-M, MS Small Business Specialist

#44 twenty

twenty

    Senior Member

  • 410 Beiträge

 

Geschrieben 08. Januar 2015 - 11:22

Hallo!

 

Wir haben zu dem Problem einen Case bei MS eröffnet. Sobald es etwas zu berichten gibt, melde ich mich.

 

Gruß Twenty



#45 Dominik Weber

Dominik Weber

    Member

  • 299 Beiträge

 

Geschrieben 08. Januar 2015 - 13:45

Ich hatte auch solche Probleme ... da der Kunde nur einen RDS Host hat und 3 Drucker, habe ich die Drucker nun lokal am RDS Host installiert. Nun klappt es