Zum Inhalt wechseln


Foto

2012 R2 RDS - extreme Druckerprobleme


  • Bitte melde dich an um zu Antworten
160 Antworten in diesem Thema

#1 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 521 Beiträge

 

Geschrieben 16. August 2014 - 07:46

Hallo Leute,

 

ich komme echt nicht mehr zurecht, habe mich auch schon im TechNet in einen Thread mit angehängt (Links unten) und das scheinen echt Bugs zu sein, aber bei mir hilft leider auch kein Workaround und der Kunde bringt mich bald um.

 

Erstmal Grundlegend der Aufbau:

  • 1 RDS Connection Broker mit Lizenz Server (separater Server) -> 2012 R2
  • 3 RDS Session Host´s in einer Farm, in der RDS Sammlung wird User Profile Disk verwendet -> 2012 R2
  • 1 Printserver mit ca. 15 freigegebenen Druckern , Drucker werden über GPO´s gemappt-> 2012 R2

 

Folgendes Problem:

  • Drucker werden teilweise 4 oder 5 fach angezeigt (aber nur unter Systemsteuerung -> Geräte und Drucker, in Applikationen dagegen werden Sie nur 1 fach angezeigt)
  • ODER Drucker werden nur einfach angezeigt aber dafür ist ein Setzen des Standartdruckers bei manchen Druckern nicht möglich. Beispiel Drucker A ist aktuell Standard, ich will Drucker B als Standard -> Rechtsklick auf Drucker B -> Als Standard setzen -> dann gibt es quasi keinen Standartdrucker mehr, kein Drucker hat ein grünen Hacken -> Setze ich Drucker A wieder als Standard wird dort der Hacken wieder angezeigt. Man könnte meinen das wäre nur ein Anzeigefehler, dem ist aber nicht so. Denn wenn dieses Problem auftaucht kann ich zwar von Microsoft Applikationen meist auf diesen Drucker drucken, aus den meisten anderen Programmen jedoch nicht (z.b. Adobe Reader, Branchensoftware Protel, usw, das scheint davon Abzuhängen wie die Programme auf die Drucker zugreifen) Ein Drucken auf Druckern die sich als Standartdrucker setzen lassen (also mit dem grünen Hacken) ist aus den genannten Applikationen möglich.

 

Beide Probleme treten bei ALLEN 3 RDS Servern bei ALLEN User vollkommen WILLKÜRLICH auf. Wenn Problem 1 auftritt, kann ich die Drucker manuell löschen in der Systemsteuerung, diese tauchen beim Löschen aber teilweise automatisch dann in doppelter Anzahl wieder auf. Beispiel Drucker mit dem Namen Drucker A will ich löschen, in dem Moment des Löschens wird er automatisch wieder gemappt aber dafür dann gleich 2x. Dieses Problem tritt aber auch nicht immer auf, manchmal lassen sich die Drucker löschen.

 

Wenn die User Drucker Probleme haben gibt es folgende Lösungsmöglichkeiten:

 

  • Wenn Drucker nur 1 fach vorhanden sind, dann reicht ein gpupdate /force. In der GPP  ist eingestellt das erst alle verbundenen Drucker gelöscht werden und dann neuverbunden werden. So werden alle Drucker gelöscht und neuverbunden ist MEIßT ist dann ein Drucken möglich, jedoch auch nicht immer.
  • Wenn die Drucker mehrfach vorhanden sind funktioniert ein gpupdate /force nicht, dann werden die Drucker nicht gelöscht sondern „optisch“ passiert gar nichts. Dann hilft nur ein manuell Löschen und mit gpupdate neu verbinden.

 

Was ich alles versucht habe:

Ursprünglich habe ich die Drucker über den Printserver -> Mit Gruppenrichtlinie Bereitstellen auf Computerbasis verbunden (da alle User auf die ca. 15 Drucker Zugriff haben müssen). Das hatte soweit funktioniert, jedoch wurde das Problem dann mit den teilweise sogar 5 oder 6 fach Verbundenen Druckern immer schlimmer und es war auch kein Drucken aus oben genannten Applikationen möglich (wenn Drucker mehrfach vorhanden).

 

Nach vielen googlen musste ich feststellen das viele Leute genau diese Probleme haben, woraus ich mal schließe das das definitiv Bugs in Windows Server 2012 R2 sind (letztendlich kann man da ja auch nicht viel falsch machen, ein paar Beispiel Links zu Foren die dieses Problem behandeln weiter unten).

 

  • In diesen Foren konnten die Probleme eingedämmt werden, in dem auf dem Druckserver bei allen Druckern in der Freigabe der Hacken „Druckauftragsaufbereitung auf Clientcomputern durchführen“ ENTFERNT wurde. Dies habe ich bei allen Druckern dann auch gemacht und das mehrfach Verbunden war nicht mehr ganz so oft, aber weiterhin vorhanden.
  • Außerdem sollte laut den Foren darauf geachtet werden das nur der Druckprozessor Winprint vorhanden und genutzt ist. Dies war bei mir nicht relevant da die Druckertreiber keinen anderen Druckprozessor „mit installiert“ haben
  • Des weiteren sollten die RDS Server komplett von den Druckern bereinigt werden nachdem der Hacken von 1. Entfernt wurde. Dies sollte über die Registry erfolgen in dem man unter

HKLM\Software\Microsoft\Windows NT\Current Version\Print\Providers\Client Side Rendering Print Providers komplett alle Zweige darunter löscht. Interessanter weise steht unter Servers dort auch der Printserver meißt doppelt drin, einmal mit dem normalen DNS Namen, einmal mit den FQDN Namen (eventuell kommt daher der Fehler mit den doppelten und dreifachen Druckern.)

 

  • Diese Punkte habe ich alle ausgeführt und die Server neugestartet. Meißt hält der Zustand des funktionierens dann auch 1 – 2 Tage an bis alle Probleme von vorne wieder los gehen.

 

Danach habe ich die Richtlinie gelöscht, welche die Drucker auf Computer Basis verteilt und eine neue Richtlinie erstellt, die die Drucker auf Userbasis erst ALLE löscht und dann neuverbindet. Ich hatte mir erhofft damit das Problem weiter einzudämmen, aber auch das hat nicht funktioniert. Die Probleme sind weiterhin alltäglich bei verschiedenen User und verschiedenen Druckern.

 

Auch ist das Problem mit verschiedenen Treiber aufgetreten. Mit XPS Treibern die bei der Installation des Druckers auf dem Printserver automatisch „vorgeschlagen“ werden tritt das Problem identisch auf wie mit Treibern des Herstellers (Triumph Adler). An den treibern liegt es meiner Meinung nach aber definitiv nicht, da in Foren die all diese Probleme haben immer völlig unterschiedliche Drucker zum Einsatz kommen (HP, etc.).

 

Außerdem habe ich den Printserver SOWIE die RDS Server komplett von Treibern befreit mit „printui /s“ und die RDS Server so komplett bereinigt,  sodass sich die Treiber wirklich 100% neu vom Printserver gezogen werden, auch das funktioniert nicht.

 

Ich bin wirklich ratlos und habe auf das Windows 8.1 / 2012 R2 Update „2“ vom 12.08. gehofft, aber auch das hat keine Lösung gebracht.

 

Anbei ein paar Links die alle genau das identische Problem haben:

 

http://social.technet.microsoft.com/Forums/de-DE/3c90880d-523b-4f3b-9915-360f1f4eb9ae/terminalserver-2012r2-icon-des-standarddrucker-verschwindet?forum=windowsserver8de&prof=required

 

https://forums.adobe.com/thread/1344069

 

http://social.technet.microsoft.com/Forums/en-US/71d06204-3735-4473-8bc9-20be9e19090e/problem-with-multiple-instances-of-shared-printers-being-installed-on-client-computers-when-the?forum=winserverprint

 

http://digitalzombies.com/2014/07/03/print_issues_rds_2012/

 

 

Alle haben exakt das gleiche Problem, oder Probleme die darauf aufbauen (Adobe ist kein Drucken möglich etc.) oder behandeln Workarounds die teilweise die Probleme eindämmen aber, zumindest bei mir, definitiv nicht lösen.

 

PS: Die RDS Hosts wurden auch schon komplett neuinstalliert, auch ohne Erfolg.

 

Ich wäre euch super super dankbar wenn Ihr mir helfen könntet. Im ersten TechNet Link habe ich mich mit "eingehackt".



#2 Sunny61

Sunny61

    Expert Member

  • 22.231 Beiträge

 

Geschrieben 16. August 2014 - 09:46

Ich habe jetzt nur den ersten Thread gelesen in dem Du dich eingeha*k*t hast, aber ich vermisse ganz deutlich den Hinweis auf einen Supportcall bei MSFT. Wenn sich so viele einig sind, dass es ein Bug ist, kannst Du oder jemand anderer ja auch einen Call eröffnen.

Hast Du den Tipp aus diesem Thread denn ausprobiert? http://social.techne...rum=winserverTS

BTW: Es heißt Standar*d* und Ha*k*en! Danke.

Bearbeitet von Sunny61, 16. August 2014 - 09:46.

Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#3 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 521 Beiträge

 

Geschrieben 16. August 2014 - 09:52

Supportcall will ich Montag aufmachen, ich hatte bisher gehofft das diese Probleme eventuell durch "Update 2" gelöst werden, was ja nun nicht der Fall ist.

 

Den Thread kenne ich auch schon, hilft leider aber nicht wirklich. Trotzdem Danke



#4 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 521 Beiträge

 

Geschrieben 17. August 2014 - 08:30

Update: Mittlerweile ist es so, das die User immer wieder Ihren Standartdrucker verlieren, warum auch immer.

 

Nach googeln konnte ich das finden:

http://social.techne...rum=winserverTS

 

Der Kollege dort hatte sogar einen Call bei Microsoft der nicht weiter geholfen hat :schreck:  :thumb2:



#5 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 521 Beiträge

 

Geschrieben 25. August 2014 - 09:33

Zur Info: eben Ticket bei Microsoft geöffnet, ich gebe Rückmeldung dazu

#6 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 521 Beiträge

 

Geschrieben 02. September 2014 - 07:16

Kurzer Zwischenstand, Problem befindet sich bei Microsoft immernoch in Bearbeitung, habe einige Diagnosetools ausgeführt, viel Email und Telefonverkehr und auch Fernwartungen.

Bisher leider noch keine Lösung in Sicht, halt euch auf den laufenden.

#7 rattenkoenig

rattenkoenig

    Newbie

  • 29 Beiträge

 

Geschrieben 02. September 2014 - 13:23

Hallo Leuchtkondom

 

Ich habe exakt die gleichen Probleme wie du in mehreren 2012 R2 RDS Umgebungen.

Gut dass du uns informiert hälst.

 

Gruss



#8 oburger

oburger

    Newbie

  • 13 Beiträge

 

Geschrieben 08. September 2014 - 12:34

Ebenfalls exakt das gleiche Problem. Bitte um Benachrichtigung wenn eine Lösung besteht.

 

Liebe Grüße



#9 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 521 Beiträge

 

Geschrieben 09. September 2014 - 06:45

Kurze Rückmeldung, Ticket ist immernoch offen und ich arbeite regelmäßig meine "Action-Pläne" ab, die ich durch Microsoft erhalte. Lösung bisher leider noch nicht in Sicht.

#10 oburger

oburger

    Newbie

  • 13 Beiträge

 

Geschrieben 09. September 2014 - 11:36

Wir werden auch mal ein Ticket aufmachen.



#11 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 521 Beiträge

 

Geschrieben 09. September 2014 - 12:02

Das schlimmste daran ist das da gefühlt jeden Tag etwas neues ist, man kann es eigentlich gar nicht richtig erklären was alles nicht geht und Probleme macht, richtig schlimm leider :-(

#12 rattenkoenig

rattenkoenig

    Newbie

  • 29 Beiträge

 

Geschrieben 09. September 2014 - 12:27

Hallo Leuchtkondom

 

kannst du deine Action Pläne mal erläutern?

Ich bringe einen mindestens dreifach vorhanden Drucker einfach nicht wieder weg.

 

Danke und Gruss



#13 Leuchtkondom

Leuchtkondom

    Board Veteran

  • 521 Beiträge

 

Geschrieben 12. September 2014 - 14:50

Gibt es was neues bei euch oburger?

 

Also ich musste manuell Registry Keys setzen, Keys löschen usw. Es hatte erst den Anschein es würde besser gehen, aber jetzt fängt der Spaß wieder von Vorne an.

 

Seit den Registry Keys werden die Drucker zwar nicht mehr 3 fach angezeigt, der Hacken des Standartdruckers wird aber nicht angezeigt.

Und sobald dieser Zustand erreicht ist, ist auch kein Druck mehr möglich aus nicht Microsoft Anwendungen...

 

so langsam habe ich echt die Schn**** voll, und der Kunde ist auf Drucken angewiesen (ja wer ist das nicht, aber das ist ein Hotel die bei jeden Checkout normalerweise Drucken müssten) und es ist weiterhin keine Lösung in Sicht



#14 oburger

oburger

    Newbie

  • 13 Beiträge

 

Geschrieben 12. September 2014 - 15:21

Hey,

 

Support hat sich heute gemeldet. Werde am Wochenende mal die Punkte durchführen.

 

Dass kein Druck mehr aus nicht Microsoft proprietär Anwendungen mehr möglich ist hört sich eher nach einer Verschlechterung an. Das macht mich unruhig. Wir haben 35 Leute, welche viel drucken, weil wir Papierakten handhaben. Keine Druckmöglichkeit ist der Supergau.

 

Der Supporter meinte, dass Microsoft einige Tickets offen hat und irgendwann ein Fix kommen wird, nur wann kann er nicht sagen.

 

Am Montag meldet er sich wieder um weitere Schritte durchzugehen.

 

Gruß Oburger



#15 GuentherH

GuentherH

    Super Moderator

  • 19.433 Beiträge

 

Geschrieben 12. September 2014 - 16:09

Hi.

 

Ich hatte ebenfalls das Problem bei einigen Kunden. Es trat immer im Zusammenhang mit Windows 8, Windows 8.1 und der Installation der Drucker über Gruppenrichtlinien auf.

 

Die Lösung aus diesem Link - http://social.technet.microsoft.com/Forums/en-US/71d06204-3735-4473-8bc9-20be9e19090e/problem-with-multiple-instances-of-shared-printers-being-installed-on-client-computers-when-the?forum=winserverprint und Umstellung der Druckerinstallation über Script hat in allen Fällen geholfen.

 

 

LG Günther