Zum Inhalt wechseln


Foto

SCCM - Nach Upgrade alle Updates expired


  • Bitte melde dich an um zu Antworten
11 Antworten in diesem Thema

#1 srkonus

srkonus

    Senior Member

  • 398 Beiträge

 

Geschrieben 01. Juli 2014 - 07:21

Hallo zusammen,

 

ich habe ein merkwürdiges Problem:

 

Nach einem mehr oder weniger erfolgreichem Upgrade von SCCM 2012 auf 2012R2 habe ich das Betriebssystem (Server 2012 auf 2012R2) hochgehoben. Dies habe ich nicht mit dem User gemacht, der die WSUS Rolle installiert hat.

Danach meinte der SCCM, das der WSUS nicht mehr konfiguriert sei. Ich habe dann die Rolle mit meinem Admin-Account neu installiert, bekam aber keine Verbindung zur Datenbank.

Zum Test habe ich den WSUS mit einer lokalen Datenbank installiert und schon syncronisierte sich der SCCM wieder. Also habe ich die WSUS Rolle entfernt und mit dem ursprünglichem Benutzer und der SQL Datenbank eingerichtet. Der Status ist jetzt auch grün und er syncronisiert sich.

Allerdings sind fast alle Updates als Expired gekennzeichnet. Auch das die aktuellen Endpoint Pattern runtergeladen wurden, sieht man nicht. Es macht den Anschein, das das was ich sehe nicht mehr der aktuelle Stand ist.

Nun sind bei mir ein paar Fragen entstanden:

 

- Was kann ich machen, das ich den aktuellen Stand sehe?

- Wie finde ich heraus, welche WSUS Datenbank verwendet wird?

- Wie kann ich angebliche expired Updates wieder aktiv schalten?

 

Es gibt VMware Snapshots kurz vor dem kompletten Upgrade, kann man ohne Probleme dorthin zurück und das Upgrade neu machen?

 

Ich bedanke mich erst einmal für konstruktive Beiträge,

 

 

mfg

 

srkonus

 

 

 

Nachtrag:

 

Wenn ich die ADR (AutoAutomatic Deployment Rule) für die Endpoint Pattern manuell ausführe, läuft diese auch durch und falls vorhanden, werden Pattern runtergeladen und deployed. In der Übersicht der Software Update Groups ändert sich allerdings nix an der Endpoint Gruppe.

Vielleicht ist dies noch ein Hinweis.

 

Nachtrag 2:

Ich versuche gerade die WSUS Rolle neu zu installieren, und kann mich nicht mir der SQL Datenbank/Instanz verbinden - error 26.


Bearbeitet von srkonus, 01. Juli 2014 - 10:06.


#2 Sunny61

Sunny61

    Expert Member

  • 22.173 Beiträge

 

Geschrieben 01. Juli 2014 - 12:57

Wenn Du von 'hochheben' von 2012 auf 2012R2 sprichst, meinst Du damit ein sog. Inplace Upgrade? Wenn ja, da muss man *vorher* den WSUS deinstallieren, und anschließend wieder installieren.

Im allgemeinen halte ich von sog. Inplace Upgrades nichts, es gibt genügend Fehler die erst später kommen.

Die verwendete WSUS-Datenbank ist die SUSDB. Du kannst dich mit einem LOKAL installierten aktuellen SQL Server Management Studio 2014 an der WSUS Datenbank anmelden. Siehe diesen Artikel: http://www.mssccmfaq...agement-studio/
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#3 srkonus

srkonus

    Senior Member

  • 398 Beiträge

 

Geschrieben 01. Juli 2014 - 13:22

Hallo sunny61,

 

ja, ich habe ein Inplace Upgrade durchgeführt. Die Anleitungen die ich gefunden hatte, sagten nix davon, das der WSUS vorher deinstalliert werden muss/sollte (schließe aber nicht aus, das ich die falschen Anleitungen hatte :suspect:  ). Deswegen habe ich dies auch nicht gemacht - Ergebnis sieht man jetzt.

Jetzt ist der WSUS ja neu installiert, die Konsole zeigt aber keine updates der Software Update Gruppen. Muss man den SUP jetzt neu installieren? Die Logs zeigen an, das er im Hintergrund syncronisiert und auch verteilt.

Die Registry zeigt mir auch, das er die SUSDB auf dem SQL-Server nutzt.

Was geschieht mit der SUP Konfiguration, muss die erneut getätigt werden?

Ich habe beides (SCCM und OS) von Version 2012 auf Version 2012 R2 "upgegraded".

 

 

mfg

 

srkonus



#4 Sunny61

Sunny61

    Expert Member

  • 22.173 Beiträge

 

Geschrieben 01. Juli 2014 - 16:39

ja, ich habe ein Inplace Upgrade durchgeführt. Die Anleitungen die ich gefunden hatte, sagten nix davon, das der WSUS vorher deinstalliert werden muss/sollte (schließe aber nicht aus, das ich die falschen Anleitungen hatte :suspect:  ). Deswegen habe ich dies auch nicht gemacht - Ergebnis sieht man jetzt.


Jepp, ein Grund mehr es nicht zu machen, das upgraden.

Jetzt ist der WSUS ja neu installiert, die Konsole zeigt aber keine updates der Software Update Gruppen. Muss man den SUP jetzt neu installieren? Die Logs zeigen an, das er im Hintergrund syncronisiert und auch verteilt.
Die Registry zeigt mir auch, das er die SUSDB auf dem SQL-Server nutzt.
Was geschieht mit der SUP Konfiguration, muss die erneut getätigt werden?
Ich habe beides (SCCM und OS) von Version 2012 auf Version 2012 R2 "upgegraded".


Ich kenn den SCCM nicht, aber wäre es nicht einfacher gewesen beides auf dem neuen OS einfach zu installieren?
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#5 srkonus

srkonus

    Senior Member

  • 398 Beiträge

 

Geschrieben 02. Juli 2014 - 06:27

Ob es einfacher gewesen wäre...tja...im derzeitigen Zustand ja. Hätte alles funktioniert, dann wäre eine komplette Neuinstallation mehr Arbeit gewesen. Das hilft mir aber jetzt nicht wirklich bei dem Problem.



#6 Sunny61

Sunny61

    Expert Member

  • 22.173 Beiträge

 

Geschrieben 02. Juli 2014 - 11:23

Das hilft mir aber jetzt nicht wirklich bei dem Problem.


Evtl. kommt Torsten ja noch vorbei, ansonsten würde ich alles komplett neu machen. Alternativ wieder auf den vorherigen Stand zurück gehen.
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#7 srkonus

srkonus

    Senior Member

  • 398 Beiträge

 

Geschrieben 02. Juli 2014 - 11:50

Torsten???

 

Auf den Snapshot zurück habe ich auch schon überlegt. Im Moment glaube ich folgende Alternativen zu haben:

 

- SUP neu installieren

- Irgendwie das fixen (vielleicht eine Berechtigungssache)

- Server komplett neu aufsetzen

- Auf den Snapshot zurück und dann mal schauen (keine Ahnung ob das wirklich eine Alternative ist)



#8 Sunny61

Sunny61

    Expert Member

  • 22.173 Beiträge

 

Geschrieben 02. Juli 2014 - 13:15

Torsten???


TorstenM ist ein User hier im Forum, MVP für den SCCM.
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#9 RHaneberg

RHaneberg

    MCSEboard.de Partner

  • 48 Beiträge

 

Geschrieben 02. Juli 2014 - 14:27

HI,

 

bei der Installation des SUP konfiguriert SCCM den WSUS. Wenn der WSUS jetzt manuell neu installiert wurde ist diese Konfiguration wohl hinüber.

Die SUP Rolle neu zu machen sollte also eigentlich funktionieren (bevor alles neu gemacht wird eh eine alternative ;) )



#10 TorstenM

TorstenM

    Senior Member

  • 459 Beiträge

 

Geschrieben 02. Juli 2014 - 19:37

Sie haben geläutet? ;-)
Die Frage kommt mir bekannt vor (TechNet Forum). Ich blicke bei den ganzen Aktionen nicht ganz durch, was bisher genau gemacht worden ist oder nicht. Das Problem an der Sache ist, dass ja einerseits die Updates in der WSUS-Datenbank stehen und ebenfalls noch in der ConfigMgr-Datenbank. Entsprechend habe ich dort auch schon eine Antwort gepostet - aber bisher ohne Feedback.


MCSA 2000/2003/2012, MCSE NT 4.0/2000/2003/2012, MCITP:EA, MCTS SCCM, Microsoft MVP - SCCM, http://www.mssccmfaq.de


#11 Sunny61

Sunny61

    Expert Member

  • 22.173 Beiträge

 

Geschrieben 02. Juli 2014 - 22:17

Sie haben geläutet? ;-)


Geht doch! :)

Die Frage kommt mir bekannt vor (TechNet Forum).



Mist, schon wieder ein Crossposting. :(
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#12 srkonus

srkonus

    Senior Member

  • 398 Beiträge

 

Geschrieben 03. Juli 2014 - 07:21

Hallo,

 

danke für die Antworten. 

Im wsyncmgr.log sehe ich, das Updates die Pattern diese Nacht runtergeladen und das Paket verteilt wurde. Auch sehe ich z.B ganz ganz viele Updates als superseded - die wurden im Log als "skipped" markiert.

Zur Zeit überlege ich, ob es nicht einfacher ist, einmal die SUP Rolle zu entfernen und neu einzurichten. Dann sollte ja alles neu konfiguriert sein.

 

Was ich gemacht habe:

 

W2k12 Server aufgesetzt, SCCM 2012 (als SccmUser - Anleitung siehe hier: http://www.windows-n...1-installation/) installiert, knapp ein Jahr lang glücklich gewesen.

 

Letzte Woche SCCM Upgrade durchgeführt (mit meinem Admin User) - alles sah noch gut aus. Danach W2k12R2 Upgrade durchgeführt (wieder mit meinem Admin User), danach fingen die Probleme an.

Die WSUS Konfig war wohl dahin, der SUP hat den WSUS nicht mehr erkannt. Was ich danach gemacht habe:

 

1. WSUS neu installiert (mit meinem Admin User) - keine Besserung in der SCCM Konsole

2. WSUS mit lokaler WID installiert (mit meinem Admin User) - keine Besserung in der SCCM Konsole - er syncronisiert sich aber

3. WSUS neu installiert (als SccmUser) - keine Besserung in der SCCM Konsole - er syncronisiert aber

4. Owner der SUSDB auf dem SQL Server von meinem Admin User auf SA geändert - keine Besserung in der SCCM Konsole - er syncronisiert aber

 

Da der WSUS/SCCM ja irgendwie synchronisiert und auch die Endpoint Pattern runterlädt und verteilt, scheint ja einiges noch zu gehen. Im Moment sieht es für mich so aus, als ob eine Neuinstallation des SUP reichen könnte. Im schlimmsten Fall muss man die Updates neu konfigurieren. 


Bearbeitet von srkonus, 03. Juli 2014 - 08:31.