Zum Inhalt wechseln


Foto

Windows 8.1 Inplace Upgrade und RAID Treiber


  • Bitte melde dich an um zu Antworten
4 Antworten in diesem Thema

#1 jensw_2000

jensw_2000

    Newbie

  • 45 Beiträge

 

Geschrieben 05. November 2013 - 18:10

Moin,

das Windows 8.1 Inplace Upgrade macht mich fertig.

 

Ich starte unter Windows 7 das 8.1er Setup und wähle die Option "nur persönliche Daten behalten" und lasse das Setup nach Updates suchen. Das Setup läuft dann ohne Warnungen bis 100% hoch und bootet den PC.

 

Nach dem Neustart läuft der Rechner in das Windows Setup. Dort gibt es nach der Sprachauswahl gibt es nur die beiden Optionen "Problembehandlung" und "PC herunterfahren".

 

Das Einzige das mir zum Installieren des Updates noch gerade so plausibel erscheint ist der Weg "Problembehandlung >> PC auffrischen".

 

Das Setup bricht dort aber mit folgender Meldung ab:

 

Das Laufwerk, auf dem Windows installiert ist, ist gesperrt. Entsperren Sie das Laufwerk, und versuchen Sie es erneut.

 

Ich habe dann tagelang die Bitlocker Verschlüsselung von allen meinen Laufwerken entfernt, die versteckte Startpartition auf 1 GB vergrößert, sichergestellt, dass es nur eine aktive Partition im System gibt, mein Windows 7 mit SFC /scannow überprüft, MSXML 6 neu installiert und bin jedem verdächtigen Log-Eintrag hinterhergegooglet.

 

Nichts... Windows 8.1 Setup meint ich soll mein Laufwerk entsperren und es neu versuchen.

 

In der Commandline, die man aus dem 8.1er Setup aufrufen kann habe ich nun festgestellt, dass der RAID Treiber meines Areca 1231 offensichtlich nicht geladen wurde. 

Der unter Windows 7 (x64) installierte Treiber ist signiert und aktuell.

 

Diskpart > LIST DISK zeigt mir meine Windows 7 HDD (die an dem RAID Controller hängt) nicht an.

 

BootRec /ScanOs läuft durch und findet keine Windows Installationen.

 

Dummerweise finde ich im Windows 8.1 Setup keine Möglichkeit den RAID Controller Treiber nachzuladen.

 

Boote ich den PC danach wieder, dann läuft das Rollback zum Glück sauber durch und mein Windows 7 ist wieder heile.

 

Unter Windows 7 habe ich alle Laufwerke mit DISKPART > "ATT DIS" überprüft. Es gibt keine Laufwerke die "aktuell schreibgeschützt" oder "schreibgeschützt" sind.

Chkdsk bringt ebenfalls keine Fehler.

 

Kann mir jemand helfen oder muss ich den MS Support hinzuziehen?

Wäre schade dafür einen Technet Freecall zu opfern, nur weil dieses 8.1er Setup derart missglückt ist ...


Bearbeitet von jensw_2000, 05. November 2013 - 19:03.

Schöne Grüße aus Ahrensburg ;)

#2 Daniel -MSFT-

Daniel -MSFT-

    Expert Member

  • 2.434 Beiträge

 

Geschrieben 04. Dezember 2013 - 20:23

Hallo Jens,

 

Du müßtest das Windows 8.1 komplett herunterladen und dann den RAID-Treiber offline in die Installatonsquelle integrieren: Hinzufügen und Entfernen von Treibern (offline). Die notwendigen Tools bekommst Du aus dem Windows ADK.

 

Have fun!
Daniel


.: Daniel Melanchthon :.

 

Ich arbeite für die Microsoft Deutschland GmbH.

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität.

 

Hinweis zur Rechtsverbindlichkeit dieser Informationen

Diese Informationen sind Hinweise, die das Verständnis hinsichtlich der Microsoft Produktlizenzierung verbessern sollen. Microsoft weist ausdrücklich darauf hin, dass diese Informationen keinen rechtsverbindlichen Charakter haben, sondern als erklärende Informationen zu verstehen sind. Die einzig rechtsverbindlichen Lizenzinformationen sind in den entsprechenden Endnutzer-Lizenzverträgen (als Beilage zu Softwarepaketen oder in Form von Lizenzverträgen) zu finden.


#3 jensw_2000

jensw_2000

    Newbie

  • 45 Beiträge

 

Geschrieben 15. Dezember 2013 - 21:47

Hallo Daniel,

 

ich habe mir jetzt einen USB Installationsstick erstellt und auf einem Windows 8.1 Referenz-PC den RAID Treiber per "DISM /Add-Driver .." in die WIM's auf dem USB Installationsmedium integriert.

Das hat soweit geklappt.

 

Wenn ich von USB boote und Diskpart aufrufe, dann werden mir alle Disks (incl. der RAID Disks) angezeigt.

Der integrierte Treiber funktioniert also.

Ich könnte das Windows Setup vom Stick starten, jedoch ohne Übernahme meines Windows 7 Profils und der Anwendungen.

Das will ich nicht ...  :shock:.  

Ich wäre Wochen damit beschäftigt meine Entwicklungsumgebungen wieder so einzurichten, dass ich produktiv weiterarbeiten könnte.

 

Wenn ich das "gewünschte" Inplace Upgrade, aus Windows 7 heraus, von dem modifizierten USB Stick starte, dann habe ich exakt den gleichen Effekt wie vorher.

Die Integration des RAID Treibers wird durch die "Inplace Upgrade Vorbereitung" vergessen und die RAID Disks sind nach dem Reboot ins Windows 8.1 Setup nicht mehr zu sehen.

Das Inplace Upgrade greift beim Reboot auch nicht auf den USB Stick zurück. Daher nützt der hinzugefügte Treiber hier offenbar nicht viel.

In der vom Setup präparierten Bootumgebung (Win PE) fehlt mein RAID Treiber in SYSTEM32\DRIVERS. Die RAID Laufwerke fehlen und das Setup kann nicht fortgesetzt werden   ...

 

Haben die Jungs aus Silicon Valley den Mann, der die "F6" Taste im Windows Setup programmiert hat in Rente geschickt? Im normalen Windows 8.1 Setup kann ich Storagetreiber bei Bedarf manuell nachladen. Dieser Mechanismus fehlt beim Inplace Upgrade. 

 

Wo legt das Setup, dass ich unter Windows 7 starte, die Boot.wim (bzw. die Setup "Bootumgebung") ab?

Kann ich dort eventuell noch vor dem Start des zweiten Setup Abschnittes den RAID Treiber dazumogeln? 

 

Daniel, hast Du noch eine Idee?

Google hilft mir nicht weiter und der MS Supporter, den ich hinzugezogen habe, ist leider auch ziemlich am Ende mit seinem Latein.

 

PS:

Schade, dass ihr keine Technet Events in Hamburg mehr macht.

Das waren echt schöne Zeiten, als es noch echte Live-Events von euch gab.

Die Webcasts gehen zur Not auch, sind aber definitiv kein adäquater Ersatz für Vorträge von Dir, Steffen Krause, Ralf Schnell u.v.a. ...

 

 

Grüße

Jens


Bearbeitet von jensw_2000, 16. Dezember 2013 - 00:45.

Schöne Grüße aus Ahrensburg ;)

#4 Daniel -MSFT-

Daniel -MSFT-

    Expert Member

  • 2.434 Beiträge

 

Geschrieben 16. Dezember 2013 - 22:23

Hilft eventuell das hier weiter? http://technet.micro...ibrary/cc766485(v=ws.10).aspx

 

Have fun!
Daniel


.: Daniel Melanchthon :.

 

Ich arbeite für die Microsoft Deutschland GmbH.

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität.

 

Hinweis zur Rechtsverbindlichkeit dieser Informationen

Diese Informationen sind Hinweise, die das Verständnis hinsichtlich der Microsoft Produktlizenzierung verbessern sollen. Microsoft weist ausdrücklich darauf hin, dass diese Informationen keinen rechtsverbindlichen Charakter haben, sondern als erklärende Informationen zu verstehen sind. Die einzig rechtsverbindlichen Lizenzinformationen sind in den entsprechenden Endnutzer-Lizenzverträgen (als Beilage zu Softwarepaketen oder in Form von Lizenzverträgen) zu finden.


#5 xaxoxix

xaxoxix

    Newbie

  • 25 Beiträge

 

Geschrieben 27. März 2014 - 18:24

wenn du Windows 7 mit allen Programmen uebernehmen möchtest , musst du Windows 7 erst nach Windows 8(.0) updaten und erst danach nach Windows 8.1 updaten
Windows 7 direkt nach 8.1 funktioniert definitiv nicht! da werden ausschliesslich Persönliche Sateien uebernommen und der rest unter windows.old gespeichert

wenn du Windows 8.1 von null weg installieren möchtest, kannst du das ueber einen Trick direkt machen - du brauchst vom Prinzip die iso, die du dir zuvor uebers Setup brennen kannst

bzgl. dem Raidcontrollertreiber gehe ich davon aus, dass du das Problem eventuell auch nicht hasst - wenn du zuvor auf windows 8 migrierst, da da dann Treiberprobleme gecheckt werden und im falle dessen auch darauf hingewiesen wird.

Bearbeitet von xaxoxix, 27. März 2014 - 18:26.