Zum Inhalt wechseln


Foto

IIS: php 5.5.0 per FastCGI laden

Windows Server 2012 IIS

  • Bitte melde dich an um zu Antworten
3 Antworten in diesem Thema

#1 S.R.

S.R.

    Senior Member

  • 481 Beiträge

 

Geschrieben 11. Juli 2013 - 20:26

Hallo,

 

ich habe hier einen W2K12 Server mit IIS und habe dort bereits php 5.4.17 am Laufen. Nun möchte ich meine ersten Tests mit php 5.5.0 starten und habe die php-cgi.exe genauso eingebunden, wie auch die der alten Version.

 

Dann habe ich das mini-Script

 

<?php

  phpinfo();

?>

 

angelegt und rufe dies nun auf. Im Browser erhalte ich dann einen 500er-Fehler:

 

HTTP-Fehler 500.0 - Internal Server Error C:\php\php-5.5.0-nts-Win32-VC11-x86\php-cgi.exe - Der FastCGI-Prozess wurde unerwartet abgebrochen.

 

Ich habe ehrlich gesagt keinen blassen Schimmer was ich falsch gemacht habe und leider auch keinen blassen Schimmer, wo ich weiter suchen soll... Finde auch keine Log oder eine Protokollierung, wo weitere Infos stehen...

 

Bin für jeden Tipp dankbar :-)

 

Gruß

 

Stefan



#2 blakedj06

blakedj06

    Newbie

  • 1 Beiträge

 

Geschrieben 12. Juli 2013 - 09:31

Hallo Stefan,

 

auch ich habe wochenlang nach einer Lösung gesucht da ich das gleiche Problem hatte dabei ist die Lösung eigentlich logisch und somit simpel. ^^

 

Also da php 5.5 mit c++ 2012 compiliert wurde musst Du natürlich die Libarys dazu installieren.

 

Visual C++ Redistributable for Visual Studio 2012

 

Einfach das installieren und IIS neustarten dann klappts auch. :)



#3 S.R.

S.R.

    Senior Member

  • 481 Beiträge

 

Geschrieben 16. Juli 2013 - 07:06

Hallo,

 

vielen, vielen Dank für die Info. Daran hat es natürlich gelegen. Installiert und schon klappts - danke!

 

Gruß

 

Stefan


  • blakedj06 gefällt das

#4 Schmalzloke

Schmalzloke

    Newbie

  • 1 Beiträge

 

Geschrieben 18. Juli 2016 - 06:59

Hallo Stefan,

 

auch ich habe wochenlang nach einer Lösung gesucht da ich das gleiche Problem hatte dabei ist die Lösung eigentlich logisch und somit simpel. ^^

 

Also da php 5.5 mit c++ 2012 compiliert wurde musst Du natürlich die Libarys dazu installieren.

 

Visual C++ Redistributable for Visual Studio 2012

 

Einfach das installieren und IIS neustarten dann klappts auch. :)

 

Vielen Dank hab mich extra registriert um die das zu sagen. 

War eigentlich total simpel aber du hast meinen ars*** gerettet! :D





Auch mit einem oder mehreren der folgenden Tags versehen: Windows Server 2012, IIS