Zum Inhalt wechseln


Foto

Dateizugriff extrem langsam - Hintergrundsuche?

Windows 7

  • Bitte melde dich an um zu Antworten
14 Antworten in diesem Thema

#1 quake

quake

    Newbie

  • 14 Beiträge

 

Geschrieben 02. Juni 2013 - 20:57

Hallo,

habe ein riesen Performanceproblem bei Netzwerkzugriffen, welches ich auf das Betriebssystem zurückführen kann, aber nicht abgeschaltet bekomme.

Server: Windows 2008 Server und Suse Enterprise auf vSphere
Netzwerk: Gbit HP Procurve und 9 Remotestandorte per VPN mit 2,3 Mbit
Clients: XP und Windows 7
Software: Office 2003

Nun mein Problem
Befinde mich gerade in der Umstellung der Clients von XP auf Windows 7. Am lokalen Standort sind schon einige neue PCs mit Windows 7 im Betrieb, die im Netzwerk deutlich besser laufen könnten. Nun habe ich den ersten Remotestandort ebenfalls mit neuen Geräten ausgestattet und bekomme extreme Probleme beim öffnen von Dateien auf Netzlaufwerken. Beim Öffnen einer Worddatei öffnet sich diese zwar schnell, friert dann aber ohne ersichtlichen Grund ein und ist erst nach einigen Sekunden/Minuten je nach Größe des Freigabe-Ordners bearbeitbar. Mit XP-Clients kein Problem.

Ich habe schon alle möglichen Änderungen durchgeführt.
Windows Search - abgeschaltet
Virenschutz - ausgeschaltet
DNS - funktioniert tadellos
Word - neu installiert, keine Security-Eintrag in Registry

Jetzt habe ich beim Zugriff auf eine Netzwerk-Freigabe mit dem ProzessMonitor gesehen, daß Windows anscheinend nach dem Öffnen der Datei eine Dateiliste aller auf der Freigabe befindlichen Dateien erstellt obwohl die Indizierung ausgeschaltet ist. Sobald die Dateiliste vollständig ist, steht die Datei zur Bearbeitung zur Verfügung. Bei Freigaben mit vielen Dateien eine Katastrophe, zumal es sich hier um ca. 230000 Dateien in 30 Unterordnern handelt

Da es sich nicht nur um Office-Dateien, sonder z.B. auch Bild-Dateien handelt, kann es nur Windows selber sein. Seltsamerweise sind PDF-Dateien nicht betroffen. Bei Zugriff auf eine lokale Datei, wird diese Liste nicht erstellt.

Im ProzessMonitor wird dieser Vorgang als QueryDirectory mit der Dateiliste als Result aufgeführt. Dies wird auch am lokalen Standort ausgeführt, fällte hier nur nicht so auf, da man ja direkt am Rechenzentrum sitzt.

Wie kann ich diesen Vorgang unterbinden?
Bitte dringend um eure Hilfe, bin mit meinem Latein am Ende. Habe das Internet schon dreimal komplett durchgelesen ;)

#2 blub

blub

    Moderator

  • 7.605 Beiträge

 

Geschrieben 03. Juni 2013 - 03:55

Hallo,

Ich kenne diese Problembeschreibung ("Langsamer Zugriff auf Freigaben, wenn dort sehr viele Dateien liegen"), wenn in den Netzwerkeinstellungen die MTU-Size nicht zur Fenstergröße passt. Setz die MTU-Size an einem Client mal etwas runter, ca. 1300. 

Dazu gibts Tools bzw. irgendwo liegt auch ein RegKey dazu

 

blub


Ein Kluger bemerkt alles, Ein Dummer macht über alles eine Bemerkung. (Heinrich Heine)


#3 quake

quake

    Newbie

  • 14 Beiträge

 

Geschrieben 03. Juni 2013 - 08:30

Danke erstmal für den Tip.

 

Das werde ich mal testen, da die Auswertung der VPN-Verbindung (Watchguard-Router) über netsh eine maximale Größe von 1390 empfiehlt. Das könnte auf jeden Fall Verbindungsabbrüche verhindern, auch wenn dadurch die Bandbreite etwas verringert würde.

 

Allerdings beseitigt das noch nicht das Problem, daß Windows nach dem Öffnen einer Datei, eine kompette Dateiliste des Freigabeordners erstellt. Dies würde auch bei Änderung des MTU passieren.



#4 quake

quake

    Newbie

  • 14 Beiträge

 

Geschrieben 04. Juni 2013 - 11:51

... keiner mehr Ideen?

 

Ich habe jetzt noch die Erstellung der Thumbs.db auf Netzwerkordnern deaktiviert - bringt auch nichts!

Windows Search bzw. Offlinedateien deaktiviert - kein Erfolg!

MTU angepaßt - keine Änderung!

 

Warum wird bloß diese Dateiliste erstellt?

Das ist definitiv die Bremse, da in dem Ordner das Laden der knapp 45000 Dateinamen richtig Zeit in Anspruch nimmt. Auf dem Server ist keine Auslastung zu erkennen. Es ist auch vollkommen egal, ob ich auf die Freigabe eines Windows 2008 oder auf eine Samba-Freigabe des Suse zugreife. Bei Zugriff auf einen Freigabeordner mit nur hundert Dateien, geht es natürlich viel schneller.

 

Bin jetzt echt am verzweifeln, da auch eine kontaktierte Supportfirma mit wirklichen Profis keine Idee hat.



#5 XP-Fan

XP-Fan

    Moderator

  • 11.238 Beiträge

 

Geschrieben 04. Juni 2013 - 13:46

Hallo,

 

versuche mal das TCP Tuning von Windows 7 zu deaktivieren und den TCP Offload einzuschalten, könnte helfen.

 

In einer administrativen cmd ( Als Admin ausführen ) auf einem PC testen, nach dem Ausführen der Befehle den Rechner neustarten.

 

Zum Abschalten:

netsh int tcp set global autotuninglevel=disabled

 

Weiterhin könnte es helfen den TCP Chimney Offload zu aktivieren:

netsh int tcp set global chimney=enabled

 

Zum Zurücksetzen falls erfolglos:

netsh int tcp set global autotuninglevel=enabled

netsh int tcp set global chimney=disabled


Gruß und viel Erfolg !

www.ServerHowTo.de - Das MCSEboard.de HowTo Projekt ist online!


#6 quake

quake

    Newbie

  • 14 Beiträge

 

Geschrieben 04. Juni 2013 - 14:19

Ich dachte schon, ich mache mir selbst Vorschläge... :p

 

Die Einstellungen habe ich gerade probiert, wobei ich die chimney-Option gar nicht kannte.

 

Das hat schonmal etwas gebracht, wenngleich das Hauptproblem direkt nach dem Laden der Datei bleibt. Trotzdem sieht man einen Fortschritt. Die Kiste startet recht fix und steht sehr schnell zur Verfügung.

 

Ich muß aber auch gestehen, daß ich die SMB-Signierung vorhin mal deaktiviert habe und erstmal damit weitertesten wollte.

 

Deaktivieren:

sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled

 

Aktivieren (...der vollständigkeithalber):

sc config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/Nsi

sc config mrxsmb20 start = auto
 
...trotzdem ein großes Danke...


#7 quake

quake

    Newbie

  • 14 Beiträge

 

Geschrieben 04. Juni 2013 - 20:34

Zur Verdeutlichung was da abgeht, habe ich mal einen gefilterten Ausschnitt aus dem ProcessMonitor beigefügt.

Am Anfang wird die Normal.dot geladen. In Zeile 13 ist die Datei test.doc fertig geladen in der Anwendung. Ab Zeile 17 folgt dann die Auflistung des Ordnerinhalts, jeweils fast immer genau 137 Dateinamen. Im rechten Ausschnitt ist ein Ausschnitt der Details zu erkennen.

Erst wenn dieses Listing fertig ist, kann in Word gearbeitet werden. Am lokalen Standort dauert das nur einige Sekunden, vom Remote-Standort geht für Minuten nichts. Andere Anwendungen können allerdings ohne Einschränkungen während der Abfrage benutzt werden.

Vielleicht kann ja mal jemand ohne dieses Problem mit dem ProcessMonitor bei sich schauen, ob es dort auch dieses QueryDirectory auf einem umfangreichen UNC-Pfad gibt.

Angehängte Dateien

  • Angehängte Datei  image.jpg   195,5K   31 Mal heruntergeladen


#8 mcdaniels

mcdaniels

    Board Veteran

  • 1.602 Beiträge

 

Geschrieben 19. Juni 2013 - 05:41

Hallo,

hast du eventuell ein aktuelleres Office zur Verfügung, um festzustellen, ob das Problem auch mit zb. Office 2010 auftritt?

 

Ich denke hier u.a. auch an das Supportende von Office 2003 im April 2014...

 

Hast du das Office File Validation Add In installiert? Wenn ja, dann versuch mal das zu deinstallieren und teste erneut.

 

 

LG

Daniel


Bearbeitet von mcdaniels, 19. Juni 2013 - 05:45.

Greetz Daniel

Das Problem sitzt meistens 30 cm von der Tastatur entfernt... ;-)

#9 quake

quake

    Newbie

  • 14 Beiträge

 

Geschrieben 19. Juni 2013 - 06:56

Hallo,

 

eine beauftragte Supportfirma hat das schon unter anderen Versionen (bis office 2013) mit gleichem Ergebnis getestet. Der Microsoft Support (Ticket besteht noch) hat bisher auch keine Lösung.

 

Das ist ja echt zum heulen :( !!! Nun hat vermutlich jeder das beschriebene Problem, nur fällt es nicht auf, wenn man direkt an der Freigabe sitzt. Aber von einem Remote-Standort ist es wirklich eine große Katastrophe bei Freigaben mit einer Vielzahl von Dateien.

 

Auch wenn man SMB2 ausschaltet, MRU anpaßt, Office FileValidation abschaltet....es bleibt extrem langsam!

 

Ich bin mittlerweile der Meinung, das es irgendetwas zwischen 32 und 64 bit ist. Da Microsoft ja selber nur die Verwendung von 32bit-Office auf 64bit-Windows empfiehlt, würde mich mal interessieren, ob dieses Verhalten bei einem 64bit-Office auch auftritt.

 

Wer hat es und kann das mal testen? Würde mir und vielen anderen sehr helfen.

Wenn es dann nicht auftritt, ist es ein vermutlich ein Fehler beim Umsetzen der 32bit-Kompatibilität (.dll o.ä.).

 

Mit gleichem Verhalten bei anderen Dateitypen (z.B. jpg) kann ich gut leben, weil es bei mir eher die Ausnahme ist.

 

 

LG

Markus



#10 Ewum

Ewum

    Newbie

  • 1 Beiträge

 

Geschrieben 30. Juli 2014 - 15:45

Markus,

 

wenn Du den Server neu startest, ist dann das Problem zumindest kurzfristig behoben? So ist es zumindest in unserem Netzwerk. Das Öffnen von Office Dateien geht bisweilen auf den Clients ziemlich langsam - Serverneustart - alles ok. Leider kenne ich die Ursache auch noch nicht.

 

Schöne Grüße,

 

Uwe



#11 Daniel -MSFT-

Daniel -MSFT-

    Expert Member

  • 2.434 Beiträge

 

Geschrieben 30. Juli 2014 - 19:34

Du hast nicht die SMB-Signierung abgeschaltet, sondern die erweiterten, neueren SMB-Protokollversionen v2... How to shoot yourself into the foot

Bearbeitet von Daniel -MSFT-, 30. Juli 2014 - 19:48.

  • DocData gefällt das

.: Daniel Melanchthon :.

 

Ich arbeite für die Microsoft Deutschland GmbH.

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität.

 

Hinweis zur Rechtsverbindlichkeit dieser Informationen

Diese Informationen sind Hinweise, die das Verständnis hinsichtlich der Microsoft Produktlizenzierung verbessern sollen. Microsoft weist ausdrücklich darauf hin, dass diese Informationen keinen rechtsverbindlichen Charakter haben, sondern als erklärende Informationen zu verstehen sind. Die einzig rechtsverbindlichen Lizenzinformationen sind in den entsprechenden Endnutzer-Lizenzverträgen (als Beilage zu Softwarepaketen oder in Form von Lizenzverträgen) zu finden.


#12 zahni

zahni

    Expert Member

  • 16.399 Beiträge

 

Geschrieben 30. Juli 2014 - 19:36

@Daniel,

 

jetzt bist Du auch reingefallen ;)

Schau mal auf das Datum.


Wen du nicht mit Können beeindrucken kannst, den verwirre mit Schwachsinn!


#13 Daniel -MSFT-

Daniel -MSFT-

    Expert Member

  • 2.434 Beiträge

 

Geschrieben 30. Juli 2014 - 19:49

Boah, wie ich das hasse. Vielen Dank für den Hinweis. Warum gibt es da nicht eine fette Warnung ⚠ in der Mobilansicht?

.: Daniel Melanchthon :.

 

Ich arbeite für die Microsoft Deutschland GmbH.

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität.

 

Hinweis zur Rechtsverbindlichkeit dieser Informationen

Diese Informationen sind Hinweise, die das Verständnis hinsichtlich der Microsoft Produktlizenzierung verbessern sollen. Microsoft weist ausdrücklich darauf hin, dass diese Informationen keinen rechtsverbindlichen Charakter haben, sondern als erklärende Informationen zu verstehen sind. Die einzig rechtsverbindlichen Lizenzinformationen sind in den entsprechenden Endnutzer-Lizenzverträgen (als Beilage zu Softwarepaketen oder in Form von Lizenzverträgen) zu finden.


#14 silencar

silencar

    Newbie

  • 1 Beiträge

 

Geschrieben 29. August 2014 - 13:42

Hallo,

 

Datum hin oder her, dass Problem ist nach wie vor nicht gelöst und betrifft nach dem Umstieg auf Windows 7 auch mich.

Netzlaufwerk mit über 200.000 Dokumenten. Word 2003 blieb nach öffnen eines Dokuments für mehrere Sekunden "ohne Rückmeldung". Mit Word 2007 kann mit der Datei zwar direkt gearbeitet werden. Dennoch verursacht das Öffnen UND das Schließen jeweils für mehrere Sekunden eine hohe (sinnlose) Netzwerkauslastung (siehe Taskmanager).  (Frage zum erwähnten Netzwerktimeout: verursacht ein Netzwerktimeout Traffic?)

Die Ursache ist in Windows 7 allein oder in der Kombi mit Office zu suchen.

Und ich würde sehr gerne diesen unnützen Traffic vermeiden.

Gruß an die Microsoft-Entwickler - wäre schön wenn ihr da ne Lösung hättet.

 

BG

Mike


Bearbeitet von silencar, 29. August 2014 - 13:43.


#15 =BT=Viper

=BT=Viper

    Board Veteran

  • 665 Beiträge

 

Geschrieben 26. November 2014 - 09:58

Hi, ich denke wir haben das gleiche Problem

 

http://www.mcseboard...r-sehr-langsam/

 


Probier das mal http://www.computerw...ie-loesung.html

 

Habe bei mir nicht sofort eine Besserung fest gestellt, kann aber auch gut sein das man etwas warten muss, gerade bei großen Ordnern.


Bearbeitet von =BT=Viper, 26. November 2014 - 10:16.