Zum Inhalt wechseln


Foto

WSUS - Einzelner Server meldet sich nicht


  • Bitte melde dich an um zu Antworten
16 Antworten in diesem Thema

#1 Awaved

Awaved

    Newbie

  • 8 Beiträge

 

Geschrieben 20. Februar 2013 - 10:06

Hallo WSUS-Spezialisten!

 

Ich habe folgendes Problem: Ich habe auf einem Win 2003 SP2 Server einen WSUS erfolgreich am laufen, jedoch hab ich einen Server, der rumzickt und sich einfach nicht beim WSUS melden will.

 

Ich hatte das Problem auch mit einigen anderen Servern, aber nach ein wenig Recherche konnte ich herausfinden, dass beim Clonvorgang die SUSClientID erneuert werden muss, damit alle Server sich richtig beim WSUS melden. Dieser Vorgang hat in dem speziellen Fall jedoch nicht funktioniert.

 

Ich habe bereits das WindowsUpdate.log überprüft, jedoch keine Ungereimtheiten entdeckt, deswegen brauche ich eure Hilfe! :)

 

Gibt es noch andere Möglichkeiten nach Fehlerquellen dafür zu suchen?

 

 

Beste Grüße


Bearbeitet von Awaved, 20. Februar 2013 - 15:30.


#2 Sunny61

Sunny61

    Expert Member

  • 22.101 Beiträge

 

Geschrieben 20. Februar 2013 - 23:18

Ich habe folgendes Problem: Ich habe auf einem Win 2003 SP2 Server einen WSUS erfolgreich am laufen, jedoch hab ich einen Server, der rumzickt und sich einfach nicht beim WSUS melden will.


Welches OS hat der uns unbekannte andere rumzickende Server?

 

Ich hatte das Problem auch mit einigen anderen Servern, aber nach ein wenig Recherche konnte ich herausfinden, dass beim Clonvorgang die SUSClientID erneuert werden muss, damit alle Server sich richtig beim WSUS melden. Dieser Vorgang hat in dem speziellen Fall jedoch nicht funktioniert.


Meldet er sich sicher nicht oder wird ein anderer Eintrag überschrieben?
 

Ich habe bereits das WindowsUpdate.log überprüft, jedoch keine Ungereimtheiten entdeckt, deswegen brauche ich eure Hilfe! :)


Hat denn der Server auch alle Registry Keys bezüglich WSUS übernommen? Du kannst den Downloadcache auf dem Problemserver leeren und nochmal neu suchen lassen:

net stop wuauserv
rd /s /d %windir%\SoftwareDistribution
net start wuauserv
wuauclt /detectnow
wuauclt /reportnow
10 Minuten warten, jetzt muß der Server im WSUS auftauchen.
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#3 Awaved

Awaved

    Newbie

  • 8 Beiträge

 

Geschrieben 21. Februar 2013 - 10:09

Welches OS hat der uns unbekannte andere rumzickende Server?

 

Win 2003 R2 64bit

 

 

Meldet er sich sicher nicht oder wird ein anderer Eintrag überschrieben?

 

Es wird nichts überschrieben, er meldet sich sicher nicht.

 

 

Hat denn der Server auch alle Registry Keys bezüglich WSUS übernommen? Du kannst den Downloadcache auf dem Problemserver leeren und nochmal neu suchen lassen:

net stop wuauserv
rd /s /d %windir%\SoftwareDistribution
net start wuauserv
wuauclt /detectnow
wuauclt /reportnow
10 Minuten warten, jetzt muß der Server im WSUS auftauchen

 

Der Server hat alle Registry Keys übernommen, ich hab auch alle nochmal erneuert.

Das neu suchen lassen habe ich gerade auch getestet, leider ohne Erfolg. :(



#4 Timsk

Timsk

    Newbie

  • 59 Beiträge

 

Geschrieben 21. Februar 2013 - 10:23

Hi,

 

du sagst du hast in das WindowsUpdate.log auf den betreffenden Server geschaut, richtig? Hast du denn irgendwelche Hinweise auf den deinen WSUS Server gefunden?

 

Wenn du ein wuauclt.exe /detectnow /reportnow durchführst müsste im WindowsUpdate.log ja was zu sehen sein.

 

Zum Beispiel:

 

 

+++++++++++  PT: Synchronizing server updates  +++++++++++
+ ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = http://#Servername#:...ice/client.asmx

 

Kannst du deinen WSUS Server entdecken? Werden keine Fehlermeldungen ausgegeben?

 

Viele Grüße!


Bearbeitet von Timsk, 21. Februar 2013 - 10:23.

done:70-640, 70-642, 70-643, 70-680, 70-647

MCITP:EA :)

#5 Awaved

Awaved

    Newbie

  • 8 Beiträge

 

Geschrieben 21. Februar 2013 - 10:35

du sagst du hast in das WindowsUpdate.log auf den betreffenden Server geschaut, richtig? Hast du denn irgendwelche Hinweise auf den deinen WSUS Server gefunden?

 

Kannst du deinen WSUS Server entdecken? Werden keine Fehlermeldungen ausgegeben?

 

Ich seh lediglich eine Proxy IP. Wenn ich /reportnow /detectnow mach kommt folgendes:

 

 

2013-02-21 11:30:50:777 996 15b8 AU Triggering AU detection through DetectNow API
2013-02-21 11:30:50:777 996 15b8 AU Can not perform non-interactive scan if AU is interactive-only
 
 
Grüße :)


#6 sysiphos

sysiphos

    Board Veteran

  • 846 Beiträge

 

Geschrieben 21. Februar 2013 - 11:52

Hi,

funkt da vielleicht eine GPO zwischen?

 

Mach mal in der CMD rsop.msc und schau mal nach ob der richtige WSUS Server eingetragen ist.

Computerkonfiguration -> Administrative Vorlage -> Windows-Komponenten -> Windows Update

 

Grüße


Never change a running System

#7 Awaved

Awaved

    Newbie

  • 8 Beiträge

 

Geschrieben 21. Februar 2013 - 12:26

Ich kann leider keinen WSUS-Eintrag entdecken, geschweige denn einen "Windows Update" Bereich in den Einstellungen die du mir geschildert hast. 

 

Wenn ich auf Benutzerkonfiguration geh, sehe ich eine Windows Update Einstellung, in der auch nur steht, dass "Zugriff auf alle Windows Update-Funktionen entfernen" deaktiviert ist.



#8 sysiphos

sysiphos

    Board Veteran

  • 846 Beiträge

 

Geschrieben 21. Februar 2013 - 12:37

Den Eintrag sollte es aber geben, komisch.

Ist der nicht funktionierende Server in einer anderen OU als die Server die funktionieren?

Hast du die WSUS GPO auf eine bestimmte OU oder auf die ganze Domäne verlinkt?

Vielleicht hilft auf den nicht funktionierenden Server auch ein gpupdate /force.

 

 

Gib mal in der CMD gpresult ein, dann siehst du unter Computereinstellungen welche GPOs der Server zugewiesen bekommen hat, wenn die WSUS GPO da nicht aufgelistet ist hast du ein GPO Problem.

 

Grüße


Bearbeitet von sysiphos, 21. Februar 2013 - 12:38.

Never change a running System

#9 Awaved

Awaved

    Newbie

  • 8 Beiträge

 

Geschrieben 21. Februar 2013 - 12:46

Sowohl der nicht funktionierende Server, als auch die funktionierenden Server sind in der gleichen OU. Die WSUS GPO ist auf eine bestimmte OU verlinkt.

 

gpupdate /force hab ich schon mehrere male ohne Erfolg probiert.

 

Auch unter gpresult ist die WSUS GPO gelistet.

 

 

Gruß



#10 sysiphos

sysiphos

    Board Veteran

  • 846 Beiträge

 

Geschrieben 21. Februar 2013 - 13:10

Vergleich mal das Resultat von RSOP.msc mit einem funktionierenden Server, wie gesagt unter dem von mir genannten Zweig muss der Windows Update Ordner liegen, ich denke du hast ein GPO Problem. Ist der Server der nicht funktioniert geclont?


Bearbeitet von sysiphos, 21. Februar 2013 - 13:11.

Never change a running System

#11 Awaved

Awaved

    Newbie

  • 8 Beiträge

 

Geschrieben 21. Februar 2013 - 13:41

Ja, der ist geclont, genau so wie alle anderen Server die funktionieren.

 

Ich habe die Resultate mal verglichen mit RSOP.msc auf einem funktionierenden Server, und sehe unter deinem Zweig leider nirgendwo den Windows Update Ordner.

 

Ich sehe lediglich Windows Media Player, Windows Installer, Windows Messenger, Windows Movie Maker, Internet Explorer. :/



#12 sysiphos

sysiphos

    Board Veteran

  • 846 Beiträge

 

Geschrieben 21. Februar 2013 - 14:02

Hast du dem Server eine neue SID gegeben?

 

Schau mal in der Registry unter HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate ob der WSUS da eintragen ist.


Never change a running System

#13 Awaved

Awaved

    Newbie

  • 8 Beiträge

 

Geschrieben 21. Februar 2013 - 15:48

Ja neue SID hat er bekommen, des öfteren schon.

 

WSUS ist auch in der Registry eingetragen.



Ich habe nochmal alle Vorgänge wiederholt und habe nun zig Warnings im Windows Update Log:

 

 

2013-02-21 16:12:44:543 996 1030c AU ###########  AU: Uninitializing Automatic Updates  ###########
2013-02-21 16:12:44:590 996 1030c Service *********
2013-02-21 16:12:44:590 996 1030c Service **  END  **  Service: Service exit [Exit code = 0x240001]
2013-02-21 16:12:44:590 996 1030c Service *************
2013-02-21 16:12:47:090 996 45c4 Misc ===========  Logging initialized (build: 7.6.7600.256, tz: +0100)  ===========
2013-02-21 16:12:47:090 996 45c4 Misc  = Process: C:\WINDOWS\System32\svchost.exe
2013-02-21 16:12:47:090 996 45c4 Misc  = Module: C:\WINDOWS\system32\wuaueng.dll
2013-02-21 16:12:47:090 996 45c4 Service *************
2013-02-21 16:12:47:090 996 45c4 Service ** START **  Service: Service startup
2013-02-21 16:12:47:090 996 45c4 Service *********
2013-02-21 16:12:47:153 996 45c4 Agent  * WU client version 7.6.7600.256
2013-02-21 16:12:47:153 996 45c4 Agent  * Base directory: C:\WINDOWS\SoftwareDistribution
2013-02-21 16:12:47:153 996 45c4 Agent  * Access type: Named proxy
2013-02-21 16:12:47:153 996 45c4 Agent  * Default proxy: 80.87.171.201:8080
2013-02-21 16:12:47:153 996 45c4 Agent  * Network state: Connected
2013-02-21 16:12:49:184 996 2258 Agent ***********  Agent: Initializing Windows Update Agent  ***********
2013-02-21 16:12:49:184 996 2258 Agent ***********  Agent: Initializing global settings cache  ***********
2013-02-21 16:12:49:184 996 2258 Agent  * WSUS server: http://<MEINWSUS>:8530
2013-02-21 16:12:49:184 996 2258 Agent  * WSUS status server: http://<MEINWSUS>:8530
2013-02-21 16:12:49:184 996 2258 Agent  * Target group: (Unassigned Computers)
2013-02-21 16:12:49:184 996 2258 Agent  * Windows Update access disabled: Yes
2013-02-21 16:12:49:184 996 2258 DnldMgr Download manager restoring 0 downloads
2013-02-21 16:12:49:184 996 2258 AU ###########  AU: Initializing Automatic Updates  ###########
2013-02-21 16:12:49:184 996 2258 AU AU setting next sqm report timeout to 2013-02-21 15:12:49
2013-02-21 16:12:49:184 996 2258 AU  # WSUS server: http://<MEINWSUS>:8530
2013-02-21 16:12:49:184 996 2258 AU  # Detection frequency: 1
2013-02-21 16:12:49:184 996 2258 AU  # Approval type: Scheduled (Policy)
2013-02-21 16:12:49:184 996 2258 AU  # Scheduled install day/time: Saturday at 10:00
2013-02-21 16:12:49:184 996 2258 AU  # Auto-install minor updates: Yes (User preference)
2013-02-21 16:12:49:200 996 2258 AU Setting AU scheduled install time to 2013-02-23 09:00:00
2013-02-21 16:12:49:200 996 2258 AU Initializing featured updates
2013-02-21 16:12:49:200 996 2258 AU Found 0 cached featured updates
2013-02-21 16:12:49:200 996 2258 AU AU finished delayed initialization
2013-02-21 16:12:49:200 996 2258 AU Triggering AU detection through DetectNow API
2013-02-21 16:12:49:200 996 2258 AU Triggering Online detection (non-interactive)
2013-02-21 16:12:49:403 996 45c4 Report ***********  Report: Initializing static reporting data  ***********
2013-02-21 16:12:49:403 996 45c4 Report  * OS Version = 5.2.3790.2.0.196624
2013-02-21 16:12:49:731 996 45c4 Report  * Computer Brand = Dell Inc.
2013-02-21 16:12:49:731 996 45c4 Report  * Computer Model = PowerEdge R610
2013-02-21 16:12:49:731 996 45c4 Report  * Bios Revision = 6.0.7
2013-02-21 16:12:49:731 996 45c4 Report  * Bios Name = Default System BIOS
2013-02-21 16:12:49:731 996 45c4 Report  * Bios Release Date = 2011-08-18T00:00:00
2013-02-21 16:12:49:731 996 45c4 Report  * Locale ID = 1031
2013-02-21 16:12:49:762 996 45c4 AU #############
2013-02-21 16:12:49:762 996 45c4 AU ## START ##  AU: Search for updates
2013-02-21 16:12:49:762 996 45c4 AU #########
2013-02-21 16:12:49:762 996 45c4 AU <<## SUBMITTED ## AU: Search for updates [CallId = {45043A29-4334-40F3-8D63-387B7969D06A}]
2013-02-21 16:12:51:684 996 df34 PT WARNING: Cached cookie has expired or new PID is available
2013-02-21 16:12:51:684 996 df34 PT Initializing simple targeting cookie, clientId = a6ff1033-b2bd-4df1-a09e-f47c016415a8, target group = , DNS name = server.domain
2013-02-21 16:12:51:684 996 df34 PT  Server URL = http://<MEINWSUS>:8530/SimpleAuthWebService/SimpleAuth.asmx
2013-02-21 16:12:54:200 996 df34 PT WARNING: GetAuthorizationCookie failure, error = 0x80244018, soap client error = 10, soap error code = 0, HTTP status code = 403
2013-02-21 16:12:54:200 996 df34 PT WARNING: Failed to initialize Simple Targeting Cookie: 0x80244018
2013-02-21 16:12:54:200 996 df34 PT WARNING: PopulateAuthCookies failed: 0x80244018
2013-02-21 16:12:54:200 996 df34 PT WARNING: RefreshCookie failed: 0x80244018
2013-02-21 16:12:54:200 996 df34 PT WARNING: RefreshPTState failed: 0x80244018
2013-02-21 16:12:54:200 996 df34 PT WARNING: PTError: 0x80244018
2013-02-21 16:12:54:200 996 df34 Report WARNING: Reporter failed to upload events with hr = 80244018.
2013-02-21 16:12:54:497 996 df34 PT WARNING: Cached cookie has expired or new PID is available
2013-02-21 16:12:54:497 996 df34 PT Initializing simple targeting cookie, clientId = a6ff1033-b2bd-4df1-a09e-f47c016415a8, target group = , DNS name = server.domain
2013-02-21 16:12:54:497 996 df34 PT  Server URL = http://<MEINWSUS>:8530/SimpleAuthWebService/SimpleAuth.asmx
2013-02-21 16:12:54:497 996 df34 PT WARNING: GetAuthorizationCookie failure, error = 0x80244018, soap client error = 10, soap error code = 0, HTTP status code = 403
2013-02-21 16:12:54:497 996 df34 PT WARNING: Failed to initialize Simple Targeting Cookie: 0x80244018
2013-02-21 16:12:54:512 996 df34 PT WARNING: PopulateAuthCookies failed: 0x80244018
2013-02-21 16:12:54:512 996 df34 PT WARNING: RefreshCookie failed: 0x80244018
2013-02-21 16:12:54:512 996 df34 PT WARNING: RefreshPTState failed: 0x80244018
2013-02-21 16:12:54:512 996 df34 PT WARNING: PTError: 0x80244018
2013-02-21 16:12:54:512 996 df34 Report WARNING: Reporter failed to upload events with hr = 80244018.
2013-02-21 16:12:54:793 996 df34 PT WARNING: Cached cookie has expired or new PID is available
2013-02-21 16:12:54:793 996 df34 PT Initializing simple targeting cookie, clientId = a6ff1033-b2bd-4df1-a09e-f47c016415a8, target group = , DNS name = server.domain
2013-02-21 16:12:54:793 996 df34 PT  Server URL = http://<MEINWSUS>:8530/SimpleAuthWebService/SimpleAuth.asmx
2013-02-21 16:12:54:809 996 df34 PT WARNING: GetAuthorizationCookie failure, error = 0x80244018, soap client error = 10, soap error code = 0, HTTP status code = 403
2013-02-21 16:12:54:809 996 df34 PT WARNING: Failed to initialize Simple Targeting Cookie: 0x80244018
2013-02-21 16:12:54:809 996 df34 PT WARNING: PopulateAuthCookies failed: 0x80244018
2013-02-21 16:12:54:809 996 df34 PT WARNING: RefreshCookie failed: 0x80244018
2013-02-21 16:12:54:809 996 df34 PT WARNING: RefreshPTState failed: 0x80244018
2013-02-21 16:12:54:809 996 df34 PT WARNING: PTError: 0x80244018
2013-02-21 16:12:54:809 996 df34 Report WARNING: Reporter failed to upload events with hr = 80244018.
2013-02-21 16:12:54:809 996 df34 Agent *************
2013-02-21 16:12:54:809 996 df34 Agent ** START **  Agent: Finding updates [CallerId = AutomaticUpdates]
2013-02-21 16:12:54:809 996 df34 Agent *********
2013-02-21 16:12:54:809 996 df34 Agent  * Online = Yes; Ignore download priority = No
2013-02-21 16:12:54:809 996 df34 Agent  * Criteria = "IsHidden=0 and IsInstalled=0 and DeploymentAction='Installation' and IsAssigned=1 or IsHidden=0 and IsPresent=1 and DeploymentAction='Uninstallation' and IsAssigned=1 or IsHidden=0 and IsInstalled=1 and DeploymentAction='Installation' and IsAssigned=1 and RebootRequired=1 or IsHidden=0 and IsInstalled=0 and DeploymentAction='Uninstallation' and IsAssigned=1 and RebootRequired=1"
2013-02-21 16:12:54:809 996 df34 Agent  * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7} Managed
2013-02-21 16:12:54:809 996 df34 Agent  * Search Scope = {Machine}
2013-02-21 16:12:54:809 996 df34 Misc Validating signature for C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wuident.cab:
2013-02-21 16:12:54:809 996 df34 Misc Microsoft signed: Yes
2013-02-21 16:12:54:809 996 df34 Misc WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80190193
2013-02-21 16:12:54:809 996 df34 Misc WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80190193
2013-02-21 16:12:54:825 996 df34 Misc WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80190193
2013-02-21 16:12:54:825 996 df34 Misc WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80190193
2013-02-21 16:12:54:825 996 df34 Misc WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80190193
2013-02-21 16:12:54:825 996 df34 Misc WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80190193
2013-02-21 16:12:54:825 996 df34 Misc WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80190193
2013-02-21 16:12:54:825 996 df34 Misc WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80190193
2013-02-21 16:12:54:825 996 df34 Misc WARNING: DownloadFileInternal failed for http://<MEINWSUS>:8530/selfupdate/wuident.cab: error 0x80190193
2013-02-21 16:12:54:825 996 df34 Setup FATAL: IsUpdateRequired failed with error 0x80244018
2013-02-21 16:12:54:825 996 df34 Setup WARNING: SelfUpdate: Default Service: IsUpdateRequired failed: 0x80244018
2013-02-21 16:12:54:825 996 df34 Setup WARNING: SelfUpdate: Default Service: IsUpdateRequired failed, error = 0x80244018
2013-02-21 16:12:54:825 996 df34 Agent  * WARNING: Skipping scan, self-update check returned 0x80244018
2013-02-21 16:12:54:887 996 df34 Agent  * WARNING: Exit code = 0x80244018
2013-02-21 16:12:54:887 996 df34 Agent *********
2013-02-21 16:12:54:887 996 df34 Agent **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2013-02-21 16:12:54:887 996 df34 Agent *************
2013-02-21 16:12:54:887 996 df34 Agent WARNING: WU client failed Searching for update with error 0x80244018
2013-02-21 16:12:54:887 996 126a4 AU >>##  RESUMED  ## AU: Search for updates [CallId = {45043A29-4334-40F3-8D63-387B7969D06A}]
2013-02-21 16:12:54:887 996 126a4 AU  # WARNING: Search callback failed, result = 0x80244018
2013-02-21 16:12:54:887 996 126a4 AU  # WARNING: Failed to find updates with error code 80244018
2013-02-21 16:12:54:887 996 126a4 AU #########
2013-02-21 16:12:54:887 996 126a4 AU ##  END  ##  AU: Search for updates [CallId = {45043A29-4334-40F3-8D63-387B7969D06A}]
2013-02-21 16:12:54:887 996 126a4 AU #############
2013-02-21 16:12:54:887 996 126a4 AU AU setting next detection timeout to 2013-02-21 16:10:29
2013-02-21 16:12:54:887 996 126a4 AU Setting AU scheduled install time to 2013-02-23 09:00:00
 
 
 
 
Ist daraus etwas abzuleiten? :)
 
 
Grüße


#14 Sunny61

Sunny61

    Expert Member

  • 22.101 Beiträge

 

Geschrieben 21. Februar 2013 - 19:58

Du hast wohl ein Proxy Problem. http://support.microsoft.com/kb/896226 Prüf nach ob auf diesem Server der gleiche Proxy eingetragen ist, wie bei den anderen. Mit proxycfg bis VISTA findest Du das heraus, hier ist die Syntax dazu: http://msdn.microsof...1(v=vs.85).aspx
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#15 sysiphos

sysiphos

    Board Veteran

  • 846 Beiträge

 

Geschrieben 22. Februar 2013 - 07:37

HI,

 

2013-02-21 16:12:49:184 996 2258 Agent  * Target group: (Unassigned Computers)

bist du sicher dass der Server nicht im WSUS ist, lass dir mal alle Computer unter Unassigned Computer anzeigen.

 

Versuch mal den LINK aufzurufen http://<MEINWSUS>:85...SimpleAuth.asmx


Never change a running System